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• Revision: 1.3

• Software Version: 10.0.0

• Part Number: UG0022-03

• Copyright: © 2009 Miranda Technologies, Inc. All rights reserved. 

• No part of this manual may be reproduced in any form by photocopy, microfilm, xerography or 
any other means, or incorporated into any information retrieval system, electronic or mechani-
cal, without the written permission of Miranda Technologies, Inc. 

• The information contained in this manual is subject to change without notice or obligation.

• All title and copyrights as well as trade secret, patent and other proprietary rights in and to the 
Software Product (including but not limited to any images, photographs, animations, video, 
audio, music, test, and “applets” incorporated into the Software Product), the accompanying 
printed materials, and any copies of the Software Product, are owned by Miranda Technologies, 
Inc. The Software Product is protected by copyright laws and international treaty provisions. 
Customer shall not copy the printed materials accompanying the software product.

Notice
The software contains proprietary information of Miranda Technologies, Inc. It is provided under a 
license agreement containing restrictions on use and disclosure and is also protected by copyright 
law. Reverse engineering of the software is prohibited.

Due to continued product development, the accuracy of the information in this document may 
change without notice. The information and intellectual property contained herein is confidential 
between Miranda and the client and remains the exclusive property of Miranda. If you find any 
problems in the documentation, please report them to us in writing. Miranda does not warrant that 
this document is error-free.

FCC Statement 
This equipment has been tested and found to comply with the limits for a Class A digital device, 
pursuant to part 15 of the FCC Rules. These limits are designed to provide reasonable protection 
against harmful interference when the equipment is operated in a commercial environment. This 
equipment generates, uses, and can radiate radio frequency energy and, if not installed and used in 
accordance with the instruction manual, may cause harmful interference to radio communications. 
Operation of this equipment in a residential area is likely to cause harmful interference in which 
case the user will be required to correct the interference at his own expense.

Declaration of Conformance (CE) 
All of the equipment described in this manual has been designed to conform with the required 
safety and emissions standards of the European Community. Products tested and verified to meet 
these standards are marked as required by law with the CE mark. (See Symbols and Their Mean-
ings on page v.)
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When shipped into member countries of the European Community, this equipment is accompanied 
by authentic copies of original Declarations of Conformance on file in Miranda offices in Grass 
Valley, California USA.

Trademarks
Miranda is a registered trademark of Miranda Technologies, Inc.

Brand and product names mentioned in this manual may be trademarks, registered trademarks or 
copyrights of their respective holders. All brand and product names mentioned in this manual serve 
as comments or examples and are not to be understood as advertising for the products or their man-
ufactures.

Software License Agreement and Warranty Information
Contact Miranda for details on the software license agreement and product warranty.

Technical Support Contact Information 
Miranda has made every effort to ensure that the equipment you receive is in perfect working order 
and that the equipment fits your needs. In the event that problems arise that you cannot resolve, or 
if there are any questions regarding this equipment or information about other products manufac-
tured by Miranda, please contact your local representative or contact Miranda directly through one 
of the appropriate means listed here.

• Main telephone: 530-265-1000 (9 am to 9 pm PST)
Fax: 530-265-1021 
In the Americas, call toll-free: +1-800-224-7882 (9 am to 9 pm EST)
In Europe, the Middle East, African or the UK, call  +44 (0) 1491 820222 (9 am to 6 pm, GMT)
In France, call +33 1 55 86 87 88 (9 am to 5 pm, GMT + 1)
In Asia, call +852-2539-6987 (9 am to 5 pm, GMT + 8)
In China, call +86-10-5873-1814

• Emergency after hours: toll-free: +1-800-224-7882
Tel: +1-514-333-1772 

• E-Mail: 
In the Americas, support@miranda.com
In Europe, the Middle East, African or the UK, eurotech@miranda.com
In France, eurotech@miranda.com
In Asia, asiatech@miranda.com
In China, asiatech@miranda.com

• Website: http://www.miranda.com
• Mail Shipping

Miranda GVD Miranda GVD
P.O. Box 1658 125 Crown Point Court
Nevada City, CA 95959, USA Grass Valley, CA 95945, USA 

Note Return Material Authorization (RMA) required for all returns.
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Change History
The table below lists the changes to the UniConfig User’s Guide.

• User’s Guide Part # UG0022-03

• Software version: 10.0.0 

Rev Date ECO Description Approved By

1.0 02 Oct 07 13619 Initial Release DEM, RH, GW

1.1 13 Feb 09 15573 Software update. Corrections. DEM, D.Cox

1.2 31 Mar 09 15703 Format change. D.Cox

1.3 14 Dec 09 16272 Added EC9535 configuration, monitor connections. DEM
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Important Safeguards and Notices
This section provides important safety guidelines for operators and service personnel. Specific 
warnings and cautions appear throughout the manual where they apply. Please read and follow this 
important information, especially those instructions related to the risk of electric shock or injury to 
persons. 

Symbols and Their Meanings

The lightning flash with arrowhead symbol within an equilateral triangle alerts the user to the pres-
ence of dangerous voltages within the product’s enclosure that may be of sufficient magnitude to 
constitute a risk of electric shock to persons.

The exclamation point within an equilateral triangle alerts the user to the presence of important 
operating and maintenance/service instructions.

The Ground symbol represents a protective grounding terminal. Such a terminal must be connected 
to earth ground prior to making any other connections to the equipment.

The fuse symbol indicates that the fuse referenced in the text must be replaced with one having the 
ratings indicated.

The presence of this symbol in or on Miranda equipment means that it has been designed, tested 
and certified as complying with applicable Underwriter’s Laboratory (USA) regulations and rec-
ommendations.

The presence of this symbol in or on Miranda equipment means that it has been designed, tested 
and certified as essentially complying with all applicable European Union (CE) regulations and 
recommendations.

Warning Any instructions in this manual that require opening the equipment cover or 
enclosure are for use by qualified service personnel only. To reduce the risk of 
electric shock, do not perform any service other than that contained in the operat-
ing instructions unless you are qualified to do so.
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General Warnings

A warning indicates a possible hazard to personnel which may cause injury or death. Observe the 
following general warnings when using or working on this equipment:

• Heed all warnings on the unit and in the operating instructions.

• Do not use this equipment in or near water.

• This equipment is grounded through the grounding conductor of the power cord. To avoid elec-
trical shock, plug the power cord into a properly wired receptacle before connecting the equip-
ment inputs or outputs.

• Route power cords and other cables so they are not likely to be damaged.

• Disconnect power before cleaning the equipment. Do not use liquid or aerosol cleaners; use 
only a damp cloth.

• Dangerous voltages may exist at several points in this equipment. To avoid injury, do not touch 
exposed connections and components while power is on.

• Do not wear rings or wristwatches when troubleshooting high current circuits such as the power 
supplies.

• To avoid fire hazard, use only the specified fuse(s) with the correct type number, voltage and 
current ratings as referenced in the appropriate locations in the service instructions or on the 
equipment. Always refer fuse replacements to qualified service personnel.

• To avoid explosion, do not operate this equipment in an explosive atmosphere.

• Have qualified service personnel perform safety checks after any service.

General Cautions

A caution indicates a possible hazard to equipment that could result in equipment damage. Observe 
the following cautions when operating or working on this equipment:

• When installing this equipment, do not attach the power cord to building surfaces.

• To prevent damage to equipment when replacing fuses, locate and correct the problem that 
caused the fuse to blow before re-applying power.

• Use only the specified replacement parts.

• Follow static precautions at all times when handling this equipment.

• This product should only be powered as described in the manual. To prevent equipment dam-
age, select the proper line voltage on the power supply(ies) as described in the installation doc-
umentation.

• To prevent damage to the equipment, read the instructions in the equipment manual for proper 
input voltage range selection.

• Some products include a backup battery. There is a risk of explosion if the battery is replaced by 
a battery of an incorrect type. Dispose of batteries according to instructions.

• Products that have (1) no on/off switch and (2) use an external power supply must be installed 
in proximity to a main power output that is easily accessible.
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1. Preface

Chapter 1 provides an introduction to the UniConfig User’s Guide. The following topics are dis-
cussed: 

• Chapter Structure 

• The PDF Document 

• Terms, Conventions and Abbreviations 

Chapter Structure 
The following chapters provide detailed instructions for all aspects of Configuration Application: 

• Chapter 1, Preface, (this chapter) outlines easy ways to use this guide, provides a list of terms 
and conventions. 

• Chapter 2, Introduction, provides a functional description of the product.
• Chapter 3, UniConfig Basics, provides an overview of using UniConfig windows and menus.
• Chapter 4, Configuration Basics, provides an overview of configuration tasks.
• Chapter 5, Installation, provides instructions of installing UniConfig.
• Chapter 6, Setting Up Communication, provides instructions on setting up communication 

between UniConfig, the router, and the router control system.
• Chapter 7, Managing Control Cards on a Network, provides information about adding and 

removing routers from a network.
• Chapter 8, Managing Partitions and Signal Types, provides instructions on setting up and 

updating partitions.
• Chapter 9, Managing Switch Point Settings, provides instructions on setting up and updating 

switch point settings.
• Chapter 10, Managing Inputs and Outputs, provides instructions on performing takes and test-

ing of switching configurations.
• Chapter 11, Managing Machine Control Ports, provides instructions on setting up and updating 

machine control ports.
• Chapter 12, Configuring EC9535, provides information regarding the EC9535 router interface.
• Chapter 13, NV8500 Monitor Configuration and Operation, provides information regarding 

NV8500 input and output monitors.
• Chapter 14, Locating NVISION Routing Devices, provides instructions on locating devices 

connected to UniConfig.
• Chapter 15, Setting Gain and Inverting Polarity, provides instructions for setting gain and 

inverting polarity for NV7512 routers with a DSP module installed.
• Chapter 16, Removing Locks, provides instructions on setting and clearing locks.
• Chapter 17, Working With Salvos, provides instructions on creating and managing salvos.
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The PDF Document
• Chapter 18, Managing Protocols, provides instructions on loading protocols.
• Chapter 19, Viewing System Status, provides instructions on viewing system status.
• Chapter 20, Connection Reports and Logs, provides instructions on creating connection reports 

and using the ‘Logs’ window.
• Chapter 21, Glossary, presents a list of terms used in this User’s Guide.
• An Index is also provided for your reference. 

The PDF Document 
This guide is provided in PDF format, allowing you to use Acrobat’s “bookmarks” to navigate to 
any desired location. You can also easily print a hardcopy. Please note:

• Use the Table of Contents or the bookmarks page to jump to any desired section. 

• Many hyperlinks are provided within the chapters.

• Use the index to jump to specific topics within a chapter. Each page number in the index is a 
hyperlink.

• Use Acrobat’s ‘Go to Previous View’ and ‘Go to Next View’ buttons to retrace your complete 
navigational path. 

• Use the ‘First Page’, ‘Previous Page’, and ‘Next Page’, and ‘Last Page’ buttons to go to the 
first, previous, next, or last page within a PDF file. 

• Use Acrobat’s extensive search capabilities, such as the ‘Find’ tool and ‘Search’ tool to perform 
comprehensive searches as required. 

Terms, Conventions and Abbreviations 
The following conventions are used throughout this guide: 

• Notes, Cautions and Important messages are presented in note boxes.

• Entries written in bold-face or capital letters denote physical control panel buttons or GUI but-
tons. 

Click Apply to ... 

Press the SRC 12 button.

• Entries in single quotes denote a field name, page name or label.

The AES3 reference connection is labeled ‘AES3 REF 1’.

Note To display the navigation buttons, right-click the Tool Bar area, and check 
‘Navigation’.
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2. Introduction

UniConfig is a software application used to set up and modify configuration settings for Miranda 
routers and perform diagnostics. UniConfig runs on a unit external to the router, such as a PC, and 
communicates with the router through the router’s control card. UniConfig configures the router by 
configuring settings on the router control card. Configuration settings vary depending upon matrix 
type, the protocol in use, and the level of complexity of the router partitioning. 

Product Overview
UniConfig configures the router by configuring settings on the router control card. Configuration 
settings vary depending upon matrix type, the protocol in use, and the level of complexity of the 
router partitioning.

The router control card facilitates communication between an external control device—a router 
control system—and the router matrix hardware. Protocols are used to send commands from the 
router control system to the control card. The discussion throughout this chapter assumes that Uni-
Config is interacting with an Miranda router control system using Miranda’s proprietary control 
protocol. The Miranda protocol is always available through the Ethernet connections and serial 
‘CTRL 2’ connections. Other protocols are active on the serial ‘CTRL 1’ connection only. The con-
trol card allows only one third-party protocol to be loaded at any one time. For information on 
changing control system protocols, contact Miranda Technical Support. For contact information, 
see Technical Support Contact Information on page iii.

Storing Configuration Settings

Configuration settings are stored in non-volatile EEPROM (EE) memory located on the router 
motherboard. The EE memory stores all configuration settings entered through UniConfig, but not 
the matrix crosspoint switching data. Crosspoint data is stored on the control card in battery 
backed-up RAM. This allows a control card to be moved from one router to another and have the 
card properly initialize. When the card initializes in a new router, data is forwarded to the cross-
point array. Each control card has its own unique memory and must be configured separately. 

Utilities

UniConfig can be used to perform a variety of utilities, such as running diagnostics or viewing sys-
tem status. In addition, UniConfig can be used to test and update router crosspoint switching con-
figuration independent of the router control system.

UniConfig is periodically updated with new features and functionality. Contact Miranda for the lat-
est version of UniConfig. See Technical Support Contact Information on page iii.
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2. Introduction
Supported Routers
UniConfig Version

This document describes UniConfig version 8.3.0 communicating with a control card running cur-
rent firmware under Miranda protocol. Your specific version of UniConfig and control card firm-
ware/protocol may be very different. As a result not all features or functions detailed in this guide 
may be available on your system. Contact Miranda Technical Support for information on obtaining 
the latest versions of UniConfig and firmware for your situation. See Technical Support Contact 
Information on page iii.

Upgrading matrix control card firmware is only recommended if a specific feature or function you 
require is not provided by your current version. In some cases new hardware may be required to run 
the very latest firmware revision.

Supported Routers
UniConfig currently supports the following NVISION routers:

The NV3512 expandable digital audio router, the NV3064 multi-format router, and the NV6000 
series routers are not covered by this User’s Guide. Please contact Miranda Technical Support for 
assistance. See Technical Support Contact Information on page iii.

UniDiag

UniDiag is a legacy configuration application released prior to UniConfig. The NV3128 machine 
control router and the NV3256 machine control router use UniDiag. UniDiag has limited function-
ality and not all UniConfig procedures and functions apply directly to UniDiag. If configuring an 
older, legacy router (such as the NV3000 series), please contact Miranda Technical Support. See 
Technical Support Contact Information on page iii.

NVISION Router Control Card

NV5100 multi-format 128× 128 router EM0374

NV5128 multi-format 128×128 router EM0374

NV5256 256×256 port expandable machine control router EM0374

NV7256 digital audio 256×256 router
NV7256-Plus 256×256 expandable digital audio router

EM0374

NV7512 512×512 expandable digital audio router EM0374

NV8256-Plus 256×256 expandable digital video router EM0374

NV8288 digital video 288×288 router
NV8288-Plus 288×576 compact expandable digital video router

EM0529

NV8500 Family:
NV8144 digital video router 144×144
NV8280 digital video router 288×576
NV8280-Plus expandable digital video router 288×288
NV8576 digital video router 576×1152
NV8576-Plus expandable digital video router 576×576

EM0666

EC9535 GSC Node Bus Converter (no signal inputs or outputs) EM0374
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3. UniConfig Basics

UniConfig is a software application that runs on a unit external to the router, such as a PC, and 
communicates with the router through the router’s control card. The UniConfig interface is 
designed to enable you to manage all configuration tasks through standardized menus and win-
dows. 

The UniConfig Interface
The UniConfig screen is divided into sections. At the top is a menu bar featuring menu links. 
Below the menu bar individual windows display. If an Ethernet connection is being used to com-
municate with the router, an additional ‘Control Card’ pane displays in the left-hand section below 
the menu bar listing all control cards currently on the network.

Figure 3-1 shows an example of the UniConfig screen: 

Figure 3-1. Example of UniConfig Screen

UniConfig follows standard industry practices for IBM-based applications. This chapter assumes a 
knowledge of basic interface functions, such as using the mouse and keyboard to select items on a 

(Control Card
Pane. Displays
when Ethernet
connection
selected.)

Menu Bar Active Window
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3. UniConfig Basics
Working With UniConfig Windows
list or clicking GUI buttons. For detailed information on using the interface, see your operating sys-
tem’s Help.

Screen Appearance

The UniConfig screen size may be changed. To change the screen size, click on the lower, right cor-
ner of the UniConfig screen, and using your mouse, drag the edge until it is the size you want. Uni-
Config windows, that display within the UniConfig screen, do not change size during this process.

UniConfig remembers any changes made to screen sizing when closed. The next time UniConfig is 
launched, the screen appears the same size as when you lasted exited UniConfig.

Using the Menu Bar

UniConfig features a menu bar at the top of the window. (See Figure 3-1.) Each menu bar link 
opens a list of related options. Menu bar links and/or options change depending on the currently 
active window. A window must be active to activate related menu links and options. 

To selection a menu option, click on the menu bar link you want, and then from the list of options 
that display, click on the desired option. The related window or dialog box appears.

Working With UniConfig Windows
By default, when UniConfig launches all windows are opened and then minimized along the lower 
edge of the main screen, with the exception of the ‘Configuration’ window which remains open. 
(See Figure 3-1 on page 5.)

A window must be active in order to activate related menu bar links and options. To activate a win-
dow, from the menu bar, select ‘Window’ and then the name of the window. Or, click anywhere in a 
window. The window displays in front of any other open window. 

UniConfig windows can be minimized, but not closed. To minimize a window, click the X in the 
upper, right-hand corner of the window.

By default, windows are arranged in a cascading manner. To change how windows are arranged, 
from the menu bar, select ‘Window’ and then an arrangement option.

The following lists arrangement options:

Menu Option Description

Cascade Default setting. Window top bars are listed in a cascading 
series.

Tile Windows are arranged in a tiled format such that each 
window appears in miniature sandwiched between other 
windows.

Arrange Icons Enables you to arrange window icons in any order you 
want.
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3. UniConfig Basics
Working With UniConfig Windows
Control Cards Pane

The ‘Control Cards’ pane displays in the left-hand section of the UniConfig screen, as shown in 
Figure 3-1 on page 5. This pane only displays if an Ethernet connection between the router and 
UniConfig has been established. If you are only using a serial port for communication between the 
control card and UniConfig, and have not entered Ethernet settings for the control card, it does not 
appear in the ‘Control Cards’ pane. For more information, see Adding a Control Card to a Network 
on page 41.

The ‘Control Cards’ pane lists all control cards that have been manually added. Control cards are 
added by assigning each card an IP address (i.e., Ethernet settings). Control cards and the routers on 
which they reside must be on the same network as UniConfig. To select a control card on the net-
work, simply click on the control card name. To be part of a network, UniConfig and the control 
cards must have Ethernet connections and IP addresses. (See Managing Control Cards on a Net-
work on page 39.) 

To access a list of menu options for adding and updating control cards on the network, right-click 
on the control card node in the ‘Control Cards’ pane.

How to Open the ‘Control Cards’ Pane

1 Launch UniConfig. (See Launching UniConfig on page 9.)

2 From the menu bar, select ‘Communications > Ethernet’. The ‘Control Card’ pane appears as 
shown in Figure 3-1 on page 5. An Ethernet connection must be established to view the ‘Con-
trol Card’ pane. (See Entering Initial Serial and Ethernet Settings on page 26.)

3 On the ‘Control Cards’ pane, click on the name of a control card to select it.
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Working With UniConfig Windows
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4. Configuration Basics

UniConfig is used to configure the control card found on current Miranda routers. In most cases the 
router does not function properly until the control card has been configured.

Configuration choices vary depending on the specific router model and the communication proto-
col loaded on the control card. UniConfig automatically reads the router model and control card 
protocol to determine the appropriate menu options and interface windows to display.

This section covers what you need to know before proceeding with configuration tasks, including 
launching UniConfig, selecting a control card, and viewing and writing changes.

Before Starting Configuration
Before initiating configuration tasks, review the following check list of required items:

• The Miranda router has all input, output, crosspoint, and control cards installed. For details, see 
the router User’s Guide.

• A PC with UniConfig installed. See Installation on page 19.

• Power has been applied to all Miranda routers.

• All required reference signals have been connected. For details, see the router User’s Guide.

• The router control system that will be used to control the router is available and ready for con-
figuration. Router control system configuration is not covered by this User’s Guide. For details, 
refer to the router control system User’s Guide.

Launching UniConfig
To access UniConfig, the application is launched and a connection between the router and UniCon-
fig established. Connections to UniConfig can be through Ethernet or serial ports. When setting up 
communication parameters for the router and UniConfig, it is strongly recommended that Ethernet 
settings be entered and UniConfig and all routers placed on a network. (See Adding a Control Card 
to a Network on page 41.) This enables UniConfig and the connected routers to be accessed from 
any workstation. For more information on using Ethernet or serial connections, see Ethernet vs. 
Serial on page 21.

Before any communication can occur between UniConfig and a router, communication parameters 
must be set on the router control card. For instructions, see Entering Initial Serial and Ethernet Set-
tings on page 26.
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4. Configuration Basics
Selecting a Control Card
How to Launch UniConfig and Establish Communication

1 Click on the short-cut on your desktop or from the operating system ‘Start’ menu, select ‘Pro-
grams > UniConfig’. Refer to your operating system’s Help system for details.

2 Establish communication using an Ethernet or serial connection:

For an Ethernet connection:

a Connect the PC running UniConfig to the RJ45 Ethernet port of the router. For details, see 
the router User’s Guide.

b From the menu bar, select ‘Communications > Ethernet’. This informs UniConfig that com-
munication with the router is through an Ethernet port.

For a serial connection:

a Connect the PC running UniConfig to the router diagnostic serial ports. There are two types 
of serial ports: a temporary port on the control card and a permanent port on the router. See 
Control Card Serial Port (Temporary Connection) and Router Serial ‘DIAG’ Port (Perma-
nent Connection) on page 24.

b From the menu bar, select ‘Communications > Serial’. This informs UniConfig that com-
munication with the router is through a serial port.

Selecting a Control Card
Each control card on a router must be configured separately. This means connecting to and commu-
nicating with each specific control card. To connect to a control card, you can either use an Ethernet 
connection or a serial connection. It is recommended that an Ethernet connection be used for ease 
of use. For more information on using Ethernet connections and setting up communication between 
UniConfig and router control cards, see Entering Initial Serial and Ethernet Settings on page 26.

When performing tasks that involve a network, it is assumed that communication parameters for an 
Ethernet connection (IP address, etc.) have been set. (See Entering Initial Serial and Ethernet Set-
tings on page 26.) However, it is possible to perform network-related activities using a serial con-
nection. Serial ports are used to create a direct, physical connection to the control card itself using 
temporary serial ports or through serial ports on the router. See Control Card Serial Port (Tempo-
rary Connection) and Router Serial ‘DIAG’ Port (Permanent Connection) on page 24.

Control cards are selected using the ‘Control Cards’ pane or by making a physical connection to the 
router or control card using serial ports. Only control cards that have Ethernet settings configured 
display on the ‘Control Cards’ pane. (See Control Cards Pane on page 7.)

How to Select a Control Card

1 Launch UniConfig. (See Launching UniConfig on page 9.)

2 Depending on the connection being using to communicate between the router and UniConfig, 
select a control card, as follows:

If you are using an Ethernet connection, from the menu bar, select ‘Communications > Ether-
net’. The ‘Control Card’ pane appears, as shown in. (See Figure 3-1 on page 5.) On the ‘Control 
Cards’ pane, click on the name of a control card to select it.
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4. Configuration Basics
Viewing Configurations
Or

If you are using a serial connection, connect directly to the serial port for that control card using 
either the temporary port on the control card or the permanent port on the router and then from 
the menu bar, select ‘Communications > Serial’. See Control Card Serial Port (Temporary Con-
nection) and Router Serial ‘DIAG’ Port (Permanent Connection) on page 24. 

Viewing Configurations
Using the ‘Configuration’ window, configuration settings for a specific control card can be viewed 
at any time. Current configurations can be viewed by clicking Read All or by setting up the ‘Auto-
read’ function. By default, ‘Auto-read’ is enabled.

How to View Current Configuration Settings

1 Launch UniConfig. (See Launching UniConfig on page 9.)

2 Select a control card. (See Selecting a Control Card on page 10.)

3 From the menu bar, select ‘Windows > Configuration’. The ‘Configuration’ window appears: 

Figure 4-1. Example of Configuration Window

Depending on the router, an additional ‘Expansion’ section displays.

4 Click Read All. Current configuration settings populate the ‘Configuration’ window fields.

Or

Set up the Auto-read function. By default, ‘Auto-read’ is enabled:
UniConfig Configuration Application  •  User’s Guide 11



4. Configuration Basics
Writing Changes to the Control Card
a From the menu bar, select ‘Tools > Options’. The ‘Configuration Options’ dialog box 
appears: 

Figure 4-2. Configuration Options Dialog Box

b Check the ‘Auto refresh when selecting different node’ check box. By default this box is 
checked. When checked, whenever a control card is selected, UniConfig automatically 
updates the ‘Configuration’ window to display that control card’s settings. 

c Click OK to save changes and close the dialog box.

Or

Click Cancel to close the dialog box without saving changes.

Writing Changes to the Control Card
UniConfig does not save any changes. Instead, changes are written to EE memory on the mother-
board in the router frame. Each control card utilizes its own independent set of EE memory. This 
means that changes must be written to each control card separately. When written, changes are glo-
bal and immediately overwrite any previous settings. There is no way to undue a “write” action.

How to Write Changes

1 On the currently open UniConfig window in which changes have been made, click Write or 
Write All. If the changes are successfully written to the control card, a dialog box appears 
prompting you to reboot the control card.

Caution Once written, all previous values are overwritten and the changes cannot 
be undone.
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4. Configuration Basics
Applying Configurations to Another Control Card (Save As)
2 Click Yes to reboot the control card. All crosspoint settings are maintained during the reboot 
cycle but crosspoints cannot be changed until the control card has finished rebooting. 

Or

Click No to reboot at a later time. Changed settings are stored in non-volatile EE memory, but 
not copied into RAM for use by the control card. The system will continue to run using the pre-
vious settings until a reboot is performed.

Applying Configurations to Another Control Card (Save As)
Once a configuration has been created, the configuration settings can be applied to multiple control 
cards. This is similar to a “Save As” function where information from one control card is saved as 
the current information for another control card.

How to Apply a Configuration to Another Control Card

1 Launch UniConfig. (See Launching UniConfig on page 9.)

2 Select a control card. (See Selecting a Control Card on page 10.)

3 From the menu bar, select ‘Windows > Configuration’. The ‘Configuration’ window appears, 
as shown in Figure 4-1 on page 11. 

4 Click Read All. Current configuration settings for the selected control card populate the ‘Config-
uration’ window fields.

5 From the menu bar, select ‘Tools > Options’. The ‘Configuration Options’ dialog box appears: 

Figure 4-3. Configuration Options Dialog Box

6 Uncheck the ‘Auto refresh when selecting different node’ check box. By default this box is 
checked. When checked, whenever a control card is selected, UniConfig automatically updates 
the ‘Configuration’ window to display that control card’s settings. To have the currently dis-
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Viewing ‘Write All’ Sequence
played settings applied to another control card, this option must be deselected so that the current 
settings are not overwritten when another control card is selected.

7 Click OK to save changes and close the dialog box.

Or

Click Cancel to close the dialog box without saving changes.

8 Select the control card to which you want the current configuration settings applied. (See 
Selecting a Control Card on page 10.)

9 Important: If you are using an Ethernet connection, be sure to up the IP address in the ‘IP 
Address’ field on the ‘Configuration’ window. (See Figure 4-1 on page 11.) Each control must 
have a unique IP address. (See Updating Ethernet Communication Settings on page 30.)

10 On the ‘Configuration’ window, click Write All. The current configuration settings are sent to the 
currently selected control card.

Viewing ‘Write All’ Sequence
When making changes, it is sometimes beneficial to view current writing activity to know when the 
writing of data to the control card is complete.

How to View Write Sequence Progress

1 Launch UniConfig. (See Launching UniConfig on page 9.)

2 Select a control card. (See Selecting a Control Card on page 10.)

3 From the menu bar, select ‘Windows > Configuration’. The ‘Configuration’ window appears, 
as shown in Figure 4-1 on page 11. 

4 Click Read All. Current configuration settings for the selected control card populate the ‘Config-
uration’ window fields.

Note Do not click Read All. Whenever Read All is clicked, UniConfig reads configu-
ration settings from the currently selected control card and overwrites any 
previously displayed settings.
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Viewing ‘Write All’ Sequence
5 From the menu bar, select ‘Tools > Options’. The ‘Configuration Options’ dialog box appears: 

Figure 4-4. Configuration Options Dialog Box

6 Check the ‘Show advanced Serial EE settings’ check box. By default this box is not checked. 
When checked, more options appear: .

Figure 4-5. Configuration Options Dialog Box with Expanded Options

7 Check the ‘Display diagnostic screen during updates’ check box. The next time Write All is 
clicked, the ‘Serial EE Write Status’ dialog box displays the status of data being written to the 
control card.

8 Click OK to save changes and close the dialog box.

Or

Click Cancel to close the dialog box without saving changes.
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Applying Only Current Changes or All Settings
When making changes to configurations, you can choose to have only the most recent changes or to 
have all configurations settings, plus changes, written to the control card. Limiting changes that are 
written is helpful when trying to isolate a specific change behavior. Data is written to the control 
card when the Write All button is clicked on the ‘Configuration’ window.

How to Write Current or All Settings to the Control Card

1 Launch UniConfig. (See Launching UniConfig on page 9.)

2 Select a control card. (See Selecting a Control Card on page 10.)

3 From the menu bar, select ‘Windows > Configuration’. The ‘Configuration’ window appears, 
as shown in Figure 4-1 on page 11. 

4 Click Read All. Current configuration settings for the selected control card populate the ‘Config-
uration’ window fields.

5 From the menu bar, select ‘Tools > Options’. The ‘Configuration Options’ dialog box appears: 

Figure 4-6. Configuration Options Dialog Box
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6 Check the ‘Show advanced Serial EE settings’ check box. By default this box is not checked. 
When checked, more options appear: .

Figure 4-7. Configuration Options Dialog Box with Expanded Options

7 In the ‘Serial EE data updates’ section, select what data is sent to the control card when Write All 
on the ‘Configuration’ window is clicked:

Select the ‘Write only changes’ radio button to apply only the most current changes to the con-
trol card.

Or

Select the ‘Write all’ radio button to apply all configuration settings, whether currently updated 
or not, to the control card.

8 Click OK to save changes and close the dialog box. 

Or

Click Cancel to close the dialog box without saving changes.
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5. Installation

This chapter provides information on installing UniConfig. UniConfig is an application that runs on 
a PC connected to the router being configured.

Preparing for Installation
You will need a PC with the following features to install UniConfig: 

You will need the following items to use UniConfig: 

Installing UniConfig
UniConfig is a software application used to configure router settings. UniConfig runs on a PC con-
nected to the router. UniConfig communicates with the router through the router’s diagnostic con-
nections. 

How to Install UniConfig
1 Obtain the Router and Control System CD (SB0033) and insert in your CD drive. 
2 Open the CD’s top-level directory. Then open the ‘Software’ sub-folder. Find 

UniConfig_Install.exe. That is the installer. (You may copy the file to your hard drive if you 
want.) Double-click the installer, either on the CD or on your hard drive.

Windows® 2000, or Windows XP Professional.® UniConfig will not run under any 
version of the Macintosh or Linux OS. 

A late model Pentium-class processor, such as a Pentium III (or later) or an AMD 
Athlon.

At least 90 MB of disk space.

A CD drive

256 MB or more RAM.

At least one RS-232 or RS-422 serial port capable of running at speeds up to and 
including 115.2 kBaud. Note that many USB serial adapters do not function correctly 
at higher Baud rates. 

A 10baseT or, preferably, a 10/100baseT Ethernet port that can use a fixed IP address 
on the same subnet as your NVISION series routers and control panels.

100 Mb/s Ethernet switch with at least 4 ports. 

Ethernet cables (category 5 or better).

Straight-through RS-232 or RS-422 serial cable(s). 
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Installing UniConfig
3 The UniConfig installer will launch: 

Figure 5-1. UniConfig Installer Window

4 Follow the instructions, clicking ‘Next’ to proceed from step to step. The actual installation 
takes about 30 seconds. By default, the installer creates an entry in the Windows ‘Start’ menu 
and also creates a shortcut on your desktop: 

Figure 5-2. Shortcut Icon

The default pathname is: 
C:\Program Files\NVision\NV_UniConfig\UniConfig.exe

The default path in the Windows Start menu is: 

Programs > NVision > UniConfig
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6. Setting Up Communication

The control card communicates with UniConfig through an Ethernet or serial port located on the 
rear of the router, or through the serial port located on the control card. In order for the control card 
and UniConfig to communicate through an Ethernet or serial port located on the router, the ports 
need to be initialized. Initialization is performed by setting the necessary information on the control 
card using UniConfig.

Because the router Ethernet and rear serial port settings are unknown, a port with fixed setting of 
9600 Baud is provided on the front edge of the control card. After the ports are initialized, commu-
nication between UniConfig and the router can occur through an Ethernet connection, through the 
serial port on the control card, or through the serial ports located on the rear of the router, labeled 
‘DIAG’. (See Entering Initial Serial and Ethernet Settings on page 26.)

This section provides information about setting up and managing communication between the 
router and UniConfig. For information on setting up EC9535 communication, see Entering Initial 
EC9535 Serial and Ethernet Settings on page 118.

Communicating with the Router for the First Time
Before UniConfig can establish communication with the router, the communication ports need to 
be initialized. Initialization is performed using UniConfig. To enter initial settings, a serial port is 
provided on the front edge of the control card. This port has fixed settings that match default serial 
port settings in UniConfig to establish immediate communication without having to initialize the 
port first. For instructions on establishing this connection, see Control Card Serial Port (Temporary 
Connection) on page 23.

Initialization has two basic parts: entering settings for the router and entering settings for UniCon-
fig. Settings are entered for each control card individually, and for Ethernet and serial ports sepa-
rately.

Ethernet vs. Serial

There are advantages and limitations to using Ethernet or serial connections to communicate with 
UniConfig. Miranda recommends using an Ethernet connection for ease of use and faster download 
speeds.

Note Each control card utilizes its own independent set of EE memory on the mother-
board in the router frame. UniConfig must be used to configure each control card 
in the system separately even if the control card is part of a redundant pair.
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Communicating with a Router Control System
The following points list the differences between Ethernet and serial connections:

Ethernet

• Can select a control card by simply selecting it on the ‘Control Card’ pane in the UniConfig 
screen. 

• UniConfig and control cards can be accessed through any workstation on the network.
• If updating control card firmware, the Ethernet’s higher speed makes downloads much faster.
• If the control card IP address is unknown, you must use a serial connection to determine it and/

or initially set it.

Serial

• Serial communication is limited to one control card at a time; a cable must be physically moved 
from one control card to the next.

• Very simple to establish communication between host PC and control card, especially using the 
temporary serial port on the control card itself.

• In most instances, it is necessary to use a serial connection to initially configure functionality. It 
is also recommended for configuration updates because port has fixed, known settings (9600 
baud, 8 data bits). 

• The permanent diagnostic ports on the rear of the router are best used when upgrading firmware 
or application code residing on the control card and there is no Ethernet connection to the 
router.

Communicating with a Router Control System
The router control system can communicate through an Ethernet port or through serial ports, 
labeled ‘CTRL 1’ and ‘CTRL 2’, on the rear of the router (For more information, see the router 
User’s Guide). Depending on the protocol loaded onto the control card, UniConfig provides limited 
configuration options for the ports.

Currently, Ethernet is only supported when the Miranda protocol is loaded onto the control card. 
Similarly, certain protocols offer the ability to configure Baud rate and/or communication parame-
ter for the serial ports while others do not. Depending on the protocol loaded, the related fields are 
active, inactive (grayed-out) or do not display. If the protocol currently loaded on the control card 
enables an action, the related Ethernet or serial port configuration fields are active and display.

Third-party protocols affect only the ‘CTRL 1’ serial port located on the rear of the router. The 
‘CTRL 2’ port always supports Miranda protocols. The control card supports dual, simultaneous 
control so that it is possible to connect a third-party router control system to ‘CTRL 1’ and an 
Miranda router control system, such as the NV9000 (or other devices capable of running Miranda 
serial protocol) to ‘CTRL 2’. For more information, see the router User’s Guide.

Note The NV8288, NV8288-Plus and NV8500 Family routers have only a rear diag-
nostic port, which is fixed at 38.4 K. This enables the rear port to double as a tem-
porary connection to the control card, as well as a permanent connection.
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SMS7000 Note
Miranda supports communication with the SMS7000 router control system. The SMS7000 uses a 
set of very specific switching and configuration rules. When SMS7000 protocol is loaded onto the 
control card, the number of partitions available in UniConfig is restricted to two. Additionally a 
communications mezzanine module must be installed on the control card to support the SMS GSC 
Node Bus connector. This connector affects the behavior of the ‘CTRL 1’ port. 

For those Miranda routers that do not have a GSC Node Bus connector (i.e., NV8288, NV8288-
Plus and the NV8500 Family), an EC9535 GSC Node Bus Converter may be used. For more infor-
mation, contact Technical Support. See Technical Support Contact Information on page iii.

Communicating with the Router Through Serial Ports
UniConfig can communicate with the router through Ethernet or serial ports. There are two types of 
serial ports: one on the control card and one on the rear of the router. The control card serial port is 
located on the front of each control card and is a temporary connection. In other words, you create 
the connection as needed. The other serial ports are located on the rear of the router, labeled 
‘DIAG’ and are permanent; these connections once created are usually left connected. Miranda rec-
ommends using the control card serial port when configuring or reconfiguring the router because 
the port has fixed communication parameters. In addition, because it is on the control card itself, it 
is easy to establish communication with the exact control card you want to update. The permanent 
ports are usually used for upgrading firmware or control card protocols when there is no Ethernet 
connection to the router. 

For more information about control cards and diagnostic connections, see your router’s User’s 
Guide.

EC9535 Note
The EC9535 GSC Node Bus Converter enables a SMS7000 system controller to communicate with 
Miranda routers that do not have a GSC Node Bus connector. For information on setting up 
EC9535 serial ports, see Entering Initial EC9535 Serial and Ethernet Settings on page 118.

Control Card Serial Port (Temporary Connection)
A temporary connection between a router and UniConfig can be instantly created through the DE9 
serial port located on the front of the control card. This connection is set to a fixed rate of 
9600 Baud.

Note The NV8288, NV8288-Plus and NV8500 Family routers have only a rear diag-
nostic port, which is fixed at 38.4 K. This enables the rear port to double as a tem-
porary connection to the control card, as well as a permanent connection. See 
Router Serial ‘DIAG’ Port (Permanent Connection) on page 24.
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How to Make a Temporary Serial Connection

1 Locate the primary control card slot. The control card is accessed through the front of the router 
when the router door is open. See your router user’ guide for details.

2 On the front of the control card, connect to the DE9 connection using a DE9 connector and a 
serial cable set for EIA-232. 
The following lists the wiring for the DE9 pin connectors for RS-232:

3 Connect the other end of the cable to the hardware running the UniConfig application using a 
DE9 connector. (See Installing UniConfig on page 19.)

Router Serial ‘DIAG’ Port (Permanent Connection) 
There are two permanent serial ports located on the router, labeled ‘DIAG’: one primary (‘PRI 
CTRL’) and one secondary (‘SEC CTRL’). The primary control port connects to the primary con-
trol card. The secondary control port connects to the secondary (optional for redundancy) control 
card. By default, the ports are typically set to 38400 baud, RS-232, but can be set to RS-422 using 
UniConfig. (See Updating Serial Communication Settings on page 30.)

If you are using a permanent serial port to communicate with UniConfig, it is best to set the com-
munications parameters to the highest baud rate possible to minimize the time required to down-
load the code.

Hardware End Pin Router End 

DCD 1 Ground

RXD 2 TXD

TXD 3 RXD

DTR 4 DSR

Signal Ground 5 Signal Ground

DSR 6 DTR

RTS 7 CTS

CTS 8 RTS

Ground 9 Ground

Note The NV8288, NV8288-Plus and NV8500 Family routers have only a rear diag-
nostic port. This enables the rear port to double as a temporary connection to the 
control card, as well as a permanent connection. See Control Card Serial Port 
(Temporary Connection) on page 23.
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How to Make a Permanent Diagnostic Connection

1 Locate the permanent serial ports on the rear of the router, as shown in Figure 6-1. The ports are 
labeled ‘DIAG’: 

Figure 6-1. Diagnostic Connections (Rear View)

2 Connect to the ‘DIAG’ connection in the ‘PRI CTRL’ section using a DE9 connector and a 
serial cable. By default, the ports are typically set for RS-232:
The following lists the wiring for the DE9 pin connectors for RS-232:

For all routers except the NV8288, NV8288-Plus and NV8500 Family, the DE9 connector can 
be set for RS-422, but settings changes will need to be made in UniConfig. For more informa-
tion, see Updating Serial Communication Settings on page 30. The NV8288, NV8288-Plus and 
NV8500 Family routers are always set to RS-232 8, N, 1.
The following lists the wiring for the DE9 pin connectors for RS-422:
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Hardware End Pin Router End

DCD 1 Ground

RXD 2 TXD

TXD 3 RXD

DTR 4 DSR

Signal Ground 5 Signal Ground

DSR 6 DTR

RTS 7 CTS

CTS 8 RTS

Ground 9 Ground

Hardware End Pin Router End 

Ground 1 Ground

Receive – 2 Transmit –

Transmit + 3 Receive +

Transmit Common 4 Receive Common

N/C 5 N/C

Receive Common 6 Transmit Common

Receive + 7 Transmit +

Transmit – 8 Receive –

Ground 9 Ground
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3 Connect the other end of the cable to the hardware running the UniConfig application.

Entering Initial Serial and Ethernet Settings
Using UniConfig, communication parameters are entered that enable the router to communicate 
with UniConfig, and the router control system to communicate with the router. To set communica-
tion parameters, several steps must be performed:

1 Serial connection settings are entered for the router and the router control system.

2 Serial connection settings are entered for UniConfig.

3 Ethernet connection settings are entered for the router so that the router can communicate over 
a network. These settings are used by the router control system if the router control system uses 
an Ethernet connection.

4 Ethernet connection settings are entered for UniConfig so that UniConfig can communicate 
with the router control cards through a network. Routers are added to a network through a sepa-
rate procedure. (See Adding a Control Card to a Network on page 41.)

Although you can choose to only communicate with the router and/or router control system using a 
serial connection, both Ethernet and serial communication parameters are provided in the proceed-
ing procedure. It is strongly recommended that an Ethernet connection between the router and Uni-
Config be established for ease of use and efficiency. (See Ethernet vs. Serial on page 21.)

How to Enter Communication Parameters

1 Connect to the temporary diagnostic connection on the primary control card. (See Control Card 
Serial Port (Temporary Connection) on page 23.) The Baud rate is fixed at 9600.

2 Launch UniConfig. (See Launching UniConfig on page 9.)

3 From the menu bar, select ‘Communications > Serial’. This informs UniConfig that communi-
cation with the router is through a serial port.

4 Again from the menu bar, select ‘Communication > Setup’. The ‘Serial Communications’ dia-
log box appears: 

Figure 6-2. Serial Communication Dialog Box

The ‘Serial Communications’ dialog box sets the serial communication parameters for UniCon-
fig. By default the ‘Comm port’ is set to ‘None’ and the ‘Baud rate’ is set to ‘9600’, matching 
the settings of the control card serial port.
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5 From the ‘Comm port’ drop-down list, select the communication port number that matches the 
port number on the PC running UniConfig and click OK.

Or

Click Cancel to close the dialog box without saving changes.

6 Again from the menu bar, select ‘Windows > Router Serial Configuration’. The ‘Router Serial 
Configuration’ window appears: .

Figure 6-3. Router Serial Configuration Window

The ‘Router Serial Configuration’ window sets serial communication parameters for the router 
control system (‘Control Settings’ sections) and for the permanent serial connection labeled 
‘DIAG’ located on the rear of the router (‘Rear Diagnostic Port’). 

7 On the ‘Router Serial Configuration’ window, select settings as follows. If a serial connection is 
not being used for the router control system, skip steps a, b, and c and go directly to step d:

a From the ‘Baud Rate’ drop down list, select a baud rate. By default the baud rate is set to 
38400.

b In both the ‘Control 1 Settings’ section and the ‘Control 2 Settings’ section, from the drop-
down list select ‘enabled’ for ‘Control 1 (Main)’ and select ‘enabled’ ‘Control 2 (Aux) 
Port’. By default, the ports are set to ‘enabled’.

‘Control 1’ corresponds to the ‘PRIMARY CONTROL’ ‘CTRL 1’ serial connection and 
‘Control 2’ corresponds to the ‘PRIMARY CONTROL’ ‘CTRL 2’ serial connection. For 
more information, see your router User’s Guide.

c In both the ‘Control 1 Settings’ section and the ‘Control 2 Settings’ section, select a ‘Reply 
when’ option from the drop-down lists provided. By default, ‘enabled’ and ‘always’ are 
selected. 

‘Reply when’ determines how the control card responds to queries and commands sent 
through the ‘CTRL’ ports: 
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• ‘Always’ configures the control card to respond to queries and commands even if it is 
not the currently active control card.

• ‘Active’ configures the control card to respond to queries and commands only when it is 
the currently active control card.

d In the ‘Rear Diagnostic Port’ section, select a ‘Port type’ and ‘Baud rate’ from the drop-
down lists provided. By default, ‘RS232’ and ‘38400’ are selected. This sets the communi-
cation parameters for the permanent serial ports on the router.

e Click Write to write changes to the control card, overwriting any previous settings.

8 Again from the menu bar, select ‘Window > Configuration’. The ‘Configuration’ window 
appears, as shown in Figure 6-4. Using this window, enter Ethernet connection settings (i.e., IP 
address and subnet) to enable communication with the router through a network. 

Figure 6-4. Configuration Window

The ‘Configuration’ window sets Ethernet communication parameters (IP address and subnet 
mask) for the router control system and router. 

9 On the ‘Configuration’ window, select settings as follows:

a Click Read All. The ‘Configuration’ window populates with the current router configuration 
and Ethernet settings. Because no prior configuration is stored, many of the fields are blank.

b In the ‘Router Ethernet Settings’ section, choose the ‘Enabled’ radio button. ‘Enabled’ must 
be selected to allow Ethernet communication.

Warning Do not click Read. Clicking Read reads all settings on the control card, 
overwriting any changes you have entered. There is no warning message.
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c In the ‘Router Ethernet Settings’ section, enter an ‘IP Address’ and ‘Subnet Mask’ in the 
fields provided as determined by your network. Make sure that the unit (e.g., PC) running 
UniConfig is configured to operate on the same subnet as the control card(s).

For details on what IP addresses to use and additional network information, see Network 
Basics on page 39.

d Click Write All to write changes to the control card, overwriting any previous settings.

10 Again from the menu bar, select ‘Communication > Ethernet’. This informs UniConfig that 
communication with the router is through an Ethernet port. The ‘Control Card’ pane appears on 
the left-hand side of the UniConfig screen. Be sure all Ethernet cables are connected to the 
router and UniConfig PC.

11 Again from the menu bar, select ‘Communication > Setup’. The ‘Ethernet Communication’ dia-
log box appears: 

Figure 6-5. Ethernet Communication Dialog Box

The ‘Ethernet Configuration’ window sets Ethernet communication parameters (IP address) for 
UniConfig. 

12 On the ‘Ethernet Communication’ dialog box, select settings as follows:

a Enter an ‘IP Address’ for the router control card in the field provided. Make sure that the 
unit (e.g., PC) running UniConfig is configured to operate on the same subnet as the control 
card(s). For details on what IP addresses to you and additional network information, see 
Network Basics on page 39.

b Click OK to save changes and close the dialog box.

Or

c Click Cancel to close the dialog box without saving changes.

13 If a secondary (optional for redundancy) control card is installed, make a temporary connection 
to the secondary control card and repeat steps 2 though 12.

Note Be sure to change Ethernet settings for both the router and UniConfig. Uni-
Config and the router must be on the same subnet to successfully commu-
nicate.

Note The ‘Log Comm Messages’ check box is used for creating a log when per-
forming troubleshooting tasks. Do not check the check box.
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Updating Ethernet Communication Settings
Ethernet ports can be used by a router to communicate with UniConfig and/or a router control sys-
tem. Settings for the Ethernet ports can be updated at any time. Be sure that the updated settings are 
compatible with your facility and network.

When updating Ethernet communication settings, be sure to change Ethernet settings for both the 
router and UniConfig so that UniConfig can communicate using the new IP address entered in the 
router.

For information on adding control cards to a network or establishing a gateway, see Managing Con-
trol Cards on a Network on page 39.

How to Update Ethernet Communication Settings

1 Launch UniConfig. (See Launching UniConfig on page 9.)

2 Select a control card. (See Selecting a Control Card on page 10.)

3 Update Ethernet settings as described in steps 8–10, under Entering Initial Serial and Ethernet 
Settings on page 26.

4 A dialog box appears asking if you want to reboot. Reboot at this time.

5 Repeat steps 2–4 for each control card being updated.

Updating Serial Communication Settings
Serial ports can be used by a router to communicate with UniConfig and/or a router control sys-
tem.Settings for the serial communication ports can be updated at any time.

To update communication parameters, either a serial or an Ethernet connection can be used. The 
serial parameters can be updated from Ethernet mode at anytime.

How to Update Serial Communication Settings

1 Launch UniConfig. (See Launching UniConfig on page 9.)

2 Select a control card. (See Selecting a Control Card on page 10.)

3 Update serial settings as described in steps 3–7, under Entering Initial Serial and Ethernet Set-
tings on page 26.

4 A dialog box appears asking if you want to reboot. Reboot at this time.

5 Repeat steps 2–4 for each control card being updated.

Note Each control card must be updated separately.

Note Each control card must be updated separately.
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Retaining Serial Port Settings
Once serial port settings are entered or updated, UniConfig can be directed to remember the most 
current settings entered. (See Entering Initial Serial and Ethernet Settings on page 26.) Serial port 
settings are the ‘Comm port’ and ‘Baud rate’ that display in the ‘Serial Communication’ dialog box 
as shown: 

Figure 6-6. Serial Communication Dialog Box

How to Retain the Most Current Serial Communication Settings

1 Launch UniConfig. (See Launching UniConfig on page 9.)

2 Select a control card. (See Selecting a Control Card on page 10.)

3 From the menu bar, select ‘Tools > Options’. The ‘Configuration Options’ dialog box appears: 

Figure 6-7. Configuration Options Dialog Box

4 Check the ‘Retain serial port settings’ check box. By default this box is checked.

5 Click OK to save changes and close the dialog box.

Or

Click Cancel to close the dialog box without saving changes.

6 Repeat steps 2 through 5 for each control card being updated.
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Viewing Current Communication Settings
Settings for Ethernet or serial communication ports can be viewed at any time. 

Viewing Serial Settings for UniConfig

Serial communication settings display in a separate ‘Serial Communication’ dialog box. You can 
choose to have UniConfig retain the most current settings entered. See Retaining Serial Port Set-
tings on page 31.

How to View Current UniConfig Serial Communication Settings

1 Launch UniConfig. (See Launching UniConfig on page 9.)

2 Select a control card. (See Selecting a Control Card on page 10.)

3 Again from the menu bar, select ‘Communication > Setup’. The ‘Serial Communications’ dia-
log box appears displaying current ‘Comm port’ and ‘Baud rate’ settings: 

Figure 6-8. Serial Communication Dialog Box

4 Click Cancel to close the dialog box.

Viewing Serial Settings for the Router

Serial communication settings for the router display in the ‘Router Serial Configuration’ window. 

How to view current router serial communication settings

1 Launch UniConfig. (See Launching UniConfig on page 9.)

2 Select a control card. (See Selecting a Control Card on page 10.)
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3 Again from the menu bar, select ‘Windows > Router Serial Configuration’. The ‘Router Serial 
Configuration’ window appears: .

Figure 6-9. Router Serial Configuration Window

4 Click Read. The current serial connection settings display in the fields provided.

Viewing Ethernet Settings for UniConfig

Ethernet communication settings for UniConfig display in a separate ‘Ethernet Communication’ 
dialog box.

How to View Current UniConfig Ethernet Communication Settings

1 Launch UniConfig. (See Launching UniConfig on page 9.)

2 Select a control card. (See Selecting a Control Card on page 10.)

3 From the menu bar, select ‘Communication > Ethernet’. This informs UniConfig that commu-
nication with the router is through an Ethernet port. The ‘Control Card’ pane appears on the 
left-hand side of the UniConfig screen.

4 Again from the menu bar, select ‘Communication > Setup’. The ‘Ethernet Communication’ dia-
log box appears: 

Figure 6-10. Ethernet Communication Dialog Box

The current IP address displays in the ‘IP Address’ field.
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5 Click Cancel to close the dialog box.

Viewing Ethernet Settings for the Router

Ethernet communication settings for the router display in the ‘Configuration’ window. UniConfig 
displays either basic settings, such as IP address and subnet mask, or advanced settings, such as 
gateway information. For information on entering gateway settings, see Setting Up a Gateway on 
page 45.

How to View Basic Ethernet Communication Settings

1 Launch UniConfig. (See Launching UniConfig on page 9.)

2 Select a control card. (See Selecting a Control Card on page 10.)

3 Again from the menu bar, select ‘Communications > Setup’. The ‘Configuration’ window 
appears: 

Figure 6-11. Configuration Window

4 Click Read All. The ‘Configuration’ window populates with the current router configuration and 
Ethernet settings.

How to View Expanded Ethernet Communication Settings

1 Launch UniConfig. (See Launching UniConfig on page 9.)

2 Select a control card. (See Selecting a Control Card on page 10.)

3 From the menu bar, select ‘Windows > Configuration’. The ‘Configuration’ window appears, 
as shown in Figure 6-4. 
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4 Click Read All. Current configuration settings for the selected control card populate the ‘Config-
uration’ window fields.

5 From the menu bar, select ‘Tools > Options’. The ‘Configuration Options’ dialog box appears: 

Figure 6-12. Configuration Options Dialog Box

6 Check the ‘Show advanced Ethernet settings’ check box. By default this box is not checked.

7 Click OK to save changes and close the dialog box.

Or

Click Cancel to close the dialog box without saving changes.
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8 The ‘Configuration’ window displays advanced settings in the ‘Router Ethernet Settings’ sec-
tion: 

Figure 6-13. Example of Configuration Window with Expanded Ethernet Settings Displaying

9 (Optional) Enable a gateway. See Setting Up a Gateway on page 45.

Removing Communication Parameters
At times you may want to remove the ability for UniConfig to communicate with a router. If you 
are using only a serial connection, simply remove any physical connections between the router, 
control card, and UniConfig. 

If UniConfig is communicating with the router through an Ethernet port, the port must be disabled. 
To do this, each control card on the router must have all communication parameters removed. 

How to Remove a Control Card from the Network

1 Launch UniConfig. (See Launching UniConfig on page 9.)

2 Select a control card. (See Selecting a Control Card on page 10.)

3 From the menu bar, select ‘Windows > Configuration’. The ‘Configuration’ window appears, 
as shown in Figure 6-4.

4 (Optional) Click Read All. The ‘Configuration’ window populates with the current router config-
uration and Ethernet settings.

5 In the ‘Router Ethernet Settings’ section, select the ‘Disable’ radio button. This disables the 
control card from being able to communicate with UniConfig through the Ethernet.

6 Repeat steps 2–5 for each control card being removed.
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Selecting Bus for Serial Router Control System Connection
When more than one control card is installed in a router, the control cards communicate with each 
other using an internal bus. If the router can be connected to another router for expansion purposes 

— the NV5256, NV7256-Plus, NV7512, NV8256-Plus, NV8288-Plus and NV8500 Family (in 
expanded mode) — the internal bus is used only in standalone mode (i.e., the router is not connected 
to another router). When the router is connected to another router, communication between the con-
trol cards occurs through a bus in the 10Base2 loop-thru connections on the rear of the router 
frame. The 10base2 connection is used to enable multiple routers to communicate with a router 
control system. For more information on router expansion and the 10Base2 connection, see the 
router User’s Guide. For the NV8288-Plus and NV8500 Family (in expanded mode), only the inter-
nal bus option is available.

The ‘Configuration’ window displays a ‘Control Card Bus’ section. This section enables you to 
select the type of bus being used by the control card: 10Base2 connection bus if connected to 
another router, or the internal bus if in standalone mode.

How to Select a Bus

1 Launch UniConfig. (See Launching UniConfig on page 9.)

2 Select a control card. (See Selecting a Control Card on page 10.)

3 Again from the menu bar, select ‘Communications > Setup’. The ‘Configuration’ window 
appears: 

Figure 6-14. Example of a Configuration Window with Control Card Bus Section
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4 Select the ‘10bse2’ or ‘Internal’ radio button:

10Base2 — Informs UniConfig that the multiple routers are connected and internal control card 
communication is through the 10Base2 connection.

Internal — Informs UniConfig that the router is in standalone mode and internal control card 
communication is through an internal bus.

5 Click Write All to send changes to the control card.

6 Repeat steps 2–5 for each control card being updated.
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Although a serial connection can be used to communicate between the router and the router control 
system, it is strongly recommended that an Ethernet connection be implemented. An Ethernet con-
nection enables UniConfig, the router control cards, and the router control system to communicate 
through a network. This means that UniConfig can communicate with any router through any work 
station on the network. Additionally, commands or data are transmitted and processed through 
Ethernet connections at a much higher speed than serial connections. This is especially important 
when upgrading firmware or updating protocols. The files required to do this can be quite large and 
may take a long time to load using a serial connection to the router; the Ethernet interface signifi-
cantly reduces the time needed.

This section discusses how to add, update, and remove control cards from a network and UniConfig 
control.

Using Ethernet or Serial Connection
For routers to communicate with UniConfig through a network, each control card on the router is 
assigned an IP address and subnet mask. In general, it is assumed that if a control card is added to a 
network that communication between the control card and UniConfig is through Ethernet ports. 
However, it is possible to add and update control cards using a serial connection. For example, if 
you want to change the IP address for a control card, you can connect to that control using a tempo-
rary serial port connection and update control card Ethernet settings. (See Control Card Serial Port 
(Temporary Connection) on page 23.)

Control cards that reside on a network are listed in the ‘Control Cards’ pane. Using this pane you 
can see all control cards currently on the network. (See Control Cards Pane on page 7.)

Network Basics
For devices to communicate on a network, all devices must reside on the same subnet. The subnet 
is determined by the first three octets in the IP address. These are analogous to Country, City, and 
Street. The fourth octet, analogous to the street address, is unique for every device on the subnet.

Each control card, including any secondary, redundant control cards, must have a unique IP address 
to function correctly. The IP address must be valid for the connection between the host PC running 
UniConfig and the communications between the routers and the router control system.

IP Addresses
An IP address is comprised of four octets each with a possible value of 0 to 255. Zero (0) and 255 
are reserved for specific uses and must not be used in any part of an IP address, leaving a range of 1 
through 254. 
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IP addresses must be entered as fixed addresses using UniConfig. Dynamically generated IP 
addresses, such as those created by a DHCP (Dynamic Host Connection Protocol), cannot be used 
because DCHP servers only assign IP addresses from a pre-configured pool and the control card 
software does not know how to negotiate with a DHCP server. It is unlikely the pool of addresses 
matches the range chosen for your router subnet, thereby causing communication to fail because 
the PC and router(s) are on different subnets.

In addition to IP addresses, many networks support the use of plain English names for devices on 
the network. These are usually managed by a name server using DNS (Dynamic Name Service), 
WINS (Windows Integrated Name Service), or similar. Miranda routers and UniConfig do not sup-
port any plain text naming. Any name service must be disabled or turned off on subnets used for 
router communication. The router network should be a closed, private network.

IP addresses are divided into classes. Specific classes are intended for different functions. For 
example, IP addresses on the 192.168.x subnet are known as class C addresses and are intended for 
use in private closed networks. This range is recommended for use with all Miranda products using 
a fixed IP structure.

In lieu of specific IP addresses provided by your IT administrator, Miranda suggests the following 
IP address settings for the control cards:

The host PC should be set to the following IP address: 192.168.1.19.

If the host PC is already connected to a network, it may not be practical to change the assigned IP 
address settings. Many facilities dedicate a PC to maintenance functions, allowing the network set-
tings to be changed as needed. If this is not practical for your setup, Miranda recommends installing 
a second network card in the PC that is connected to the subnet containing the routers. This keeps 
any existing network settings as configured and allows a fixed IP address, as well as any other 
required network settings, to be entered on the new network interface card or NIC.

Check with your IT administrator before adding a NIC to any PC already set up with a network 
connection. This new NIC may interfere with Windows bindings or other network settings if not 
added correctly.

Subnet Mask
The subnet mask does exactly as its name implies — it masks off a portion of the IP address range. 
Miranda recommends that the subnet mask be set to 255.255.255.0. 

Devices that reside on the same subnet must be connected together in some fashion such that they 
may communicate with each other. When only two devices are present (for example, the host PC 
and only one router control card) an Ethernet crossover cable may be used between the devices.

Router Number Primary Control Card Secondary Control Card

1 192.168.1.5 192.168.1.6

2 192.168.1.7 192.168.1.8

3 192.168.1.9 192.168.1.10

4 192.168.1.11 192.168.1.12

and so on
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Using Hubs

When several devices must be interconnected, a network hub or switch is required. Hubs and 
switches route data from any one port to all other ports, and receive data from any port. All 
Miranda products support communication at 100 Mb/s. When selecting a hub or switch make sure it 
works at this speed and that it has one port for every device you intend to connect.

Adding a Control Card to a Network
Routers are added to a network by using UniConfig to assign each control card in each router a 
unique IP address and a subnet mask. Be sure all IP addresses are compatible with your network.

How to Add a Control Card to a Network

1 On the PC hosting UniConfig, assign an IP address and subnet mask to the unit (e.g., PC) host-
ing the UniConfig application on the network. Miranda recommends that the subnet mask be set 
to 255.255.255.0.

The subnet mask should be the same as entered in UniConfig for Ethernet communication. For 
instructions, refer to the PC’s user documentation. 

2 Connect the router and the PC to the network. It is recommended that a hub or switch be used.

3 Launch and connect to UniConfig using an Ethernet connection. (See Launching UniConfig on 
page 9.)

4 Open the ‘Control Cards’ pane. (See Control Cards Pane on page 7.)

The ‘Control Cards’ pane appears in the left-hand section and the ‘Configuration’ window 
appears in the right-hand section of the screen, as shown in Figure 7-1.
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If no control cards have been added, the pane is blank. 

Figure 7-1. Configuration Window with Control Card Pane (Left Side)

5 Using the ‘Control Cards’ pane, add router control cards to the network:

a Right-click on ‘Control Cards’ and from the pop-up menu select ‘Add Control Card’. The 
‘Control Card Configuration’ dialog box appears: 

Figure 7-2. Control Card Configuration Dialog Box
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b For the first control card being added, enter the ‘IP Address’ and ‘Name’ in the fields pro-
vided and click OK. See IP Addresses on page 39 for a list of recommended IP addresses.

Or

Click Search/Refresh to list all control cards currently in UniConfig and their IP addresses in 
the ‘IP Address’ column. Double-click on an IP address to have the address appear in the 
‘IP Address’ field.

The added control card name and IP address appear in the ‘Control Cards’ pane. To display 
all control cards currently added to the network without looking at the ‘Control Cards’ pane, 

c Repeat step a and step b until all control cards on all routers on the network display in the 
‘Control Cards’ pane.

6 To close the ‘Control Card Configuration’ dialog box, click X in the upper, right-hand corner.

Communicating with a Control Card on a Network
Once a router’s control card(s) have been added to a network, you can communicate with the con-
trol cards through any workstation on the network. 

The router should currently exist on a network. (See Adding a Control Card to a Network on page 
41.) However, at any time, communication between the router and UniConfig can be initiated by 
using the temporary serial connection on the control card(s). (See Launching UniConfig on page 9.)

How to Communicate with a Device on the Network

1 Launch UniConfig. (See Launching UniConfig on page 9.)

2 Open the ‘Control Cards’ pane. (See Control Cards Pane on page 7.) The ‘Control Card’ pane 
appears, as shown in Figure 7-1.

3 Select a control card. (See Selecting a Control Card on page 10.)

4 On the ‘Control Cards’ pane, select the control card you want to communicate with.

5 Click Read All. The ‘Configuration’ window populates with the current router configuration and 
serial and Ethernet settings and initiates communication with the selected control card.

Viewing Control Cards on a Network
Control cards currently residing on a network can be viewed at any time. The router should cur-
rently exist on a network. (See Adding a Control Card to a Network on page 41.)

How to View Control Cards on a Network

1 Launch UniConfig. (See Launching UniConfig on page 9.)

2 Open the ‘Control Cards’ pane. (See Control Cards Pane on page 7.) The ‘Control Card’ pane 
appears listing all control cards currently on the network.
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Moving the ‘Control Cards’ Pane
The ‘Control Cards’ pane can be moved from its original position and relocated elsewhere on the 
screen, where it can then be resized and positioned as desired. To move the window away from its 
anchored position, left-click on the border (frame) at the top of the window and drag it to the 
desired location on the screen. The label at the top of the relocated window changes to ‘Instant 
Bar’.

Updating Control Cards on a Network
The name and IP address assigned to a control card can be updated at any time. Make sure when 
updating an IP address that the new address is valid for your network.

How to Update Control Card Settings on a Network

1 Launch UniConfig. (See Launching UniConfig on page 9.)

2 Open the ‘Control Cards’ pane. (See Control Cards Pane on page 7.) The ‘Control Card’ pane 
appears, as shown in Figure 7-1.

3 Select a control card. (See Selecting a Control Card on page 10.)

4 On the ‘Control Card’ pane, right-click on the control card you want to update and from the 
pop-up menu select ‘Edit Name and IP Address’. The ‘Control Card Configuration’ dialog box 
appears, as shown in Figure 7-2. 

5 (Optional) On the ‘Configuration’ window, click Read All to view current router configuration 
and Ethernet settings.

6 Update the ‘IP Address’ and ‘Name’ in the fields provided and click OK. 

The updated control card information appears in the ‘Control Cards’ pane. To display all con-
trol cards currently on the network without looking at the ‘Control Cards’ pane, click Search/
Refresh.

Be careful! If you change the IP address to one that is already assigned to another control card, 
you will switch to that control card, not update the current control card’s IP address. Or, if you 
enter an IP address that is not yet assigned to a router, then UniConfig is pointing to no control 
card.

7 To close the ‘Control Card Configuration’ dialog box, click X in the upper, right-hand corner.

8 Repeat steps 2 through 7 for each control card being updated.

Removing Control Cards from a Network
To remove a control card from the network so that UniConfig can no longer ‘see’ it, the control 
card is disabled using the ‘Configuration’ window. However, disabling a control card does not 
remove it from the network and can be accessed through the serial ports. (See Communicating with 
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the Router Through Serial Ports on page 23.) To remove a control card permanently from a net-
work, it must also be removed from the configuration setup.

How to Remove a Control Card from the Network

1 Launch UniConfig. (See Launching UniConfig on page 9.)

2 Open the ‘Control Cards’ pane. (See Control Cards Pane on page 7.) The ‘Control Card’ pane 
appears, as shown in Figure 7-1.

3 Select a control card. (See Selecting a Control Card on page 10.)

4 On the ‘Control Card’ pane, right-click on the control card you want to delete and from the pop-
up menu select ‘Delete. 

The card is still on the network, but no longer displays in the ‘Control Cards’ pane. 

5 Again from the menu bar, select ‘Windows > Configuration’. The ‘Configuration’ window 
appears, as shown in Figure 7-1.

6 (Optional) Click Read All. The ‘Configuration’ window populates with the current router config-
uration and Ethernet settings.

7 In the ‘Router Ethernet Settings’ section, select the ‘Disable’ radio button. This removes the 
control card from the network.

8 Repeat steps 2–7 for each control card being removed.

Setting Up a Gateway
If you are using Ethernet connections and a network, you can create a gateway to other sites. A 
gateway is an IP address through which devices not on the current network can enter and access the 
network. For example, if several facilities are in different geographical locations, a gateway enables 
one facility to talk to routers at another facility.

To set up a gateway, an IP address is entered for the gateway on each, individual control card. This 
enables you to limit access to control cards on a one-by-one basis.

How to Set Up a Gateway

1 Launch UniConfig. (See Launching UniConfig on page 9.)

2 Select a control card. (See Selecting a Control Card on page 10.)

3 From the menu bar, select ‘Windows > Configuration’. The ‘Configuration’ window appears, 
as shown in Figure 7-1. 

4 Click Read All. Current configuration settings for the selected control card populate the ‘Config-
uration’ window fields.
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5 From the menu bar, select ‘Tools > Options’. The ‘Configuration Options’ dialog box appears: 

Figure 7-3. Configuration Options Dialog Box

6 Check the ‘Show advanced Ethernet settings’ check box. By default this box is not checked.

7 Click OK to save changes and close the dialog box.

Expanded settings appear in the ‘Router Ethernet Settings’ section on the ‘Configuration’ win-
dow: 

Figure 7-4. Example of Configuration Window with Expanded Ethernet Settings Displaying

8 (Optional) Enter a ‘Router Name’ in the field provided. This is used to identify the control card 
by name instead of IP address.
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9 Check the ‘Enable Gateway’ check box.

10 Enter the IP address for the gateway in the ‘Gateway IP Addr” field.

11 Click Write All to write changes to the control card.

12 Repeat steps 2–11 for each control card being updated.
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8. Managing Partitions and Signal Types

Creating partitions is one of the most critical components of the configuration process. All router 
control systems utilize the partition information in one form or another to communicate intelli-
gently with the router and manage the crosspoint connections.

When configuring the UniConfig router, up to four partitions can be set up for all routers except the 
NV5100MC and the NV5128 which can have up to eight partitions.

For information on configuring the EC9535, see Setting Up EC9535 Partitions on page 122.

This section discusses what partitions are, what they do, and how to manage partitions using Uni-
Config.

About Partitions
Partitions are boundaries within the router used to organize switching. After creating partitions, a 
signal type is selected to associate with each partition. This defines what signal format is in use and 
enables the control card to determine the correct switching rules and reference requirements.

Signals are switched within a partition, not between partitions. Inputs can be switched only to out-
puts contained in the same partition. Every matrix must contain at least one partition. The control 
card will be in an error state (red LED illuminated) if no partition information is found in EE mem-
ory on the router motherboard during boot up.

It is not required that different signal formats be split into separate partitions. In fact, there are cases 
where doing this prohibits system functionality. For example, on a router with 32 x 32 SD video 
and 32 x 32 analog video with analog-to-digital conversion input and output cards, if the system is 
divided into two partitions it is not possible to route between the analog and digital partitions even 
though the conversion cards are designed to allow this. Making one 64 x 64 partition eliminates this 
issue. In this case the router control system may address the router by specifying physical input and 
output ports on a single partition.

Many router control systems support partitioning use virtual instead of physical partitions, called 
“levels”. Because each router control system creates and manages virtual levels in a unique manner, 
this document only covers those instances that apply to a majority of existing systems. 

Each router control system utilizes partitions in a slightly different way. Restructuring the partitions 
on the control card using UniConfig is quick and easy, but may have profound effects on the router 
control system physical input and output mapping tables. If there is any doubt about the best way to 
partition the router, create small test configurations in the router control system to evaluate router 
behavior. Once the desired results have been obtained proceed with creating the complete configu-
ration.

In the UniConfig interface, ‘Levels’ are analogous to partitions.
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Signal Types
Routing matrices are intended to switch signals from input to output. However, the control card has 
no knowledge of the type of signal actually being passed through the matrix. The control card’s 
task is to accept control messages from the router control system, convert these messages into 
appropriate crosspoint selections, and then initiate the switch at the correct moment in time.

Using UniConfig a signal type is selected and that information sent to the control card. This selec-
tion determines the switching rules the control card uses to make routes. Signal types are selected 
for each partition and vary depending upon the type of matrix.

Depending on the signal type, the control card requires reference signals to accurately determine 
when to perform the actual switch from one input to another. In general, all Miranda routers, 
regardless of format, have video reference and AES reference connections. For video references, 
SMPTE standards define where the switch should occur for most common signal types. For 525 
line analog and SD video the switch should occur on line 10. High definition signals should be 
switched on HD line 4. For AES references, the reference signal should have a sample rate of 
48 kHz, clock-locked to the video reference signal. For more information on reference connections, 
see the router User’s Guide.

About Output Follow Mode
When setting up partitions, the ‘Output Follow’ mode can be selected. The ‘Output Follow’ mode 
provides monitor output functionality on routers that do not support a monitor card (e.g., the 
NV5128) or on routers that support a monitor card, but the card does not have enough outputs for 
monitoring purposes (e.g., the NV8256-Plus). In addition, ‘Output Follow’ mode enables the auto-
matic tracking of one output to another output.

To use the ‘Output Follow’ functionality, output follow is set up as a separate partition in the router. 
This partition allows inputs within the partition to map to outputs from the router; an output can be 
set to follow the input of another output. 

For example, output 2 is set to follow output 1. An operator switches input 1 to output 1. Input 1 is 
seen on both outputs 1 and 2. An operator switches input 5 to output 1. Input 5 is seen on both out-
puts 1 and 2. An operator switches input 128 to output 1. Input 128 is seen on both outputs 1 and 2, 
and so on.

About Data X/Y Mode
When setting up partitions, UniConfig allows a ‘Data X/Y’ mode to be selected. The ‘Data X/Y’ 
mode enables a machine control router, such as the NV5256, to behave like an X/Y router. 

X/Y routers allow any input to be routed to any output or any set of outputs. An input port is a sin-
gle physical connector, and similarly, an output port is a single physical connector. This means that 
the input signal for an output port has a single direction.
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Machine control routers also have ports, however each port allows a signal to be both input and 
output on single port. This means that a single physical connector is bi-directional; both input and 
output.

When a ‘take’ is performed in an X/Y router, for example input 1 to output 2, only one signal is 
passed through the router from 1 to 2. When a ‘take’ is performed for port 1 to port 2 in a machine 
control router, two signals are passed through: from 1 to 2 and from 2 to 1. In addition, if a another 
‘take’ occurs, for example, for port 1 to port 4, the router passes signals 1 to 4 and 4 to 1 removing 
the signal path connections associated with port 2.

If a machine control router is in ‘Data X/Y’ mode when a ‘take’ is performed, only one signal is 
passed. For example, if a ‘take’ is performed for port 1 to port 2, one signal is passed from 1 to 2, 
not 2 to 1. This allows another take to be performed without removing prior path connections. For 
example, a ‘take’ for port 1 to port 4, passes one signal from 1 to 4 without disconnecting the signal 
path of 1 to 2.

About Machine Control Modes
When setting up machine control partitions, ‘Forward’, ‘Reverse’ or ‘Broadcast’ mode can be 
selected. Machine control ports are bi-directional; neither inputs or outputs. This means that each 
port can be set to send signals in a specific direction. 

Specific directions through the machine control ports can be selected as follows:

Forward — Sends signals from a controlling device to the ports (the status of ‘P2P Controlling’ 
devices). For more information, see Setting Up Machine Control Ports on page 101. 

• Reverse — Distributes from the ports to a controlled device (the status of ‘P2P Controlled’ 
devices). For more information, see Setting Up Machine Control Ports on page 101. 

• Broadcast — Sends signals from the controlling device (the status of ‘Bcast Controlling’) to 
ports on the router, which in turn switch the signals to ports for distribution to controlled 
devices (the status of ‘RecvOnlyControlled’). One signal can be “broadcast” to several devices. 
For more information, see Setting Up Machine Control Ports on page 101.

Setting Up Partitions
How partitions are set up is determined by the router control system. The Miranda NV9000 router 
control system uses levels—logical segmentation—to manage switching, so in many cases only a 
single partition needs to be created. For third-party router control systems (and the NV9000), indi-
vidual partitions can be created to manage signal switching. Signals can only be switched within a 
partition, not across partitions. Partitions are typically based on signal types.

Depending on the router being configured, different fields display. For example, if the router routes 
only video signals, audio signals are not listed as a signal type option. Differences for specific rout-
ers are noted in the following procedure. Be sure to follow instructions for your specific router.

Note Each control card must be configured separately.
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All routers can act as standalone routers. However, the NV5256, NV7256-Plus, NV7512, NV8256-
Plus, NV8288-Plus and the NV8500 Family (in expanded mode) routers can be connected to 
another identical router to expand switching capability. When routers are connected together, one 
router is designated as the master router. All configuration and crosspoint information is copied 
from the master router to all connected slave routers.

Follow instructions for your router set up: a standalone router or multiple routers connected 
together over an inter-level bus.

Standalone Routers

If a router is acting as a standalone router, partitions are set up for the number of inputs and outputs 
being switched by that router. For information on configuring the EC9535, see Setting Up EC9535 
Partitions on page 122.

How to Set Up Partitions for a Standalone Router

1 Launch UniConfig. (See Launching UniConfig on page 9.)

2 Select a control card. (See Selecting a Control Card on page 10.)

3 From the menu bar, select ‘Windows > Configuration’. The ‘Configuration’ window appears:

Figure 8-1. Example of a Configuration Window for NV5128

This is an example of the ‘Configuration’ window for the NV5100MC and the NV5128 router. 
For other routers, the Partitions 1–4 button does not display.

4 The NV5256, NV7256-Plus, NV7512, NV8256-Plus, NV8288-Plus and the NV8500 Family 
(in expanded mode) routers can be connected to an identical router to expand the switching 
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matrix. The ‘Configuration’ window for these routers displays an additional ‘Expansion’ sec-
tion: 

Figure 8-2. Example of a Configuration Window for a Router with Frame Expansion

5 Click Read All. The ‘Configuration’ window populates with the current router configuration and 
Ethernet settings. If no prior configuration is stored, many of the fields are blank.

6 To set up a partition, enter ‘Level’, ‘Physical Inputs’, ‘Controller Inputs’, ‘Physical Outputs’ 
and ‘Controller Output’ information for each switching matrix in the fields provided. Each row 
represents one partition (called ‘Level’ on the interface) in the router control system.

For the NV5100MC and NV5128, there are 8 partitions. Only four display at any one time. 
Click Partition 1–4 or Partition 5–8 to view the corresponding levels. For all other routers, there 
are four partitions. Machine control cards and corresponding signals must be assigned to a sin-
gle, individual partition; the physical inputs and outputs must be on a separate level from other 
signal types. The physical input and output ranges should be 1–32 or 1–64, depending on the 
size of your machine control partition.

Note Make sure that the ‘Main - Standalone’ radio button is selected in the 
‘Expansion’ section.

Note Partitions (also called ‘levels’) must be unique. If a partition is not unique, 
the router control system has no way of distinguishing one set of cross-
points from another.
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The following is a list of each field and the corresponding information to be entered:

7 From the ‘Signal Type’ drop-down list, select a signal type for each partition. Select the signal 
type on the same row listing the partition information.

Field Description Values

Level Numeric value identifying a particular configured partition. This value 
usually has to match what has been configured in the control system 
being used.
Enter a number for the router signal type. If multiple signal types are 
managed by the router, enter additional, unique numbers, one for each 
signal type, creating a new row for each signal.

0–250

Physical 
Inputs

Input connectors this partition starts and ends with:
NV5100MC — 1 through 128
NV5128 — 1 through 128
NV5256 — 1 through 256
NV7256/NV7256-Plus — 1 through 256
NV7512 — 1 through 512
NV8256-Plus — 1 through 256; 512
NV8288/NV8288-Plus — 1 through 288
NV8500 Family:
NV8144 — 1 through 144
NV8280 — 1 through 288
NV8280-Plus — 1 through 288
NV8576 — 1 through 576
NV8576-Plus — 1 through 576

1–xxx

Controller 
Input

Logical number this partition starts with. Typically must match what 
control system has been configured to use.

Typically 0 or 
1

Physical 
Outputs

Output connectors this partition starts and ends with:
NV5100 — 1 through 128
NV5128 — 1 through 128
NV5256 — 1 through 256
NV7256/NV7256-Plus — 1 through 256
NV7512 — 1 through 512
NV8256-Plus — 1 through 256
NV8288 — 1 through 576
NV8288-Plus — 1 through 288
NV8500 Family:
NV8144 — 1 through 144
NV8280 — 1 through 576
NV8280-Plus — 1 through 288
NV8576 — 1 through 1,152
NV8576-Plus — 1 through 576

1–xxx

Controller 
Output

Logical number this partition starts with. Typically must match what 
control system has been configured to use. 

Typically 0 or 
1

Signal Type Defines what software signal type in use. Generally, enables the matrix 
controller to determine correct switching rules and reference 
requirements.

—
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Choose the signal type according to the input signal format for the partition. The signal type, in 
conjunction with the switch point setup, determines the rules used by the router for switching 
the signals when the operator executes a “take.” For information on setting the switch point, see 
Managing Switch Point Settings on page 71. 

The following lists the signal type selection in the UniConfig menu and the required reference 
signals. For more information on video and AES references, see your router User’s Guide.

Depending on the router, not all signal type options display. Only those signal types valid for 
your router appear in the drop-down list.

Router Input Signal Format  Signal Type Selection
Video 
Ref. AES Ref.

NV5100MC
NV5128
NV7256
NV7256-Plus
NV7512
NV8500 Family

Analog Audio (Stereo) Analog Audio X *

Analog Audio (Mono) Analog Audio X *

Synchronous AES3 Digital 
Audio (Stereo)

Synchronous AES, Analog 
Audio

X X

Synchronous AES3 Digital 
Audio (Mono)

Synchronous AES, Analog 
Audio

X X

Mixed Analog and 
Synchronous AES Digital 
Audio

Synchronous AES, Analog 
Audio, Mono AES, Analog 
Audio

X X

Asynchronous AES3 Digital 
Audio (Stereo)

Video, Asynchronous AES, 
Time Code

X

NV5100
NV5128

Analog Video (PAL or 
NTSC)

Video, Asynchronous AES, 
Time Code

X

NV5100
NV5128
NV8256-Plus
NV8288
NV8288-Plus
NV8500 Family

SD, SWB or 3Gig Video Video, Asynchronous AES, 
Time Code

X

Video, Asynchronous AES3 
Time Code

X

NV5100MC
NV5128
NV7256
NV7256-Plus

Time Code (Linear) Video, Asynchronous 
AES3, Time Code

X

NV5128
NV5256

Machine Control 
(RS-422)**

Machine Control Reverse, 
Machine Control Broadcast, 
Machine Control Forward
See About Machine 
Control Modes on page 51

X

NV5100MC
NV5128
NV7256
NV7256-Plus
NV7512
NV8256-Plus
NV8288
NV8288-Plus

Output Follow See About Output Follow 
Mode on page 50.
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8 Click Write All to writes changes to the control card.

9 Repeat steps 2 through 8 for each control card being updated.

Multiple Frames

The NV5256, NV7256-Plus, NV7512, NV8256-Plus, NV8288-Plus and NV8500 Family (in 
expanded mode) routers can be connected to another identical router to expand switching capabil-
ity. For example, the NV8256-Plus (256 x 256) can be connected to another NV8256-Plus to create 
a switching matrix of 512 inputs x 512 outputs.

When routers are connected together, one router is designated as the master router. All configura-
tion and crosspoint information is copied from the master router to all connected slave routers. This 
ensures synchronization of all connected frames. Once a slave router is created, any change made 
to the master router configuration is automatically copied to the slave router. Slave router configu-
rations cannot be updated independent of the master router. Slave router configuration windows 
display, but are inactive.

How to Set Up Partitions for a Master Router 

1 Launch UniConfig. (See Launching UniConfig on page 9.)

2 Select the primary control card on the router acting as the master router. (See Selecting a Con-
trol Card on page 10.)

NV5100MC
NV5128
NV5256

Data X/Y See About Data X/Y 
Mode on page 50.

 * If possible, connect an external AES 48kHz reference signal.
** Note: RS-232 machine control hardware is optional. For more information, contact NVISION sales.

Router Input Signal Format  Signal Type Selection
Video 
Ref. AES Ref.
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3 From the menu bar, select ‘Windows > Configuration’. The ‘Configuration’ window appears 
displaying an ‘Expansion’ section: 

Figure 8-3. Example of a Configuration Window for Routers with Frame Expansion

4 Click Read All. The ‘Configuration’ window populates with the current router configuration and 
Ethernet settings. 
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5 Select the ‘Main -Expanded’ radio button in the ‘Expansion’ section. This sets the control card 
on the router as the master (or main) control card controlling all slave routers and expands the 
‘Expansion’ section: 

Figure 8-4. Example of a Configuration Window for Routers with Frame Expansion Section

6 For ‘Local Inputs’ and ‘Outputs’, enter a ‘Start’ and ‘End’ number in the corresponding fields. 
The inputs are the total number of signals for all routers. In this example, the NV7512 can man-
age 512 x 512 and is connected to a second 512 x 512 router. This means that the router 
receives a total of 1,024 inputs: 512 from the local inputs and 512 from the connected router. 
However, the router only distributes local outputs, for a total of 512.

The following lists the maximum number of inputs and outputs for the master router:

Router
Number of Frames That Can 
be Connected  Inputs  Outputs

NV5256 2 at 256 ports each 2 routers: 1–512 1–512

NV7256-Plus 4 at 256 × 256 each 2 routers: 1–512
3 routers: 1–768
4 routers: 1–1,024

1–256

NV7512 4 at 512 × 512 each 2 routers: 1–1,024
3 routers: 1–1,536
4 routers: 1–2,048

1–512

NV8256-Plus 2 at 256 × 256 2 routers: 1–512 1–256

NV8288-Plus 2 at 288 × 288 2 routers: 1–576 1 –288

NV8500 Family:
NV8280-Plus
NV8576-Plus

2 at 288 x 288
2 at 576 x 576

2 routers: 1–576
2 routers: 1–1,152

1–576
1–1,152
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7 Enter a unique ‘Index’ number in the field provided in the ‘Expansion’ section. This number 
acts as an identification number in UniConfig. The number must be unique and not assigned to 
any other router.

8 To set up a partition, enter ‘Level’, ‘Physical Inputs’, ‘Controller Inputs’, ‘Physical Outputs’ 
and ‘Controller Output’ information for each switching matrix in the fields provided. Each row 
represents one partition (called ‘Level’ on the interface) in the router control system. A total of 
four partitions can be created.

For the NV5256, machine control signals must be assigned to a single, individual partition; the 
physical inputs and outputs must be on a separate level from other signal types. The physical 
input and output ranges should be 1–32 or 1–64, depending on the size of your machine control 
partition.

The following is a list of each field and the corresponding information to be entered:

Note Partitions (also called ‘levels’) must be unique. If a level is not unique, the 
router control system has no way of distinguishing one set of crosspoints from 
another.

Field Description Values

Level Numeric value identifying a particular configured 
partition. This value usually has to match what has been 
configured in the control system being used.
Enter a number for the router signal type. If multiple 
signal types are managed by the router, enter additional, 
unique numbers, one for each signal type, creating a new 
row for each signal.

0–250

Physical Inputs This number dependent on the number of routers 
connected together. Refer to step 6 for a list of total inputs. 
Input connectors this partition starts and ends with:
NV5256 — 1 through 512 (2 routers)
NV7256-Plus — 1 through 1,024 (4 routers)
NV7512 — 1 through 2,048 (4 routers)
NV8256-Plus — 1 through 512 (2 routers)
NV8288-Plus — 1 through 576 (2 routers)
NV8500 Family:
NV8280-Plus — 1 through 288
NV8576-Plus — 1 through 576

1–xxx

Controller Input Logical number this partition starts with. Typically must 
match what control system has been configured to use.

Typically 0 or 1

Physical Outputs Output connectors this partition starts and ends with:
NV5256 — 1 through 256
NV7256-Plus — 1 through 256
NV7512 — 1 through 512
NV8256-Plus — 1 through 256
NV8288-Plus — 1 through 288
NV8500 Family:
NV8280-Plus — 1 through 576 (2 routers)
NV8576-Plus — 1 through 1,152 (2 routers)

1–xxx
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9 From the ‘Signal Type’ drop-down list, select a signal type for each partition, such as ‘Digital 
Video’. Select the signal type on the same row listing the partition information.

Choose the signal type according to the input signal format for the partition. The signal type, in 
conjunction with the switch point setup, determines the rules used by the router for switching 
the signals when the operator executes a “take.” For information on setting the switch point, see 
Managing Switch Point Settings on page 71. 

The following lists the signal type selection in the UniConfig menu and the required reference 
signals. For more information on video and AES references, see your router User’s Guide.

Depending on the router, not all signal type options display. Only those signal types valid for 
your router appear in the drop-down list.

Controller Output Logical number this partition starts with. Typically must 
match what control system has been configured to use. 

Typically 0 or 1

Signal Type Defines what software signal type in use. Generally, 
enables the matrix controller to determine correct 
switching rules and reference requirements.

—

Router Input Signal Format UniConfig Signal Type Selection Video Ref. AES Ref.

NV7256-Plus
NV7512
NV8500 Family

Analog Audio (Stereo) Analog Audio X *

Analog Audio (Mono) Analog Audio X *

Synchronous AES3 
Digital Audio (Stereo)

Synchronous AES, Analog 
Audio

X X

Synchronous AES3 
Digital Audio (Mono)

Synchronous AES, Analog 
Audio

X X

Mixed Analog and 
Synchronous AES 
Digital Audio

Synchronous AES, Analog 
Audio
Mono AES, Analog Audio

X X

Asynchronous AES3 
Digital Audio (Stereo)

Video, Asynchronous AES, 
Time Code

X

NV8256-Plus
NV8288-Plus
NV8500 Family

SD, SWB or 3Gig 
Video

Video, Asynchronous AES, 
Time Code

X

Video, Asynchronous AES3 
Time Code

X

NV7256-Plus Time Code (Linear) Video, Asynchronous AES3, 
Time Code

X

NV5256 Machine Control 
(RS-422)**

Machine Control Reverse, 
Machine Control Broadcast, 
Machine Control Forward
See About Machine Control 
Modes on page 51.

X

NV5100
NV5128
NV7256
NV7256-Plus
NV7512
NV8256-Plus
NV8288
NV8288-Plus

Output Follow See About Output Follow 
Mode on page 50.

Field Description Values
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10 Click Write All to write changes to the control card.

11 Repeat steps 2 through 10 for each control card on the master router. 

How to Set U p Partitions for Slave Routers

Slave routers cannot be configured separately, instead all configurations set in the master router are 
automatically copied to the slave router. To change a slave router, changes must be made in the 
master router, which are then copied to the slave routers.

1 Launch UniConfig. (See Launching UniConfig on page 9.)

2 Select a control card on the router acting as the slave router. (See Selecting a Control Card on 
page 10.)

3 From the menu bar, select ‘Windows > Configuration’. The ‘Configuration’ window appears 
displaying an ‘Expansion’ section: 

Figure 8-5. Example of a Configuration Window for Routers with Frame Expansion

4 Click Read All. The ‘Configuration’ window populates with the current router configuration and 
Ethernet settings. 

NV5100
NV5128
NV5256

Data X/Y See About Data X/Y Mode 
on page 50.

 * If possible, connect an external AES 48kHz reference signal.
** Note: RS-232 machine control hardware is optional. For more information, contact NVISION sales.

Router Input Signal Format UniConfig Signal Type Selection Video Ref. AES Ref.
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5 Select the ‘Slave - Expanded’ radio button in the ‘Expansion’ section. This sets the control card 
on the router as the slave control card controlled by the master (or main) router and expands the 
‘Expansion’ section: 

Figure 8-6. Example of a Configuration Window for Routers with Frame Expansion Section

6 For ‘Local Inputs’ and ‘Outputs’, enter a ‘Start’ and ‘End’ number in the corresponding fields. 
The inputs are the total number of signals for all routers. In this example, the NV7512 can man-
age 512×512 and is connected to a second 512×512 router. This means that the router receives a 
total of 1,024 inputs: 512 from the local inputs and 512 from the connected router.

This table lists the maximum number of inputs and outputs for the slave router for each router:

Router
Number of Frames That 
Can be Connected  Inputs  Outputs

NV5256 2 at 256 ports each 2 routers: 1–512 257–512

NV7256-Plus 4 at 256 x 256 each 2 routers: 1–512
3 routers: 1–768
4 routers: 1–1,024

2nd router: 257–512
3rd router: 513–768
4th router: 769–1,024

NV7512 4 at 512 x 512 each 2 routers: 1–1,024
3 routers: 1–1,536
4 routers: 1–2,048

2nd router: 513– 1,024
3rd router: 1,025–1,536
4th router: 1,537–2,048

NV8256-Plus 2 at 256 x 256 2 routers: 1–512 257–512

NV8288-Plus 2 at 288 x 288 2 routers: 1–576 289–576

NV8500 Family:
NV8280-Plus
NV8576-Plus

2 at 288 x 288
2 at 576 x 576

2 routers: 1–576
2 routers: 1–1,152

288– 576
576–1,152
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7 Enter a unique ‘Index’ number in the field provided in the ‘Expansion’ section. This number 
acts as an identification number in UniConfig. The number must be unique and not assigned to 
any other router.

8 Click Write All to send changes to the control card.

The ‘Level’, ‘Physical Inputs’, ‘Controller Inputs’, ‘Physical Outputs’ and ‘Controller Output’ 
fields are greyed-out. All partition information is copied from the master router to the slave 
router. In addition, all crosspoint information is copied to each slave router to ensure synchroni-
zation of all connected frames. Crosspoint information displays in the ‘Connections’ window. 
(See Managing Inputs and Outputs on page 87.)

9 Repeat steps 2 through 8 for each control card on all slave routers.

Updating Partitions
Partitions can be updated at any time. However, changing partition parameters may have a direct 
impact on how signals are switched. Before implementing any changes, it is recommended that the 
new partitions be verified through the router control system.

If updating routers that are connected together, changes are made to the master router only, which 
then automatically copies changes to all connected slave routers. (See Multiple Frames on page 
56.)

How to Update Partitions

1 Launch UniConfig. (See Launching UniConfig on page 9.)

2 Select a control card. (See Selecting a Control Card on page 10.)

3 From the menu bar, select ‘Windows > Configuration’. The ‘Configuration’ window appears, 
as shown in Figure 8-2 on page 53.

4 Click Read All. The ‘Configuration’ window populates with the current router configuration and 
Ethernet settings. 

5 In the ‘Level’, ‘Physical Inputs’, ‘Controller Inputs’, ‘Physical Outputs’ and ‘Controller Out-
put’, update information as needed as described in step 6 in How to Set Up Partitions for a Stan-
dalone Router on page 52 for a standalone router or step 8 in How to Set Up Partitions for a 
Master Router on page 56 if updating a master router.

6 From the ‘Signal Type’ drop-down list, update the signal type for each partition as needed as 
described in step 7 in How to Set Up Partitions for a Standalone Router on page 52 for a standa-
lone router or step 9 in How to Set Up Partitions for a Master Router on page 56 if updating a 
master router. 

7 Click Write All to send changes to the control card.

8 Repeat steps 2 through 7 for each control card being updated.

Note Each control card must be updated separately.
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Setting Up Mono Signal Switching
UniConfig can manage mono audio signals. Mono signals are only supported by the NV5100, 
NV5128, NV7256, NV7256-Plus and NV7512 routers. Mono signals enable you to combine left or 
right channels with other channels, and then output new stereo signals. The router control system 
determines how mono signals are recombined and routed to matrix outputs.

This section discusses mono signal switching configurations. For detailed steps on how to enter or 
update switching configurations, see Setting Up Partitions on page 51 or Updating Partitions on 
page 63.

Keeping Inputs and Outputs Straight
When a signal is applied to an input card, the signal is comprised of a left channel and a right chan-
nel. For example, when a signal comes into input card slot 1, the signal is comprised of a left chan-
nel (#1) and a right channel (#2). Likewise, when a signal comes into input card slot 2, the signal is 
comprised of a left channel (#3) and a right channel (#4), and so on through all 16 inputs, where 
input card 16 routes left channel #31 and right channel #32, creating up to 32 independent inputs 
(left and right channels). Depending on the control system, each channel can be combined with 
another channel and routed to a specific output. For example, left channel #7 from input card 4 can 
be combined with right channel #16 from input card 8 and routed to output card 12. For more infor-
mation on card slots, see your router’s User’s Guide.

The following table lists the channel number for each receiving connector on an input card. Input 
cards can manage up to 16 incoming stereo signals or 32 mono signals (i.e., 16 left and right chan-
nels pairs):

Input Connector Left Channel Right Channel 

1 1 2

2 3 4

3 5 6

4 7 8

5 9 10

6 11 12

7 13 14

8 15 16

9 17 18

10 19 20

11 21 22

12 23 24

13 25 26

14 27 28

15 29 30

16 31 32
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Routing Mono Signals
Successful mono routing relies heavily upon the router control system and how mono channel par-
titions are configured. It is usually desirable to implement routing to allow any input channel to 
route to any output channel. However, depending on how the routing is configured, the creation of 
every possible combination can cause the router control system database to nearly triple in size. 

To help you configure the most efficient mono routing for your needs, three possible options are 
presented: 

• Mixed stereo and mono
• Mono only
• Mono only using two partitions

Status Display Issues

When a device is configured as both mono and stereo, the router control system interface may not 
display status correctly. The router control system can have different sources routed to its left chan-
nels and right channels. When in stereo mode, the router control system reports status for only one 
channel, typically the left channel (i.e., as a single channel pair). As a result, there may appear to be 
a destination status error when viewing a destination configured for both stereo and mono operation 
simultaneously.

Several iterations of each device connected to the router control system must be built. At least two 
are required: one on the stereo partition and one on the mono partition. Depending upon the options 
available for channel swapping within the router control system, two entries for each device may be 
required on the mono partition.

Matrix partitions may overlap. When a device is configured such that it utilizes overlapping parti-
tions, the router control system interface may receive two possible values for source ports for a 
given destination port (left and right). Behavior with third party control systems cannot be pre-
dicted. It is recommended that you test for this issue before placing the system into service

Option 1: Mixed Stereo and Mono Mode

A mixed stereo and mono mode is used when it is necessary to have stereo 2-channel routing in 
some areas (e.g., a dubbing room) and mono channel switching in others (e.g., edit bays or audio 
mixing rooms). To implement a stereo-mono mode, two partitions must be created — a stereo parti-
tion and a mono partition.

This mode is the most complex to implement. It requires careful understanding of the relationship 
between physical connections and the logical mapping used within the control system. It is not 
guaranteed to operate satisfactorily with any router control system except the Miranda NV9000 
because setup relies heavily on partitions and how status is reported when the partitions overlap.

With this option you can have a single stereo partition display on some control system interfaces 
and separate mono partitions on another. Three virtual levels should be built in the router control 
system: stereo, left and right.
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Figure 8-7 shows typical UniConfig settings for a router using mixed mono and stereo mode. For 
instructions on managing mono signal partitions, see About Partitions on page 49. For details on 
which settings to use for your router control system, see your router’s user’s guide. 

Figure 8-7. Typical UniConfig Settings for Stereo-Mono Mode

If you are using the Miranda NV9000 router control system, the following tables lists example set-
tings. Devices 1 and 2 are source only, 3 and 4 are destination only, and device 5 is an example of 
bi-directional (such as a record VTR). Before proceeding, it is recommended that a small portion of 
the device list and corresponding physical connections data be built to test the user interface for 
functionality.

Device Name Stereo IN Left Input Right Input Stereo OUT Left Output Right Output 

1 1

1L 1 1

1R 2 2

2 2

2L 3 3

2R 4 4

3 1

3L 1 1

3R 2 2

4 2

4L 3 3

4R 4 4

5 3 3
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When entering settings for mixed stereo and mono mode, remember the following:
• Mono operation is only supported with AES3 synchronous hardware or analog audio cards.
• On mono partition 2, the controller input and output end values (the “grayed out” fields) are 

double the corresponding stereo values.
• Stereo partition uses physical partition 1, depending on the router control system protocol. (For 

more information, see the UniConfig User’s Guide.)
• Mono partitions (left and right) both use physical partition 2, depending on the router control 

system protocol. (For more information, see the UniConfig User’s Guide.)

Separate Partitions for Stereo and Mono

Separate level sets can be built for stereo and mono, or stereo and mono can be grouped together in 
a single partition set. The advantage to separate sets is less confusion on the router control system 
interface — only partitions pertinent to a particular destination display. The disadvantage is that tie 
lines are needed if stereo devices must be routed to a mono destination.

A single partition set approach places all partitions on display all of the time, possibly creating 
some confusion with status or device selection. However, a single partition set is much easier to 
manage. 

The following illustrates both approaches:

Option 2: Mono Only Mode

Mono-only mode is easy to implement because only a single set of configuration rules are used. In 
mono-only mode, devices are represented as two separate partitions on router control system inter-
faces. Mono switching is natively supported. Stereo switches, where left and right channels switch 
together, may be ‘simulated’ by populating both partitions of the physical connections table in the 
router control system interface with connection information. The left and right levels should be 
built as virtual levels using the router control system.

5L 5 5 5 5

5R 6 6 6 6

Status Partition/Destination Status Partition/Destination Status Partition/Destination

Device 1 Stereo Device 1 Stereo

Device 1L Left Device 1L Left Device 1 Left

Device 1R Right Device 1R Right Device 1 Right

Standard Stereo or mono route, 
single partition set

Standard Stereo or mono route, 
single partition set
(Note status on stereo partition is 
determined by the source routed to 
the left partition.)

Two partition sets, mono 
destination selected, breakaway 
established

Device Name Stereo IN Left Input Right Input Stereo OUT Left Output Right Output 
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Figure 8-8 shows typical UniConfig settings for a router using mono-only mode. For instructions 
on managing mono signal partitions, see About Partitions on page 49. For details on which settings 
to use for the router control system, see your router’s user’s guide. 

Figure 8-8. Typical UniConfig Settings for Mono-Only Mode

If you are using the Miranda NV9000 router control system, the following tables lists recom-
mended settings. Before proceeding, it is recommended that a small portion of the device list and 
corresponding physical connections data be built to test the user interface functionality.

Device Name Left Input Right Input Left Output Right Output

1

1L 1 1

1R 2 2

2

2L 3 3

2R 4 4

3

3L 1 1

3R 2 2

4

4L 3 3

4R 4 4

5
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When entering settings for mono-only mode, remember the following:
• Mono operation is only supported with AES3 synchronous hardware or analog audio cards.
• Controller input and output end values (the “grayed out” fields) are doubled.
• Both left and right partition use physical partition 1.

Option 3: Mono Only Mode Using Two Partitions

Mono-only mode using two partitions is used when the router control system does not support vir-
tual levels. In general, with two partitions the router control system will not allow channel swaps 
because the channels are configured on different physical partitions. However, this is not a limita-
tion for the Miranda NV9000 router control system, which readily supports this functionality.

Figure 8-7 on page 66 shows typical UniConfig settings for a router using mono-only mode. When 
entering settings for mono-only mode using two partitions, remember the following:

• Mono operation is only supported with AES3 synchronous hardware or analog audio cards.
• Controller input and output start values are offset by the mono size.
• Controller input and output end values (the “grayed out” fields) are doubled.

Allowing Channel Swapping

Rudimentary channel swapping capability can be enabled even with router control systems that do 
not directly support it. Figure 8-9 shows typical UniConfig settings for channel swapping: 

Figure 8-9. Typical UniConfig Settings for Overlapping Partitions

5L 5 5 5 5

5R 6 6 6 6

Device Name Left Input Right Input Left Output Right Output
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When creating two partitions to allow channel swapping, remember the following:
• Create two partitions on the control card, one for left and one for right, that overlap. 
• When entering connection data into the control system, create entries for each device on both 

partitions, as shown in Figure 8-9.

For instructions on managing mono signal partitions, see About Partitions on page 49. For details 
on which settings to use for the router control system, see your control system User’s Guide.

Note This mode is not recommended for use with the Miranda NV9000 router control 
system.
70 Rev 1.1 • 14 Dec 09



9. Managing Switch Point Settings

A “switch point” is a point in time in which an output is switched from the current source to a new 
source. Different video and audio formats require different switch points to prevent data or picture 
disturbances. UniConfig enables you to set switch point parameters for individual outputs. Switch 
points are initially set up as part of configuring a router.

Switch points are managed through the ‘Switch Point Setup’ window.

Reference information for video and audio signals is through reference connections housed on the 
router. For video reference signals, there are two connections labeled ‘VIDEO REF’. Both video 
reference connections can reference the same signal or each connection can reference a unique sig-
nal. For audio reference signals, there are two connections labeled ‘AES REF’. One or both con-
nections are connected to a stable source of AES3 at a sample rate of 48 kHz. If both reference 
connections are connected, one acts as a backup, automatically providing a reference signal should 
an AES reference source fail. For more information, see the router User’s Guide.

This section discusses how to set up and manage switch point settings for routers. For information 
on setting up EC9535 GSC Node Bus Converter switch points, see Setting Up EC9535 Switch 
Points on page 123.

About Video Signal Fields and Frames
Video signals are comprised of a series of still images presented sequentially giving the impression 
of movement. One complete set of still images on a video screen is called a frame.

Depending on the video equipment, still images are “painted” on screens using interlaced or pro-
gressive video techniques. For interlaced video, a frame is composed of two fields, FIELD1 and 
FIELD2. Each frame is divided into 525 scan lines. Because a field is one-half a frame, each field is 
composed of 262.5 scan lines. Scan lines start at the top of the screen and “paint” horizontally 
across the screen until the bottom of the screen is reached. For interlaced video, to paint an entire 
frame, first FIELD1 paints all the odd scan lines and then FIELD2 paints all the even scan lines. 
For NTSC interlaced video, there are 30 frames per second and 60 fields per second. For NTSC 
progressive video, there are only frames, or put another way, frames and fields are the same, so 
there are 60 frames per second.

Depending on the router type, UniConfig enables you to switch video signals on a frame or a field:

See How to Select Switch Point Settings for the NV5100MC or NV5128 Router on page 73.

See How to Select Switchpoint Settings for the NV7256 and NV7256-Plus Router on page 75.

See How to Select Switch Point Settings for the NV7512 Router on page 77.

Note In UniConfig, all routers have a ‘Switch Point Setup’ window except NV5256. 
The NV5256 routes only machine control signals, which do not have a config-
urable switch point.
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About Redundant and Dual Video References
See How to Select Switch Point Settings for the NV8256-Plus Router on page 79.

See How to Select Switch Point Settings for the NV8288 and NV8288-Plus Routers on page 81.

See How to Select Switch Point Settings for the NV8500 Family Routers on page 83.

See How to Select Switch Point Settings for the EC9535 on page 123.

About Redundant and Dual Video References
Each router has two video reference connections. The same reference can be used for both connec-
tions or a different reference for each connection. When using the same, or “redundant,” references 
for both connections, if one reference fails, the control card automatically fails-over to the redun-
dant reference. When using different references, or “dual” references, routing switch ‘takes’ can be 
configured to occur based on one or the other reference. For example, ‘VIDEO REF 1’ uses NTSC 
as a reference and ‘VIDEO REF 2’ uses PAL as a reference. 

“Redundant” or “dual” mode is selected using UniConfig. If “dual” is selected, each output can be 
configured individually to use ‘VIDEO REF 1’ or ‘VIDEO REF 2’ as the reference.

Setting Up Switch Points
Switch points can be set up for video or audio signals. Depending on the router being configured, 
different fields display. For example, if the router routes only video signals, audio signals are not 
listed as a switching option. Differences for specific routers are noted in the following procedures. 
Be sure to follow instructions for your specific router.

Video signals require that the video reference connections be connected for proper switching. 
Using the ‘Switch Point Setup’ window, you can choose to have signals switch on the SD, analog 
video or HD line, as appropriate. For information on making video reference connections, see your 
router User’s Guide. 

EC9535 is a GSC Node Bus converter and not configured like other routers. For details on setting 
up a switch points for an EC9535 see Setting Up EC9535 Switch Points on page 123.

Note Each control card must be configured separately.
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How to Select Switch Point Settings for the NV5100MC or NV5128 
Router

1 Launch UniConfig. (See Launching UniConfig on page 9.)

2 Select a control card. (See Selecting a Control Card on page 10.)

3 From the menu bar, select ‘Window > Switch Point Setup’. The ‘Switch Point Setup’ window 
appears displaying current output settings for the router being configured: 

Figure 9-1. Switch Point Setup Window

4 In the ‘Output Range’ section, enter a ‘Start’ and ‘End’ output signal number in the fields pro-
vided and click Read Outputs. Outputs corresponding to the range entered display in the ‘Select 
Outputs to edit’ pane with default settings.

The following lists each column and the information it presents:

Column Description

Output The number assigned to the signal for internal routing reference purposes. The 
number usually refers to the physical port through which the signal is distributed.

Reclock/bypass Indicates if the signal bypasses re-clocking. See step 6.

HD/SD Indicates if the signal is a standard definition (SD) or high definition (HD) video 
signal. See step 6.
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5 In the ‘Select Outputs to edit’ pane, select the outputs being updated:
To select specific outputs, use your keyboard and mouse.
Or
To select all outputs, from the menu bar select ‘Edit > Select All’.
Or
To clear all outputs currently displaying, from the menu bar select ‘Edit > Remove all Outputs’.

6 In the ‘Set selection(s) to’ section, check each check box to apply re-clocking and switching on 
the SD or HD line for the selected outputs.

The following lists each check box and its function:

7 In the ‘Dual Video Reference Option’ section, select ‘Redundant’ or ‘Dual’.

• ‘Redundant’ — Both ‘VIDEO REF 1’ and ‘VIDEO REF 2’ are used, such that if one fails, 
the other can be used as a fail-over. In this instance, both video reference signals should be 
identical.

• ‘Dual’ — Choose which video reference signal to use, ‘VIDEO REF1’ or ‘VIDEO REF 2’. 
In this instance, the reference signals can be different.

For information on dual or redundant references, see About Redundant and Dual Video Refer-
ences on page 72.

8 In the ‘NTSC/PAL Reference Options’ section, select the radio button corresponding to the sig-
nal type being used as a video reference: ‘1080i’, ‘720p’ or ‘1080p’. This signal will be used as 
the switching reference. This section only appears if the installed control card supports NTSC/
PAL.

9 Click Apply Changes to Selected Outputs, or from the menu bar select ‘Edit > Apply Changes’, to 
apply your changes to the selected outputs. This does not write your changes to the control 
cards. The changes display in the right-hand field.

10 Click Write All, or from the menu bar select ‘Edit > Write Changes’, to send your changes to the 
control card.

11 Repeat steps 2–10 for each control card being updated.

Check Box(es) Description

Use Reclocker
Bypass Reclocker

Choose to re-clock the signal or bypass the re-clocker, retaining the 
signal’s current rate.
These check boxes affect only SWB outputs. Make the desired 
selection for each SWB output.
‘Reclock’ or ‘Bypass’ appears in the ‘Reclock/Bypass’ column.

Switch on SD Line
Switch on HD Line

Choose ‘Switch on SD Line’ if the selected signal is a standard 
definition digital video signals (SD) or an analog video signal. 
Choose ‘Switch on HD Line’ if a high definition digital video signal 
(HD). 
‘SD’ or ‘HD’ appears in the ‘SD/HD’ column.
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How to Select Switchpoint Settings for the NV7256 and NV7256-Plus 
Router

1 Launch UniConfig. (See Launching UniConfig on page 9.)
2 Select a control card. (See Selecting a Control Card on page 10.)
3 From the menu bar, select ‘Window > Switch Point Setup’. The ‘Switch Point Setup’ window 

appears displaying current output settings for the router being configured: 

Figure 9-2. Switch Point Setup Window

4 In the ‘Output Range’ section, enter a ‘Start’ and ‘End’ output signal number in the fields pro-
vided and click Read Outputs. Outputs corresponding to the range entered display in the ‘Select 
Outputs to edit’ pane with default settings.
In the ‘Output’ column the number assigned to the signal for internal routing reference pur-
poses displays. The number usually refers to the physical port through which the signal is dis-
tributed.

5 In the ‘Select Outputs to edit’ pane, select the outputs being updated:
To select specific outputs, use your keyboard and mouse.
Or
To select all outputs, from the menu bar select ‘Edit > Select All’.
Or
To clear all outputs currently displaying, from the menu bar select ‘Edit > Remove all Outputs’.
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6 In the ‘Set selection(s) to’ section, check to have video signals ‘Switch on Frame Boundary’ or 
‘Switch on Field Boundary’. For more information, see About Video Signal Fields and Frames 
on page 71.

7 In the ‘Dual Video Reference Option’ section, select ‘Redundant’ or ‘Dual’.
• ‘Redundant’ — Both ‘VIDEO REF 1’ and ‘VIDEO REF 2’ are used, such that if one fails, 

the other can be used as a fail-over. In this instance, both video reference signals should be 
identical.

• ‘Dual’ — Choose which video reference signal to use, ‘VIDEO REF1’ or ‘VIDEO REF 2’. 
In this instance, the reference signals can be different.

For information on dual or redundant references, see About Redundant and Dual Video Refer-
ences on page 72.

8 Click Apply Changes to Selected Outputs, or from the menu bar select ‘Edit > Apply Changes’, to 
apply your changes to the selected outputs. This does not write your changes to the control 
cards. The changes display in the right-hand field.

9 Click Write All, or from the menu bar select ‘Edit > Write Changes’, to send changes to the con-
trol card.

10 Repeat steps 2–8 for each control card being updated.
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How to Select Switch Point Settings for the NV7512 Router
1 Launch UniConfig. (See Launching UniConfig on page 9.)
2 Select a control card. (See Selecting a Control Card on page 10.)
3 From the menu bar, select ‘Window > Switch Point Setup’. The ‘Switch Point Setup’ window 

appears displaying current output settings for the router being configured: 

Figure 9-3. Switch Point Setup Window

4 In the ‘Output Range’ section, enter a ‘Start’ and ‘End’ output signal number in the fields pro-
vided and click Read Outputs. Outputs corresponding to the range entered display in the ‘Select 
Outputs to edit’ pane with default settings.
The following lists each column and the information it presents:

5 In the ‘Select Outputs to edit’ pane, select the outputs being updated:
To select specific outputs, use your keyboard and mouse.
Or
To select all outputs, from the menu bar select ‘Edit > Select All’.

Column Description

Output The number assigned to the signal for internal routing reference purposes. The number 
usually refers to the physical port through which the signal is distributed.

Crossfade Indicates if the crossfade functionality is applied to the signal. Crossfade requires the 
installation of the DSP sub-module. See step 5.
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Or
To clear all outputs currently displaying, from the menu bar select ‘Edit > Remove all Outputs’.

6 In the ‘Set selection(s) to’ section, check each check box to apply ‘Enable Crossfade’ or ‘Dis-
able Crossfade’ to the selected outputs. ‘Enable’ or ‘Disable’ displays in the ‘Crossfade’ col-
umn.
This functionality is only active if the DSP sub-module has been installed on the router’s cross-
point card. The DSP sub-module enables manipulation of audio input or output (gain adjust-
ment, phase inversion, crossfade, and channel summing) and effects only the signals being 
directly switched by the crosspoint card on which it is installed. For more information about the 
sub-module and installation, see the NV7512 User’s Guide.

7 In the ‘Dual Video Reference Option’ section, select ‘Redundant’ or ‘Dual’.
• ‘Redundant’ — Both ‘VIDEO REF 1’ and ‘VIDEO REF 2’ are used, such that if one fails, 

the other can be used as a fail-over. In this instance, both video reference signals should be 
identical.

• ‘Dual’ — Choose which video reference signal to use, ‘VIDEO REF1’ or ‘VIDEO REF 2’. 
In this instance, the reference signals can be different.

For information on dual or redundant references, see About Redundant and Dual Video Refer-
ences on page 72.

8 Click Apply Changes to Selected Outputs, or from the menu bar select ‘Edit > Apply Changes’, to 
apply your changes to the selected outputs. This does not write your changes to the control 
cards. The changes display in the right-hand field.

9 Click Write All, or from the menu bar select ‘Edit > Write Changes’, to send changes to the con-
trol card.

10 Repeat steps 2–8 for each control card being updated.
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How to Select Switch Point Settings for the NV8256-Plus Router

1 Launch UniConfig. (See Launching UniConfig on page 9.)

2 Select a control card. (See Selecting a Control Card on page 10.)

3 From the menu bar, select ‘Window > Switch Point Setup’. The ‘Switch Point Setup’ window 
appears displaying current output settings for the router being configured: 

Figure 9-4. Switch Point Setup Window

4 In the ‘Output Range’ section, enter a ‘Start’ and ‘End’ output signal number in the fields pro-
vided and click Read Outputs. Outputs corresponding to the range entered display in the 
‘Select Outputs to edit’ pane with default settings.

The following lists each column and the information it presents:

Note If the ‘NTSC/PAL Reference Options’ section does not display, you may have 
an older control card. For more information, Contact Technical Support. For 
contact information, see Technical Support Contact Information on page iii.

Column Description

Output The number assigned to the signal for internal routing reference purposes. The 
number usually refers to the physical port through which the signal is distributed.

Reclock/bypass Indicates if the signal bypasses re-clocking. See step 5.
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5 In the ‘Select Outputs to edit’ pane, select the outputs being updated:
To select specific outputs, use your keyboard and mouse.
Or
To select all outputs, from the menu bar select ‘Edit > Select All’.
Or
To clear all outputs currently displaying, from the menu bar select ‘Edit > Remove all Outputs’.

6 In the ‘Set selection(s) to’ section, check each check box to apply re-clocking, frame or field 
boundary, and the SD or HD line switching for the selected outputs.
The following lists each check box and its function:

7 In the ‘Dual Video Reference Option’ section, select ‘Redundant’ or ‘Dual’.
• ‘Redundant’ — Both ‘VIDEO REF 1’ and ‘VIDEO REF 2’ are used, such that if one fails, 

the other can be used as a fail-over. In this instance, both video reference signals should be 
identical.

• ‘Dual’ — Choose which video reference signal to use, ‘VIDEO REF1’ or ‘VIDEO REF 2’. 
In this instance, the reference signals can be different.

For information on dual or redundant references, see About Redundant and Dual Video Refer-
ences on page 72.

8 In the ‘NTSC/PAL Reference Options’ section, select the radio button corresponding to the sig-
nal type being used as a video reference: ‘1080i’, ‘720p’ or ‘1080p’. This signal will be used as 
the switching reference.

9 Click Apply Changes to Selected Outputs, or from the menu bar select ‘Edit > Apply Changes’, to 
apply your changes to the selected outputs. This does not write your changes to the control 
cards. The changes display in the right-hand field.

10 Click Write All, or from the menu bar select ‘Edit > Write Changes’, to send changes to the con-
trol card.

11 Repeat steps 2–9 for each control card being updated.

Field/Frame Indicates if the signal switches on the field or the frame. See step 5.

HD/SD Indicates if the signal is a standard definition (SD) or high definition (HD) video 
signal. See step 5.

Check Box(es) Description

Use Reclocker
Bypass Reclocker

Choose to re-clock the signal or bypass the re-clocker, retaining the signal’s 
current rate.
These check boxes affect only SWB outputs. Make the desired selection for 
each SWB output.
‘Reclock’ or ‘Bypass’ appears in the ‘Reclock/Bypass’ column.

Switch on Field Line
Switch on Frame Line

Choose to switch video signals on the ‘field’ of the ‘frame’. For more 
information, see About Video Signal Fields and Frames on page 71.
‘Field’ or ‘Frame’ appears in the ‘Field/Frame’ column.

Switch on SD Line
Switch on HD Line

Choose ‘Switch on SD Line’ if the selected signal is a standard definition 
digital video signals (SD) or an analog video signal. Choose ‘Switch on HD 
Line’ if a high definition digital video signal (HD).
‘SD’ or ‘HD’ appears in the ‘SD/HD’ column.
Note: The default choice is Switch on SD Line.

Column Description
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How to Select Switch Point Settings for the NV8288 and 
NV8288-Plus Routers

1 Launch UniConfig. (See Launching UniConfig on page 9.)

2 Select a control card. (See Selecting a Control Card on page 10.)

3 From the menu bar, select ‘Window > Switch Point Setup’. The ‘Switch Point Setup’ window 
appears displaying current output settings for the router being configured: 

Figure 9-5. Switch Point Setup Window

4 In the ‘Output Range’ section, enter a ‘Start’ and ‘End’ output signal number in the fields pro-
vided and click Read Outputs. Outputs corresponding to the range entered display in the ‘Select 
Outputs to edit’ pane with default settings.

The following lists each column and the information it presents:

Column Description

Output The number assigned to the signal for internal routing reference purposes. The 
number usually refers to the physical port through which the signal is distributed.

Reclock/bypass Indicates if the signal bypasses re-clocking. See step 5.

HD/SD Indicates if the signal is a standard definition (SD) or high definition (HD) video 
signal. See step 5.

Ref1/Ref2 Indicates if the signal is using the reference signal through ‘VIDEO REF1’ or 
‘VIDEO REF2’ connection on the router. See step 5.
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5 In the ‘Select Outputs to edit’ pane, select the outputs being updated:
To select specific outputs, use your keyboard and mouse.
Or
To select all outputs, from the menu bar select ‘Edit > Select All’.
Or
To clear all outputs currently displaying, from the menu bar select ‘Edit > Remove all Outputs’.

6 In the ‘Set selection(s) to’ section, check each check box to apply a video reference, re-clocking 
and switching on the SD or HD line for the selected outputs.
The following lists each check box and its function:

7 In the ‘Dual Video Reference Option’ section, select ‘Redundant’ or ‘Dual’.
• ‘Redundant’ — Both ‘VIDEO REF 1’ and ‘VIDEO REF 2’ are used, such that if one fails, 

the other can be used as a fail-over. In this instance, both video reference signals should be 
identical.

• ‘Dual’ — Choose which video reference signal to use, ‘VIDEO REF1’ or ‘VIDEO REF 2’. 
In this instance, the reference signals can be different.

For information on dual or redundant references, see About Redundant and Dual Video Refer-
ences on page 72.

8 In the ‘NTSC/PAL Reference Options’ section, select the radio button corresponding to the sig-
nal type being used as a video reference: ‘1080i’, ‘720p’ or ‘1080p’. This signal will be used as 
the switching reference.

9 Click Apply Changes to Selected Outputs, or from the menu bar select ‘Edit > Apply Changes’, to 
apply your changes to the selected outputs. This does not write your changes to the control 
cards. The changes display in the right-hand field.

10 Click Write All, or from the menu bar select ‘Edit > Write Changes’, to write changes to the con-
trol card.

11 Repeat steps 2–9 for each control card being updated.

Check Box(es) Description

Use Video Reference 1
Use Video Reference 2

Choose to have the signal entering the ‘VIDEO REF 1’ or ‘VIDEO 
REF 2’ connection on the router as the reference.
‘Ref1’ or ‘Ref2’ appears in the ‘Ref1/Ref2’ column.

Use Reclocker
Bypass Reclocker

Choose to re-clock the signal or bypass the re-clocker, retaining the 
signal’s current rate.
These check boxes affect only SWB outputs. Make the desired 
selection for each SWB output.
‘Reclock’ or ‘Bypass’ appears in the ‘Reclock/Bypass’ column.

Switch on SD Line
Switch on HD Line

Choose ‘Switch on SD Line’ if the selected signal is a standard 
definition digital video signals (SD) or an analog video signal. 
Choose ‘Switch on HD Line’ if a high definition digital video signal 
(HD).
‘SD’ or ‘HD’ appears in the ‘SD/HD’ column.
Note: The default choice is Switch on SD Line.
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How to Select Switch Point Settings for the NV8500 Family Routers
1 Launch UniConfig. (See Launching UniConfig on page 9.)
2 Select a control card. (See Selecting a Control Card on page 10.)
3 From the menu bar, select ‘Window > Switch Point Setup’. The ‘Switch Point Setup’ window 

appears displaying current output settings for the router being configured: 

Figure 9-6. Switch Point Setup Window

4 In the ‘Output Range’ section, enter a ‘Start’ and ‘End’ output signal number in the fields pro-
vided and click Read Outputs. Outputs corresponding to the range entered display in the ‘Select 
Outputs to edit’ pane with default settings.
The following lists each column and the information it presents:

Column Description

Output The number assigned to the signal for internal routing reference purposes. The 
number usually refers to the physical port through which the signal is distributed.

Reclock/bypass Indicates if the signal bypasses re-clocking. See step 5.

HD/SD Indicates if the signal is a standard definition (SD) or high definition (HD) video 
signal. See step 5.

Ref1/Ref2 Indicates if the signal is using the reference signal through ‘VIDEO REF1’ or 
‘VIDEO REF2’ connection on the router. See step 5.
UniConfig Configuration Application  •  User’s Guide 83



9. Managing Switch Point Settings
Setting Up Switch Points
5 In the ‘Select Outputs to edit’ pane, select the outputs being updated:
To select specific outputs, use your keyboard and mouse.
Or
To select all outputs, from the menu bar select ‘Edit > Select All’.
Or
To clear all outputs currently displaying, from the menu bar select ‘Edit > Remove all Outputs’.

6 In the ‘Set selection(s) to’ section, check each check box to apply a video reference, re-clocking 
and switching on the SD or HD line for the selected outputs.
The following lists each check box and its function:

7 In the ‘Dual Video Reference Option’ section, select ‘Redundant’ or ‘Dual’.
• ‘Redundant’ — Both ‘VIDEO REF 1’ and ‘VIDEO REF 2’ are used, such that if one fails, 

the other can be used as a fail-over. In this instance, both video reference signals should be 
identical.

• ‘Dual’ — Choose which video reference signal to use, ‘VIDEO REF1’ or ‘VIDEO REF 2’. 
In this instance, the reference signals can be different.

For information on dual or redundant references, see About Redundant and Dual Video Refer-
ences on page 72.

8 In the ‘NTSC/PAL Reference Options’ section, select the radio button corresponding to the sig-
nal type being used as a video reference: ‘1080i’, ‘720p’ or ‘1080p’. This signal will be used as 
the switching reference.

9 Click Apply Changes to Selected Outputs, or from the menu bar select ‘Edit > Apply Changes’, to 
apply your changes to the selected outputs. This does not write your changes to the control 
cards. The changes display in the right-hand field.

10 Click Write All, or from the menu bar select ‘Edit > Write Changes’, to write changes to the con-
trol card.

11 Repeat steps 2–10 for each control card being updated.

Check Box(es) Description

Use Video Reference 1
Use Video Reference 2

Choose to have the signal entering the ‘VIDEO REF 1’ or ‘VIDEO 
REF 2’ connection on the router as the reference.
‘Ref1’ or ‘Ref2’ appears in the ‘Ref1/Ref2’ column.

Use Reclocker
Bypass Reclocker

Choose to re-clock the signal or bypass the re-clocker, retaining the 
signal’s current rate.
These check boxes affect only SWB outputs. Make the desired 
selection for each SWB output.
‘Reclock’ or ‘Bypass’ appears in the ‘Reclock/Bypass’ column.

Switch on SD Line
Switch on HD Line

Choose ‘Switch on SD Line’ if the selected signal is a standard 
definition digital video signals (SD) or an analog video signal. 
Choose ‘Switch on HD Line’ if a high definition digital video signal 
(HD).
‘SD’ or ‘HD’ appears in the ‘SD/HD’ column. Note: The default 
choice is Switch on SD Line.
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Updating Switch Points
Switch points can be updated at any time. When the Write All button is clicked, changes are immedi-
ately written to the control card and impact the router switching matrix.

How to Update Switch Point Settings

1 Launch UniConfig. (See Launching UniConfig on page 9.)

2 Select a control card. (See Selecting a Control Card on page 10.)

3 From the menu bar, select ‘Window > Switch Point Setup’. The ‘Switch Point Setup’ window 
appears displaying current output settings.

4 In the ‘Output Range’ section, enter a ‘Start’ and ‘End’ number in the fields provided and click 
Read Outputs. Outputs corresponding to the range entered display in the ‘Select Outputs to edit’ 
field. 

5 In the ‘Select Outputs to edit’ field, select the outputs being updated.

6 Update settings for the selected outputs by checking or unchecking the check boxes as 
described in the following procedures. Be sure to follow procedures for your specific router:

How to Select Switch Point Settings for the NV5100MC or NV5128 Router on page 73.

How to Select Switchpoint Settings for the NV7256 and NV7256-Plus Router on page 75.

How to Select Switch Point Settings for the NV7512 Router on page 77.

How to Select Switch Point Settings for the NV8256-Plus Router on page 79.

How to Select Switch Point Settings for the NV8288 and NV8288-Plus Routers on page 81.

How to Select Switch Point Settings for the NV8500 Family Routers on page 83.

How to Select Switch Point Settings for the EC9535 on page 123.

7 Click Apply Changes to Selected Outputs to apply your changes to the selected outputs. This does 
not write your changes to the control cards. The changes display in the right-hand field.

8 Click Write All to send your changes to the control card.

9 Repeat steps 2–8 for each control card being updated.

Note Each control card must be updated separately.
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10. Managing Inputs and Outputs

Routers receive incoming signals and route them to specific connections for distribution. The actual 
switching from an input to a designated output occurs through the crosspoint array on the router. 
All inputs and outputs on a router and the switching matrix (which input is being sent to which out-
put) display in the ‘Connections’ window. 

Using the ‘Connections’ window, you can view, test, and update switching configurations. Testing 
and updating is done by performing a ‘take’. A take is a specific moment in time when signals are 
switched based on defined parameters.

Changes made through the ‘Connections’ window changes how the crosspoint routes signals in the 
router. Although changes to the switching matrix can be made using the ‘Connections’ window, it 
is recommended that crosspoint management occur through the router control system. The ‘Con-
nections’ window is mainly a means of testing and viewing switching configurations or making 
minor changes when the router control system is unavailable.

Machine control signals are unique because they are bi-directional; neither an input or an output. 
For information on testing and managing machine control signals for the NV5128 and NV5256, see 
Managing Machine Control Ports on page 101.

Important Note

The ‘Connections’ window does not obey rules defined when partitions are configured. (See Set-
ting Up Partitions on page 51.) Be careful when making routing connections in the ‘Connections’ 
window that you do not route incompatible signals. For example, do not route analog video input to 
analog audio output.

Saving and Uploading Switching Configurations
Switching matrices are viewed and managed using the ‘Connections’ window. A “snapshot” of the 
current configuration can be saved for uploading at a future date. This snapshot is called a “salvo”. 
For more information, see Working With Salvos on page 145.

This section provides information on managing incoming and outgoing signals.

Setting ‘Connection’ Window Preferences
When a UniConfig ‘Connections’ window opens, the information that displays is not current. To 
display current information, the Read button must be clicked. To avoid having to click Read each 
time, certain automatic read functions for ‘takes’ can be activated. In addition, preferences can be 
set to advance or decrease the input/output number entered in the ‘Single Take’ fields. 

Note The ‘Connections’ window displays all crosspoints in a router as one large set 
whereas the ‘Configuration’ window displays each partition separately.
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Automatic Refresh After ‘Take’

Once set, clicking the Read button on the “Connections’ window automatically refreshes the ‘Con-
nection’ window with the results of the ‘take’.

How to Set Automatic Refresh after a Take

1 Launch UniConfig. (See Launching UniConfig on page 9.)

2 From the menu bar, select ‘Window > Connections’. The ‘Connections’ window appears with 
blank fields. (See Figure 10-6 on page 93.) The ‘Connections’ window must be active to acti-
vate the necessary menu bar options.

3 Again from the menu bar, select ‘Tools > Options’. The ‘Connections Options’ dialog box 
appears: 

Figure 10-1. Connections Options Dialog Box with Connection Preference Tab in Front

4 Select the ‘Connections Preferences’ tab to bring it to the front.

5 Check the ‘Auto refresh connections after Takes’ check box to automatic read function each 
time a ‘take’ is performed in the ‘Connections’ window.

6 Click OK to save changes and close the dialog box. 

Or 

Click Cancel to close the dialog box without saving any changes.

Automatically Increment/Decrement after ‘Take’

Once set, clicking the Read button on the “Connections’ window automatically increments or dec-
rements the input and/or output listed in the ‘Single Take’ fields. Increment means the number 
advances by one; decrement means the number decreases by one. For example, if increment is 
selected and the current input in the ‘Single Take’ section is 15, the number listed in the ‘Input’ 
field increases by one (16, 17, 18...) each time the Read button is clicked. If decrement is selected, 
the number decreases by one (18, 17, 16...)
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How to Set Automatic Incrementing

1 Launch UniConfig. (See Launching UniConfig on page 9.)
2 From the menu bar, select ‘Window > Connections’. The ‘Connections’ window (Figure 10-6 

on page 93) appears with blank fields. The ‘Connections’ window must be active to activated 
the necessary menu bar options.

3 Again from the menu bar, select ‘Tools > Options’. The ‘Connections Options’ dialog box 
appears: 

Figure 10-2. Connections Options Dialog Box with Connection Preference Tab in Front

4 Select the ‘Connections Preferences’ tab to bring it to the front.
5 In the ‘Input’ section, check a check box to increment or decrement the input number after each 

‘take’ when the Read button in the ‘Connections’ window is clicked:
‘Auto increment after Take’ automatically increases the signal number in the ‘Input’ field by 
one.
‘Auto decrement after Take’ automatically decreases the signal number in the ‘Input’ field by 
one.

6 In the ‘Output’ section, check a check box to increment or decrement the output number after 
each ‘take’ when the Read button in the ‘Connections’ window is clicked:
‘Auto increment after Take’ automatically increases the signal number in the ‘Output’ field by 
one.
‘Auto decrement after Take’ automatically decreases the signal number in the ‘Output’ field by 
one

7 Click OK to save changes and close the dialog box. 
Or 
Click Cancel to close the dialog box without saving any changes.

Displaying Take Buttons

When a UniConfig ‘Connections’ window opens, it does not display the ‘Take’ buttons. Once dis-
played, the ‘Take’ buttons enable you to perform a ‘take’ by clicking the button instead of selecting 
from the menu bar ‘Action > Take’.
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How to Display ‘Take’ Buttons

1 Launch UniConfig. (See Launching UniConfig on page 9.)

2 From the menu bar, select ‘Window > Connections’. The ‘Connections’ window appears with 
blank fields. (See Figure 10-6 on page 93.) The ‘Connections’ window must be active to acti-
vate the necessary menu bar options.

3 Again from the menu bar, select ‘Tools > Options’. The ‘Connections Options’ dialog box 
appears: 

Figure 10-3. Connections Options Dialog Box with Other Tab in Front

4 Select the ‘Other’ tab to bring it to the front.

5 Check the ‘Show Take Buttons on Connection Dialog’ check box. The ‘Take’ buttons display 
on the ‘Connections’ window.

6 Click OK to save changes and close the dialog box. 

Or 

Click Cancel to close the dialog box without saving any changes.

Updating ‘Connection’ Window Preferences
Preferences set for the ‘Connection’ window can be updated at any time. Changes to preferences 
take effect immediately. Preferences include auto-refresh and incrementing or decrementing after a 
‘take’ is performed.

How to Update Preferences

1 Launch UniConfig. (See Launching UniConfig on page 9.)

2 From the menu bar, select ‘Window > Connections’. The ‘Connections’ window appears with 
blank fields. (See Figure 10-6 on page 93.) The ‘Connections’ window must be active to acti-
vate the necessary menu bar options.
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3 Again from the menu bar, select ‘Tools > Options’. The ‘Connections Options’ dialog box 
appears: 

Figure 10-4. Connections Options Dialog Box with Connection Preference Tab in Front

4 Select the ‘Connections Preferences’ tab to bring it to the front.

5 Uncheck the ‘Auto refresh connections after Takes’ check box to turn off the automatic read 
function each time a take is performed in the ‘Connections’ window.

6 In the ‘Input’ section, uncheck a check box to turn of incrementing or decrementing the input 
number after each ‘take’ when the Read button in the ‘Connections’ window is clicked.

7 In the ‘Output’ section, uncheck a check box to turn off incrementing or decrementing the out-
put number after each ‘take’ when the Read button in the ‘Connections’ window is clicked.

8 Select the ‘Other’ tab to bring it to the front: 

Figure 10-5. Connections Options Dialog Box with Other Tab in Front

9 Uncheck the ‘Show Take Buttons on Connection Dialog’ check box to remove the ‘Take’ but-
tons from the ‘Connections’ window, as needed.

10 Click OK to save changes and close the dialog box. 

Or, click Cancel to close the dialog box without saving any changes.
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Viewing Signal Inputs and Outputs
The ‘Connections’ window features tabs that display standard, mono or machine control signals. 
Standard switching refers to signals that are switched as single, complete signals, not as individual 
channels. Mono channels are switched as individual channels. Machine control signals are single 
bi-directional signals.

Depending on the router connected to UniConfig, only the signals a router can switch are viewable.

The following is a list of what inputs and outputs are viewable for each router:

• NV5100 — standard and mono signals.

• NV5128 — standard, mono, and machine control signals.

• NV5256 and NV7256-Plus — standard and mono signals.

• NV7512 — standard and mono signals.

• NV8256-Plus — standard signals only.

• NV8288 and NV8288-Plus — standard signals only.

• NV8500 Family — standard signals only.

For information on viewing machine control signals for the NV5128 and NV5256, see Managing 
Machine Control Ports on page 101.

Viewing Standard X/Y Crosspoint
Depending on the router connected to UniConfig, different tabs appear in the ‘Connections’ win-
dow. All routers, except the NV5256, display a ‘X/Y Standard’ tab. This tab displays all inputs and 
outputs for audio stereo, audio analog, video digital, and video analog signals. The term ‘X/Y’ 
refers to the switching of an input (X) to an output (Y).

How to View Standard Signals

1 Launch UniConfig. (See Launching UniConfig on page 9.)

2 Select a control card. (See Selecting a Control Card on page 10.)

3 From the menu bar, select ‘Window > Connections’. The ‘Connections’ window appears with 
blank fields.
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4 If not already in front, select the ‘X-Y/Standard’ tab, as shown in Figure 10-6. Each input is 
listed with its corresponding output. 

Figure 10-6. Example of Connections Window with Standard Tab in Front

The ‘Connections’ window displays all crosspoints in a router as one large set whereas the 
‘Configuration’ window displays each partition separately.

5 In the ‘Physical Output Range’ section, enter a ‘Start’ and ‘End’ number in the fields provided 
and click Read Outputs. The corresponding inputs and outputs display on the tab, as shown in 
Figure 10-6. The current router switching configuration displays.

The following lists each column and the information it presents:

6 Repeat steps 2–5 for each control card being viewed.

Viewing Mono Signals Crosspoint
A stereo audio signal is comprised of a left channel and a right channel. When separate, each chan-
nel is referred to a mono signal. Each channel, or mono signal, can then routed separately within a 
router and recombined with other channels for distribution as a new stereo signal.

Column Description

Input The number assigned to the signal for internal routing reference purposes. The number 
usually refers to the physical port through which the signal is received.

Output The number assigned to the signal for internal routing reference purposes. The number 
usually refers to the physical port through which the signal is distributed.

LPR Indicates if the configuration has been locked/protected. Locks are set using the router 
control system. To unlock, see Removing Locks on page 143.

Status The status that displays depends on the current signal type selected. Status information is 
acquired from the control card and displays any status or error states.
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Only the NV5100, NV5128, NV7256, NV7256-Plus and NV7512 routers switch mono signals. 
When these routers are connected to UniConfig, an additional ‘X/Y Mono’ tab appears in the ‘Con-
nections’ window. This tab displays each mono signal individually and not as part of a stereo pair. 
This is very useful when managing mono signal routing. For more information on mono signals 
and switching configurations, see Setting Up Mono Signal Switching on page 64.

How to View Mono Signals

1 Launch UniConfig. (See Launching UniConfig on page 9.)
2 Select a control card. (See Selecting a Control Card on page 10.)
3 From the menu bar, select ‘Window > Connections’. The ‘Connections’ window appears with 

blank fields.
4 Select the ‘X-Y/Mono’ tab: 

Figure 10-7. Example of Connections Window with Mono Tab in Front

Each input is listed with its corresponding output. 

The ‘Connections’ window displays all crosspoints in a router as one large set whereas the 
‘Configuration’ window displays each partition separately.

5 In the ‘Mono Output Range’ section, enter a ‘Start’ and ‘End’ number in the fields provided and 
click Read Outputs. The corresponding inputs and outputs displays on the tab.

The entries in the ‘Input’ and ‘Output’ sections refer to the mono channel number associated 
with the physical input and output, respectively. For example, physical input signal 2 includes 
channel 1 and channel 2 (one left channel and one right channel). For physical input signal 2, 
channel 1 is signal number 3 and channel 2 is signal number 4. Outputs are similarly repre-
sented. 
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The following lists each column and the information it presents:

If no mono audio partitions have not been set up, these fields are grayed-out. (See Setting Up 
Partitions on page 51.)

6 Repeat steps 2–5 for each control card being viewed.

Testing Input/Output Switching ‘Takes’
Using the UniConfig ‘Connections’ window, current switching matrix can be tested. Testing is 
accomplished by performing a series of ‘takes’. A ‘take’ is a specific moment in time when signals 
are switched based on defined parameters. Both standard and mono switching configurations can 
be tested.

For information on testing machine control signals for the NV5128 and the NV5256, see Managing 
Machine Control Ports on page 101.

Standard Signals
The ‘X-Y/Standard’ tab displays for all routers except the NV5256. If no partitions have been set 
up, this tab is inactive. (See Managing Partitions and Signal Types on page 49.)

How to Test Standard Switching Configurations

1 Launch UniConfig. (See Launching UniConfig on page 9.)

2 Select a control card. (See Selecting a Control Card on page 10.)

3 From the menu bar, select ‘Window > Connections’. The ‘Connections’ window appears with 
blank fields. (See Figure 10-6 on page 93.)

4 Select the ‘X-Y/Standard’ tab.

5 In the ‘Physical Output Range’ section, enter a ‘Start’ and ‘End’ number in the fields provided.

6 Click Read Outputs. The corresponding inputs and outputs display on the tab, as shown in 
Figure 10-6 on page 93. The current router switching configuration displays.

The ‘Connections’ window displays all crosspoints in a router as one large set whereas the 
‘Configuration’ window displays each partition separately.

Column Description

Mono The number assigned to the signal for internal routing reference purposes. For example, 
the left channel of stereo signal 1 (listed in the ‘Phys’ column) is assigned number 1 and 
the right channel is assigned number 2.

Phys The physical signal being received or distributed. A stereo audio signal is comprised of 
two channels: one left and one right.

Chnl The signal number assigned to the left channel or right channel of the physical signal.

LPR Indicates if the configuration has been locked/protected. Locks are set using the router 
control system. To unlock, see Removing Locks on page 143.

Status Mono takes are reported as a breakaway in the ‘Status’ column on the tab. 

Note Each control card must be tested separately.
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7 On the tab, select the outputs being tested:

To select specific outputs use your keyboard and mouse.

Or

To select all outputs, from the menu bar select ‘Edit > Select All’.

8 To perform a ‘take’ on multiple signals, from the menu bar select ‘Action’ or right-click in the 
pane to open a pop-up menu, and then select an option. If an option is not applicable to the cur-
rently active tab, the option is greyed-out.

The following lists the menu options:

9 To perform a single ‘take’ of a single input to a single output for an audio digital stereo, audio 
analog, video digital or video analog signal (depending on the router connected), perform the 
following:

Enter an ‘Input’ and an ‘Output’ in the fields provided in the ‘Single Take’ section. 

Click Execute. 

10 (Optional) Create a switching configuration “salvo”. For more information, see Working With 
Salvos on page 145.

11 Repeat steps 2–9 for each control card being tested.

Mono Signals

The ‘X-Y/Mono’ tab appears only for the NV5100, NV5128, NV7256, NV7256-Plus, and NV7512 
routers. If no mono partitions have been set up, this tab is inactive. (See Managing Partitions and 
Signal Types on page 49.)

Option Description

Diagonal Take Connects a contiguous range of physical inputs to a contiguous range of physical 
outputs, usually within a partition or within the entire matrix. Example: 1-1, 2-2, ..., 
32-32. Each input is routed to each output. 
Note: A ‘Diagonal Take’ is useful for restoring a matrix or partition to a default 
starting point when testing it.

Range Take Connects a desired input to a contiguous range of physical outputs. Test outputs 
from one input; one source is fed to multiple destinations.

Rev Diagonal 
Take

Connects a contiguous range of physical inputs to a contiguous range of physical 
outputs in reverse order, usually within a partition or within the entire matrix. 
Example: 33–48, 34–47, ..., 48–33. A reverse diagonal take is useful for restoring a 
matrix or partition to a default starting point when testing it.

Chop Take Two inputs are connected to a single output in a rapid, continuous alternating 
sequence. 
To exit ‘Chop Take’ mode, perform a new ‘Single Take’ to the test output. See step 
9.

Caution The input and output must be an actual I/O currently listed on the tab. Entering 
an input or output that is not currently listed on the tab will create a new 
switching configuration.
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How to Test Mono Switching Configurations

1 Launch UniConfig. (See Launching UniConfig on page 9.)
2 Select a control card. (See Selecting a Control Card on page 10.)
3 From the menu bar, select ‘Window > Connections’. The ‘Connections’ window appears with 

blank fields. (See Figure 10-6 on page 93.)
4 Select the ‘X-Y/Mono’ tab.
5 In the ‘Mono Output Range’ section, enter a ‘Start’ and ‘End’ number in the fields provided. 
6 Click Read Outputs. The corresponding inputs and outputs display on the tab, as shown in 

Figure 10-7 on page 94. The current router switching configuration displays.
The ‘Connections’ window displays all crosspoints in a router as one large set whereas the 
‘Configuration’ window displays each partition separately.

7 On the tab, select the outputs being tested:
To select specific outputs use your keyboard and mouse.
Or
To select all outputs, from the menu bar select ‘Edit > Select All’.

8 To perform a ‘take’ on multiple signals, from the menu bar select ‘Action’ or right-click in the 
pane to open a pop-up menu, and then select an option. If an option is not applicable to the cur-
rently active tab, the option is greyed-out.
The following lists the menu options:

Option Description

Diagonal Take Connects a contiguous range of physical inputs to a contiguous range of physical 
outputs, usually within a partition or within the entire matrix. Example: 1-1, 2-2,..., 
32-32. Each input is routed to each output. 
Note: A ‘Diagonal Take’ is useful for restoring a matrix or partition to a default 
starting point when testing it.

Range Take Connects a desired input to a contiguous range of physical outputs. Test outputs 
from one input; one source is fed to multiple destinations.

Rev Diagonal 
Take

Connects a contiguous range of physical inputs to a contiguous range of physical 
outputs in reverse order, usually within a partition or within the entire matrix. 
Example: 33-48, 34-47,..., 48-33. A reverse diagonal take is useful for restoring a 
matrix or partition to a default starting point when testing it.

Chop Take Two inputs (either channel) are alternately connected to either channel of a single 
output. This mode of alternately switching between inputs to an output is useful 
when comparing signals or making timing adjustments.
To exit ‘Chop Take’ mode, perform a new ‘Single Take’ to the test output. See step 
9.
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9 To perform a single ‘take’ of a single input to a single output for a mono audio signal (NV5100, 
NV5128, NV7256, NV7256-Plus, and NV7512), perform the following:

a Enter an ‘Input’ and an ‘Output’ in the fields provided in the ‘Physical Mono Take’ section.

b Click Execute. 

Or

a Enter an ‘Input’ and an ‘Output’ in the fields provided in the ‘Physical Mono Take’ section.

b From the drop-down lists, select a ‘Channel’ 1 or a ‘Channel’ 2 for the input and the output.

c Click Execute. 

10 (Optional) Create a switching configuration “salvo”. For more information, see Working With 
Salvos on page 145.

11 Repeat steps 2–9 for each control card being tested.

Updating Input/Output Switching
The UniConfig ‘Connections’ window manages crosspoint switching settings for individual sig-
nals. The ‘Connections’ window displays all crosspoints in a router as one large set whereas the 
‘Configuration’ window displays each partition separately. This is helpful if changes to switching 
settings need to be made before the router control system is set up. However, the ‘Connections’ 
window is not intended for use as a router control system. Switching configurations should be man-
aged using a router control system.

To update a single switching configuration, that is, changing what one input sends to an output, 
enter the new input to output that you want to configure and perform a single ‘take’.

Depending on the router, audio digital stereo, audio analog, video digital or video analog signals 
are managed using the ‘X-Y/Standard’ tab. For mono signals, switching is managed through the 
‘X-Y/Mono’ tab. Follow the instructions matching the type of signal for which switching is being 
updated. If the router does not manage mono signals, or mono signal partitions have not been set 
up, the ‘X-Y/Mono’ tab is not available.

For information on updating machine control signal switching for NV5128 or NV5256, see Manag-
ing Machine Control Ports on page 101.

Caution The input and output must be an actual I/O currently listed on the tab. Entering 
an input or output that is not currently listed on the tab will create a new 
switching configuration.

Note Each control card must be configured separately.
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Standard Signals
The ‘X-Y/Standard’ tab displays for all routers except the NV5256. If no partitions have been set 
up, this tab is inactive. (See Managing Partitions and Signal Types on page 49.) Switching can only 
be changed for a single input and single output at a time. For managing multiple switching configu-
rations, use the router control system.

How to Update a Standard Switching Configuration

1 Launch UniConfig. (See Launching UniConfig on page 9.)

2 Select a control card. (See Selecting a Control Card on page 10.)

3 From the menu bar, select ‘Window > Connections’. The ‘Connections’ window appears with 
blank fields. (See Figure 10-6 on page 93.)

4 Select the ‘X-Y/Standard’ tab.

5 To view current switching configuration, in the ‘Physical Output Range’ section, enter a ‘Start’ 
and ‘End’ number in the fields provided and click Read Outputs. The corresponding inputs and 
outputs display on the tab, as shown in Figure 10-6 on page 93.

6 In the ‘Physical Take’ section, enter the ‘Input’ and ‘Output’ that you want to switch. 

For example, if currently input 1 switches to output 3, and you want input 1 to switch to output 
6, enter 6 in the ‘Output’ field. 

7 Click Execute. A ‘take’ is performed and the new switching configuration set.

8 (Optionally) create a switching configuration “salvo.” For more information, see Working With 
Salvos on page 145.

9 Repeat steps 2–7 for each control card being updated.

Mono Signals

The ‘X-Y/Mono’ tab only displays for the NV5100, NV5128, NV7256, NV7256-Plus, and 
NV7512 routers. If no mono partitions have been set up, this tab is inactive. (See Managing Parti-
tions and Signal Types on page 49.)

How to Update a Mono Switching Configuration

1 Launch UniConfig. (See Launching UniConfig on page 9.)

2 Select a control card. (See Selecting a Control Card on page 10.)

3 From the menu bar, select ‘Window > Connections’. The ‘Connections’ window appears with 
blank fields. (See Figure 10-6 on page 93.) 

4 Select the ‘X-Y/Mono’ tab.

5 To view current switching configuration, in the ‘Mono Output Range’ section, enter a ‘Start’ 
and ‘End’ number in the fields provided and click Read Outputs. The corresponding inputs and 
outputs display on the tab, as shown in Figure 10-6 on page 93. The current router switching 
configuration displays.
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6 In the ‘Physical Mono Take’ section, enter the ‘Input’ and the ‘Output’ you want to switch.

For example, if currently input 1 switches to output 3, and you want input 1 to switch to output 
6, enter 6 in the ‘Output’ field.

7 From the drop-down lists, select a ‘Channel’ 1 or a ‘Channel’ 2 for the input and the output.

8 Click Execute. A ‘take’ is performed and the new switching configuration set.

9 (Optionally) create a switching configuration “salvo.” For more information, see Working With 
Salvos on page 145.

10 Repeat steps 2–8 for each control card being updated.
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Machine control ports are used for communicating between machines. Machine control ports are 
bi-directional; neither inputs nor outputs. Only the NV5128 and the NV5256 route machine control 
signals. Machine control signals are configured separately from audio, video, or time code signals. 
For more information on managing other signals, see Managing Inputs and Outputs on page 87.

Using the ‘Connections’ window, you can view, test, and update machine control port switching 
configurations. Testing and updating is done by performing a ‘take’. A ‘take’ is a specific moment 
in time when signals are switched based on defined parameters.

Although changes to the switching matrix can be made using the ‘Connections’ window, it is rec-
ommended that crosspoint management occur through the router control system. The ‘Connec-
tions’ window is mainly a means of testing and viewing switching configurations or making minor 
changes when the router control system is unavailable.

Important Note

Machine control routes established using the ‘Connections’ window do not obey the rules defined 
when partitions are configured. (See Setting Up Partitions on page 51.) Be careful when making 
routing connections in the ‘Connections’ window that you do not route incompatible signals. 
Routes made using the ‘Connections’ window always follow the ‘Data Reverse’ mode.

In addition, the ‘Machine Control Setup’ window is used to configure machine control ports. (See 
Setting Up Machine Control Ports on page 101.) The viewing and testing of machine control 
switching (i.e., performing ‘takes’) is performed using the ‘Connections’ window. Whatever mode 
is set in the ‘Machine Control Setup’ window overrides whatever is set in the ‘Connections’ win-
dow.

Saving and Uploading Switching Configurations
Switching matrices are viewed and managed using the ‘Connections’ window. A “snapshot” of the 
current configuration can be saved for uploading at a future date. This snapshot is called a “salvo”. 
For more information, see Working With Salvos on page 145.

This sections provides information on how to set up, test, and manage machine control ports.

Setting Up Machine Control Ports
When setting up the machine control ports, the ports can be configured to function in a specific 
manner. By default, all machine control ports are set to ‘Dynamic’. A dynamic port changes its con-
figuration to match the current operation requirements as directed by the router control system. 

Machine control ports are bi-directional, but can be set to send signals in only one direction. If set 
as a Controlling device, the ports only send and do not receive signals. If set as a Controlled device, 
the ports only receive and do not send signals. This is valuable when you want to send signals from 
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one machine (e.g. machine containing master) to multiple other machines (e.g. machines that create 
copies).

In addition, the machine control ports can be configured to only connect to a primary or secondary 
device. 

How to Configure Port Matching Control Ports
1 Launch UniConfig. (See Launching UniConfig on page 9.)
2 Select a control card. (See Selecting a Control Card on page 10.)
3 From the menu bar, select ‘Window > Machine Control Port Setup’. The ‘Machine Control Port 

Setup’ window appears: 

Figure 11-1. Machine Control Port Setup Window

4 Click Read, or from the menu bar, select ‘Edit >Read All’. The current configuration of each 
ports displays in the right-hand pane with default settings.

5 Enter a number in the ‘Take Delay’ field to set the frame ‘take’ delay. The “take delay” is the 
number of video frames between the time a port is disconnected from one device and connected 
to another. The delay period should be long enough to allow devices to recognize that they have 
been reconnected to a new device, usually 20 to 30 frames. Be sure to verify that the delay is 
sufficient.

6 In the right-hand pane, select the ports being updated.

Note Each control card must be configured separately.

Note Menu options for the ‘Machine Control Port Setup’ window do not activate 
until a ‘take’ delay number is entered.
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7 From the menu bar select ‘Edit’, or right-click on a selected port to open a pop-up menu, and 
then an option.
The following describes each menu option and its function:

8 Click Read to display your changes. This does not save your changes.

9 Click Write or, from the ‘Edit’ menu, select ‘Write Ports’ to send the edited settings to the con-
trol card.

10 Repeat steps 2–9 for each control card being updated.

Updating Machine Control Port Setups
Machine control port switching configurations can be updated at any time. Whatever mode is set in 
the ‘Machine Control Setup’ window overrides whatever is set in the ‘Connections’ window.

How to Update Machine Control Port Settings
1 Launch UniConfig. (See Launching UniConfig on page 9.)
2 Select a control card. (See Selecting a Control Card on page 10.)

Port Type Description

Set as Dynamic The port configuration changes to match the requirements of the current 
operation. The changes take place under the direction of the router control system. 
Note: This is both the default and the recommended setting for most applications.
‘Dynamic’ appears in the ‘Type’ column.

Set as DTE Configures the port to connect to a controlling device. This selection is used only 
in RS-232 applications.
Note: DTE is an abbreviation for Data Terminal Equipment.
‘DTE’ appears in the ‘Type’ column.

Set as DCE Configures the port to connect to a controlled device. This selection is used only 
in RS-232 applications.
Note: DCE is an abbreviation for Data Communications Equipment.
‘DCE’ appears in the ‘Type’ column.

Set as Master Configures or “hard wires” the port to connect to a primary device. 
‘Master’ appears in the ‘Type’ column.

Set as Slave Configures or “hard wires” the port to connect to a secondary device.
‘Slave’ appears in the ‘Type’ column.

Set as Controlling Configures the port to connect to a device that normally functions as a controlling 
device (but may also serve as a controlled device).
‘P2P Controlling’ appears in the ‘Type’ column.

Set as Controlled Configures the port to connect to a device that normally functions as a controlled 
device (but may also serve as a controlling device).
‘P2P Controlled’ appears in the ‘Type’ column.

Note Each control card must be updated separately.
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3 From the menu bar, select ‘Window > Machine Control Port Setup’. The ‘Machine Control Port 
Setup’ window appears displaying current port settings, as shown in Figure 11-1 on page 102.

4 As needed, update the number in the ‘Take Delay’ field to set the frame ‘take’ delay. The “take 
delay” is the number of video frames between the time a port is disconnected from one device 
and connected to another. The delay period should be long enough to allow devices to recognize 
that they have been reconnected to a new device, usually 20 to 30 frames. Be sure to verify that 
the delay is sufficient

5 In the right-hand pane, select the ports being updated.
6 Update settings for the selected outputs by checking or unchecking the check boxes as 

described in step 7 in Setting Up Machine Control Ports on page 101.
7 Click Write to send your changes to the control card.
8 Repeat steps 2–7 for each control card being updated.

Setting Machine Control Take Preferences
Using the UniConfig ‘Connections’ window, options for how machine control port ‘takes’ are per-
formed can be set. Because machine control ports are bi-directional, you can set in which direction 
the ‘take’ occurs. Directions of signals are based on whether a device is set as a Controlling or Con-
trolled device in the ‘Machine Control Port Setup’ window. For more information, see Setting Up 
Machine Control Ports on page 101.

For information on setting other ‘Connections’ window preferences, see Setting ‘Connection’ Win-
dow Preferences on page 87.

‘Takes’ can be configured to perform as follows:
• Forward — Configures the router to perform a ‘take’ by sending signals from the Controlling 

device to the Controlled device. 
• Reverse — Configures the router to perform a ‘take’ by sending signals from the Controlled 

device to the Controlling device. 
• Broadcast — Configures the router to perform a ‘take’ by sending signals from the Controlling 

device to multiple Controlled devices. One signal can be “broadcast” to several devices. For 
more information, see Broadcasting Machine Control Signals on page 112.

• Data X/Y — Configures the router to act as if machine control ports are standard I/O ports and 
not bi-directional. See “About Data X/Y Takes” on this page.

About Data X/Y Takes
Machine control routers have bi-directional port; every port can pass both input and output signals. 
X/Y routers have single direction ports; a port can either pass an input or an output signal, but not 
both.

When a ‘take’ is performed in an X/Y router, for example input 1 to output 2, only one signal is 
passed through the router from 1 to 2. When a ‘take’ is performed for port 1 to port 2 in a machine 
control router, two signals are passed through: from 1 to 2 and from 2 to 1. Additionally, if a 
another ‘take’ occurs, for example, for port 1 to port 4, the router passes signals 1 to 4 and 4 to 1 
removing the signal path connections associated with port 2.
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If a machine control router is in ‘Data X/Y’ mode, when a ‘take’ is performed, only one signal is 
passed. For example, if a ‘take’ is performed for port 1 to port 2, one signal is passed from 1 to 2, 
not 2 to 1. This allows another ‘take’ to be performed without removing prior path connections. For 
example, a ‘take’ for port 1 to port 4, passes one signal from 1 to 4 without disconnecting the signal 
of path of 1 to 2.

How to Set Machine Control Take Preferences

1 Launch UniConfig. (See Launching UniConfig on page 9.)

2 From the menu bar, select ‘Window > Connections’. The ‘Connections’ window appears with 
blank fields: 

Figure 11-2. Example of Connections Window with Machine Control Tab in Front

The ‘Connections’ window must be active to activate the necessary menu bar options.
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3 Again from the menu bar, select ‘Tools > Options’. The ‘Connections Options’ dialog box 
appears: 

Figure 11-3. Connections Options Dialog Box with Connection Preference Tab in Front

4 Select the ‘Machine Control’ tab to bring it to the front: 

Figure 11-4. Connections Options Dialog Box with Connection Preference Tab in Front

5 In the ‘Machine Control Take Formats’ section, select a radio button to configure what occurs 
when a ‘take’ is performed using the ‘Connections’ window. (See Updating Machine Control 
Port Switching on page 110.)

• Forward — Configures the router to perform a ‘take’ by sending signals from the 
Controlling device to the Controlled device. 

• Reverse — Configures the router to perform a ‘take’ by sending signals from the Controlled 
device to the Controlling device. 

• Broadcast — Configures the router to perform a ‘take’ by sending signals from the 
Controlling device to multiple Controlled devices. One signal can be “broadcast” to several 
devices. For more information, see Broadcasting Machine Control Signals on page 112.

• Data X/Y — Configures the router to act as if machine control ports are standard I/O ports 
and not bi-directional. See “About Data X/Y Takes” on this page.
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6 Click OK to save changes and close the dialog box.
Or 
Click Cancel to close the dialog box without saving any changes.

Updating Machine Control Take Preferences
Preferences set for the ‘Connection’ window can be updated at any time. Changes to preferences 
take effect immediately. However, settings in the ‘Machine Control Setup’ window override the 
‘Connection’ window settings. (See Setting Up Machine Control Ports on page 101.)

How to Update Machine Control Take Preferences

1 Launch UniConfig. (See Launching UniConfig on page 9.)

2 From the menu bar, select ‘Window > Connections’. The ‘Connections’ window appears with 
blank fields. The ‘Connections’ window must be active to activate the necessary menu bar 
options. (See Figure 11-2.) 

3 Again from the menu bar, select ‘Tools > Options’. The ‘Connections Options’ dialog box 
appears, as shown in Figure 11-3.

4 \Select the ‘Machine Control’ tab to bring it to the front, as shown in Figure 11-4.

5 In the ‘Machine Control Take Formats’ section, select a different radio button to configure what 
occurs when a take is performed using the ‘Connections’ window. (See Updating Machine Con-
trol Port Switching on page 110.) For details, see step 5, Setting Machine Control Take Prefer-
ences on page 104.

6 Click OK to save changes and close the dialog box.
Or 
Click Cancel to close the dialog box without saving any changes.

Viewing Machine Control Switching
Only the NV5128 and NV5256 routers switch machine control signals. Machine control signals are 
neither inputs or outputs, but rather bi-directional. Both routers display a ‘Machine Control’ tab in 
the ‘Connections’ window, which display all machine control ports on the router.

How to View Machine Control Signals

1 Launch UniConfig. (See Launching UniConfig on page 9.)

2 Select a control card. (See Selecting a Control Card on page 10.)

3 From the menu bar, select ‘Window > Connections’. The ‘Connections’ window appears with 
blank fields.

4 Select the ‘Machine Control’ tab, as shown in Figure 11-2. Each input is listed with its corre-
sponding output.
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5 In the ‘Physical Output Range’ section, enter a ‘Start’ and ‘End’ number in the fields provided 
and click Read Outputs. The corresponding ports display on the tab.

The following lists each column and the information it presents:

If no machine control partitions have been set up, these fields are grayed-out. (See Setting Up 
Partitions on page 51.)

6 Repeat steps 2–5 for each control card being viewed.

Testing Machine Control Ports Switching
Only the NV5128 and NV5256 routers switch machine control signals. Machine control signals are 
neither inputs or outputs, but rather bi-directional. Both routers display a ‘Machine Control’ tab in 
the ‘Connections’ window, which lists all machine control ports on the router.

Machine control port routing is tested by performing “takes”. A ‘take’ is a specific moment in time 
when signals are switched based on defined parameters. For machine control signals, performing a 
‘take’ of multiple signals may not always be practical. For example, performing a ‘Diagonal Take’, 
connects port 1 to port 1, port 2 to port 2 and so on. (See Updating Machine Control Port Switching 
on page 110.) When ports are connected to themselves in this manner, the port’s connections are 
automatically tri-stated..

Note When the Machine Control tab is selected, entries in ‘Physical Output Range’ 
and in ‘Single Take’ fields refer to machine control port numbers, not physical 
input or output numbers on the frame.

Column Description

Input The number assigned to the signal for internal routing reference purposes. The number 
usually refers to the physical port through which the signal is received.

Output The number assigned to the signal for internal routing reference purposes. The number 
usually refers to the physical port through which the signal is distributed.

LPR Indicates if the configuration has been locked/protected. Locks are set using the router 
control system. To unlock, see Removing Locks on page 143.

Status The current state of the ports for machine control signals:
Tristate — The port is “open” and has no machine control routing directions assigned.
P2P Controlled — Indicates that the port is being controlled by another device. See 
Setting Up Machine Control Ports on page 101.
P2P Controlling — Indicates that the device is normally a controlling device. See 
Setting Up Machine Control Ports on page 101.
BcastControlling — Indicates that a controlling device is broadcasting (sending) signals 
to the ports for distribution to controlled (receiving) devices. See Broadcasting Machine 
Control Signals on page 112.
RecvOnlyControlled — Indicates that a controlled device is receiving signals from the 
ports from a controlling (sending) device. See Broadcasting Machine Control Signals 
on page 112.

Caution Performing random ‘takes’ on machine control ports may cause unexpected results 
if the ports are connected to a variety of equipment throughout your facility.
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How to Test Machine Control Signals

1 Launch UniConfig. (See Launching UniConfig on page 9.)

2 Select a control card. (See Selecting a Control Card on page 10.)

3 From the menu bar, select ‘Window > Connections’. The ‘Connections’ window appears with 
blank fields.

4 Select the ‘Machine Control’ tab: 

Figure 11-5. Example of Connections Window with Machine Control Tab in Front

Each input is listed with its corresponding output.

5 In the ‘Physical Output Range’ section, enter a ‘Start’ and ‘End’ number in the fields provided 
and click Read Outputs. The corresponding ports display on the tab.

If the ‘Machine Control’ tab is blank, perform a ‘Diagonal Take’ (step 7), connecting port 1 to 
port 1, and so on. When ports are connected to themselves in this manner, the port’s connec-
tions are automatically tri-stated.

Note Each control card must be configured separately.

Note When the ‘Machine Control’ tab is selected, entries in the ‘Physical Output 
Range’ and in ‘Single Take’ fields refer to machine control port numbers, not 
physical input or output numbers on the frame.
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6 On the tab, select the outputs being tested:
To select specific outputs use your keyboard and mouse.
Or
To select all outputs, from the menu bar select ‘Edit > Select All’.

7 To perform a take on multiple signals, from the menu bar select ‘Action’, right-click in the con-
nections pane to open a pop-up menu, and then select an option. If an option is not applicable to 
the currently active tab, the option is greyed-out.

The following lists the menu options:

8 To perform a single ‘take’ of a single input to a single output, perform the following:

a Enter an ‘Input’ and an ‘Output’ in the fields provided in the ‘Single Take’ section. 

b Click Execute.

9 (Optionally) create a switching configuration “salvo”. For more information, see Working With 
Salvos on page 145.

10 Repeat steps 2–8 for each control card being tested.

Updating Machine Control Port Switching
The UniConfig ‘Connections’ window manages switching matrix settings for individual signals. 
This is helpful if changes to switching settings need to be made before the router control system is 
set up. However, the ‘Connections’ window is not intended for use as a router control system. 
Switching configurations are managed using a router control system. 

Option Description

Diagonal Take Connects a contiguous range of physical inputs to a contiguous range of physical 
outputs, usually within a partition or within the entire matrix. 
To set the router to tri-sate, connect each port to itself. Example: 1-1, 2-2,..., 32-32. 
Each input is routed to each output. 
To test current machine control routing, connect each port to the next port in 
sequence. Example: 1-2, 3-4,5-6, and so on.

Range Take Caution: while this function is available, it is not allowed for machine control ports.
Connects a desired input to a contiguous range of physical outputs. Test outputs 
from one input; one source is fed to multiple destinations.

Rev Diagonal 
Take

Caution: while this function is available, it is not allowed for machine control ports.
Connects a contiguous range of physical inputs to a contiguous range of physical 
outputs in reverse order, usually within a partition or within the entire matrix. 
Example: 33-48, 34-47,..., 48-33. A reverse diagonal take is useful for restoring a 
matrix or partition to a default starting point when testing it.

Chop Take This option not available for machine control ports.

Caution The input and output must be an actual I/O currently listed on the tab. Entering 
an input or output that is not currently listed on the tab will create a new 
switching configuration.
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To update a single machine control switching configuration, that is, changing what one port sends 
to another port, enter the new port to port that you want to configure and perform a single ‘take’.

Unique to machine control signals, any given port may only connect to itself (tri-stated) or to one 
other bidirectional port. Because of this, port connections are exclusive, requiring prior connec-
tions, if they exist, to first be broken before a new connection can be established. Only single ports 
can be reconfigured, not a range of ports..

How to Update Switching Configurations

1 Launch UniConfig. (See Launching UniConfig on page 9.)

2 Select a control card. (See Selecting a Control Card on page 10.)

3 From the menu bar, select ‘Window > Connections’. The ‘Connections’ window appears, as 
shown in Figure 11-2.

4 Select the ‘Machine Control’ tab to bring it to the front, as shown in Figure 11-5.

5 In the ‘Physical Output Range’ section, enter a ‘Start’ and ‘End’ number in the fields provided 
and click Read Outputs. The corresponding ports display on the tab.

If the ‘Machine Control’ tab is blank, perform a ‘Diagonal Take’, connecting port 1 to port 1, 
and so on. When ports are connected to themselves in this manner, the port’s connections are 
automatically tri-stated. (See Testing Machine Control Ports Switching on page 108.) 

6 To perform a single ‘take’ of a single input to a single output, perform the following:
Enter the new ‘Input’ and ‘Output’ in the fields provided in the ‘Single Take’ section. For 
example, if currently input 1 switches to output 3, and you want input 1 to switch to output 6, 
enter 6 in the ‘Output’ field. 
Click Execute. A ‘take’ is performed based on the ‘take’ format selected. (See Setting Machine 
Control Take Preferences on page 104.)

7 (Optionally) create a switching configuration “salvo”. For more information, see Working With 
Salvos on page 145.

8 Repeat steps 2–6 for each control card being updated.

Note A port must be in ‘Dynamic’ mode in the ‘Machine Control Setup’ window in 
order to make changes in the ‘Connections’ window. (See Setting Up Machine 
Control Ports on page 101.)

Note Each control card must be configured separately.

Note When the Machine Control tab is selected, entries in ‘Physical Output Range’ 
and in ‘Single Take’ fields refer to machine control port numbers, not physical 
input or output numbers on the frame.

Note A port must be in ‘Dynamic’ mode in the ‘Machine Control Setup’ window in 
order to make changes in the ‘Connections’ window. (See Setting Up Machine 
Control Ports on page 101.)
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Broadcasting Machine Control Signals
UniConfig enables you to “broadcast” signals from one device, through the router, out to one or 
more connected devices. To set up broadcasting, two steps must be performed. First, bi-directional 
communication is set up between the Controlling device and one of the Controlled devices. This 
allows the Controlled device to return a status indicating if commands received from the Control-
ling device are being performed. Next, single direction communication is set up between the Con-
trolling device and all other Controlled devices. This enables the commands to be sent from the 
Controlling device to many other Controlled devices without having to receive multiple status 
reports; all status reporting is through the first Controlled device. 

Figure 11-6 shows Device A as the Controlling device routing data to Device B, Device C, and 
Device D. Device B sends a status back to Device A. Device A forwards information to all other 
devices, but only Device B can send information in reverse. 

Figure 11-6. Broadcasting from Device A to Devices B, C, and D.

How to Broadcast Signals

1 Launch UniConfig. (See Launching UniConfig on page 9.)

2 Select a control card. (See Selecting a Control Card on page 10.)

3 Select the ports that will act as Controlling and as Controlled:

a From the menu bar, select ‘Window > Machine Control Port Setup’. The ‘Machine Control 
Port Setup’ window appears displaying current port settings, as shown in Figure 11-1.

b Click Read, or from the menu bar, select ‘Edit >Read All’. The current configuration of each 
of the ports displays in the right-hand pane with default settings.

c Enter a number in the ‘Take Delay’ field to set the frame ‘take’ delay. The “take delay” is 
the number of video frames between the time a port is disconnected from one device and 
connected to another. The delay period should be long enough to allow devices to recognize 
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Note Each control card must be configured separately.
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that they have been reconnected to a new device, usually 20 to 30 frames. Be sure to verify 
that the delay is sufficient.

d In the right-hand pane, select the ports being set as the ‘Controlling’ ports that will receive 
signals from the Controlling device.

e From the menu bar select ‘Edit’, or right-click on a selected port to open a pop-up menu, 
and then ‘Set as Controlling’. The port can receive, but not send, signals.

f In the right-hand pane, select the ports being set as the ‘Controlled’ ports that will distribute 
signals from the Controlling device to the Controlled devices.

g From the menu bar select ‘Edit’, or right-click on a selected port to open a pop-up menu, 
and then ‘Set as Controlled’. The port can send, but not receive, signals.

h Click Write or from the ‘Edit’ menu, select ‘Write Ports’ to send the edited settings to the 
control card.

4 From the menu bar, select ‘Window > Connections’. The ‘Connections’ window appears, as 
shown in Figure 11-5.

5 In the ‘Physical Output Range’ section, enter a ‘Start’ and ‘End’ number in the fields that corre-
spond to the ports selected in step 3 and click Read Outputs. The corresponding ports display on 
the tab.

If the ‘Machine Control’ tab is blank, perform a ‘Diagonal Take’ (step 7), connecting port 1 to 
port 1, and so on. When ports are connected to themselves in this manner, the port’s connec-
tions are automatically tri-stated.

6 Set the connections option to ‘Broadcast’:

a Again from the menu bar, select ‘Tools > Options’. The ‘Connections Options’ dialog box 
appears, as shown in Figure 11-3.

b Select the ‘Machine Control’ tab to bring it to the front, as shown in Figure 11-4.

c In the ‘Machine Control Take Formats’ section, select the ‘Broadcast’ radio button. This 
configures the router to perform a ‘take’ by sending signals from the Controlling device to 
all Controlled devices. One signal can be “broadcast” to several devices. For more informa-
tion, see Setting Up Machine Control Ports on page 101.

Note Menu options for the ‘Machine Control Port Setup’ window do not activate 
until a ‘take’ delay number is entered.

Note When the Machine Control tab is selected, entries in ‘Physical Output Range’ 
and in ‘Single Take’ fields refer to machine control port numbers, not physical 
input or output numbers on the frame.

Note A port must be in ‘Dynamic’ mode in the ‘Machine Control Setup’ window in 
order to make changes in the ‘Connections’ window. (See Setting Up Machine 
Control Ports on page 101.)
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d Click OK to save changes and close the dialog box.
Or 
Click Cancel to close the dialog box without saving any changes.

7 Once again on the ‘Connections’ window, perform a ‘take’ to have signals sent from the Con-
trolling device, through the router, to the Controlled devices. Perform with a single ‘take’ or a 
‘Range Take’:

To perform a ‘Diagonal Take’ on multiple signals, from the menu bar select ‘Action’, right-
click in the connections pane to open a pop-up menu, and then select ‘Diagonal Take’.

The following lists the menu options:

To perform a single ‘take’ of a single input to a single output, perform the following:

a Enter the new ‘Input’ and ‘Output’ in the fields provided in the ‘Single Take’ section. For 
example, if currently input 1 switches to output 3, and you want input 1 to switch to output 
6, enter 6 in the ‘Output’ field. 

b Click Execute. A ‘take’ is performed based on the take format selected. (See Setting 
Machine Control Take Preferences on page 104.)

8 (Optional) Create a switching configuration “salvo”. For more information, see Working With 
Salvos on page 145.

9 Repeat steps 2–7 for each control card on the router.

Option Description

Diagonal Take Connects a contiguous range of physical inputs to a contiguous range of physical 
outputs, usually within a partition or within the entire matrix. 
To set the router to tri-sate, connect each port to itself. Example: 1-1, 2-2,..., 32-32. 
Each input is routed to each output. 
To test current machine control routing, connect each port to the next port in 
sequence. Example: 1-2, 3-4,5-6, and so on.

Range Take Caution: while this function is available, it is not allowed for machine control ports.
Connects a desired input to a contiguous range of physical outputs. Test outputs 
from one input; one source is fed to multiple destinations.

Rev Diagonal 
Take

Caution: while this function is available, it is not allowed for machine control ports.
Connects a contiguous range of physical inputs to a contiguous range of physical 
outputs in reverse order, usually within a partition or within the entire matrix. 
Example: 33–48, 34–47, ..., 48–33. A reverse diagonal take is useful for restoring a 
matrix or partition to a default starting point when testing it.

Chop Take This option not available for machine control ports.
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The EC9535 GSC Node Bus Converter is a communications protocol converter designed to enable 
Miranda’s NV8288, NV8288-Plus or NV8500 Family (NV8144, NV8280 or NV8576) routers to 
communicate with a SMS7000 system controller. A system controller is a hardware system that 
runs a router control system application. The router control system sends commands to a router’s 
control cards (i.e., circuit boards), telling them what switching tasks to perform.

The SMS7000 system controller requires a GSC Node Bus connection in order to connect and com-
municate with the router. All of Miranda’s routers have a GSC Node Bus connection, except for the 
NV8288, NV8288-Plus or NV8500 Family. The EC9535 solves this problem by providing an inter-
face with a GSC Node Bus. The SMS7000 connects to the EC9535, which in turn, is connected to 
the NV8288, NV8288-Plus or NV8500 Family router.

Using UniConfig, the EC9535 is configured so that the SMS7000 system controller, the EC9535 
and the Miranda router can communicate. This section provides information on how to set up and 
manage EC9535 GSC Node Bus Converters.

Similar to routers, an EC9535 is configured by performing the following steps:

1 Set up communication between UniConfig and EC9535. See Setting Up EC9535 Communica-
tion on page 115.

2 If you are using an Ethernet connection to UniConfig, setting up initial parameters so that Uni-
Config and EC9535 can communicate over a network. See Entering Initial EC9535 Serial and 
Ethernet Settings on page 118.

3 Set up EC9535 partitions (e.g., logical divisions). See Setting Up EC9535 Partitions on page 
122.

4 Set up EC9535 switch points. See Setting Up EC9535 Switch Points on page 123.

For details on making EC9535 connections to a SMS7000 system controller or Miranda router, see 
the EC9535 GSC Node Bus Converter User’s Guide.

Setting Up EC9535 Communication
The control card on the EC9535 communicates with UniConfig through diagnostic serial ports. 
There are two sets of diagnostic connections: one set is located on the front of the control cards and 
one set is located on the rear of the EC9535, labeled ‘DIAG’. Which is used is entirely up to you 
and your facility needs. Usually the control card connection is used when the diagnostic connection 
to UniConfig is temporary. The diagnostic connections on the rear of the EC9535 frame are most 
often used to make a permanent connection to UniConfig. 

In addition to the serial ports the rear of the EC9535 features an Ethernet connection. This port can 
also be used to communicate with UniConfig through a network. 
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In order for the control card and UniConfig to communicate through an Ethernet or serial port 
located on the router, the ports need to be initialized. Initialization is performed by setting the nec-
essary information on the control card using UniConfig.

For more information on initial communication, see Communicating with the Router for the First 
Time on page 21.

EC9535 and Router Baud Rates Must Match
When configuring the EC9535, the EC9535’s ‘CTRL 1’ serial port must be set to the same baud 
rate as the controlled router’s ‘CTRL 1’ serial port rate. By default, the NV8288, NV8288-Plus and 
NV8500 Family routers have the ‘CTRL 1’ ports set to 38,400 baud. However, the number of des-
tinations that can be switched per frame in a system using a SMS7000 system controller, an 
EC9535, and a NV8288, NV8288-Plus or NV8500 Family router is determined by the EC9535 and 
the router serial port baud rates. Because higher rates may be used, you may want to set the serial 
ports at the highest available rate (115,200 baud) unless doing so results in communication errors. 
For information on setting the serial port baud rates for routers, see Updating Serial Communica-
tion Settings on page 30.

EC9535 Control Card Diagnostic Connections
A temporary diagnostic connection can be created using the DE9 port located on the front of the 
primary control card. The baud rate for this port is locked to 9600.

How to Make Control Card Diagnostic Connections

1 Facing the front of the EC9535, open the door and locate the primary control card slot. The pri-
mary control card is located on top (above) and the secondary control card is located below.

2 On the front of the control card is a single serial port. Connect to the serial port using a DE9 
connector and a serial cable.
The following lists the DE9 pin connectors for RS-232:

Note Each control card utilizes its own independent set of EE memory on the mother-
board in the router frame. UniConfig must be used to configure each control card 
in the system separately even if the control card is part of a redundant pair.

PC End (DCE) Pins Router End (DTE)

DCD 1 Ground

RXD 2 TXD

TXD 3 RXD

DTR 4 DSR

Signal Ground 5 Signal Ground

DSR 6 DTR

RTS 7 CTS

CTS 8 RTS

Ground 9 Ground
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3 Connect the other end of the cable to the PC running the UniConfig application using a DE9 
connector.

4 When done configuring, remove the temporary connection.

EC9535 Frame Diagnostic Connections

There are two diagnostic ports located on the rear of the EC9535, labeled ‘DIAG’. The diagnostic 
ports are fixed at a baud rate of 38400, RS-232. 

How to Make Frame Diagnostic Connections

1 Locate the diagnostic connections on the rear of the EC9535. The diagnostic connections are 
labeled ‘DIAG’:  

Figure 12-1. EC9535 Diagnostic Connections (Rear View)

2 Connect to the ‘DIAG’ connection in the ‘PRI’ section using a DE9 connector and a serial 
cable. The ports are set for RS-232:

The following lists the DE9 pin connectors for RS-232:

3 Connect the other end of the cable to the PC running the UniConfig application.

4 If a secondary (optional for redundancy) control card is installed, connect to the ‘DIAG’ con-
nection in the ‘SEC’ section using a DE9 connector and a serial cable as described in step 2 and 
step 3.
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Diagnostic Connections

PC End (DCE) Pins Router End (DTE)

DCD 1 Ground

RXD 2 TXD

TXD 3 RXD

DTR 4 DSR

Signal Ground 5 Signal Ground

DSR 6 DTR

RTS 7 CTS

CTS 8 RTS

Ground 9 Ground
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Entering Initial EC9535 Serial and Ethernet Settings
Using UniConfig, communication parameters are entered that enable the EC9535 to communicate 
with UniConfig, and the SMS7000 system controller to communicate with the EC9535. To set 
communication parameters, several steps must be performed:

1 Serial connection settings entered for the EC9535 and the SMS7000 router control system.

2 Serial connection settings entered for UniConfig.

3 (Optional) Ethernet connection settings entered for UniConfig so that UniConfig can communi-
cate with the router control cards through a network. Routers are added to a network through a 
separate procedure. (See Adding a Control Card to a Network on page 41.)

Although you can choose to only communicate with the EC9535 using a serial connection, both 
Ethernet and serial communication parameters are provided in the proceeding procedures. For more 
information on the benefits of each, see Ethernet vs. Serial on page 21.

How to Enter Serial Communication Parameters

1 Connect to the serial diagnostic connection on the primary control card. (See EC9535 Control 
Card Diagnostic Connections on page 116.) The baud rate is fixed at 9600.

2 Launch UniConfig. (See Launching UniConfig on page 9.)

3 From the menu bar, select ‘Communications > Serial’. This informs UniConfig that communi-
cation with the router is through a serial port.

4 Again from the menu bar, select ‘Communication > Setup’. The ‘Serial Communications’ dia-
log box appears: 

Figure 12-2. Serial Communication Dialog Box

The ‘Serial Communications’ dialog box sets the serial communication parameters for UniCon-
fig. By default the ‘Comm port’ is set to ‘None’ and the ‘Baud rate’ is set to ‘9600’, matching 
the default settings of the control card serial port.

5 From the ‘Comm port’ drop-down list, select the communication port number that matches the 
port number on the PC running UniConfig and click OK.
Or
Click Cancel to close the dialog box without saving changes.
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6 Again from the menu bar, select ‘Windows > Router Serial Configuration’. The ‘Router Serial 
Configuration’ window appears: .

Figure 12-3. Router Serial Configuration Window

The ‘Router Serial Configuration’ window sets serial communication parameters for the router 
control system (‘Control Settings’ sections) and for the diagnostic serial connection labeled 
‘DIAG’ located on the rear of the EC9535 (‘Rear Diagnostic Port’ section). 

7 In the ‘Control 1 and 2 Baud Rate Setting’ section, from the ‘Baud Rate’ drop-down list, select 
‘115200’.

8 In the ‘Rear Diagnostic Port’ section, select a ‘Port type’ of ‘RS232’ and ‘Baud rate’ of 
‘115200’ from the drop-down lists. This sets the communication parameters for the permanent 
serial ports on the EC9535.

9 Click Write to write changes to the control card, overwriting any previous settings.

Warning Do not click Read. Clicking Read reads all settings on the control card, over-
writing any changes you have entered. There is no warning message.
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How to Enter Ethernet Communication Parameters

1 Locate the two Ethernet ports labeled ‘10/100BT’, as shown in Figure 12-4. These ports are 
divided into two sets, one primary (‘PRI CTRL’) and one secondary (‘SEC CTRL’). 

Figure 12-4. Ethernet Connections (Rear View)

2 Connect to the ‘10/100BT’ connection in the ‘PRI CTRL’ section using a RJ45 connector and 
Ethernet cable. 

3 Connect the other end of the cable to the PC running the UniConfig application.

4 From the menu bar, select ‘Window > Configuration’. The ‘Configuration’ window appears, as 
shown in Figure 12-5. Using this window, Ethernet connection settings are entered (i.e., IP 
address and subnet) to enable communication with the EC9535 through a network. 

For details on what IP addresses to use and additional network information, see Network Basics 
on page 39. 

Figure 12-5. Configuration Window
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5 On the ‘Configuration’ window, perform the following steps:

a Click Read All. The ‘Configuration’ window populates with the current router configuration 
and Ethernet settings. Because no prior configuration is stored, many of the fields are blank.

b In the ‘Router Ethernet Settings’ section, choose the ‘Enabled’ radio button. ‘Enabled’ must 
be selected to allow Ethernet communication.

c In the ‘Router Ethernet Settings’ section, enter an ‘IP Address’ and ‘Subnet Mask’ in the 
fields provided as determined by your network. Make sure that the unit (e.g., PC) running 
UniConfig is configured to operate on the same subnet as the control card(s).

d Click Write All to write changes to the control card, overwriting any previous settings.

6 Again from the menu bar, select ‘Communication > Ethernet’. This informs UniConfig that 
communication with the EC9535 is through an Ethernet port. The ‘Control Card’ pane appears 
on the left-hand side of the UniConfig screen.

7 Again from the menu bar, select ‘Communication > Setup’. The ‘Ethernet Communication’ dia-
log box appears: 

Figure 12-6. Ethernet Communication Dialog Box

The ‘Ethernet Configuration’ window sets Ethernet communication parameters (IP address) for 
UniConfig. 

8 On the ‘Ethernet Communication’ dialog box, select settings as follows:

a Enter an ‘IP Address’ for the router control card in the field provided. Make sure that the 
unit (e.g., PC) running UniConfig is configured to operate on the same subnet as the control 
card(s). For details on what IP addresses to you and additional network information, see 
Network Basics on page 39.

b Click OK to save changes and close the dialog box.
Or

c Click Cancel to close the dialog box without saving changes.

9 On the rear of the EC9535, locate the unused ‘10 B 2’ connection in the ‘PRI CTRL’ section 
just above the Ethernet connection. Install a 50 ohm terminator on the unused connection.

10 If a secondary (optional for redundancy) control card is installed, make a temporary connection 
to the secondary control card and repeat steps 2 though 9.

Note Be sure to change Ethernet settings for both the EC9535 and UniConfig. 
UniConfig and the EC9535 must be on the same subnet to successfully 
communicate.

Note The ‘Log Comm Messages’ check box is used for creating a log when per-
forming troubleshooting tasks. Do not check the check box.
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Setting Up EC9535 Partitions
Individual partitions can be created to manage signal switching for the SMS7000 system controller. 
Signals can only be switched within a partition, not across partitions. Partitions are typically based 
on signal types. (See About Partitions on page 49.)

For the EC9535 GSC Node Bus Converter there is only one partition or “level”.

How to Set Up Partitions for an EC9535

1 Launch UniConfig. (See Launching UniConfig on page 9.)

2 Select a control card. (See Selecting a Control Card on page 10.)

3 From the menu bar, select ‘Windows > Configuration’. The ‘Configuration’ window appears: 

Figure 12-7. Example of a Configuration Window for EC9535

4 Click Read All. The ‘Configuration’ window populates with the current router configuration and 
Ethernet settings. If no prior configuration is stored, many of the fields are blank.

5 To set up a partition, enter ‘Level’, ‘Physical Inputs’, ‘Controller Inputs’, ‘Physical Outputs’ 
and ‘Controller Output’ information in the fields provided. Each row represents one partition 
(called ‘Level’ on the interface) in the router control system. The EC9535 has only one partition

Note Each control card must be configured separately.
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The following is a list of each field and the corresponding information to be entered:

6 Click Write All to writes changes to the control card.

7 Repeat steps 2–6 for the remaining control card.

Setting Up EC9535 Switch Points
A “switch point” is a point in time in which an output is switched from the current source to a new 
source. Different video and audio formats require different switch points to prevent data or picture 
disturbances. UniConfig enables you to set switch point parameters for individual outputs. Switch 
points are initially set up as part of configuring the EC9535.

Switch points are managed through the ‘Switch Point Setup’ window. Reference information for 
video and audio signals is through reference connections housed on the EC9535. For video refer-
ence signals, there are two connections labeled ‘VIDEO REF’. Both video reference connections 
can reference the same signal or each connection can reference a unique signal. For audio reference 
signals, there are two connections labeled ‘AES REF’. One or both connections are connected to a 
stable source of AES3 at a sample rate of 48 kHz. If both reference connections are connected, one 
acts as a backup, automatically providing a reference signal should an AES reference source fail.

Important: in general, the video reference and AES reference on the EC9535 are not used. The 
reference signals are received from the router connected to the EC9535. If you plan to connect ref-
erence signals to the EC9535, please contact Technical Support before proceeding. (See Technical 
Support Contact Information on page iii.)

How to Select Switch Point Settings for the EC9535
1 Launch UniConfig. (See Launching UniConfig on page 9.)
2 Select a control card. (See Selecting a Control Card on page 10.)

UniConfig Field Description Values

Level Numeric value identifying a particular configured partition. 0

Physical Inputs Input connectors this partition starts and ends with. 1–1024

Controller Input Logical number this partition starts with. 1

Physical Outputs Output connectors this partition starts and ends with. 1–1024

Controller Output The controller partition starts with the logical number zero. 0

Signal Type Defines what software signal type in use. From the ‘Signal 
Type’ drop-down list, select the signal type ‘Video, 
Async, AES, Timecode’.

Video, Async, 
AES, Timecode
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3 From the menu bar, select ‘Window > Switch Point Setup’. The ‘Switch Point Setup’ window 
appears displaying current output settings for the router being configured: 

Figure 12-8. Switch Point Setup Window

4 In the ‘Output Range’ section, enter a ‘Start’ number of ‘1’ and an ‘End’ number of ‘1024’ and 
click Read Outputs. Outputs corresponding to the range entered display in the ‘Select Outputs to 
edit’ pane with default settings.
The following lists each column and the information it presents:

Column Description

Output The number assigned to the signal for internal routing reference purposes. The 
number usually refers to the physical port through which the signal is distributed.

Reclock/bypass Indicates if the signal bypasses re-clocking. See step 5.

HD/SD Indicates if the signal is a standard definition (SD) or high definition (HD) video 
signal. See step 5.

Ref1/Ref2 Indicates if the signal is using the reference signal through ‘VIDEO REF1’ or 
‘VIDEO REF2’ connection on the router. See step 5.
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5 In the ‘Select Outputs to edit’ pane, select any outputs being updated (It is recommended that 
outputs remain as the default provided):
To select specific outputs, use your keyboard and mouse.
Or
To select all outputs, from the menu bar select ‘Edit > Select All’.
Or
To clear all outputs currently displaying, from the menu bar select ‘Edit > Remove all Outputs’.

6 In the ‘Set selection(s) to’ section, check each check box to apply a video reference, re-clocking 
and switching on the SD or HD line for the selected outputs. 

The following lists each check box and its function:

7 In the ‘Dual Video Reference Option’ section, select ‘Redundant’ or ‘Dual’. 

‘Redundant’ — Both ‘VIDEO REF 1’ and ‘VIDEO REF 2’ are used, such that if one fails, the 
other can be used as a fail-over. In this instance, both video reference signals should be identi-
cal.
‘Dual’ — Choose which video reference signal to use, ‘VIDEO REF1’ or ‘VIDEO REF 2’. In 
this instance, the reference signals can be different.
For information on dual or redundant references, see About Redundant and Dual Video Refer-
ences on page 72.

8 Click Apply Changes to Selected Outputs, or from the menu bar select ‘Edit > Apply Changes’, to 
apply your changes to the selected outputs. This does not write your changes to the control 
cards. The changes display in the right-hand field.

9 Click Write All, or from the menu bar select ‘Edit > Write Changes’, to write changes to the con-
trol card.

10 Repeat steps 2–9 for each control card being updated.

Important Contact Technical Support before using an EC9535 video reference. (See 
Technical Support Contact Information on page iii.)

Check Box(es) Description

Use Video Reference 1
Use Video Reference 2

Choose to have the signal entering the ‘VIDEO REF 1’ or ‘VIDEO REF 2’ 
connection on the router as the reference.
‘Ref1’ or ‘Ref2’ appears in the ‘Ref1/Ref2’ column.

Use Reclocker
Bypass Reclocker

Choose to re-clock the signal or bypass the re-clocker, retaining the signal’s 
current rate.
These check boxes affect only SWB outputs. Make the desired selection for 
each SWB output.
‘Reclock’ or ‘Bypass’ appears in the ‘Reclock/Bypass’ column.

Switch on SD Line
Switch on HD Line

Choose ‘Switch on SD Line’ if the selected signal is a standard definition 
digital video signals (SD) or an analog video signal. Choose ‘Switch on HD 
Line’ if a high definition digital video signal (HD).
‘SD’ or ‘HD’ appears in the ‘SD/HD’ column. Note: The default choice is 
Switch on SD Line.

Important Contact Technical Support before using an EC9535 video reference. (See 
Technical Support Contact Information on page iii.)
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13. NV8500 Monitor Configuration and 
Operation

The NV8500 family of routers support the monitoring of output and input signals. Third-party con-
trol systems or software drivers can be used to monitor NV8500 family router capabilities. Control-
ling which inputs and outputs are switched to the different monitor outputs is accomplished by 
partitioning the router’s inputs and outputs and then assigning the partition a unique level titled 
“Monitor.” “Level” is the term used to describe an organizational partition in the router. A monitor 
level solely manages monitor signals.This partition is then addressed using a standard “take” com-
mand as defined in the protocol being used.

Whether both outputs and inputs are monitored depends upon the control card currently installed in 
the router frame. Older control cards run an application that supports only output monitor signals. 
More recent control cards run an application that supports both output and input signal monitoring.

Control cards running the following application versions support the listed monitor signals:
• APP, Versions 13.0.3.xx and older — The control card supports output monitor signals only 

(matching FPGA versions: CPLD, SV0900-06, SV0901-05 and older). 
• APP, Versions 14.0.0.xx and newer — The control card supports both input and output monitor 

signals (matching FPGA versions: CPLD, SV0900-07, SV0901-06 and newer).

To properly access and control monitor cards and signals, a monitor level must be configured using 
version 8.9.0.42 of UniConfig, or later. 

Overview
The NV8500 family is composed of several routers that are either standalone routers or routers that 
can be connected together to create larger switching matrices called “expandable” router frames. 
Expandable router frames are denoted by the word “Plus.”

The following is a list of routers within the NV8500 family. 

Router Switching Matrix Expandable Expanded Switching Matrix I/O Cards

NV8144  144 inputs, 144 outputs No — 9 inputs, 
18 outputs

NV8280 288 inputs, 576 outputs No — 9 inputs, 
18 outputs

NV8280-Plus 288 inputs, 288 outputs Yes 576 inputs, 576 outputs 9 inputs, 
9 outputs

NV8576 576 inputs, 1152 outputs No — 9 inputs, 
18 outputs

NV8576-Plus 576 inputs, 576 outputs Yes 1152 inputs, 1152 outputs 9 inputs, 
9 outputs
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Overview
Figure 13-1. Backplanes

Depending on the router frame, up to 4 monitor cards can be installed. Each 
monitor card produces 2 signals that can be sent to monitoring equipment for 
the purpose of assessing signal presence and quality. The monitor card must 
have a corresponding monitor backplane installed. (See Figure .) The back-
plane contains connectors through which signals are sent from the “mated” 
monitor card to monitoring equipment. The backplane connectors are labeled 
‘IN 1’, ‘IN 2’, ‘OUT 1’ and ‘OUT 2’. Two of the connectors connect cables 
to the monitoring equipment. The other two connectors are used for “chain-
ing together” multiple monitor cards or multiple routers.

The connectors labeled ‘IN’ on the backplane:
• Cross-connect monitor cards to other monitor cards, such as when two 

expandable frames (NV8280-Plus or NV8576-Plus) are connected 
together, which enables the monitoring equipment access to all inputs or 
outputs, or 

• Connect to an ‘OUT’ connector when cross-connecting multiple monitor 
cards in the same frame to each other. This only applies to NV8576 or 
NV8576-Plus.

The connectors labeled ‘OUT’ on the backplane:
• Connect to an ‘IN’ connector when cross-connecting monitor cards (as 

noted above), or
• Send signals for monitoring purposes to monitoring equipment.

There is a single type of monitor card; not different monitor cards for moni-
toring inputs or outputs. Whether the card monitors inputs, outputs, or both 
depends on the type of router frame, the slot into which it is installed on the 
frame, and the backplane associated with the card.

The NV8144 has one monitor card slot and uses one monitor card and a sin-
gle output monitor backplane. The single monitor card receives one signal 
from each input card and each output card: ‘OUT 1’ is used to monitor all 
outputs and ‘OUT 2’ is used to monitor all inputs. This function is unique to 
the NV8144.

The NV8280/NV8280-Plus and NV8576/NV8576-Plus router frames have 
separate monitor card slots for monitoring inputs and outputs. The NV8280/
NV8280-Plus router frame uses two cards: one for inputs; one for outputs. 
The NV8576/NV8576-Plus router frame uses four cards: two for inputs; two 
for outputs. The card slot determines the signals monitored: a monitor card in 
the input monitor card slot monitors inputs; a monitor card in the output mon-
itor card slot monitors outputs.

In the NV8280/NV8280-Plus, the input monitor card receives one signal 
from each input card. Similarly, an output monitor card receives one signal 
from each output card. The NV8576/NV8576-Plus monitor cards work 
exactly the same way except that the monitor cards in the upper portion of the 
router frame receive signals only from the output cards and input cards 
located in the upper region. Likewise, the monitor cards in the lower region 
of the frame receive signals only from the input and output cards installed in 
the lower region of the frame.
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To maximize efficiency, only one signal is sent from each input or output card to the monitor card 
for forwarding to monitoring equipment. This means that only one signal from each input card or 
output card is monitored at any give time.

Whether or not input and/or output monitor signals can be accessed and managed depends on the 
application version currently loaded on the router’s control cards and if a Monitor Level has been 
created using UniConfig. (See UniConfig Settings on page 130.)

For instructions on making connections to the monitor backplanes, see the NVV8500 Family Rout-
ers User’s Guide.

UniConfig Settings
To access and control monitor signals, a Monitor Level needs to be created in UniConfig. Every 
router has at least one control card. The version of the control application currently loaded on the 
control card determines what monitor signals are accessed and how to configure a Monitor Level in 
UniConfig. The level must be created separately for each control card in the router. 

Each output monitor backplane has two outputs. These outputs in the NV8280/NV8280-Plus and 
the NV8576/NV8576-Plus can function independently, but only when routed to separate output 
cards (each card has 18 outputs), otherwise the monitor take is executed on both monitor outputs. 
For example, when the Monitor Level is selected, performing a take of 2 to 1 followed by take 5 to 
2 results in both monitors routed to output 5. In contrast, take 3 to 1 followed by 19 to 2 result in 
monitors connected to different outputs (3 and 19 correspondingly).

Similarly, each input monitor backplane has two outputs. Specific to application version 14.0.0.xx, 
in the NV8280/NV8280-Plus and the NV8576/NV8576-Plus these outputs only function indepen-
dently when they are routed to separate input cards. Each card has 9 inputs, so performing a take of 
2 to 3 followed by take 5 to 4 results in both input monitors routed to output 5. However, take 3 to 
3 followed by take 10 to 4 result in monitors connected to different outputs (3 and 10 correspond-
ingly).

NV8144 has two monitor outputs, one for monitoring router outputs and one for monitoring router 
inputs. These two outputs are independent because they have connections to different sets of cards: 
input and output respectively.

Mapping to the Monitor Level
In UniConfig, when creating the Monitor Level you enter the total number of monitor signals. Only 
‘OUT’ connectors on the monitor backplanes are used to send signals to monitoring equipment. 
Therefore, only these connectors are managed in UniConfig and configured as ‘Physical Outputs’ 
and ‘Controller Outputs’. How each ‘OUT’ connector maps to a Monitor Level output changes 
depending on the router and number of connectors.

The NV8144 uses only one monitor card. This means that the ‘OUT 1’ is used to monitor all out-
puts and ‘OUT 2’ is used to monitor all inputs. ‘IN 1’ and ‘IN 2’ are unused because the NV8144 is 
a standalone router. However, when configuring the Monitor Level in UniConfig, four connections 
are configured. This is due to the design of the monitor card, which maps ‘OUT 1’ to output 1 and 
maps ‘OUT 2’ to output 3.
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NV8280/NV8280-Plus and NV8576/NV8576-Plus each have a minimum of two monitor cards: 
one for inputs and one for outputs. Therefore, the ‘OUT’ connectors map directly to the same level 
in UniConfig.

The following lists how for each router, the associated monitor backplane connectors, map to Uni-
config Monitors on the Monitor Page, and to the ports on Monitor Level:

Version 13.0.3.xx

Control cards running control application versions APP, 13.0.3.xx and older support output moni-
tors only (matching FPGA versions: CPLD, SV0900-06, SV0901-05 and older). 

Version 14.0.0.xx

Control cards running control application versions APP, 14.0.0.xx and newer support input and out-
put monitors (matching FPGA versions: CPLD, SV0900-07, SV0901-06 and newer). 

How to Set Up a Monitor Level

1 Launch UniConfig and establish communication:
a Click on the short-cut on your desktop or from the operating system ‘Start’ menu, select 

‘Programs > UniConfig’. Refer to your operating system’s Help system for details.
b Establish communication using an Ethernet or serial connection:

For an Ethernet connection, connect the PC running UniConfig to the RJ45 Ethernet port of 
the router and from the menu bar, select ‘Communications > Ethernet’. 
Or
For a serial connection, connect the PC running UniConfig to one of the router diagnostic 
serial ports and from the menu bar, select ‘Communications > Serial’.

2 Select a control card:
If you are using an Ethernet connection, from the menu bar, select ‘Communications > Ether-
net’. The ‘Control Card’ pane appears. On the ‘Control Cards’ pane, click on the name of a con-
trol card to select it.
Or
If you are using a serial connection:

a From the menu bar, select ‘Communications > Serial’. 
b Again, from the menu bar, select ‘Communications > Setup’. The ‘Serial Communications 

Setup’ pane appears.

Router Monitor
Monitor Backplane 
Connector UniConfig Monitors Controller Outputs

NV8144 (Output Monitor) OUT 1 Monitor 3 3

NV8144 (Input Monitor) OUT 2 Monitor 1 1

NV8280/NV8280-Plus
NV8576/NV8576-Plus
(Output Monitor)

OUT 1 Monitor 1 1

OUT 2 Monitor 2 2

NV8280/NV8280-Plus
NV8576/NV8576-Plus
(Input Monitor)

OUT 1 Monitor 3 3

OUT 2 Monitor 4 4
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c From the ‘Comm port’ drop-down list, select the port associated with the control card you 
want to select.

d From the ‘Baud rate’ drop-down list select 38400.
e Click OK.

3 From the menu bar, select ‘Windows > Configuration’. The ‘Configuration’ window appears: 

Figure 13-2. Example of a Configuration Window for NV8576-Plus

4 Click Read All. The ‘Configuration’ window populates with the current router configuration and 
Ethernet settings. If no prior configuration is stored, many of the fields are blank

5 In the ‘Level’ column enter a unique number between 1 and 240. This value identifies a partic-
ular partition in the router and should match what has been configured in the controller being 
used. This number must be unique to enable the controller to differentiate sets of crosspoints.

6 Enter values for inputs and outputs for the level in the following fields. 

For version 13.0.3.xx, enter the following values: :

Router

Physical Inputs Controller Inputs Physical Outputs Controller Outputs

Start End Start End Start End Start End

NV8144 1 144 1 144 1 2 1 2

NV8280/
NV8280-Plus

1 576 1 576 1 2 1 2

NV8576/
NV8576-Plus

1 1152 1 1152 1 2 1 2
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7 From the ‘Signal Type’ drop-down list, select the signal type ‘Monitor’. 

8 Click Write All to writes changes to the control card.

9 Repeat steps 2 through 8 for each control card being updated.

Using Partitioning Addressing
Third-party control systems or software drivers may be used to control the monitoring of router 
inputs and outputs. This section assumes that the control card in the router is running application 
version 14.0.0.xx and newer (matching FPGA versions: CPLD, SV0900-07, SV0901-06 and 
newer), which supports the monitoring of both input and output signals.

Controlling which inputs and outputs are switched to the different monitor outputs is accomplished 
using the same switching methods for controlling crosspoints. To do this, the following steps must 
occur:

1 The router’s inputs and outputs are partitioned and assigned a unique level. A level is simply a 
way of defining an organizational partition within a router. 

2 The level is assigned the unique signal type value “Monitor.”
3 Save the new partition configuration to the router.
4 Issue a standard ‘take’ command from the control system to the router’s Monitor partition, as 

defined in the protocol being used. In most cases this will be the NVISON Ethernet or Serial 
protocol. (See the UniConfig User’s Guide for more information on partitioning and signal 
types.)

Each router in the NV8500 Family—NV8144, NV8280/NV8280-Plus and NV8576/NV8576-
Plus—has subtle differences when setting up and controlling monitors. Developers writing control 
software, or system engineers using one of the router’s supported third-party protocols, must be 
aware of the differences when performing Monitor ‘takes’. In addition, to maximize efficiency, 
only one signal is sent from each input or output card to the monitor card for forwarding to moni-
toring equipment. This means that only one signal from each input card or output card is monitored 
at any given time. Programmers should be aware of these limitations when writing control soft-
ware. For more information, see Overview on page 127.

The format of a ‘take’ command may vary depending on the protocol used, but the command 
always sends the router the level value of the partition, the Output value, and the Input value. The 
‘take’ commands causes the Input value to be switched to the Output value, and because it is in the 
Monitor partition (i.e., the level with the signal type ‘Monitor” assigned), the router knows to send 
the input or output to the monitor card in the router.

Router

Physical Inputs Controller Inputs Physical Outputs Controller Outputs

Start End Start End Start End Start End

NV8144 1 144 1 144 1 4 1 4

NV8280/
NV8280-Plus

1 576 1 576 1 4 1 4

NV8576/
NV8576-Plus

1 1152 1 1152 1 4 1 4
UniConfig Configuration Application  •  User’s Guide 133



13. NV8500 Monitor Configuration and Operation
Using Partitioning Addressing
For specific ‘take’ command formats, refer to the following Miranda NVISION protocol docu-
ments:

NP0016 — NVISION Ethernet Protocol Router Control Messages

NP0010 — NVISION Serial Protocol Router Control Messages

Figure 13-3 shows how partition values as displayed in UniConfig. These values are valid for any 
NV8500 Family router. In this example, ‘Physical Inputs’ and ‘Physical Outputs’ map one-to-one 
to the ‘Controller Inputs’ and ‘Controller Outputs’. Level 1 controls switching of the router’s inputs 
or outputs through the monitor card. Level 2 controls standard crosspoint switching. 

Figure 13-3. Example of UniConfig with Partition Values

For a Monitor Level, ‘Controller Inputs’ and ‘Controller Outputs’ map to the following:
• ‘Controller Inputs’ can be any of the router’s inputs or outputs to be monitored.
• ‘Controller Outputs’ map directly to the Monitor card ‘OUT’ connectors as shown: 

Router Monitor Controller Inputs

Controller Output to Monitor Card Connector Map

Controller Outputs
Monitor Card Backplane 
Connector

NV8144 (Output Monitor) outputs 3 OUT 1

NV8144 (Input Monitor) inputs 1 OUT 2

NV8280/NV8280-Plus
NV8576/NV8576-Plus
(Output Monitor)

outputs 1 OUT 1

outputs 2 OUT 2

NV8280/NV8280-Plus
NV8576/NV8576-Plus
(Input Monitor)

inputs 3 OUT 1

inputs 4 OUT 2
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How to Monitor NV8144 Switching 

• To monitor one of the router’s inputs, switch any of the ‘Controller Inputs’ to the ‘Controller 
Output 1’.
The router knows that a router’s input is to be monitored because the input is being switched to 
‘Controller Output 1’, which is associated with the router’s monitor card ‘OUT 1’ connector.
Example: Using the example partition in Figure 13-3 on page 134, a ‘take’ command is sent to 
the router using Level 1, Source 5 and Destination 1. This switches the router’s physical Output 
5 to the router’s monitor card ‘OUT 2’ connector.

• To monitor one of the router’s outputs, switch any of the ‘Controller Inputs’ to the ‘Controller 
Output 3’.
The router knows that a router’s output is to be monitored because the output is being switched 
to ‘Controller Output 3’, which is associated with the router’s monitor card ‘OUT 2’ connector.
Example: Using the example partition table in Figure 13-3 on page 134, a ‘take’ command is 
sent to the router using Level 1, Source 5 and Destination 3. This switches the router’s physical 
Output 5 to the router’s monitor card ‘OUT 1’ connector.

How to Monitor NV8280 or NV8576 Switching

Unlike the NV8144, the NV8280 and NV8576 router frames have separate monitor cards for inputs 
and outputs. For details, see Overview on page 127.

• To monitor one of the router’s inputs, switch any of the ‘Controller Inputs’ to the ‘Controller 
Output 3’ or 4.
The router knows that a router’s input is to be monitored because the input is being switched to 
‘Controller Output 3’ or ‘Controller Output 4’ which is associated with the router’s Input moni-
tor card ‘OUT 1’ or ‘OUT 2’ connector, respectively.
Example: Using the example partition table in Figure 13-3 on page 134, a ‘take’ command is 
sent to the router using Level 1, Source 5 and Destination 3. This switches the router’s physical 
Input 5 to the router’s Input monitor card ‘OUT 1’ connector.

• To monitor one of the router’s Outputs, switch any of the’ Controller Inputs’ to the ‘Controller 
Output 1’ or ‘Controller Output 2’.
The router knows that a router’s output is to be monitored because the output is being switched 
to ‘Controller Output 1’ or ‘Controller Output 2’, which is associated with the router’s Output 
monitor card ‘OUT 1’ or ‘OUT 2’ connector, respectively.
Example: Using the example partition table in Figure 13-3 on page 134, a ‘take’ command is 
sent to the router using Level 1, Source 5 and Destination 1. This switches the router’s physical 
Output 5 to the router’s Output monitor card ‘OUT 1’ connector.

Note The NV8144 differs from the NV8280 and NV8576 because it uses only one Monitor card. 
See Overview on page 127.
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14. Locating NVISION Routing Devices

This section describes how to locate other NVISION routing products connected to UniConfig.

Locating an NVISION Device
Using UniConfig, other Miranda routing products connected to UniConfig directly, through a net-
work, or through the router control system can be located and listed.

How to Locate Devices

1 Launch UniConfig. (See Launching UniConfig on page 9.)

2 From the menu bar, select ‘Tools > Search for Miranda Device’. The ‘Search for Miranda 
Devices’ dialog box appears, as shown in Figure 14-1. 

Figure 14-1. Search for NVISION Devices Dialog Box

3 Click Search/Refresh. All current Miranda devices appear.

4 To close the dialog box, click X in the upper, right-hand corner.
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15. Setting Gain and Inverting Polarity

The gain and polarity of an analog audio card can be set using UniConfig. This section describes 
how to set the gain adjustment and invert polarity as needed.

DSP Sub-module (NV7512)
The DSP sub-module is a separate unit that can be installed on the crosspoint card on the NV7512 
router. This feature is only available with the NV7512 router. The DSP sub-module enables manip-
ulation of audio input or output as follows:

• Gain Adjustment. The gain of incoming signals can be adjusted from -108 dB up to +12 dB in 
increments of 0.1 dB. See Set Input Gain and Invert Polarity on page 139.

• Phase Inversion. On occasion, incoming signals may be out of phase. Using the DSP sub-mod-
ule, signal polarity can be inverted. The polarity of each input channel may be independently 
set to be non-inverted or inverted. See Set Input Gain and Invert Polarity on page 139.

• Crossfade. The crossfade functionality allows for switching between signals by gradually 
decreasing the value of one signal while simultaneously increasing the value of a second signal. 
A crossfade takes approximately 85 milliseconds from start to finish. See How to Select Switch 
Point Settings for the NV7512 Router on page 77.

• Channel Summing. Left and right channels of a signal can be combined so that the left channel 
and right channel are identical, called channel summing. Because the channels are now twice 
the level of the original channels, the channels are divided by 2 to return each channel back to 
the original level. See How to Select Switch Point Settings for the NV7512 Router on page 77.

The DSP sub-module effects only the signals being directly switched by the crosspoint card on 
which it is installed. To implement DSP sub-module features, the module must be installed and 
then configured using UniConfig. For more information, see the NV7512 User’s Guide.

Set Input Gain and Invert Polarity
Using the ‘Audio Adjustment’ window, input gain on audio inputs and outputs can be set. In addi-
tion, the polarity of signals can be inverted as needed. This function only applies to audio signals.

Note Each control card must be configured separately.
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How to Set Input Gain and Invert Polarity

1 Launch UniConfig. (See Launching UniConfig on page 9.)

2 From the menu bar, select ‘Window > Audio Adjustment’. The ‘Audio Adjustment’ window 
appears: 

Figure 15-1. Input Gain Values in UniConfig Audio Adjustment Window

3 Click the ‘Inputs’ tab. 

4 Click Read Inputs.The tab displays current ‘Mono Input’, ‘Gain’ and ‘Polarity’ settings.

5 (Optional) To display each left or right channel of a stereo signal, check the ‘Display Mono as 
Physical Connections’ check box: 

Figure 15-2. Audio Adjustment Window with Mono Channels

The entries in the ‘Input’ and ‘Output’ fields refer to the monaural channel number associated 
with the physical input and output, respectively. For example, channel 2 of physical input 17 is 
mono channel 34.
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6 In the ‘Mono Selection’ section, select the ‘Single’ radio button for a single input channel or 
select the ‘Range’ radio button for a range of input channels. 
If ‘Single’ is selected, enter the channel number in the corresponding field.
If ‘Range’ is selected, enter the channel number in the corresponding fields to the right. Enter 
the beginning channel number in the left-most field and the ending channel number in the right-
most field.

7 Enter the ‘Gain’ in the field provided. Gain can be adjusted from -88 dB to 12 dB in increments 
of 0.1 db.

8 Check the ‘Invert Polarity’ check box to invert polarity.

9 Click Write Inputs to write your changes to the control card.

10 Repeat steps 3–9 for each control card.
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16. Removing Locks

Configuration locks are set using the router control system. When locked, a switching configura-
tion cannot be changed until it is unlocked. This function is useful in avoiding accidental changes 
to switching configurations.

Locks
When a switching configuration is locked, it cannot be changed until unlocked. A lock stops all 
commands entered in UniConfig from being applied to the selected switching configuration. This 
ensures that unintended changes are not made. Locks are applied through the router control system, 
not UniConfig. However, using UniConfig, a lock can be removed.

How to Remove a Lock

1 Launch UniConfig. (See Launching UniConfig on page 9.)

2 Locate the signal to be unlocked. See Viewing Signal Inputs and Outputs on page 92.

3 In the ‘Connections’ window, in the same row listing the input and output which are locked, 
click in the ‘LPR’ column. The mark disappears indicating that the input/output is unlocked. 
Or
From the menu bar, select ‘Actions > System > Clear > All Locks and Protects’ to remove all 
locks.

4 To close the ‘Connections’ window, click X in the upper, right-hand corner.
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17. Working With Salvos

UniConfig can take a “snapshot”, called a salvo, of the current switching configuration (the cross-
point array), which can be saved as a separate file. Should a system failure occur, the salvo can be 
uploaded, instantly re-resetting crosspoint connections. The salvo is used by UniConfig to reset the 
switching configuration, which in turn updates the control cards, which are read by the router con-
trol system.

In addition to creating a salvo encompassing the entire switching configuration, you can select spe-
cific takes to save or modify individual takes.

Creating a Salvo
Salvos can be created at any time and saved for later uploading. Salvos can contain all switching 
configurations or just selected takes. See Building a Salvo with Individual Takes on page 147.

How to Create a Salvo
1 Launch UniConfig. (See Launching UniConfig on page 9.)
2 From the menu bar, select ‘Window > Connections’. The ‘Connection’ window appears: 

Figure 17-1. Example of Connections Window with Standard Tab in Front

The ‘Connections’ window must be active to activate salvo menu options.
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3 From the menu bar, select ‘Tools > Options’. The ‘Connections Options’ dialog box appears: 

Figure 17-2. Connections Options Dialog Box

Select to have all switching data sent to the salvo whenever Write is clicked and to have the 
‘Salvo’ field display on the ‘Connections’ window:

a Select the ‘Salvo’ tab.
b Check the ‘Send all reads to Salvo Window’ check box.
c Check the ‘Show Salvo Window’ check box. 
d Click OK to save your changes and close the dialog box. 

4 From the menu bar, select ‘Window > Connections’. The ‘Connections’ window appears with 
the ‘Salvo’ section displaying: 

Figure 17-3. Connections Window with Salvo Section
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The ‘Connections’ window must be open to activate the needed menu options.
5 On the ‘Connections’ window, click Read Outputs. The input and output settings display in the 

‘Salvo’ section.
6 From the menu bar, select ‘File > Save Salvo As’. The ‘Save Opened Salvo’ window appears.
7 Click Browse and browse to the location where you want to save the file.
8 Rename the file as needed and click Save.

Building a Salvo with Individual Takes
A salvo can be created using individual takes instead of an entire switching configuration.

How to Update a Salvo Using Individual Takes

1 Launch UniConfig. (See Launching UniConfig on page 9.)

2 From the menu bar, select ‘Window > Connections’. The ‘Connections’ window appears with 
the ‘Salvo’ section displaying, as shown in Figure 17-3. The ‘Connections’ window must be 
open to activate the needed menu options.

3 From the menu bar, select ‘Actions > Edit/Change Salvo > Add Single Take’. The ‘Edit Single 
Take’ dialog box appears: 

Figure 17-4. Edit Single Take Dialog Box for Salvos

4 Enter the ‘Input’ number and the ‘Output’ number of the single take you want added to the 
salvo and click Add.

5 Repeat step 4 until all individual takes you want added have been entered. The entered takes 
display in the ‘Salvo’ section on the ‘Connections’ window. (See Figure 17-3.)

6 When all takes have been added, click Close to close the dialog box.
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Updating Individual Takes Within a Salvo
After individual takes are added to a salvo, the takes can be updated to meet changing needs.

How to Create a Salvo Using Individual Takes

1 Launch UniConfig. (See Launching UniConfig on page 9.)

2 From the menu bar, select ‘Window > Connections’. The ‘Connections’ window appears with 
the ‘Salvo’ section displaying, as shown in Figure 17-3. The ‘Connections’ window must be 
open to activate the needed menu options.

3 From the menu bar, select ‘Actions > Edit/Change Salvo > Modify Single Take’. The ‘Edit Sin-
gle Take’ dialog box appears: 

Figure 17-5. Edit Single Take Dialog Box for Salvos

4 Enter the ‘Input’ number and the ‘Output’ number of the single take being updated and click 
Modify.

5 Repeat step 4 until all individual takes you want updated have been entered. The entered takes 
display in the ‘Salvo’ section on the ‘Connections’ window. (See Figure 17-3.)

6 When all takes have been added, click Close to close the dialog box.

Opening and Uploading a Salvo
Salvos can be opened and uploaded at any time. Be sure that the salvo you are uploading contains 
the current configuration you want. Uploading a salvo overwrites any existing switching configura-
tion information.

How to Upload a Salvo

1 Launch UniConfig. (See Launching UniConfig on page 9.)

2 From the menu bar, select ‘Window > Connections’. The ‘Connections’ window appears dis-
playing current input and output settings, as shown in Figure 17-3. The ‘Connections’ window 
must be open to activate the needed menu option.

3 From the menu bar, select ‘File > Open Existing Salvo’. The ‘Open’ window appears.
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Viewing Salvos
4 Click Browse and browse to the location where you have previously saved the file.

5 Select the file and click Open. The saved information in the file displays in the ‘Salvo’ section 
of the ‘Connections’ window.

6 Click Execute to send the changes to the control cards.

Viewing Salvos
Salvos do not automatically display. The ‘Salvo’ section must be activated for viewing on the ‘Con-
nections’ window to see salvo switching information.

How to View a Salvo
1 Launch UniConfig. (See Launching UniConfig on page 9.)
2 From the menu bar, select ‘Window > Connections’. The ‘Connections’ window appears dis-

playing current input and output settings, as shown in Figure 17-3. The ‘Connections’ window 
must be open to activate the needed menu option.

3 Again, from the menu bar, select ‘Tools > Options. The ‘Connections Options’ dialog box 
appears, as shown in Figure 17-2:

a Select the ‘Salvo’ tab.
b Check the ‘Show Salvo Window’ check box.

4 Click OK to save your changes and close the dialog box.

Saving a Salvo
Once a salvo is created, it can be saved in multiple locations, with multiple names or with its origi-
nal name to its original location.

How to Save a Salvo
1 Launch UniConfig. (See Launching UniConfig on page 9.)
2 From the menu bar, select ‘Window > Connections’. The ‘Connections’ window appears dis-

playing current input and output settings, as shown in Figure 17-3. The ‘Connections’ window 
must be open to activate the needed menu option.

3 Create a new salvo or open an existing salvo. (See Creating a Salvo on page 145 and Opening 
and Uploading a Salvo on page 148.)

4 Save the salvo with the existing name or create a new salvo name:
From the menu bar, select ‘File > Save Salvo As’. The ‘Save Opened Salvo’ window appears. 
In the window, enter a ‘File Name’ and ‘Location’ in the fields provided (or browse to the file 
location) and click OK.
Or 
From the menu bar, select ‘File > Save Opened Salvo’. The current salvo is saved to its original 
location using the current file name.
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Clearing a Salvo
An existing salvo can be cleared, enabling you to create a new salvo. A new salvo cannot be created 
until the existing salvo has been cleared. This only affects the currently open salvo.

How to Clear a Salvo

1 Launch UniConfig. (See Launching UniConfig on page 9.)

2 From the menu bar, select ‘Window > Connections’. The ‘Connections’ window appears dis-
playing current input and output settings, as shown in Figure 17-3. The ‘Connections’ window 
must be open to activate the needed menu option.

3 From the menu bar, select ‘Actions > Edit/Change Salvo > Clear Salvo’. The salvo information 
is removed and the ‘Salvo’ section is blank.

Auto-send All Reads to a Salvo
Every time a the Read All button is clicked, the information can automatically be sent to a salvo.

How to Auto-Send All Reads to a Salvo

1 Launch UniConfig. (See Launching UniConfig on page 9.)

2 From the menu bar, select ‘Window > Connections’. The ‘Connections’ window appears dis-
playing current input and output settings, as shown in Figure 17-3. The ‘Connections’ window 
must be open to activate the needed menu option.

3 Again from the menu bar, select ‘Tools > Options. The ‘Connections Options’ dialog box 
appears, as shown in Figure 17-6.

a Select the ‘Salvo’ tab.

b Check the ‘Send all reads to Salvo Window’ check box.
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c Click OK to save your changes and close the dialog box. 

Figure 17-6. Connections Options Dialog Box
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18. Managing Protocols

Using UniConfig, the protocols and currently being used by the control card can be read, updated 
and saved. Protocols and other software components are stored in Flash memory on the control 
card. For information on compatible control card protocols, contact Technical Support. For contact 
information, see Technical Support Contact Information on page iii.

Protocols are embedded in files, listed as APP or PLD in the ‘Configuration’ window. Only one 
APP file is permitted per router type.

Viewing Protocols and Applications
Protocols and other software components currently loaded on a control card are listed in the ‘Con-
figuration’ window. There are two settings for viewing: Basic or Detailed.

How to View the Software List Using the ‘Basic’ Setting
1 Launch UniConfig. (See Launching UniConfig on page 9.)
2 Select a control card. (See Selecting a Control Card on page 10.)
3 From the menu bar, select ‘Windows > Configuration’. The ‘Configuration’ window appears: 

Figure 18-1. Example of Configuration Window

Protocol on Control Card

Asterisks
indicate file

currently
in use
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Viewing Protocols and Applications
4 Click Read All. Currently loaded protocols display in the ‘Software Versions’ section, as shown 
in Figure 18-1. 

How to View the Software List Using the ‘Expanded’ Setting

1 Launch UniConfig. (See Launching UniConfig on page 9.)

2 Select a control card. (See Selecting a Control Card on page 10.)

3 From the menu bar, select ‘Windows > Configuration’. The ‘Configuration’ window appears, 
as shown in Figure 18-1. 

4 Click Read All. Current configuration settings for the selected control card populate the ‘Config-
uration’ window fields.

5 From the menu bar, select ‘Tools > Options’. The ‘Configuration Options’ dialog box appears: 

Figure 18-2. Configuration Options Dialog Box

6 Check the ‘View expanded software descriptions’ check box. By default this box is not 
checked. 

7 Click OK to save changes and close the dialog box.
Or
Click Cancel to close the dialog box without saving changes.
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8 The ‘Configuration’ window displays full descriptions in the ‘Description’ column in the ‘Soft-
ware Versions’ section: 

Figure 18-3. Example of Configuration Window

To view full text of a description, move the scroll bar at the bottom of the ‘Software Versions’ 
section to the right.

Uploading a Flash Configuration File
Protocols are saved in Flash memory on the control card. Only one protocol is allowed per control 
card. Only specific protocols work on specific routers. When a new protocol is uploaded, it appears 
in the ‘Software Versions’ section on the ‘Configuration’ window. (See Figure 18-4.)

How to Upload a New Protocol
1 Launch UniConfig. (See Launching UniConfig on page 9.)
2 Select a control card. (See Selecting a Control Card on page 10.)
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Uploading a Flash Configuration File
3 From the menu bar, select ‘Windows > Configuration’. The ‘Configuration’ window appears: 

Figure 18-4. Example of a Configuration Window for NV5128

4 Click Read All. The ‘Configuration’ window populates with current router information.
5 In the ‘Software Versions’ section, all applications currently being used by the control card are 

listed. Applications begin with APP or PLD. Note the APP or PLD number of the application 
you want to replace. In this example, the applications begin with APP0 and PLD0.

6 From the menu bar, select ‘Window > Flash Memory’. The ‘Flash Memory’ window appears: 

Figure 18-5. Flash Memory Window

The ‘Flash Memory’ must be active to activate menu options
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Reading and Saving a Flash Configuration File
7 In the field corresponding to the protocol being replaced (i.e., ‘APP4’), click Browse and browse 
to the location of the new protocol.

8 On the ‘Browse’ dialog, click Open. The path to the protocol displays in the ‘Flash Memory’ 
window. 

9 Click Write Flash. The ‘Status’ bar indicates the progress of uploading the protocol. When it is 
finished, the status bar is completely filled in.

10 Again from the menu bar, select ‘Window > Configuration’. The new protocol is listed in the 
‘Software Versions’ section, as shown in Figure 18-1.

11 Repeat steps 2–10 for each control card being updated.

Reading and Saving a Flash Configuration File
Protocols are saved in Flash memory on the control card. Using UniConfig, you can read and save 
files to the Flash memory. This is especially helpful when loading several protocols multiple times.

How to Read and Save a File

1 Launch UniConfig. (See Launching UniConfig on page 9.)

2 Select a control card. (See Selecting a Control Card on page 10.)

3 From the menu bar, select ‘Window > Flash Memory’. The ‘Flash Memory’ window appears: 

Figure 18-6. Flash Memory Window

The ‘Flash Memory’ must be active to activate menu options

4 Again on the menu bar, select ‘File > Read From Flash Configuration File’. The last protocol 
that was listed in each field displays; the window populates with the last files opened.

5 Select ‘File > Save As Flash Configuration File’ to save the Flash configuration file locally on a 
PC.
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19. Viewing System Status

The status of the system’s power supply, references, and fans can be viewed using UniConfig. This 
section describes how to view the system status.

View the System Status
The UniConfig ‘System Status’ window displays the status of the system power supply, references, 
and fans. In order to view this status, you must use an Ethernet connection between the control card 
and UniConfig.

How to View System Status

1 Launch UniConfig. (See Launching UniConfig on page 9.)

2 From the menu bar, select ‘Window > System Status’. The ‘System Status’ window appears: 

Figure 19-1. System Status Window

3 Click Read to view the current system status. The ‘This Control Card Status’ section displays 
the “health” of the reference connections and control cards. ‘Power Supplies’ and ‘Fans’ status 
information display in the fields provided.
UniConfig Configuration Application  •  User’s Guide 159



19. Viewing System Status
View the System Status
4 To perform status tasks involving the system, from the menu bar select ‘Actions > System’ and 
then select an option. If a menu option is not applicable, it is greyed-out. Options may have 
additional, secondary options.

The following lists the menu options: 

5 To perform status tasks involving the control cards, from the menu bar select ‘Actions > Con-
troller State’ and then select an option. If a menu option is not applicable, it is greyed-out. 
Options may have additional, secondary options

The following lists the menu options:

6 (Optionally) click Auto Upload to have UniConfig automatically read and display the system 
status information every two seconds. This function only works when UniConfig is currently 
launched. If you exit UniConfig, you will need to click Read again to display current status 
information.

Selection Secondary Selection

Erase
Note: Do not perform this operation 
unless directed to do so by a Miranda 
support engineer.

‘All Flash’ — removes all protocols.
‘All Battery-backed RAM’
‘EEPROMS’ — Select ‘All’, ‘512 Byte’ or ‘2048 Byte’

Clear ‘All Locks and Protects’ — Clears locks and protects that 
have been applied. See Removing Locks on page 143.
‘Logs’ — Clears the log file.

Recall Last Serial EE Write Status None

Selection Description

Other Controller
Note: If a second controller is not 
installed, only ‘Offline’ will appear.

‘Hold Offline’ — Retains the secondary control card off-line
‘Release Offline’ — Places the secondary control card back 
online

This Controller ‘Offline’ — Forces the control card off-line
‘Standby’ — Places the control card in standby mode
‘Reset’ — Resets the control card
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20. Connection Reports and Logs

A report listing all input and output switching connections can be generated as needed. This section 
provides information on how to create and save the report.

Creating Connection Reports
Connection reports listing all switching input and output connection can be generated and printed 
as needed. This is handy for transferring connection information to spreadsheets or other file for-
mats.

How to Create a Connection Report
1 Launch UniConfig. (See Launching UniConfig on page 9.)
2 From the menu bar, select ‘Window > Connections’. The ‘Connections’ window appears dis-

playing current input and output settings: 

Figure 20-1. Example of Connections Window with Standard Tab in Front

The ‘Connections’ window must be open to activate the needed menu option.
3 In the ‘Physical Output Range’ section, enter a ‘Start’ and ‘End’ number in the fields provided 

and click Read Outputs. The corresponding inputs and outputs display on the tab, as shown in 
Figure 20-1. The current router switching configuration displays.
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Using the Logs Window
4 Again from the menu bar, select ‘File > Write Connection Report’. UniConfig generates a 
report and a ‘Save As’ dialog box appears.

5 On the ‘Save As’ dialog box, select a location and name for the file and click Save.

Using the Logs Window
A ‘Logs’ window (Figure 20-2) is present when communicating through an Ethernet connection. 
The ‘Logs’ window is a troubleshooting tool to be used only as directed by an Miranda service 
engineer. 

Figure 20-2. UniConfig Logs Window

The ‘Logs’ window creates a log file resides in the RAM on the control card and can be read and 
saved using the Logs window. Should a problem arise with the router, an Miranda service engineer 
may request that you perform certain operations using the ‘Logs’ window to collect and save a log 
file in your PC’s file system.
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Active Cards See Modules.

AES Audio Engineering Society, Inc., New York, www.aes.org.

AES/EBU (Audio Engineering Society/European Broadcasting Union) a professional serial interface for 
transferring digital audio from CD and DVD players to amplifiers and TVs. AES/EBU is typically 
used to transmit PCM and Dolby Digital 5.1, but is not tied to any sampling rate or audio standard.

AES3, 
AES3id

The AES routers support AES3id and provide 75Ω BNC connectors. AES3id is specified for 75Ω 
coaxial cable up to 1000 meters. (AES3 uses 110Ω shielded twisted pair (STP) cable with XLR 
connectors up to a distance of 100 meters.) 

Analog Audio A signal where the instantaneous voltage is proportional to the diaphragm velocity at the micro-
phone.

Async AES, 
Sync AES

The term “Async AES” refers to an asynchronous AES-compliant audio signal, whereas “Sync 
AES” refers to a synchronous AES signal with a data rate of 48kbps. A system where various sig-
nals are unlocked (not synchronized). Switching between signals leads to unpredictable results.

AVC “Analog Video Conversion.” NVISION uses this abbreviation to describe a simple conversion 
technique used to create an SD digital output signal from a composite analog video input, or to 
describe the means by which SD signal is coded into an analog composite video output signal. Path 
delay and subcarrier phase may not be precisely maintained in an AVC conversion path within an 
NV5128 frame. AVC coding provides a cost-effective method to provide feeds to picture monitors 
without requiring an external conversion device. AVC modules are not a substitute for professional-
grade format converters.”

Baud Rate Refers to the symbols per second or pulses per second. It is the unit of symbol rate, also known as 
baud rate or modulation rate; the number of distinct symbol changes (signaling events) made to the 
transmission medium per second in a digitally modulated signal or a line code.

D/A Digital to analog

DC Direct current

dBu Unit of audio level where 0dBu is 0.775 Vrms.

DB25 A DB25 connector is the common 25-pin subminiature D connector. Most modern PCs use a 
female DB25 connector for the printer parallel port connector.

DE9 Sometimes mistakenly referred to as a DE9 connector, a DE9 connector is the common 9-pin sub-
miniature D connector. The serial port of modern PCs employ a male DE9 connector.

Device As the term is used in a NV9000 system, a device is a grouping of input and output ports that define 
a logical entity. (The logical entity does not have to be a real entity.) For example, a system might 
have 3 levels: video, AES, and time code. A hypothetical device in this system is Camera 1, which 
consists of video on input port 1 of the video router, AES on input port 5 of the AES router, and 
time code on input port 8 of the time code router. (The UniConfig does presently include time-code 
routers.)
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DSP DSP sub-module installed on the NV7512 router crosspoint card. The DSP sub-module enables 
gain adjustment, phase inversion, crossfade, and channel summing functionality for audio stereo 
signals.

EIA Electronic Industries Alliance. The EIA (until 1997 Electronic Industries Association) is a trade 
organization for electronics manufacturers in the United States. EIA is accredited by the American 
National Standards Institute (ANSI) to help develop standards on electronic components, consumer 
electronics, electronic information, telecommunications, and Internet security. 

ESD Electrostatic discharge

HD HD and HD-SDI are equivalent in Miranda terminology. An HD signal is a high definition, serial 
digital interface video format that conforms to the SMPTE 292M standard.

Hot-
Swappable

A module that is “hot-swappable” can be safely removed and/or installed while power is applied to 
the system.

I/O Inputs and outputs are the physical connections (e.g., BNCs) on the back of the routing switcher. 
The term “input port” is used interchangeably with “input” and the term “output port” is used inter-
changeably with “output.”

Jumpers Jumpers are small, plastic sleeves that fit over a set of pins. The placement of the jumper either 
turns a function on or off, or reconfigure a function.

LED Light Emitting Diode

Matrix 1. The rack-mounted UniConfig chassis or frame which contains the subassemblies (modules, 
backplanes, power supplies, etc.) which comprise the UniConfig.

2. An X-Y array of crosspoint switches, a crosspoint matrix.

Module 1. In the UniConfig, modules are electronic assemblies that plug into the matrix. Modules include 
but are not limited to input, output and controller printed circuit boards also called active cards.

2. Any removable subassembly may be referred to as a module. Router backplanes may occasion-
ally be referred to as modules.

Operator The term operator usually refers to users other than the system administrator. An operator is respon-
sible for making most of the routes. 

P2P An abbreviation for “port to port”. 

Physical Level In a Configuration Application system, a physical level is the same thing as a router. The idea is 
that multiple routers provide different “levels” on which to switch the signals of devices. Any par-
ticular device might send or receive HD, SD, AES, time-code, or machine-code signals. A Config-
uration Application switches one type, or level, of a device’s signal set.

Physically 
Contiguous

Matrix modules are said to be in physically contiguous slots in a UniConfig frame when both the 
inputs and outputs associated with those slots are in numerical sequence. For example, input slots 5 
and 6 are physically contiguous because inputs 1-16 and 17-32 are in numerical sequence. In the 
same way, output slots 4 and 16 are contiguous because outputs 49-64 (slot 4) and 65-80 (slot 16) 
are in numerical sequence.

Port A port is the physical connection on a router. In a configuration application system, a port can only 
be an input port or an output port. 

Reference 
Signal

A timing signal used to synchronize events such as the switching of video signals during a specific 
portion of the vertical interval. Reference signals are externally applied. In their absence, internally 
generated signals are used to sustain operation.
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RAM Random Access Memory

RJ45, RJ-45 Registered Jack, type 45 as defined in the United States Code of Federal Regulations. A common 8-
pin modular plug and/or jack used in the telecommunications and broadcast industry to transport 
Ethernet or machine control signals.

RS-422 Sometimes referred to as RS-422 or TIA/RS-422-B and other similar variations. A bidirectional 
communications standard. The use of this term implies that NVISION intends to refer to the latest 
standard in effect at the time the product was developed.

RU Rack Units. A standard measure or size for frames (1.75 inches).

SD SD and SDI are equivalent terms in NVISION documents. An SD signal is a standard definition, 
serial digital interface video format that conforms to the SMPTE 259M standard.

Source/Desti-
nation

The term “source device” is used interchangeably with “source” and the term “destination device” 
is used interchangeably with “destination.” A source is a device that is connected to one or more 
input ports. A destination is a device that is connected to one or more output ports. An example of 
such a device would be a monitor.

A device can be both a source and destination. An example of such a device is a VTR.

SWB (Super Wide Band). A term originated by Miranda that refers to the ability of a router to pass a 
wide range of digital bit rates and formats. Miranda’s SWB supports data rates from about 
15 Mb/s to 1.5 GB/s.

Input signals must be nominally 800mV p-p and bi-level or tri-level in nature. The UniConfig 
video routers bypasses re-clocking for non-video rates. Rates that are re-clocked include common 
SD data rates of 143 and 270 Mb/s (SMPTE 259M-A and -C, but not B or D) and HD data rates at 
nominally 1.485 Gb/s. SWB accepts SD at 177 Mb/s, but does not reclock it. 

Sync AES, 
Async AES

The term “Async AES” refers to an asynchronous AES-compliant audio signal, whereas “Sync 
AES” refers to a synchronous AES signal with a data rate of 48 kb/s.

System admin-
istrator

The system administrator is the person responsible for installing, configuring, and maintaining a 
router control system.

Time Code A linear time code signal complying with SMPTE 12M or the corresponding EBU standard.

UniConfig A Windows-based application (Universal Configuration) used to configure NVISION products 
using a serial or Ethernet connection. UniConfig uses an easy-to-learn GUI (Graphical User Inter-
face) to simplify the configuration process.
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	5 (Optional) On the ‘Configuration’ window, click Read All to view current router configuration and Ethernet settings.
	6 Update the ‘IP Address’ and ‘Name’ in the fields provided and click OK.
	7 To close the ‘Control Card Configuration’ dialog box, click X in the upper, right-hand corner.
	8 Repeat steps 2 through 7 for each control card being updated.


	Removing Control Cards from a Network
	How to Remove a Control Card from the Network
	2 Open the ‘Control Cards’ pane. (See Control Cards Pane on page 7.) The ‘Control Card’ pane appears, as shown in Figure 7-1.
	3 Select a control card. (See Selecting a Control Card on page 10.)
	4 On the ‘Control Card’ pane, right-click on the control card you want to delete and from the pop- up menu select ‘Delete.
	5 Again from the menu bar, select ‘Windows > Configuration’. The ‘Configuration’ window appears, as shown in Figure 7-1.
	6 (Optional) Click Read All. The ‘Configuration’ window populates with the current router configuration and Ethernet settings.
	7 In the ‘Router Ethernet Settings’ section, select the ‘Disable’ radio button. This removes the control card from the network.
	8 Repeat steps 2-7 for each control card being removed.


	Setting Up a Gateway
	How to Set Up a Gateway
	2 Select a control card. (See Selecting a Control Card on page 10.)
	3 From the menu bar, select ‘Windows > Configuration’. The ‘Configuration’ window appears, as shown in Figure 7-1.
	4 Click Read All. Current configuration settings for the selected control card populate the ‘Configuration’ window fields.
	5 From the menu bar, select ‘Tools > Options’. The ‘Configuration Options’ dialog box appears:
	6 Check the ‘Show advanced Ethernet settings’ check box. By default this box is not checked.
	7 Click OK to save changes and close the dialog box.
	8 (Optional) Enter a ‘Router Name’ in the field provided. This is used to identify the control card by name instead of IP address.
	9 Check the ‘Enable Gateway’ check box.
	10 Enter the IP address for the gateway in the ‘Gateway IP Addr” field.
	11 Click Write All to write changes to the control card.
	12 Repeat steps 2-11 for each control card being updated.



	8. Managing Partitions and Signal Types
	About Partitions
	Signal Types
	About Output Follow Mode
	About Data X/Y Mode
	About Machine Control Modes
	Setting Up Partitions
	Standalone Routers
	How to Set Up Partitions for a Standalone Router
	2 Select a control card. (See Selecting a Control Card on page 10.)
	3 From the menu bar, select ‘Windows > Configuration’. The ‘Configuration’ window appears:
	4 The NV5256, NV7256-Plus, NV7512, NV8256-Plus, NV8288-Plus and the NV8500 Family (in expanded mode) routers can be connected to...
	5 Click Read All. The ‘Configuration’ window populates with the current router configuration and Ethernet settings. If no prior configuration is stored, many of the fields are blank.
	6 To set up a partition, enter ‘Level’, ‘Physical Inputs’, ‘Controller Inputs’, ‘Physical Outputs’ and ‘Controller Output’ infor...
	7 From the ‘Signal Type’ drop-down list, select a signal type for each partition. Select the signal type on the same row listing the partition information.
	8 Click Write All to writes changes to the control card.
	9 Repeat steps 2 through 8 for each control card being updated.

	Multiple Frames
	How to Set Up Partitions for a Master Router
	2 Select the primary control card on the router acting as the master router. (See Selecting a Control Card on page 10.)
	3 From the menu bar, select ‘Windows > Configuration’. The ‘Configuration’ window appears displaying an ‘Expansion’ section:
	4 Click Read All. The ‘Configuration’ window populates with the current router configuration and Ethernet settings.
	5 Select the ‘Main -Expanded’ radio button in the ‘Expansion’ section. This sets the control card on the router as the master (or main) control card controlling all slave routers and expands the ‘Expansion’ section:
	6 For ‘Local Inputs’ and ‘Outputs’, enter a ‘Start’ and ‘End’ number in the corresponding fields. The inputs are the total numbe...
	7 Enter a unique ‘Index’ number in the field provided in the ‘Expansion’ section. This number acts as an identification number in UniConfig. The number must be unique and not assigned to any other router.
	8 To set up a partition, enter ‘Level’, ‘Physical Inputs’, ‘Controller Inputs’, ‘Physical Outputs’ and ‘Controller Output’ infor...
	9 From the ‘Signal Type’ drop-down list, select a signal type for each partition, such as ‘Digital Video’. Select the signal type on the same row listing the partition information.
	10 Click Write All to write changes to the control card.
	11 Repeat steps 2 through 10 for each control card on the master router.

	How to Set U p Partitions for Slave Routers
	2 Select a control card on the router acting as the slave router. (See Selecting a Control Card on page 10.)
	3 From the menu bar, select ‘Windows > Configuration’. The ‘Configuration’ window appears displaying an ‘Expansion’ section:
	4 Click Read All. The ‘Configuration’ window populates with the current router configuration and Ethernet settings.
	5 Select the ‘Slave - Expanded’ radio button in the ‘Expansion’ section. This sets the control card on the router as the slave control card controlled by the master (or main) router and expands the ‘Expansion’ section:
	6 For ‘Local Inputs’ and ‘Outputs’, enter a ‘Start’ and ‘End’ number in the corresponding fields. The inputs are the total numbe...
	7 Enter a unique ‘Index’ number in the field provided in the ‘Expansion’ section. This number acts as an identification number in UniConfig. The number must be unique and not assigned to any other router.
	8 Click Write All to send changes to the control card.
	9 Repeat steps 2 through 8 for each control card on all slave routers.


	Updating Partitions
	How to Update Partitions
	2 Select a control card. (See Selecting a Control Card on page 10.)
	3 From the menu bar, select ‘Windows > Configuration’. The ‘Configuration’ window appears, as shown in Figure 8-2 on page 53.
	4 Click Read All. The ‘Configuration’ window populates with the current router configuration and Ethernet settings.
	5 In the ‘Level’, ‘Physical Inputs’, ‘Controller Inputs’, ‘Physical Outputs’ and ‘Controller Output’, update information as need...
	6 From the ‘Signal Type’ drop-down list, update the signal type for each partition as needed as described in step 7 in How to Se...
	7 Click Write All to send changes to the control card.
	8 Repeat steps 2 through 7 for each control card being updated.


	Setting Up Mono Signal Switching
	Keeping Inputs and Outputs Straight
	Routing Mono Signals
	Status Display Issues
	Option 1: Mixed Stereo and Mono Mode
	Separate Partitions for Stereo and Mono
	Option 2: Mono Only Mode
	Option 3: Mono Only Mode Using Two Partitions



	9. Managing Switch Point Settings
	About Video Signal Fields and Frames
	About Redundant and Dual Video References
	Setting Up Switch Points
	How to Select Switch Point Settings for the NV5100MC or NV5128 Router
	2 Select a control card. (See Selecting a Control Card on page 10.)
	3 From the menu bar, select ‘Window > Switch Point Setup’. The ‘Switch Point Setup’ window appears displaying current output settings for the router being configured:
	4 In the ‘Output Range’ section, enter a ‘Start’ and ‘End’ output signal number in the fields provided and click Read Outputs. Outputs corresponding to the range entered display in the ‘Select Outputs to edit’ pane with default settings.
	5 In the ‘Select Outputs to edit’ pane, select the outputs being updated:
	6 In the ‘Set selection(s) to’ section, check each check box to apply re-clocking and switching on the SD or HD line for the selected outputs.
	7 In the ‘Dual Video Reference Option’ section, select ‘Redundant’ or ‘Dual’.
	8 In the ‘NTSC/PAL Reference Options’ section, select the radio button corresponding to the signal type being used as a video re...
	9 Click Apply Changes to Selected Outputs, or from the menu bar select ‘Edit > Apply Changes’, to apply your changes to the selected outputs. This does not write your changes to the control cards. The changes display in the right-hand field.
	10 Click Write All, or from the menu bar select ‘Edit > Write Changes’, to send your changes to the control card.
	11 Repeat steps 2-10 for each control card being updated.

	How to Select Switchpoint Settings for the NV7256 and NV7256-Plus Router
	2 Select a control card. (See Selecting a Control Card on page 10.)
	3 From the menu bar, select ‘Window > Switch Point Setup’. The ‘Switch Point Setup’ window appears displaying current output settings for the router being configured:
	4 In the ‘Output Range’ section, enter a ‘Start’ and ‘End’ output signal number in the fields provided and click Read Outputs. Outputs corresponding to the range entered display in the ‘Select Outputs to edit’ pane with default settings.
	5 In the ‘Select Outputs to edit’ pane, select the outputs being updated:
	6 In the ‘Set selection(s) to’ section, check to have video signals ‘Switch on Frame Boundary’ or ‘Switch on Field Boundary’. For more information, see About Video Signal Fields and Frames on page 71.
	7 In the ‘Dual Video Reference Option’ section, select ‘Redundant’ or ‘Dual’.
	8 Click Apply Changes to Selected Outputs, or from the menu bar select ‘Edit > Apply Changes’, to apply your changes to the selected outputs. This does not write your changes to the control cards. The changes display in the right-hand field.
	9 Click Write All, or from the menu bar select ‘Edit > Write Changes’, to send changes to the control card.
	10 Repeat steps 2-8 for each control card being updated.

	How to Select Switch Point Settings for the NV7512 Router
	2 Select a control card. (See Selecting a Control Card on page 10.)
	3 From the menu bar, select ‘Window > Switch Point Setup’. The ‘Switch Point Setup’ window appears displaying current output settings for the router being configured:
	4 In the ‘Output Range’ section, enter a ‘Start’ and ‘End’ output signal number in the fields provided and click Read Outputs. Outputs corresponding to the range entered display in the ‘Select Outputs to edit’ pane with default settings.
	5 In the ‘Select Outputs to edit’ pane, select the outputs being updated:
	6 In the ‘Set selection(s) to’ section, check each check box to apply ‘Enable Crossfade’ or ‘Disable Crossfade’ to the selected outputs. ‘Enable’ or ‘Disable’ displays in the ‘Crossfade’ column.
	7 In the ‘Dual Video Reference Option’ section, select ‘Redundant’ or ‘Dual’.
	8 Click Apply Changes to Selected Outputs, or from the menu bar select ‘Edit > Apply Changes’, to apply your changes to the selected outputs. This does not write your changes to the control cards. The changes display in the right-hand field.
	9 Click Write All, or from the menu bar select ‘Edit > Write Changes’, to send changes to the control card.
	10 Repeat steps 2-8 for each control card being updated.

	How to Select Switch Point Settings for the NV8256-Plus Router
	2 Select a control card. (See Selecting a Control Card on page 10.)
	3 From the menu bar, select ‘Window > Switch Point Setup’. The ‘Switch Point Setup’ window appears displaying current output settings for the router being configured:
	4 In the ‘Output Range’ section, enter a ‘Start’ and ‘End’ output signal number in the fields provided and click Read Outputs. Outputs corresponding to the range entered display in the ‘Select Outputs to edit’ pane with default settings.
	5 In the ‘Select Outputs to edit’ pane, select the outputs being updated:
	6 In the ‘Set selection(s) to’ section, check each check box to apply re-clocking, frame or field boundary, and the SD or HD line switching for the selected outputs.
	7 In the ‘Dual Video Reference Option’ section, select ‘Redundant’ or ‘Dual’.
	8 In the ‘NTSC/PAL Reference Options’ section, select the radio button corresponding to the signal type being used as a video reference: ‘1080i’, ‘720p’ or ‘1080p’. This signal will be used as the switching reference.
	9 Click Apply Changes to Selected Outputs, or from the menu bar select ‘Edit > Apply Changes’, to apply your changes to the selected outputs. This does not write your changes to the control cards. The changes display in the right-hand field.
	10 Click Write All, or from the menu bar select ‘Edit > Write Changes’, to send changes to the control card.
	11 Repeat steps 2-9 for each control card being updated.

	How to Select Switch Point Settings for the NV8288 and NV8288-Plus Routers
	2 Select a control card. (See Selecting a Control Card on page 10.)
	3 From the menu bar, select ‘Window > Switch Point Setup’. The ‘Switch Point Setup’ window appears displaying current output settings for the router being configured:
	4 In the ‘Output Range’ section, enter a ‘Start’ and ‘End’ output signal number in the fields provided and click Read Outputs. Outputs corresponding to the range entered display in the ‘Select Outputs to edit’ pane with default settings.
	5 In the ‘Select Outputs to edit’ pane, select the outputs being updated:
	6 In the ‘Set selection(s) to’ section, check each check box to apply a video reference, re-clocking and switching on the SD or HD line for the selected outputs.
	7 In the ‘Dual Video Reference Option’ section, select ‘Redundant’ or ‘Dual’.
	8 In the ‘NTSC/PAL Reference Options’ section, select the radio button corresponding to the signal type being used as a video reference: ‘1080i’, ‘720p’ or ‘1080p’. This signal will be used as the switching reference.
	9 Click Apply Changes to Selected Outputs, or from the menu bar select ‘Edit > Apply Changes’, to apply your changes to the selected outputs. This does not write your changes to the control cards. The changes display in the right-hand field.
	10 Click Write All, or from the menu bar select ‘Edit > Write Changes’, to write changes to the control card.
	11 Repeat steps 2-9 for each control card being updated.

	How to Select Switch Point Settings for the NV8500 Family Routers
	2 Select a control card. (See Selecting a Control Card on page 10.)
	3 From the menu bar, select ‘Window > Switch Point Setup’. The ‘Switch Point Setup’ window appears displaying current output settings for the router being configured:
	4 In the ‘Output Range’ section, enter a ‘Start’ and ‘End’ output signal number in the fields provided and click Read Outputs. Outputs corresponding to the range entered display in the ‘Select Outputs to edit’ pane with default settings.
	5 In the ‘Select Outputs to edit’ pane, select the outputs being updated:
	6 In the ‘Set selection(s) to’ section, check each check box to apply a video reference, re-clocking and switching on the SD or HD line for the selected outputs.
	7 In the ‘Dual Video Reference Option’ section, select ‘Redundant’ or ‘Dual’.
	8 In the ‘NTSC/PAL Reference Options’ section, select the radio button corresponding to the signal type being used as a video reference: ‘1080i’, ‘720p’ or ‘1080p’. This signal will be used as the switching reference.
	9 Click Apply Changes to Selected Outputs, or from the menu bar select ‘Edit > Apply Changes’, to apply your changes to the selected outputs. This does not write your changes to the control cards. The changes display in the right-hand field.
	10 Click Write All, or from the menu bar select ‘Edit > Write Changes’, to write changes to the control card.
	11 Repeat steps 2-10 for each control card being updated.


	Updating Switch Points
	How to Update Switch Point Settings
	2 Select a control card. (See Selecting a Control Card on page 10.)
	3 From the menu bar, select ‘Window > Switch Point Setup’. The ‘Switch Point Setup’ window appears displaying current output settings.
	4 In the ‘Output Range’ section, enter a ‘Start’ and ‘End’ number in the fields provided and click Read Outputs. Outputs corresponding to the range entered display in the ‘Select Outputs to edit’ field.
	5 In the ‘Select Outputs to edit’ field, select the outputs being updated.
	6 Update settings for the selected outputs by checking or unchecking the check boxes as described in the following procedures. Be sure to follow procedures for your specific router:
	7 Click Apply Changes to Selected Outputs to apply your changes to the selected outputs. This does not write your changes to the control cards. The changes display in the right-hand field.
	8 Click Write All to send your changes to the control card.
	9 Repeat steps 2-8 for each control card being updated.



	10. Managing Inputs and Outputs
	Saving and Uploading Switching Configurations
	Setting ‘Connection’ Window Preferences
	Automatic Refresh After ‘Take’
	How to Set Automatic Refresh after a Take
	2 From the menu bar, select ‘Window > Connections’. The ‘Connections’ window appears with blank fields. (See Figure 10-6 on page 93.) The ‘Connections’ window must be active to activate the necessary menu bar options.
	3 Again from the menu bar, select ‘Tools > Options’. The ‘Connections Options’ dialog box appears:
	4 Select the ‘Connections Preferences’ tab to bring it to the front.
	5 Check the ‘Auto refresh connections after Takes’ check box to automatic read function each time a ‘take’ is performed in the ‘Connections’ window.
	6 Click OK to save changes and close the dialog box.

	Automatically Increment/Decrement after ‘Take’
	How to Set Automatic Incrementing
	2 From the menu bar, select ‘Window > Connections’. The ‘Connections’ window (Figure 10-6 on page 93) appears with blank fields. The ‘Connections’ window must be active to activated the necessary menu bar options.
	3 Again from the menu bar, select ‘Tools > Options’. The ‘Connections Options’ dialog box appears:
	4 Select the ‘Connections Preferences’ tab to bring it to the front.
	5 In the ‘Input’ section, check a check box to increment or decrement the input number after each ‘take’ when the Read button in the ‘Connections’ window is clicked:
	6 In the ‘Output’ section, check a check box to increment or decrement the output number after each ‘take’ when the Read button in the ‘Connections’ window is clicked:
	7 Click OK to save changes and close the dialog box.

	Displaying Take Buttons
	How to Display ‘Take’ Buttons
	2 From the menu bar, select ‘Window > Connections’. The ‘Connections’ window appears with blank fields. (See Figure 10-6 on page 93.) The ‘Connections’ window must be active to activate the necessary menu bar options.
	3 Again from the menu bar, select ‘Tools > Options’. The ‘Connections Options’ dialog box appears:
	4 Select the ‘Other’ tab to bring it to the front.
	5 Check the ‘Show Take Buttons on Connection Dialog’ check box. The ‘Take’ buttons display on the ‘Connections’ window.
	6 Click OK to save changes and close the dialog box.


	Updating ‘Connection’ Window Preferences
	How to Update Preferences
	2 From the menu bar, select ‘Window > Connections’. The ‘Connections’ window appears with blank fields. (See Figure 10-6 on page 93.) The ‘Connections’ window must be active to activate the necessary menu bar options.
	3 Again from the menu bar, select ‘Tools > Options’. The ‘Connections Options’ dialog box appears:
	4 Select the ‘Connections Preferences’ tab to bring it to the front.
	5 Uncheck the ‘Auto refresh connections after Takes’ check box to turn off the automatic read function each time a take is performed in the ‘Connections’ window.
	6 In the ‘Input’ section, uncheck a check box to turn of incrementing or decrementing the input number after each ‘take’ when the Read button in the ‘Connections’ window is clicked.
	7 In the ‘Output’ section, uncheck a check box to turn off incrementing or decrementing the output number after each ‘take’ when the Read button in the ‘Connections’ window is clicked.
	8 Select the ‘Other’ tab to bring it to the front:
	9 Uncheck the ‘Show Take Buttons on Connection Dialog’ check box to remove the ‘Take’ buttons from the ‘Connections’ window, as needed.
	10 Click OK to save changes and close the dialog box.


	Viewing Signal Inputs and Outputs
	Viewing Standard X/Y Crosspoint
	How to View Standard Signals
	2 Select a control card. (See Selecting a Control Card on page 10.)
	3 From the menu bar, select ‘Window > Connections’. The ‘Connections’ window appears with blank fields.
	4 If not already in front, select the ‘X-Y/Standard’ tab, as shown in Figure 10-6. Each input is listed with its corresponding output.
	5 In the ‘Physical Output Range’ section, enter a ‘Start’ and ‘End’ number in the fields provided and click Read Outputs. The co...
	6 Repeat steps 2-5 for each control card being viewed.

	Viewing Mono Signals Crosspoint
	How to View Mono Signals
	2 Select a control card. (See Selecting a Control Card on page 10.)
	3 From the menu bar, select ‘Window > Connections’. The ‘Connections’ window appears with blank fields.
	4 Select the ‘X-Y/Mono’ tab:
	5 In the ‘Mono Output Range’ section, enter a ‘Start’ and ‘End’ number in the fields provided and click Read Outputs. The corresponding inputs and outputs displays on the tab.
	6 Repeat steps 2-5 for each control card being viewed.


	Testing Input/Output Switching ‘Takes’
	Standard Signals
	How to Test Standard Switching Configurations
	2 Select a control card. (See Selecting a Control Card on page 10.)
	3 From the menu bar, select ‘Window > Connections’. The ‘Connections’ window appears with blank fields. (See Figure 10-6 on page 93.)
	4 Select the ‘X-Y/Standard’ tab.
	5 In the ‘Physical Output Range’ section, enter a ‘Start’ and ‘End’ number in the fields provided.
	6 Click Read Outputs. The corresponding inputs and outputs display on the tab, as shown in Figure 10-6 on page 93. The current router switching configuration displays.
	7 On the tab, select the outputs being tested:
	8 To perform a ‘take’ on multiple signals, from the menu bar select ‘Action’ or right-click in the pane to open a pop-up menu, and then select an option. If an option is not applicable to the currently active tab, the option is greyed-out.
	9 To perform a single ‘take’ of a single input to a single output for an audio digital stereo, audio analog, video digital or video analog signal (depending on the router connected), perform the following:
	10 (Optional) Create a switching configuration “salvo”. For more information, see Working With Salvos on page 145.
	11 Repeat steps 2-9 for each control card being tested.

	Mono Signals
	How to Test Mono Switching Configurations
	2 Select a control card. (See Selecting a Control Card on page 10.)
	3 From the menu bar, select ‘Window > Connections’. The ‘Connections’ window appears with blank fields. (See Figure 10-6 on page 93.)
	4 Select the ‘X-Y/Mono’ tab.
	5 In the ‘Mono Output Range’ section, enter a ‘Start’ and ‘End’ number in the fields provided.
	6 Click Read Outputs. The corresponding inputs and outputs display on the tab, as shown in Figure 10-7 on page 94. The current router switching configuration displays.
	7 On the tab, select the outputs being tested:
	8 To perform a ‘take’ on multiple signals, from the menu bar select ‘Action’ or right-click in the pane to open a pop-up menu, and then select an option. If an option is not applicable to the currently active tab, the option is greyed-out.
	9 To perform a single ‘take’ of a single input to a single output for a mono audio signal (NV5100, NV5128, NV7256, NV7256-Plus, and NV7512), perform the following:
	10 (Optional) Create a switching configuration “salvo”. For more information, see Working With Salvos on page 145.
	11 Repeat steps 2-9 for each control card being tested.


	Updating Input/Output Switching
	Standard Signals
	How to Update a Standard Switching Configuration
	2 Select a control card. (See Selecting a Control Card on page 10.)
	3 From the menu bar, select ‘Window > Connections’. The ‘Connections’ window appears with blank fields. (See Figure 10-6 on page 93.)
	4 Select the ‘X-Y/Standard’ tab.
	5 To view current switching configuration, in the ‘Physical Output Range’ section, enter a ‘Start’ and ‘End’ number in the field...
	6 In the ‘Physical Take’ section, enter the ‘Input’ and ‘Output’ that you want to switch.
	7 Click Execute. A ‘take’ is performed and the new switching configuration set.
	8 (Optionally) create a switching configuration “salvo.” For more information, see Working With Salvos on page 145.
	9 Repeat steps 2-7 for each control card being updated.

	Mono Signals
	How to Update a Mono Switching Configuration
	2 Select a control card. (See Selecting a Control Card on page 10.)
	3 From the menu bar, select ‘Window > Connections’. The ‘Connections’ window appears with blank fields. (See Figure 10-6 on page 93.)
	4 Select the ‘X-Y/Mono’ tab.
	5 To view current switching configuration, in the ‘Mono Output Range’ section, enter a ‘Start’ and ‘End’ number in the fields pr...
	6 In the ‘Physical Mono Take’ section, enter the ‘Input’ and the ‘Output’ you want to switch.
	7 From the drop-down lists, select a ‘Channel’ 1 or a ‘Channel’ 2 for the input and the output.
	8 Click Execute. A ‘take’ is performed and the new switching configuration set.
	9 (Optionally) create a switching configuration “salvo.” For more information, see Working With Salvos on page 145.
	10 Repeat steps 2-8 for each control card being updated.



	11. Managing Machine Control Ports
	Saving and Uploading Switching Configurations
	Setting Up Machine Control Ports
	How to Configure Port Matching Control Ports
	2 Select a control card. (See Selecting a Control Card on page 10.)
	3 From the menu bar, select ‘Window > Machine Control Port Setup’. The ‘Machine Control Port Setup’ window appears:
	4 Click Read, or from the menu bar, select ‘Edit >Read All’. The current configuration of each ports displays in the right-hand pane with default settings.
	5 Enter a number in the ‘Take Delay’ field to set the frame ‘take’ delay. The “take delay” is the number of video frames between...
	6 In the right-hand pane, select the ports being updated.
	7 From the menu bar select ‘Edit’, or right-click on a selected port to open a pop-up menu, and then an option.
	8 Click Read to display your changes. This does not save your changes.
	9 Click Write or, from the ‘Edit’ menu, select ‘Write Ports’ to send the edited settings to the control card.
	10 Repeat steps 2-9 for each control card being updated.


	Updating Machine Control Port Setups
	How to Update Machine Control Port Settings
	2 Select a control card. (See Selecting a Control Card on page 10.)
	3 From the menu bar, select ‘Window > Machine Control Port Setup’. The ‘Machine Control Port Setup’ window appears displaying current port settings, as shown in Figure 11-1 on page 102.
	4 As needed, update the number in the ‘Take Delay’ field to set the frame ‘take’ delay. The “take delay” is the number of video ...
	5 In the right-hand pane, select the ports being updated.
	6 Update settings for the selected outputs by checking or unchecking the check boxes as described in step 7 in Setting Up Machine Control Ports on page 101.
	7 Click Write to send your changes to the control card.
	8 Repeat steps 2-7 for each control card being updated.


	Setting Machine Control Take Preferences
	About Data X/Y Takes
	How to Set Machine Control Take Preferences
	2 From the menu bar, select ‘Window > Connections’. The ‘Connections’ window appears with blank fields:
	3 Again from the menu bar, select ‘Tools > Options’. The ‘Connections Options’ dialog box appears:
	4 Select the ‘Machine Control’ tab to bring it to the front:
	5 In the ‘Machine Control Take Formats’ section, select a radio button to configure what occurs when a ‘take’ is performed using the ‘Connections’ window. (See Updating Machine Control Port Switching on page 110.)
	6 Click OK to save changes and close the dialog box.


	Updating Machine Control Take Preferences
	How to Update Machine Control Take Preferences
	2 From the menu bar, select ‘Window > Connections’. The ‘Connections’ window appears with blank fields. The ‘Connections’ window must be active to activate the necessary menu bar options. (See Figure 11-2.)
	3 Again from the menu bar, select ‘Tools > Options’. The ‘Connections Options’ dialog box appears, as shown in Figure 11-3.
	4 \Select the ‘Machine Control’ tab to bring it to the front, as shown in Figure 11-4.
	5 In the ‘Machine Control Take Formats’ section, select a different radio button to configure what occurs when a take is perform...
	6 Click OK to save changes and close the dialog box.


	Viewing Machine Control Switching
	How to View Machine Control Signals
	2 Select a control card. (See Selecting a Control Card on page 10.)
	3 From the menu bar, select ‘Window > Connections’. The ‘Connections’ window appears with blank fields.
	4 Select the ‘Machine Control’ tab, as shown in Figure 11-2. Each input is listed with its corresponding output.
	5 In the ‘Physical Output Range’ section, enter a ‘Start’ and ‘End’ number in the fields provided and click Read Outputs. The corresponding ports display on the tab.
	6 Repeat steps 2-5 for each control card being viewed.


	Testing Machine Control Ports Switching
	How to Test Machine Control Signals
	2 Select a control card. (See Selecting a Control Card on page 10.)
	3 From the menu bar, select ‘Window > Connections’. The ‘Connections’ window appears with blank fields.
	4 Select the ‘Machine Control’ tab:
	5 In the ‘Physical Output Range’ section, enter a ‘Start’ and ‘End’ number in the fields provided and click Read Outputs. The corresponding ports display on the tab.
	6 On the tab, select the outputs being tested:
	7 To perform a take on multiple signals, from the menu bar select ‘Action’, right-click in the connections pane to open a pop-up menu, and then select an option. If an option is not applicable to the currently active tab, the option is greyed-out.
	8 To perform a single ‘take’ of a single input to a single output, perform the following:
	9 (Optionally) create a switching configuration “salvo”. For more information, see Working With Salvos on page 145.
	10 Repeat steps 2-8 for each control card being tested.


	Updating Machine Control Port Switching
	How to Update Switching Configurations
	2 Select a control card. (See Selecting a Control Card on page 10.)
	3 From the menu bar, select ‘Window > Connections’. The ‘Connections’ window appears, as shown in Figure 11-2.
	4 Select the ‘Machine Control’ tab to bring it to the front, as shown in Figure 11-5.
	5 In the ‘Physical Output Range’ section, enter a ‘Start’ and ‘End’ number in the fields provided and click Read Outputs. The corresponding ports display on the tab.
	6 To perform a single ‘take’ of a single input to a single output, perform the following:
	7 (Optionally) create a switching configuration “salvo”. For more information, see Working With Salvos on page 145.
	8 Repeat steps 2-6 for each control card being updated.


	Broadcasting Machine Control Signals
	How to Broadcast Signals
	2 Select a control card. (See Selecting a Control Card on page 10.)
	3 Select the ports that will act as Controlling and as Controlled:
	4 From the menu bar, select ‘Window > Connections’. The ‘Connections’ window appears, as shown in Figure 11-5.
	5 In the ‘Physical Output Range’ section, enter a ‘Start’ and ‘End’ number in the fields that correspond to the ports selected in step 3 and click Read Outputs. The corresponding ports display on the tab.
	6 Set the connections option to ‘Broadcast’:
	7 Once again on the ‘Connections’ window, perform a ‘take’ to have signals sent from the Controlling device, through the router, to the Controlled devices. Perform with a single ‘take’ or a ‘Range Take’:
	8 (Optional) Create a switching configuration “salvo”. For more information, see Working With Salvos on page 145.
	9 Repeat steps 2-7 for each control card on the router.



	12. Configuring EC9535
	2 If you are using an Ethernet connection to UniConfig, setting up initial parameters so that UniConfig and EC9535 can communicate over a network. See Entering Initial EC9535 Serial and Ethernet Settings on page 118.
	3 Set up EC9535 partitions (e.g., logical divisions). See Setting Up EC9535 Partitions on page 122.
	4 Set up EC9535 switch points. See Setting Up EC9535 Switch Points on page 123.
	Setting Up EC9535 Communication
	EC9535 and Router Baud Rates Must Match
	EC9535 Control Card Diagnostic Connections
	How to Make Control Card Diagnostic Connections
	2 On the front of the control card is a single serial port. Connect to the serial port using a DE9 connector and a serial cable.
	3 Connect the other end of the cable to the PC running the UniConfig application using a DE9 connector.
	4 When done configuring, remove the temporary connection.

	EC9535 Frame Diagnostic Connections
	How to Make Frame Diagnostic Connections
	2 Connect to the ‘DIAG’ connection in the ‘PRI’ section using a DE9 connector and a serial cable. The ports are set for RS-232:
	3 Connect the other end of the cable to the PC running the UniConfig application.
	4 If a secondary (optional for redundancy) control card is installed, connect to the ‘DIAG’ connection in the ‘SEC’ section using a DE9 connector and a serial cable as described in step 2 and step 3.


	Entering Initial EC9535 Serial and Ethernet Settings
	2 Serial connection settings entered for UniConfig.
	3 (Optional) Ethernet connection settings entered for UniConfig so that UniConfig can communicate with the router control cards ...
	How to Enter Serial Communication Parameters
	2 Launch UniConfig. (See Launching UniConfig on page 9.)
	3 From the menu bar, select ‘Communications > Serial’. This informs UniConfig that communication with the router is through a serial port.
	4 Again from the menu bar, select ‘Communication > Setup’. The ‘Serial Communications’ dialog box appears:
	5 From the ‘Comm port’ drop-down list, select the communication port number that matches the port number on the PC running UniConfig and click OK.
	6 Again from the menu bar, select ‘Windows > Router Serial Configuration’. The ‘Router Serial Configuration’ window appears: .
	7 In the ‘Control 1 and 2 Baud Rate Setting’ section, from the ‘Baud Rate’ drop-down list, select ‘115200’.
	8 In the ‘Rear Diagnostic Port’ section, select a ‘Port type’ of ‘RS232’ and ‘Baud rate’ of ‘115200’ from the drop-down lists. This sets the communication parameters for the permanent serial ports on the EC9535.
	9 Click Write to write changes to the control card, overwriting any previous settings.

	How to Enter Ethernet Communication Parameters
	2 Connect to the ‘10/100BT’ connection in the ‘PRI CTRL’ section using a RJ45 connector and Ethernet cable.
	3 Connect the other end of the cable to the PC running the UniConfig application.
	4 From the menu bar, select ‘Window > Configuration’. The ‘Configuration’ window appears, as shown in Figure 12-5. Using this wi...
	5 On the ‘Configuration’ window, perform the following steps:
	6 Again from the menu bar, select ‘Communication > Ethernet’. This informs UniConfig that communication with the EC9535 is through an Ethernet port. The ‘Control Card’ pane appears on the left-hand side of the UniConfig screen.
	7 Again from the menu bar, select ‘Communication > Setup’. The ‘Ethernet Communication’ dialog box appears:
	8 On the ‘Ethernet Communication’ dialog box, select settings as follows:
	9 On the rear of the EC9535, locate the unused ‘10 B 2’ connection in the ‘PRI CTRL’ section just above the Ethernet connection. Install a 50 ohm terminator on the unused connection.
	10 If a secondary (optional for redundancy) control card is installed, make a temporary connection to the secondary control card and repeat steps 2 though 9.


	Setting Up EC9535 Partitions
	How to Set Up Partitions for an EC9535
	2 Select a control card. (See Selecting a Control Card on page 10.)
	3 From the menu bar, select ‘Windows > Configuration’. The ‘Configuration’ window appears:
	4 Click Read All. The ‘Configuration’ window populates with the current router configuration and Ethernet settings. If no prior configuration is stored, many of the fields are blank.
	5 To set up a partition, enter ‘Level’, ‘Physical Inputs’, ‘Controller Inputs’, ‘Physical Outputs’ and ‘Controller Output’ infor...
	6 Click Write All to writes changes to the control card.
	7 Repeat steps 2-6 for the remaining control card.


	Setting Up EC9535 Switch Points
	How to Select Switch Point Settings for the EC9535
	2 Select a control card. (See Selecting a Control Card on page 10.)
	3 From the menu bar, select ‘Window > Switch Point Setup’. The ‘Switch Point Setup’ window appears displaying current output settings for the router being configured:
	4 In the ‘Output Range’ section, enter a ‘Start’ number of ‘1’ and an ‘End’ number of ‘1024’ and click Read Outputs. Outputs corresponding to the range entered display in the ‘Select Outputs to edit’ pane with default settings.
	5 In the ‘Select Outputs to edit’ pane, select any outputs being updated (It is recommended that outputs remain as the default provided):
	6 In the ‘Set selection(s) to’ section, check each check box to apply a video reference, re-clocking and switching on the SD or HD line for the selected outputs.
	7 In the ‘Dual Video Reference Option’ section, select ‘Redundant’ or ‘Dual’.
	8 Click Apply Changes to Selected Outputs, or from the menu bar select ‘Edit > Apply Changes’, to apply your changes to the selected outputs. This does not write your changes to the control cards. The changes display in the right-hand field.
	9 Click Write All, or from the menu bar select ‘Edit > Write Changes’, to write changes to the control card.
	10 Repeat steps 2-9 for each control card being updated.



	13. NV8500 Monitor Configuration and Operation
	Overview
	UniConfig Settings
	Mapping to the Monitor Level
	Version 13.0.3.xx
	Version 14.0.0.xx
	How to Set Up a Monitor Level
	2 Select a control card:
	3 From the menu bar, select ‘Windows > Configuration’. The ‘Configuration’ window appears:
	4 Click Read All. The ‘Configuration’ window populates with the current router configuration and Ethernet settings. If no prior configuration is stored, many of the fields are blank
	5 In the ‘Level’ column enter a unique number between 1 and 240. This value identifies a particular partition in the router and ...
	6 Enter values for inputs and outputs for the level in the following fields.
	7 From the ‘Signal Type’ drop-down list, select the signal type ‘Monitor’.
	8 Click Write All to writes changes to the control card.
	9 Repeat steps 2 through 8 for each control card being updated.


	Using Partitioning Addressing
	2 The level is assigned the unique signal type value “Monitor.”
	3 Save the new partition configuration to the router.
	4 Issue a standard ‘take’ command from the control system to the router’s Monitor partition, as defined in the protocol being us...
	How to Monitor NV8144 Switching
	How to Monitor NV8280 or NV8576 Switching


	14. Locating NVISION Routing Devices
	Locating an NVISION Device
	How to Locate Devices
	2 From the menu bar, select ‘Tools > Search for Miranda Device’. The ‘Search for Miranda Devices’ dialog box appears, as shown in Figure 14-1.
	3 Click Search/Refresh. All current Miranda devices appear.
	4 To close the dialog box, click X in the upper, right-hand corner.



	15. Setting Gain and Inverting Polarity
	DSP Sub-module (NV7512)
	Set Input Gain and Invert Polarity
	How to Set Input Gain and Invert Polarity
	2 From the menu bar, select ‘Window > Audio Adjustment’. The ‘Audio Adjustment’ window appears:
	3 Click the ‘Inputs’ tab.
	4 Click Read Inputs.The tab displays current ‘Mono Input’, ‘Gain’ and ‘Polarity’ settings.
	5 (Optional) To display each left or right channel of a stereo signal, check the ‘Display Mono as Physical Connections’ check box:
	6 In the ‘Mono Selection’ section, select the ‘Single’ radio button for a single input channel or select the ‘Range’ radio button for a range of input channels.
	7 Enter the ‘Gain’ in the field provided. Gain can be adjusted from -88 dB to 12 dB in increments of 0.1 db.
	8 Check the ‘Invert Polarity’ check box to invert polarity.
	9 Click Write Inputs to write your changes to the control card.
	10 Repeat steps 3-9 for each control card.



	16. Removing Locks
	Locks
	How to Remove a Lock
	2 Locate the signal to be unlocked. See Viewing Signal Inputs and Outputs on page 92.
	3 In the ‘Connections’ window, in the same row listing the input and output which are locked, click in the ‘LPR’ column. The mark disappears indicating that the input/output is unlocked.
	4 To close the ‘Connections’ window, click X in the upper, right-hand corner.



	17. Working With Salvos
	Creating a Salvo
	How to Create a Salvo
	2 From the menu bar, select ‘Window > Connections’. The ‘Connection’ window appears:
	3 From the menu bar, select ‘Tools > Options’. The ‘Connections Options’ dialog box appears:
	4 From the menu bar, select ‘Window > Connections’. The ‘Connections’ window appears with the ‘Salvo’ section displaying:
	5 On the ‘Connections’ window, click Read Outputs. The input and output settings display in the ‘Salvo’ section.
	6 From the menu bar, select ‘File > Save Salvo As’. The ‘Save Opened Salvo’ window appears.
	7 Click Browse and browse to the location where you want to save the file.
	8 Rename the file as needed and click Save.


	Building a Salvo with Individual Takes
	How to Update a Salvo Using Individual Takes
	2 From the menu bar, select ‘Window > Connections’. The ‘Connections’ window appears with the ‘Salvo’ section displaying, as shown in Figure 17-3. The ‘Connections’ window must be open to activate the needed menu options.
	3 From the menu bar, select ‘Actions > Edit/Change Salvo > Add Single Take’. The ‘Edit Single Take’ dialog box appears:
	4 Enter the ‘Input’ number and the ‘Output’ number of the single take you want added to the salvo and click Add.
	5 Repeat step 4 until all individual takes you want added have been entered. The entered takes display in the ‘Salvo’ section on the ‘Connections’ window. (See Figure 17-3.)
	6 When all takes have been added, click Close to close the dialog box.


	Updating Individual Takes Within a Salvo
	How to Create a Salvo Using Individual Takes
	2 From the menu bar, select ‘Window > Connections’. The ‘Connections’ window appears with the ‘Salvo’ section displaying, as shown in Figure 17-3. The ‘Connections’ window must be open to activate the needed menu options.
	3 From the menu bar, select ‘Actions > Edit/Change Salvo > Modify Single Take’. The ‘Edit Single Take’ dialog box appears:
	4 Enter the ‘Input’ number and the ‘Output’ number of the single take being updated and click Modify.
	5 Repeat step 4 until all individual takes you want updated have been entered. The entered takes display in the ‘Salvo’ section on the ‘Connections’ window. (See Figure 17-3.)
	6 When all takes have been added, click Close to close the dialog box.


	Opening and Uploading a Salvo
	How to Upload a Salvo
	2 From the menu bar, select ‘Window > Connections’. The ‘Connections’ window appears displaying current input and output settings, as shown in Figure 17-3. The ‘Connections’ window must be open to activate the needed menu option.
	3 From the menu bar, select ‘File > Open Existing Salvo’. The ‘Open’ window appears.
	4 Click Browse and browse to the location where you have previously saved the file.
	5 Select the file and click Open. The saved information in the file displays in the ‘Salvo’ section of the ‘Connections’ window.
	6 Click Execute to send the changes to the control cards.


	Viewing Salvos
	How to View a Salvo
	2 From the menu bar, select ‘Window > Connections’. The ‘Connections’ window appears displaying current input and output settings, as shown in Figure 17-3. The ‘Connections’ window must be open to activate the needed menu option.
	3 Again, from the menu bar, select ‘Tools > Options. The ‘Connections Options’ dialog box appears, as shown in Figure 17-2:
	4 Click OK to save your changes and close the dialog box.


	Saving a Salvo
	How to Save a Salvo
	2 From the menu bar, select ‘Window > Connections’. The ‘Connections’ window appears displaying current input and output settings, as shown in Figure 17-3. The ‘Connections’ window must be open to activate the needed menu option.
	3 Create a new salvo or open an existing salvo. (See Creating a Salvo on page 145 and Opening and Uploading a Salvo on page 148.)
	4 Save the salvo with the existing name or create a new salvo name:


	Clearing a Salvo
	How to Clear a Salvo
	2 From the menu bar, select ‘Window > Connections’. The ‘Connections’ window appears displaying current input and output settings, as shown in Figure 17-3. The ‘Connections’ window must be open to activate the needed menu option.
	3 From the menu bar, select ‘Actions > Edit/Change Salvo > Clear Salvo’. The salvo information is removed and the ‘Salvo’ section is blank.


	Auto-send All Reads to a Salvo
	How to Auto-Send All Reads to a Salvo
	2 From the menu bar, select ‘Window > Connections’. The ‘Connections’ window appears displaying current input and output settings, as shown in Figure 17-3. The ‘Connections’ window must be open to activate the needed menu option.
	3 Again from the menu bar, select ‘Tools > Options. The ‘Connections Options’ dialog box appears, as shown in Figure 17-6.



	18. Managing Protocols
	Viewing Protocols and Applications
	How to View the Software List Using the ‘Basic’ Setting
	2 Select a control card. (See Selecting a Control Card on page 10.)
	3 From the menu bar, select ‘Windows > Configuration’. The ‘Configuration’ window appears:
	4 Click Read All. Currently loaded protocols display in the ‘Software Versions’ section, as shown in Figure 18-1.

	How to View the Software List Using the ‘Expanded’ Setting
	2 Select a control card. (See Selecting a Control Card on page 10.)
	3 From the menu bar, select ‘Windows > Configuration’. The ‘Configuration’ window appears, as shown in Figure 18-1.
	4 Click Read All. Current configuration settings for the selected control card populate the ‘Configuration’ window fields.
	5 From the menu bar, select ‘Tools > Options’. The ‘Configuration Options’ dialog box appears:
	6 Check the ‘View expanded software descriptions’ check box. By default this box is not checked.
	7 Click OK to save changes and close the dialog box.
	8 The ‘Configuration’ window displays full descriptions in the ‘Description’ column in the ‘Software Versions’ section:


	Uploading a Flash Configuration File
	How to Upload a New Protocol
	2 Select a control card. (See Selecting a Control Card on page 10.)
	3 From the menu bar, select ‘Windows > Configuration’. The ‘Configuration’ window appears:
	4 Click Read All. The ‘Configuration’ window populates with current router information.
	5 In the ‘Software Versions’ section, all applications currently being used by the control card are listed. Applications begin w...
	6 From the menu bar, select ‘Window > Flash Memory’. The ‘Flash Memory’ window appears:
	7 In the field corresponding to the protocol being replaced (i.e., ‘APP4’), click Browse and browse to the location of the new protocol.
	8 On the ‘Browse’ dialog, click Open. The path to the protocol displays in the ‘Flash Memory’ window.
	9 Click Write Flash. The ‘Status’ bar indicates the progress of uploading the protocol. When it is finished, the status bar is completely filled in.
	10 Again from the menu bar, select ‘Window > Configuration’. The new protocol is listed in the ‘Software Versions’ section, as shown in Figure 18-1.
	11 Repeat steps 2-10 for each control card being updated.


	Reading and Saving a Flash Configuration File
	How to Read and Save a File
	2 Select a control card. (See Selecting a Control Card on page 10.)
	3 From the menu bar, select ‘Window > Flash Memory’. The ‘Flash Memory’ window appears:
	4 Again on the menu bar, select ‘File > Read From Flash Configuration File’. The last protocol that was listed in each field displays; the window populates with the last files opened.
	5 Select ‘File > Save As Flash Configuration File’ to save the Flash configuration file locally on a PC.



	19. Viewing System Status
	View the System Status
	How to View System Status
	2 From the menu bar, select ‘Window > System Status’. The ‘System Status’ window appears:
	3 Click Read to view the current system status. The ‘This Control Card Status’ section displays the “health” of the reference connections and control cards. ‘Power Supplies’ and ‘Fans’ status information display in the fields provided.
	4 To perform status tasks involving the system, from the menu bar select ‘Actions > System’ and then select an option. If a menu option is not applicable, it is greyed-out. Options may have additional, secondary options.
	5 To perform status tasks involving the control cards, from the menu bar select ‘Actions > Controller State’ and then select an option. If a menu option is not applicable, it is greyed-out. Options may have additional, secondary options
	6 (Optionally) click Auto Upload to have UniConfig automatically read and display the system status information every two second...



	20. Connection Reports and Logs
	Creating Connection Reports
	How to Create a Connection Report
	2 From the menu bar, select ‘Window > Connections’. The ‘Connections’ window appears displaying current input and output settings:
	3 In the ‘Physical Output Range’ section, enter a ‘Start’ and ‘End’ number in the fields provided and click Read Outputs. The co...
	4 Again from the menu bar, select ‘File > Write Connection Report’. UniConfig generates a report and a ‘Save As’ dialog box appears.
	5 On the ‘Save As’ dialog box, select a location and name for the file and click Save.
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