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Change History 

Notice
Due to continued product development, the accuracy of the information in this document may 
change without notice. The information and intellectual property contained herein is confiden-
tial between Miranda and the client and remains the exclusive property of Miranda. If you find 
any problems in the documentation, please report them to us in writing. Miranda does not 
warrant that this document is error-free.

All title and copyrights as well as trade secret, patent and other proprietary rights in and to the 
Software Product (including but not limited to any images, photographs, animations, video, 
audio, music, test, and “applets” incorporated into the Software Product), the accompanying 
printed materials, and any copies of the Software Product, are owned by Miranda Technologies, 
Inc. The Software Product is protected by copyright laws and international treaty provisions. 
Customer shall not copy the printed materials accompanying the software product.

The software contains proprietary information of Miranda Technologies, Inc. It is provided under 
a license agreement containing restrictions on use and disclosure and is also protected by copy-
right law. Reverse engineering of the software is prohibited.

FCC Statement
This equipment has been tested and found to comply with the limits for a Class A digital device, 
pursuant to part 15 of the FCC Rules. These limits are designed to provide reasonable protection 
against harmful interference when the equipment is operated in a commercial environment. 
This equipment generates, uses, and can radiate radio frequency energy and, if not installed and 
used in accordance with the instruction manual, may cause harmful interference to radio 
communications. Operation of this equipment in a residential area is likely to cause harmful 
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interference in which case the user will be required to correct the interference at his own 
expense.

Declaration of Conformance (CE) 
All of the equipment described in this manual has been designed to conform with the required 
safety and emissions standards of the European Community. Products tested and verified to 
meet these standards are marked as required by law with the CE mark. 

When shipped into member countries of the European Community, this equipment is accompa-
nied by authentic copies of original Declarations of Conformance on file in Miranda USA offices 
in Grass Valley, California.

Trademarks
Miranda is a registered trademark of Miranda Technologies, Inc.

Brand and product names mentioned in this manual may be trademarks, registered trademarks 
or copyrights of their respective holders. All brand and product names mentioned in this 
manual serve as comments or examples and are not to be understood as advertising for the 
products or their manufactures.

Software License Agreement and Warranty Information
Contact Miranda for details on the software license agreement and product warranty.
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Preface
Chapter 1 provides an introduction to the UniConfig User’s Guide. 

Topics
Chapter Structure  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  1
The PDF Document . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  2
Terms, Conventions and Abbreviations . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  2

Chapter Structure 
The following chapters provide detailed instructions for all aspects of Router Configuration 
Utility: 

• Chapter 1, Preface, (this chapter) outlines ways to use this guide, and provides a list of terms 
and conventions. 

• Chapter 2, Introduction, provides a functional description of UniConfig.

• Chapter 3, UniConfig Basics, provides an overview of UniConfig’s windows and menus.

• Chapter 4, Configuration Basics, provides an overview of configuration tasks.

• Chapter 5, Installation, provides information on installing UniConfig.

• Chapter 6, Communication, provides information on setting up communication between 
UniConfig and the router.

• Chapter 7, Partitions and Signal Types, provides information on creating partitions.

• Chapter 8, Switch Point Settings, provides information on making switch point settings.

• Chapter 10, Connections Window, provides information on crosspoints and performing 
takes.

• Chapter 9, Machine Control, provides information on machine control partitions and ports.

• Chapter 11, EC9535, provides information regarding the EC9535 GSC Node Controller, a 
router interface.

• Chapter 12, NV8500 Monitors, provides information regarding NV8500 input and output 
monitors.

• Chapter 13, Locks, provides information about releasing locks.

• Chapter 14, Salvos, provides information on salvos.

• Chapter 15, Firmware, provides information about updating firmware.

• Chapter 16, System Status, discusses the ‘System Status’ window.

• Chapter 17, Logs, discusses the ‘Logs’ window.

• Chapter 18, Technical Details, provides supplementary, but important, information.

An Index and Glossary are also provided for your reference. 
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Preface
The PDF Document
The PDF Document 
This guide is provided in PDF format, allowing you to use Acrobat’s “bookmarks” to navigate to 
any desired location. You can also easily print a hardcopy. Please note:

• Use the Table of Contents or the bookmarks page to jump to any desired section. 

• Many hyperlinks are provided within the chapters.

• Use the index to jump to specific topics within a chapter. Each page number in the index is a 
hyperlink.

• Use Acrobat’s ‘Go to Previous View’ and ‘Go to Next View’ buttons to retrace your complete 
navigational path. 

Use the ‘First Page’, ‘Previous Page’, and ‘Next Page’, and ‘Last Page’ buttons to go to the first, 
previous, next, or last page within a PDF file. 

• Use Acrobat’s extensive search capabilities, such as the ‘Find’ tool and ‘Search’ tool to per-
form comprehensive searches as required. 

Terms, Conventions and Abbreviations 
The following conventions are used throughout this guide: 

• Notes, Cautions and Important messages are presented in note boxes.

• Entries written in bold-face or capital letters denote physical control panel buttons or GUI 
buttons. 

Click Apply to ... 

Press the SRC 12 button.

• Entries in single quotes denote a field name, page name, or label.

The AES3 reference connection is labeled ‘AES3 REF 1’.

Note

To display the navigation buttons, right-click the Tool Bar area, and check ‘Navigation’.
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Introduction
Chapter 2 provides a brief functional description of UniConfig. 

Topics
Product Overview  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  3
Supported Routers . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  4

UniConfig is a software application to set up and modify configurations of Miranda’s NVISION 
series routers and to perform diagnostics. UniConfig runs on a PC and communicates with a 
router through the router’s control card either serially or over Ethernet. UniConfig modifies 
settings on the router control card. Configuration settings vary depending on the router’s matrix 
type, its communication protocol, and the level of complexity of the router’s partitioning. 

You can also use UniConfig to upload new firmware to router control cards and to perform 
minor adjustments, such as takes and lock releases, on a router that is in operation. 

Product Overview
A router’s control card handles communication between a router control system and the 
router’s hardware. 

There are several different protocols available by which the router control system can communi-
cate with the control card. 

In this chapter, we assume that UniConfig is interacting with one of Miranda’s NV9000 family 
router control systems using Miranda’s Ethernet protocol (NVEP). This protocol is always avail-
able through the router’s Ethernet connection. NVSP (the serial protocol) is always available 
through the router’s ‘CTRL 2’ connections. 

Third-party protocols can be active through the serial ‘CTRL 1’ connection only. The control card 
allows only one third-party protocol to be loaded at any one time. For information on changing 
control system protocols, contact Miranda Technical Support. 

Storing Configuration Settings
Configuration settings are stored in non-volatile memory (EEPROM) located on the router moth-
erboard. The EEPROM stores all configuration settings entered through UniConfig except the 
crosspoint switching data. Crosspoint data are stored on the control card in battery-backed 
RAM. 

Each control card in a router has its own memory. Both cards, if two are present (for redun-
dancy), must be configured separately and identically. 
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Supported Routers
Utilities
UniConfig can be used to perform a variety of utility functions, such as running diagnostics or 
viewing system status. In addition, UniConfig can be used to test and update router crosspoint 
data independently of the router control system.

Miranda GVD periodically updates UniConfig with new features and functionality. Contact 
Miranda Technical Support for the latest version of UniConfig. 

UniConfig Version
This document describes UniConfig version 12.0.0 communicating with a control card running 
current firmware under Miranda’s NVEP protocol. If your specific version of UniConfig and 
control card firmware and its protocol are different, some features or functions presented in this 
guide might not be available on your system. Contact Miranda Technical Support for informa-
tion on obtaining the latest versions of UniConfig and firmware for your situation. 

Upgrading control card firmware is recommended only if a specific feature or function you 
require is not provided by your current version. In some cases, new hardware may be required to 
execute the latest firmware revision.

Supported Routers
UniConfig currently supports the following NVISION routers:

Although the EC9535 is not a router, it is configurable in UniConfig. 

The NV3512 expandable digital audio router, the NV3064 multi-format router, and the NV6000 
series routers are not discussed in this document. Please contact Miranda Technical Support for 
assistance. 

NVISION Router Control Card

NV5100 multi-format router (128×128) EM0374

NV5128 multi-format router (128×128) EM0374

NV5256 machine control router 256×256 expandable to 512×512 EM0374

NV7256 digital audio router (256×256) 
NV7256-Plus digital audio router 256×256 expandable to 512×512

EM0374

NV7512 digital audio router 512×512 expandable to 2048×2048 EM0374

NV8256-Plus digital video router 256×256 expandable to 1024×1024 EM0374

NV8288 digital video router (288×576) 
NV8288-Plus digital video router 288×288 expandable to 576×576

EM0529

NV8500 Family:
NV8144 digital video router 144×144
NV8140 digital video router 144×288
NV8280 digital video router 288×576
NV8576 digital video router 576×1152
NV8576-Plus digital video router 576×576 expandable to 1152×1152

EM0666

EC9535 GSC Node Bus Converter (no signal inputs or outputs) EM0374
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UniConfig Basics
Chapter 3 describes the UniConfig windows and menus. 

Topics
The UniConfig Interface . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  5
Working With UniConfig Windows . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  12

The UniConfig Interface 
The UniConfig interface manages all configuration tasks through standardized menus and 
windows. Figure 3-1 shows a representative UniConfig screen: 

Fig. 3-1: UniConfig Window

Menu Bar

Control 
Card 
Pane
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Window

Work Area

Collapsed 
Windows

Status Bar
 5



UniConfig Basics
The UniConfig Interface
The UniConfig window is divided into sections. At the top is a menu bar providing 5 or more 
menus. The number of menus varies according to which UniConfig tool you are using.

At the left is an optional control card pane. (This is available only when UniConfig is in “Ethernet 
mode.”) The control card pane lists the devices for which you have specified IP addresses. These 
IP addresses need not correspond to control cards in actual routers. You can create fictitious 
entries in the control card pane if it suits your purpose. 

The main portion of the window is a work area that displays one or more sub-windows. One of 
the sub-windows is the active window. You can open and close, and minimize or maximize, any 
of these sub-windows.

At the bottom of the UniConfig window is a status bar. At right end of the status bar, you can 
always see the IP address of the control card with which you are communicating (when 
UniConfig is in Ethernet mode) or the serial port and bit rate at which you are communicating 
(in serial mode). 

UniConfig follows (older) standard industry practices for Windows applications. This document 
assumes that you have a knowledge of basic Windows functions, such as using a mouse and 
keyboard or clicking GUI buttons. 

Appearance
You can change the size of the UniConfig window. Drag the a corner or edge of the window until 
it is the size you want. 

UniConfig remembers its position and size on your PC screen the next time you launch 
UniConfig.

Menu Bar
UniConfig has 5 (or more) menus at the top of the window: 

• File • Communications • Tools

• Window • Help

A 6th menu — the ‘Actions’ menu — appears when you have certain windows open, such as the 
‘System Status’ window. 

A 7th menu — the ‘Edit’ menu — appears when you have other windows open, such as the 
‘Switch Point Setup’ menu. 

File Menu
The ‘File’ menu always has at least an ‘Exit’ command: 

The ‘Exit’ command terminates your UniConfig session.

Depending on what UniConfig window you have open, the ‘File’ menu can have other 
commands as well. 
6
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Communications Menu
The ‘Communications’ menu governs the two modes in which you can communicate with a 
router’s control card: 

If you wish to communicate with a router control card serially (through a connector at the front 
of the control card), click ‘Serial’. 

If you do not know the card’s IP address, as when the card has never been configured, you 
must initially access the control card serially. 

A serial connection requires an RS-232 connector on your PC and an RS-232 cable connected 
to the router’s control card. Many modern PCs and laptops do not have serial connectors. 
You might need to obtain a USB-to-serial interface. See USB-to-Serial Adapters on page 23.

If you wish to communicate with a control card over Ethernet, click ‘Ethernet’. In this case, your 
PC and the router’s control card must be connected, through an Ethernet switch, on the same 
network. 

A check mark appears beside the option you choose. If you chose ‘Serial’, we say UniConfig is in 
serial mode. If you chose ‘Ethernet’, we say UniConfig is in Ethernet mode. 

Setup Command
The ‘Setup . . .’ command differs in serial mode and Ethernet mode. 

If UniConfig is in serial mode, the setup dialog is for a serial connection: 

The ‘Comm. port’ field specifies through which serial port of your PC you will communicate. It to 
is this port that you connect your serial cable. The ‘Baud rate’ field allows you to specify one of 
several rates. Generally, 115200 Baud is preferable.

If UniConfig is in Ethernet mode, the setup dialog is for an Ethernet connection: 

It is in this dialog that you specify the IP address of the control card you want to configure.
7
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You can also specify — using the check box — whether UniConfig will log communications 
messages. 

Set Router Type Command
If you are configuring an NV3128 or an NV3256 and the router has lost its device ID, use the ‘Set 
Router Type’ command to restore the router’s device ID.

The command has two options: 

Click the appropriate entry to choose your router. You must write the EEPROM of the router. 

The NV3128 and NV3256 (and NV3512) are obsolete. Miranda no longer sells these routers 
and service in the field is limited. If you have one of these routers and want to write the 
EEPROM, contact Miranda if you need instructions.

Tools Menu
The ‘Tools’ menu has two commands: 

The ‘Options . . .’ command is present in certain contexts and absent in other contexts.

Options Command
In some contexts, the ‘Options’ command presents this ‘Configuration Options’ dialog: 

These are general options. 
8
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However, when a ‘Connections’ window is active, the ‘Options’ command presents this ‘Connec-
tion Options’ dialog: 

See Chapter 10, Connections Window, for information.

Search for NVISION Devices Command
Clicking this command, in the ‘Tools’ menu, produces a report of all NVISION series devices, 
including router control cards, detectable on the networks to which your PC has access: 

You can click the ‘Search/Refresh’ button to update the display of detectable devices.
9
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Window Menu
The ‘Window’ menu has commands in 3 sections: 

The first section, at the top, includes 3 commands that affect the display of the sub-windows in 
the work area: 

• Cascade. This command arranges the windows you have open in an orderly stack, with the 
active window on top (visible).

• Tile. This command distributes the windows you have open in an array of equal size win-
dows that completely cover the work area. 

• Arrange Icons. This command arranges minimized windows neatly at the bottom of the 
work area and leaves open windows unchanged.

The command in the middle section turns the control card pane (with its list of control card 
entries) on or off. (This command is disabled when UniConfig is in serial mode.)

The third section, at the bottom, includes commands that open different windows in the work 
area. The number of windows that you can open depends on what you are doing. In general, all 
windows are available when you have accessed a router control card and have read the configu-
ration from that control card. 

A check mark appears in the third section next to the active window. 

If you have accessed a control card, the ‘Configuration’ window entry also identifies the type of 
router for that control card. 

Help
The ‘Help’ menu has 3 commands: 

The ‘UniConfig Help’ command opens UniConfig’s on-line help. You can browse the on-line help 
for information. The on-line help contains the same information as this user’s guide. It has a 
search capability. 
10
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The ‘Obtaining Technical Support . . .’ command displays a list of Miranda’s technical support 
addresses, telephone numbers, and email addresses: 

The ‘About UniConfig . . .’ command tells you the version number of UniConfig: 

Actions Menu
The ‘Actions’ menu appears when any of these 3 windows is active: 

• System Status. (See Chapter 16, System Status.)

• Flash. (See Chapter 15, Firmware.)

• Connections. (See Chapter 10, Connections Window.)

The format and function of the menu varies according to which window is active. 

Edit Menu
The ‘Edit’ menu appears when any of these windows is active: 

• Switch Point Setup. (See Chapter 8, Switch Point Settings.)

• Machine Control Port Setup. (See Chapter 9, Machine Control.)

The format and function of the menu varies according to which window is active. 
11
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Working With UniConfig Windows 
By default, when UniConfig launches, all windows are opened and minimized along the lower 
edge of the work area, with the exception of the ‘Configuration’ window which is open and 
active. 

It is in an active window that you carry out configuration tasks. To activate a different window, 
go to the ‘Window’ menu and click the name of the window you want, or click anywhere in a 
window that is visible. The window you select appears in front of all other windows. 

UniConfig windows can be minimized or maximized. To minimize a window, click the X in the 
upper, right-hand corner of the window.

Control Card Pane
The control card pane appears at the left of the UniConfig window, when UniConfig is in 
Ethernet mode. 

The control card pane is a list of IP addresses (and names) of control cards in your system. The list 
makes it easy to select a control card. 

This list can include control cards for routers that do not yet exist or control cards for routers 
that are off-line. 

To select a control card from the list, simply click on the control card entry. 

You can add entries to the control card pane and you can remove entries from it.

How to Open the Control Card Pane
The control card pane appears automatically when you switch to Ethernet mode. 

If UniConfig is already in Ethernet mode, click ‘Control Card Tree’ in the ‘Window’ menu. 

If UniConfig is not in Ethernet mode, click ‘Ethernet’ in the ‘Communications’ menu. UniConfig 
will switch to Ethernet mode and the control card pane will appear. 
12
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How to Add Entries to the Control Card Pane
1 Right-click the root entry (“Control Cards”) in the control card pane: 

A context menu appears. Click ‘Add Control Card . . .’

2 The ‘Control Card Configuration’ dialog appears: 

Enter an IP address in the ‘IP address’ field and a name in the name field. 

You can click ‘Search/Refresh’ to obtain a list of control cards available on the networks to 
which your PC is connected. (These are the control cards you can configure.)

Double-clicking an entry in the search results will place that device’s IP address in the ‘IP 
address’ field. 

When you are satisfied with your entry, click OK. UniConfig will add this IP address and name 
to the control card list. 

How to Remove Entries from the Control Card Pane
1 Right-click an entry in the control card pane: 

A context menu appears. 

2 Click ‘Delete’. UniConfig removes the entry immediately. 
13
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How to Modify Entries in the Control Card Pane
1 Right-click an entry in the control card pane: 

A context menu appears. Click ‘Delete’.

2 The ‘Control Card Configuration’ dialog appears: 

Re-enter an IP address in the ‘IP address’ field or edit the name in the name field. 

You can click ‘Search/Refresh’ to obtain a list of control cards available on the networks to 
which your PC is connected. (These are the control cards you can configure.)

When you are satisfied with your entry, click OK. UniConfig will redisplay this entry in the 
control card list. 

Relocating the Control Card Pane
You can move the control card pane from its original position and relocate it elsewhere on your 
PC’s screen. You can resize it and position it as desired. 

To move the window away from its anchored position, click the double line at the top of the 
pane and drag the pane to the desired location on the screen. The pane changes shape and 
format. The label at the top of the relocated pane changes to ‘Instant Bar’.

You can dismiss the detached pane by clicking the X in its upper right corner. 

To redisplay the (detached) pane, click ‘Control Card Tree’ in the ‘Window’ menu.

To move the detached pane back to its original position, drag it to the left side of the UniConfig 
window. Position the pane so that it shape changes and release the mouse button. The pane will 
snap into its normal size and place.
14
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Configuration Options

Automatic Refresh
Under automatic refresh, whenever you select a control card, UniConfig automatically updates 
the ‘Configuration’ window to display that control card’s settings. 

To turn automatic refresh mode on (or off ),

1 From the ‘Tools’ menu, choose ‘Options’. The ‘Configuration Options’ dialog appears: 

A different ‘Configuration Options’ dialog appears if you have the ‘Connections’ window 
open. If that occurs, close the ‘Connections’ window and re-issue the ‘Options’ command 
from the ‘Tools’ menu.

2 Click the ‘Auto refresh when selecting different node’ check box. 

3 Click OK to save changes and close the dialog. Or, click Cancel to close the dialog without 
saving changes.

Viewing ‘Write All’ Sequence
When you are making changes, it is sometimes beneficial to view current writing activity to 
know when the writing of data to the control card is complete.

How to View Write Sequence Progress
1 Select a control card. 

2 Go to the ‘Configuration’ window. 

3 Click Read All. Current configuration data for the selected control card populate the ‘Config-
uration’ window.
15
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4 From the ‘Tools’ menu, choose ‘Options’. The ‘Configuration Options’ dialog appears: 

5 Check the ‘Show advanced Serial EE settings’ check box. By default, this box is not checked. 
When it is checked, additional options appear: 

6 Check the ‘Display diagnostic screen during updates’ check box. The next time you click 
Write All, a ‘Serial EE Write Status’ dialog shows the status of the data being written to the 
control card.

7 Click OK to save changes and close the dialog. Or, click Cancel to close the dialog without 
saving changes.
16
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Applying Either Current Changes or All Settings
When you are making changes to configurations, you can choose (1) to have only the most 
recent changes written to the control card or (2) to have all configurations settings, including 
changes, written to the control card. 

Limiting changes that are written is helpful if you are trying to isolate a specific change behavior. 

(Data are written to the control card when you click Write All in the ‘Configuration’ window.)

How to Choose Current Changes or All Settings 
1 Select a control card. 

2 Go to the ‘Configuration’ window. 

3 Click Read All. Current configuration data for the selected control card populate the ‘Config-
uration’ window.

4 From the ‘Tools’ menu, choose ‘Options’. The ‘Configuration Options’ dialog appears. 

5 Check the ‘Show advanced Serial EE settings’ check box. By default, this box is not checked. 
When it is checked, additional options appear: 

6 In the ‘Serial EE data updates’ section, select either ‘Write changes only’ or ‘Write all’.

7 Click OK to save changes and close the dialog. Or, click Cancel to close the dialog without 
saving changes.
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Configuration Basics
Chapter 4 discusses basic configuration tasks, including launching UniConfig, selecting a 
control card, viewing data, and writing changes. 

Topics
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Viewing Configurations . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  21
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Network Basics  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  24

UniConfig is used for configuring the control cards of NVISION series routers (and other devices 
having control cards). A router cannot function properly until its control card(s) has been 
configured.

Configuration choices vary according to the router model and the communication protocol 
loaded on the control card. After UniConfig reads the router model and control card protocol, it 
determines which menu options and windows to display.

Before Starting a Configuration
Before starting configuration tasks, please review the following check list of required conditions:

• The Miranda router has all the desired input, output, crosspoint, and control cards installed 
and is powered up. All required reference signals have been connected.

• You have a configuration PC with UniConfig installed. See Installation on page 27. This PC 
must be on the same Ethernet network as the router(s) you wish to configure. 

• The router control system that will be used to control the router is available and ready for 
configuration. 
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Launching UniConfig

How to Launch UniConfig 
Select ‘Programs > NVISION > UniConfig’ from the Windows ‘Start’ menu, or click the UniConfig 
shortcut on your desktop: 

How to Connect to a Router Control Card
If you do not know the IP address of your router’s control card, or if the control card is not acces-
sible over Ethernet, on your PC, you must make a serial connection to the control card. The 
details of that are explained in Communication on page 31. 

If your PC has an Ethernet connection to the control card, connection is much simpler. 

Ethernet Connection
1 Click ‘Ethernet’ in the ‘Communications’ menu (if you have not done so already).

2 Either click ‘Setup’ in the ‘Communications’ menu and enter an IP address in the dialog: 

3 Or, choose a control card from the control cards pane.

4 In the ‘Configuration’ window for this control card, click ‘Read All’. 

The control card must be accessible among the networks to which your PC is connected. 

Serial Connection
Serial connections require your PC to have either a serial port or a USB-to-serial adapter for 
use with a USB port. 

Selecting a control card on a serial connection means running a serial cable from a COM port of 
your PC to a DE9 port of the control card itself. (The DE9 port to use is either at the front of the 
card or at the rear of the router frame.)

There are several methods for connecting to a control card serially. The method you choose 
depends on the router control card: 

• EM0374 — Use the DE9 connector at the front of the control card. (Routers that use the 
EM0374 are the NV5128, NV5256, NV7256, NV7512, NV8256-Plus, and the NV5100MC. The 
EC9535 also uses EM0374 control cards.)

The connection is RS-232, 9600 Baud, 8N1. 

(You can use the router’s rear connector after you first set up communication using the front 
connector.)
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• EM0529 — The NV8288 and the NV8288-Plus use this control card. Connect to the rear diag-
nostic port of the router frame. There are two ports. Use the one for the control card you 
want to configure. (Both control cards must eventually be configured identically.) 

The connection is RS-232, 38400 Baud, 8N1. 

• EM0666 — This card is used by NV8500 family standard routers. Connect to the rear diagnos-
tic port of the router frame. There are two ports. Use the one for the control card you want to 
configure. (Both control cards must eventually be configured identically.) 

The connection is RS-232, 38400 Baud, 8N1.

See Communication on page 31 for complete details.

The control cards on a router must be configured separately and identically. 

Viewing Configurations
After you have connected to a control card, go to the ‘Configuration’ window.

How to View Current Configuration Settings
1 Select a control card. 

2 Go to the ‘Configuration’ window: 

Fig. 4-1: Configuration Window (NV8256 Sample)

3 Click Read All. Current configuration data populate the ‘Configuration’ window.

If ‘Auto Refresh’ is enabled, it is not necessary to click Read All. See Automatic Refresh on 
page 15.
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Writing Changes to the Control Card
UniConfig does not save any changes in your PC’s file system. Configuration changes you make 
are written to the EEPROM on the motherboard in the router frame. Each of a router’s control 
cards has its own independent EEPROM. This means that changes must be made to each control 
card separately and identically. 

When written, changes are global and immediately overwrite any previous settings. There is 
no way to undo a “write.”

How to Write Changes
1 In the currently open UniConfig window in which changes have been made, click Write or 

Write All. If the changes are successfully written to the control card, a dialog appears 
prompting you to reboot the control card. 

2 Click Yes to reboot the control card. All crosspoint settings are maintained during the reboot 
cycle but crosspoints cannot be changed until the control card has finished rebooting. 

Or, click No if you want to reboot at a later time. Changed settings are stored in EEPROM, but 
are not copied into the RAM used by the control card. The system will continue to run using 
the previous settings until a reboot is performed.

Applying Configurations to Another Control Card 
Once a configuration has been defined, the configuration settings can be applied to multiple 
control cards. 

How to Apply a Configuration to Another Control Card
1 Select a control card. (This the “from” control card.)

2 Go to the ‘Configuration’ window. 

3 Click Read All. Current configuration settings for the selected control card populate the 
‘Configuration’ window fields.

4 Ensure that ‘Auto-refresh’ is disabled. (See Automatic Refresh on page 15.)

5 Select another control card — one to which you want to copy the current configuration. 

6 Important: Enter the “to” control card’s IP address (and its subnet mask and gateway 
address, if necessary) in the Ethernet settings section of the page.

If you do not change the IP address, you will write the configuration back to the “from” con-
trol card.

7 In the ‘Configuration’ window, click Write All. UniConfig sends the current configuration to 
the selected control card. 

8 Repeat steps 5–7 for additional target control cards. 

Do not click Read All. 
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USB-to-Serial Adapters
Older PCs have one or more DE9 COM ports. Newer PCs do not have them. 

You can obtain a USB-to-serial conversion kit. With the software in the kit, a USB port acts a serial 
port.

Following is one solution. 

Obtain a USB-to-Serial-Value kit from SIIG, Inc. (www.siig.com). The kit includes a software CD 
and a USB-to-DE9 cable. 

Install their driver. The driver (software) will perform USB-to-serial conversion. 

After loading the software, determine which COM ports are available:

1 Go to the Windows System Properties dialog: 
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Click the ‘Device Manager’ button. The ‘Device Manager’ window opens: 

2 Locate, and expand, the ‘Ports (COM & LPT)’ entry. You should see entries listing the COM 
ports that are associated with USB ports. (The window details and the nomenclature might 
differ if you are using Windows 7 or a driver from a different supplier.) 

3 In UniConfig’s ‘Serial Communications Settings’ dialog, choose one of those ports as the 
COM port: 

Network Basics
For devices to communicate over Ethernet, all devices must reside on the same subnet or have 
access to the subnet through a gateway. 

Each control card on an NV9000 router network must have a unique IP address. 

An IP address is a 32-bit number divided into two portions, one identifying the subnet and the 
other specifying the address of a device within the subnet. A subnet mask specifies where in the 
IP address the division occurs. 

An IP address is usually represented by four 8-bit values (octets) written in decimal. The typical 
IP address for a router in an NV9000 system is

192.168.1.nnn where nnn ranges from 1 to 254
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and its subnet mask is typically 255.255.255.000. That mask means that 24 bits are used for the 
subnet and 8 bits are used for the device address.

(Device addresses 0 and 255 are reserved for other purposes and may not be used.) 

IP addresses for router control cards must be fixed addresses. DHCP1 is not used.

IP addresses are divided into classes. Specific classes are intended for different functions. For 
example, IP addresses on the 192.168.xxx.xxx subnet are known as class C addresses and are 
intended for use in private closed networks. This range is recommended for use with all Miranda 
products using a fixed IP structure.

Barring any IP addresses provided by your IT administrator, we suggest the following IP address 
settings for router control cards:

With these IP addresses, your configuration PC should configured so that one of its IP addresses 
is 192.168.1.nnn where nnn is different from any address used by the routers. 

All Miranda routers support Ethernet communication at 100 Mb/s. 

1. Dynamic Host Configuration Protocol

Router Primary Control Card Secondary Control Card

First router 192.168.1.5 192.168.1.6

Second router 192.168.1.7 192.168.1.8

Third router 192.168.1.9 192.168.1.10

Fourth router 192.168.1.11 192.168.1.12

. . .
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Installation
Chapter 5 provides installation instructions. 

Topics
Preparing for Installation  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  27
Installing UniConfig  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  28

Preparing for Installation
You will need a PC with the following features to use UniConfig: 

You will need the following items to use UniConfig: 

Windows® 2000, Windows XP Professional,® or Windows 7.® UniConfig does not run 
under any version of the Macintosh or Linux operating system. 

A late model Pentium-class processor, such as a Pentium III (or later) or an AMD Athlon.

At least 90 MB of disk space.

A CD drive.

256 MB or more RAM.

At least one RS-232 serial port capable of running at 38400 bps or more. Note that many 
USB-to-serial adapters do not function correctly at higher Baud rates. 

A 10/100baseT Ethernet port that can use a fixed IP address on the same network as your 
NVISION series routers.

100 Mb/s Ethernet switch with at least 4 ports. 

Ethernet cables (category 5 or better).

Straight-through RS-232 serial cable. 
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Installing UniConfig
UniConfig is available on Miranda GVD’s Software and Documentation CD (SB0033-xx). You can 
obtain the most recent release of UniConfig through Miranda customer service. 

How to Install UniConfig
1 Obtain the Software and Documentation CD (SB0033) and insert in your CD drive. 

2 The CD should “autoplay.” The main screen appears: 

3 Click ‘Configuration Software’. The configuration software page appears: 
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4 Click ‘Install UniConfig’. You will see a warning message: 

You may safely disregard the warning. Click ‘Run’ to proceed.

5 The UniConfig installer will launch: 

6 Follow the simple instructions, clicking ‘Next’ to proceed from step to step. The actual instal-
lation takes about 30 seconds. By default, the installer creates an entry in the Windows ‘Start’ 
menu and also creates a shortcut on your desktop: 

The default pathname of the application is: 

C:\Program Files\NVISION\UniConfig\UniConfig.exe

The default path in the Windows Start menu is: 

Programs > NVision > UniConfig
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Communication
Chapter 6 discusses how UniConfig communicates with routers. 

Topics
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Serial and Ethernet Settings . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  34
Communications Options  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  37
Reading and Writing Control Card Configurations  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  39
Disabling an Ethernet Port . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  39

UniConfig can communicate with any NVISION series router’s control card through its Ethernet 
port. Depending on the router, it can also communicate either through a serial port located at 
the rear of the router, or through a serial port located at the front of the control card. 

EC9535s are not routers but they do have (EM0374) control cards. For information on setting 
up EC9535 communication, see EC9535 on page 107.

Use MRC, not UniConfig, to configure NV8500 family hybrid routers (which have EM0833 
control cards). 

Communicating with a Router 

Communicating with the Router for the First Time
The first time you configure a router, it is likely not to have an IP address. You must use the 
router’s serial connection with UniConfig to assign the router’s control card its IP address. If the 
router has two control cards, you must assign an IP address to both. After you perform this 
simple step, you can use the router’s Ethernet connection to perform configuration tasks. 

Ethernet is generally preferable. You can access multiple routers, perhaps remotely, and you do 
not have to make cable connections for each change. Ethernet is also faster when you are 
uploading firmware to the router. 

Note
If your router has two control cards, use UniConfig to configure each control card sepa-
rately and identically. Each of the control cards must have a unique IP address, however.
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Front Serial Connection 
(Front serial connections apply only to routers with EM0374 control cards.)

Make a connection between the router and UniConfig. Run a cable from your PC’s serial port to 
the DE9 serial port located on the front of the control card. This connection is set to a fixed rate 
of 9600 Baud. (The protocol is RS-232, 8N1, meaning 8 data bits, no parity, and 1 stop bit). 

How to Make a Front Serial Connection
1 Open the router door and locate the control card. 

2 Run a straight-through serial cable from your PC’s serial port to the DE9 connector at the 
front of the control card.

If your PC does not have a serial port, you’ll need a USB-to-serial adapter for the cable. See 
USB-to-Serial Adapters on page 23.

3 Close the router door as much as possible. The router might overheat if you leave the door 
open.

4 Set up serial communication in UniConfig. That is, choose serial mode and set the RS-232 
settings to 9600. See Changing UniConfig’s Serial Communication Parameters on page 34.

5 Read the control card configuration from the router. See Reading a Control Card’s Configura-
tion on page 39. If the read is successful, your serial connection is good. 

(If the read is not successful, you will need to diagnose and correct the problem. The prob-
lem could be a faulty cable or that you have used a crossover cable by mistake. The problem 
might lie in UniConfig: its Baud rate not set to 9600, the wrong COM port or the wrong con-
nector chosen.) 

6 Be sure to close the router door again when you have finished with its control cards.

Rear Serial Connection (DIAG Port) 
(The serial connection for routers with EM0529 control cards or EM0666 control cards must be 
made through the DIAG connectors at the rear of the router.)

(It is your option, after you have initially set up a router having an EM0374 control card, to access 
the control card through its rear DIAG port.)

There are two serial ports located on the router, labeled ‘DIAG’. One is for the primary1 control 
card and the other is for the secondary control card. By default, these ports are set to 38400 
Baud, RS-232, but can be changed to RS-422 in UniConfig. Do not change them to RS-422.

1. The terms “primary” and “secondary” mean nothing more than to distinguish the two control cards. 
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How to Make a Rear Serial Connection
1 Locate the permanent serial ports on the rear of the router, as shown in Figure 6-2. On the 

NV8288 and NV8288-Plus, the ports are labeled ‘DIAG (38400 Baud)’: 

Fig. 6-1: Serial Ports (Rear View, NV8288, NV8288-Plus)

On the NV8500 family routers, the ports are also labeled ‘DIAG (38400 Baud)’, but in a differ-
ent orientation: This shows the NV8144: 

Fig. 6-2: Serial Ports (Rear View, NV8144)

2 Run a straight-through serial cable from your PC’s serial port to the diagnostic connector.

If your PC does not have a serial port, you’ll need a USB-to-serial adapter for the cable. See 
USB-to-Serial Adapters on page 23.

3 Set up serial communication in UniConfig. That is, choose serial mode and set the RS-232 
settings to 38400. See Changing UniConfig’s Serial Communication Parameters, following.

4 Ensure that the control card’s DIAG port is set to RS-232 and 38400 Baud. See Changing the 
Control Card’s Serial Communication Parameters on page 35. 

5 Read the control card configuration from the router. See Reading a Control Card’s Configura-
tion on page 39. If the read is successful, your serial connection is good. 

(If the read is not successful, you will need to diagnose and correct the problem. The prob-
lem could be a faulty cable or that you have used a crossover cable by mistake. The problem 
might lie in UniConfig: its Baud rate not set properly, the wrong COM port or the wrong con-
nector chosen.) 
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Serial and Ethernet Settings 

Changing UniConfig’s Serial Communication Parameters
1 From the ‘Communications’ menu, click ‘Serial’. This places UniConfig in serial mode.

2 Again from the ‘Communications’ menu, click ‘Setup’. The ‘Serial Communications’ dialog 
appears: 

From the ‘Comm port’ drop-down list, select the communication port number that matches 
the port you are using on the configuration PC running UniConfig. 

From the ‘Baud Rate’ drop-down list, select a Baud rate. Select 9600 for a front connection to 
EM0374 cards. Select 38400 for a rear DIAG connection to any router’s control card. 

3 Click OK to accept the settings or, click Cancel to close the dialog without making any-
changes.
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Changing the Control Card’s Serial Communication Parameters
1 Select a control card. In Ethernet mode, use the control card pane or enter the card’s present 

IP address manually. In serial mode, run a cable to the applicable serial port of the control 
card. See How to Connect to a Router Control Card on page 20.

2 From the ‘Window’ menu, select ‘Router Serial Configuration’. The ‘Router Serial Configura-
tion’ window appears: 

3 Click Read to acquire the control card’s settings. (Doing so might not be necessary, but it is 
not harmful, at this step.)

4 In the ‘Router Serial Configuration’ window, make settings as follows:

The first 3 regions of this window are for connections between the router and a router con-
trol system. Only the last region, “Rear Diagnostic Port” has any relation to UniConfig:

a In the ‘Rear Diagnostic Port’ section, select a ‘Port type’ and ‘Baud rate’ from the drop-
down lists. Choose ‘RS232’ and ‘38400’. (These are the defaults.)

b Click Write to write changes to the control card. 

WARNING 
Do not click Read again before you have written the new data to the control card. 
Clicking Read reads all settings from the control card, overwriting any changes you 
have entered and does so without warning.
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Changing the Control Card’s IP Address
1 Select a control card. In Ethernet mode, use the control card pane or enter the card’s present 

IP address manually. In serial mode, run a cable to the applicable serial port of the control 
card. See How to Connect to a Router Control Card on page 20.

2 From the ‘Window’ menu, select ‘Configuration’. The ‘Configuration’ window appears. This 
example is the configuration window for an NV8256: 

3 In the ‘Configuration’ window, click Read All. UniConfig populates the ‘Configuration’ win-
dow with the current router configuration. 

4 In the ‘Router Ethernet Settings’ section, choose the ‘Enabled’ radio button to enable Ether-
net communication.

Then, enter the IP address and subnet mask for this control card. (Keep in mind that you are 
doing this while your PC is connected to the router serially.) The subnet you specify should 
be the one that includes the router and your PC. 

It is possible to enable, and specify the IP address of, a gateway in this dialog. See Advanced 
Ethernet Communication Settings on page 38 if you want to do that. 

For background information, see Network Basics on page 24.

5 Click Write All to save changes to the control card. A confirmation message appears: 
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6 Click OK to dismiss the message. Then UniConfig asks permission to reset the control card. 

Click Yes if you want to reset the control card at this time. 

7 Repeat steps 1–6 for the other control card in the router frame if one is present. 

Communications Options

Retaining Serial Port Settings
You can specify that UniConfig is to retain its most recent serial settings. Otherwise, UniConfig 
uses the serial settings of the currently selected control card. 

How to Retain the Most Current Serial Communication Settings
1 From the ‘Tools’ menu, select ‘Options’. The ‘Configuration Options’ dialog appears: 

A different ‘Configuration Options’ dialog appears if you have the ‘Connections’ window 
open. If that occurs, close the ‘Connections’ window and re-issue the ‘Options’ command 
from the ‘Tools’ menu.

2 Check the ‘Retain serial port settings’ check box. By default this box is checked.

3 Click OK to save changes and close the dialog or click Cancel to close the dialog without sav-
ing changes.

4 Repeat steps 1 through 3 for each control card you want to update.
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Advanced Ethernet Communication Settings
If your routers are on an Ethernet network, you can create a gateway to other sites. A gateway is 
a device, with an IP address, through which devices on one network can access devices on 
another network. For example, several facilities in different geographical locations can use a 
gateway to communicate with routers at another facility.

In UniConfig, you can assign a gateway address to each control card. Thus, you can control 
access to control cards on an individual basis.

The advanced Ethernet option enables the use of gateway IP addresses.

1 From the ‘Tools’ menu, select ‘Options’. The ‘Configuration Options’ dialog appears: 

A different ‘Configuration Options’ dialog appears if you have the ‘Connections’ window 
open. If that occurs, close the ‘Connections’ window and re-issue the ‘Options’ command 
from the ‘Tools’ menu.

2 Check the ‘Show Advanced Ethernet settings’ check box. 

3 Click OK to save changes and close the dialog.

4 The ‘Configuration’ window now displays gateway settings in its ‘Router Ethernet Settings’ 
section: 

5 It is now your option to enable, and specify, the IP address of a gateway. 
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Disabling an Ethernet Port
It is possible to disable the Ethernet port of a control card. 

If you do disable a control card’s Ethernet port, you will have to use the card’s serial connec-
tion when you want to restore the Ethernet port to operation. 

How to Disable Communication with a Control Card 
1 Select a control card. In Ethernet mode, use the control card pane or enter the card’s present 

IP address manually. In serial mode, run a cable to the applicable serial port of the control 
card. See How to Connect to a Router Control Card on page 20.

2 From the ‘Window’ menu, select ‘Configuration’. The ‘Configuration’ window appears.

3 Click Read All. The ‘Configuration’ window populates with the current router configuration.

4 In the ‘Router Ethernet Settings’ section, select the ‘Disable’ radio button. This disables the 
control card’s Ethernet port.

5 Click Write All. The control card configuration is saved. After the control card restarts, its 
Ethernet port will be disabled.

Reading and Writing Control Card Configurations

Reading a Control Card’s Configuration
1 Select a control card that is connected to your PC. 

2 From the ‘Window’ menu, select ‘Configuration’. The ‘Configuration’ window appears: 

3 Click Read All. The ‘Configuration’ window populates with the current router configuration.
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Writing a Control Card’s Configuration
The reason to write a configuration to a control card is that you have made a change. It is 
presumed that you already have the control card selected and open for editing.

1 From the ‘Window’ menu, select ‘Configuration’. The ‘Configuration’ window appears: 

2 Click Write All to save all changes to the control card. A confirmation message appears: 

3 Click OK to dismiss the message. Then UniConfig asks permission to reset the control card. 

Click Yes if you want to reset the control card. Click No to cancel. 
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Chapter 7 provides an introduction to the UniConfig User’s Guide. 
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Creating partitions is one of the most critical parts of the configuration process. Router control 
systems use partition information to communicate with the router and manage its crosspoint 
connections.

All routers can have up to 4 partitions except the NV5100MC and the NV5128 which can have up 
to 6 partitions.

Routers operating under SMS7000 control are limited to two partitions.

The NV8500 family hybrid routers (having EM0833 control cards) should not be configured 
with UniConfig. NV8500 family standard routers that have EM0666 cards must be configured 
with UniConfig.

The EC9535 is not a router but it has EM0374 control cards configurable with UniConfig. For 
information on configuring the EC9535, see Setting Up EC9535 Partitions on page 109.

About Partitions
Partitions are bounded regions within the router’s crosspoint matrix that are used to organize 
switching. A signal type is associated with each region, allowing the control card to use the 
correct switching rules and reference signals.

Signals are switched within a partition, not between partitions. An input can be switched only to 
an output in the same partition. Every control card configuration defines at least one partition. 

Please note that, In UniConfig, some entries in the partition table do not define boundaries of 
the crosspoint matrix, but define other router functions.

It is not a requirement that different signal formats be assigned to separate partitions. In fact, 
there are cases where doing that impedes system functionality. For example, on an NV5128 
router having both SD I/O and analog video I/O (with analog-to-digital conversion), if the cross-
point matrix is divided into two partitions it would not be possible to route between the analog 
and digital signals even though the AVC cards are designed to allow this. Making one larger 
partition eliminates the problem. 

In UniConfig, the term physical level (or simply level) can be used interchangeably with the 
term partition.
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xpansion 
ettings
Configuration Window
It is in the ‘Configuration’ window that you specify the partitions of a router. The page has fields 
that exist for some routers and do not exist for other routers. Generally, the following sections 
and fields of the page are applicable to partitions: 

Fig. 7-1: Configuration Window (Sample, NV8256-Plus)

The expansion settings region applies to most NVISION series routers. The NV5128 and the 
NV5100MC routers do not support expansion. However, these two routers allow up to 8 parti-
tions because they are “multi-format” routers and support multiple signal types. 

This is a sample of the ‘Configuration’ window for an NV5128: 

Fig. 7-2: Configuration Window (Sample, NV5128)

Partition 
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The page for the NV5128 lacks an expansion settings region but has a button with which to 
select either partitions 1–4 or partitions 5–8: 

All other routers can have up to 4 partitions (under NV9000 control). 

Routers under SMS7000 control can have up to 2 partitions only.

Partition Table
Each row in the table represents either a real crosspoint partition or an artificial partition. (See 
Artificial Partition Types on page 44.) 

The values in the partition table must be matched by the physical level definitions in the router 
control system you are using. Exactly what is meant by a “match” depends on the router control 
system.

Following are descriptions of the table’s columns: 

• Level

A number that uniquely identifies a partition. The range of acceptable values is 0–250. A 
value of 0 is used in some third-party control systems. 

You must not create duplicate entries in this column. 

• Physical Input Start and Physical Input End

Router port numbers that define the start and end of an input partition. The range of accept-
able values is from 1 to the upper limit of the router. 

• Controller Input Start and Controller input End

Logical input port numbers — also to be defined in the router control system — that map to 
the start and end of router’s physical input port numbers. You can specify the “start” value. 
UniConfig derives the “end” value according to the signal type of the partition. 

You might note that for mono audio partitions (e.g., for the NV7512 router), the 
controller partition range is double the physical partition range. 

The value in the “start” field is typically either 0 or 1 — 0 for some third-party control systems.

• Physical Output Start and Physical Output End

Router port numbers that define the start and end of an output partition. The range of 
acceptable values is from 1 to the upper limit of the router. 

• Controller Output Start and Controller Output End

Logical output port numbers — defined in the router control system — that map to the start 
and end of router’s physical output port numbers. You can specify the “start” value. UniCon-
fig derives the “end” value according to the signal type of the partition. 

You might observe that for mono audio partitions (e.g., for the NV7512 router), the 
controller partition range is double the physical partition range. 

The value in the “start” field is typically either 0 or 1 — 0 for some third-party control systems.

• Signal Type

This field contains a drop-down menu in which you specify the partition type. UniConfig 
provides a list of only the signal types applicable to the router. 
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Read All and Write All
At the bottom of the ‘Configuration’ window are two buttons: Read All and Write All. 

When you open a configuration in this window, it is usually prudent to click Read All to be sure 
you are viewing the control card’s most recent configuration.

Click Write All (at any time) to have UniConfig write the entire configuration to the control card.

If you forget to click Write All and close UniConfig or open another control card, any changes 
you have made will be lost. UniConfig gives no warning.

Multiple Control Cards
Each control card in a router frame must be configured separately and identically (except for its 
IP address).

Expanded routers have multiple frames. The control cards in each frame must be configured 
identically (except for their IP addresses) but the configurations in the different frames will vary 
slightly. 

See Expanded Routers — Multiple Frames on page 50.

Partition Types 
A router’s control card has no direct information regarding the type of signals actually being 
switched in its matrix.1 

Therefore, UniConfig defines the signal types for the control card. These are the supported parti-
tion types, for all routers: 

Video Audio Machine Control

Video, Async AES, Time Code Mono AES, Analog Audio Machine Control Reverse 
Digital Video Analog Audio Machine Control Broadcast 

Async AES Machine Control Forward 
Sync AES, analog audio Data X-Y 
Asynchronous AES *

* (Asynchronous AES applies only to NV8500 family routers.)

Some partition types include more than one signal type. Some signal types are represented by 
more than one partition type.

Mono partitions are structured differently from stereo partitions and can be used differently. 

The 4 machine control partition types behave differently. 

Artificial Partition Types
Uniconfig provides two additional artificial partition types: 

• Monitor

• Output Follow

We say they are artificial because these types do not define a portion of the router’s crosspoint 
matrix, but use UniConfig’s partition table as a convenient way to define router functions.

1. Control cards in the NV8500 hybrid routers (configured with MRC) do have some information about the 
type of signals that can be switched. 
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(Control panel operators can use these levels, even though they are not part of the crosspoint 
matrix.)

Monitor “Partition”
All routers except the NV5128, NV5100MC, NV5256, and the NV8140 support the use of monitor 
cards. A monitor card is one that sends a copy of an output (or input) signal from the router to a 
monitoring device. 

A monitor level (which is not a true partition) can be defined for those routers. The monitor level 
allows NV9000 control panel operators (and MRC users) to select an output or input for the 
monitor card to sample. 

See Defining a ‘Monitor’ Level on page 56.

Output Follow “Partition”
All routers but the NV5128, NV5100MC, and the NV5256 support “output follow.” 

“Output follow” is a concept that allows input I, routed to output J, to be routed to output K also. 
In such a case, we say that output K “follows” output J. 

Such outputs can be cascaded: if M follows L, L follows K, and K follows J, then input I will be 
routed to outputs, J, K, L, and M. 

A defined “output follow” level is not a partition of the crosspoint matrix. It is an artifice that 
uses the partition table to define the range of outputs that can follow or be followed. 

The mechanism by which “output follow” operates is part of the control card’s configuration. 
Control panel operators start and stop “output follow” by performing takes on an “output 
follow” level. The takes must occur in a particular order.

See Defining an ‘Output Follow’ Level on page 57.

Note that there is an “Enable Output-Follow Take Mode” option that applies to the ‘Connections’ 
window. This mode allows you to perform output-follow takes using the ‘Connections’ page 
which normally affects the crosspoint matrix. 

Signal Types
Here are brief definitions of the various signal types.

Audio 
• Analog audio [NV5100MC, NV5128, NV7256, NV7512 only]

• Async AES [NV7256, NV7512, NV8500 family only]

Independent AES (pairs) not locked to a video signal. (This is in contrast to synchronous AES 
which is switched in sync with a video signal.)

• Mono AES [NV5100MC, NV5128, NV7256, NV7512 only]

Similar to ‘Async AES — AES not locked to a video signal — but the individual channels of the 
AES pairs are independently routable. The number of ‘Controller’ ports is therefore double 
the number of physical ports. 

• Sync AES [NV7256, NV7512 only]

Signals of MADI ports are treated as synchronous AES. 
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Video 
• Video [NV5128 only]

Analog (NTSC, PAL) or digital (SD, HD) video. (The term SWB represents I/O cards that can 
accommodate both HD and SD signals.) 

• Digital video [NV8256, NV8288, NV8500 family only]

HD or SD video. The NV8256, NV8288, and NV8500 routers also switch 3Gig video. 

• Time code [NV5128]

This means linear time code. 

NVISION series routers do not support time code, even though the partition type is available. 

Although the NV7256 and NV7512 can switch time code signals (as an analog audio parti-
tion), NVISION series routers cannot use time code signals in any way. 

Machine Control
A partition in a machine control router can operate in one of 4 modes: 

Forward Reverse Broadcast Data X/Y

Machine control ports are bi-directional. The ports are typically RS-422 or RS-232. Signal data 
flow in one direction and status flows in the other direction. 

Except in data X-Y mode, machine control routes are point-to-point. In data X-Y mode, the 
router’s partition acts like a true crosspoint matrix. 

The modes are as follows:

• Forward

The direction of a connection is from a controlling device to a controlled device. 

• Reverse

The direction of a connection is from a controlled device to a controlling device. 

• Broadcast

One signal can be “broadcast” to several outputs. 

• Data X-Y

Data X-Y mode lets a machine control router partition behave like an X-Y matrix. 

For more information, see Setting Up Machine Control Ports on page 81. 

For the NV5128, machine control signals must be assigned to a single, individual partition.

The 4 machine control partition types have different behavior. 

Data X/Y Mode 
Data X/Y mode lets a machine control router partition behave like an X/Y matrix. This mode is 
useful if you have serial data to route, and not just machines to control. 

Normally machine control routes are point-to-point. One port may be connected to at most one 
port. (Ports can also be disconnected entirely.)

A data X/Y partition allows any input to be routed to any output or any set of outputs. Further, 
the partition is not bidirectional. Data flow from input to output.
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Reference Signals
A partition’s signal type determines the switching “rules” that the control card uses to make 
routes. Signal types vary according to the router type.

Depending on the signal type, the control card might require reference signals to determine 
when to perform the actual signal switch. 

All NVISION series routers, regardless of format, have video reference and AES reference connec-
tions. For video references, SMPTE standards define where the switch should occur. 

(For 525-line analog and SD video, the switch should occur at line 10. HD signals should be 
switched at HD line 4. For AES references, the reference signal should have a sample rate of 
48 kHz, locked to the video reference signal.)

Partition Type and Reference Type Cross-Reference
This table lists the signal type selection in the UniConfig menu and the required reference 
signals.

Setting Up Partitions
How partitions are set up is determined by your router control system and the NVISION series 
routers in use. Miranda’s NV9000 router control system uses the concept of levels — virtual and 
physical — to organize switching.

In many cases, it is necessary to create only a single partition for each router. 

UniConfig presents different signal types for router partitions, depending on the router type. For 
example, if you are configuring a video router, UniConfig presents only video signal types. It 
does not allow you to choose, for example, an audio signal type for a video router. In contrast, 
the NV5128 multi-format router allows switching of almost any signal type. 

Standalone v. Expanded Routers
NVISION series routers are categorized as either stand-alone routers or expanded routers. 

A stand-alone router consists of a single router frame. An expanded router consists of multiple 
interconnected router frames. (Each frame contains one or two control cards.)

Partition Type Video Ref. AES Ref.

Analog Audio *

Mono AES, Analog Audio

Sync AES, Analog Audio

Async AES

Digital Video

Video, Asynchronous AES, Time Code**

Machine Control Reverse, Machine Control Broadcast, Machine Control 
Forward, Data X-Y

* If possible, connect an external 48.000 kHz AES reference signal.
** For the NV5128 and NV5100MC, video includes analog video (PAL or NTSC), SD, and HD. 
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Setting Up Partitions
All NVISION series router frames can act as standalone routers. 

The NV5256, NV7256-Plus, NV7512, NV8256-Plus, NV8288-Plus, and the NV8576-Plus routers can 
be connected to an other identical router frame (or frames) to create a router with a larger 
switching matrix.

When router frames are interconnected, one router is designated as the master (or main) frame 
and the other frames are considered the slave (or subsidiary) frames. The master frame commu-
nicates with the router control system. The slave frames communicate with the master frame.

Standalone Routers
For a standalone router, partitions are set up for the number of inputs and outputs being 
switched by that router frame. 

For information on configuring the EC9535, see Setting Up EC9535 Partitions on page 109.

How to Set Up Partitions for a Standalone Router
1 Select a control card. 

2 From the ‘Window’ menu, select ‘Configuration’. The ‘Configuration’ window appears:

Fig. 7-3: Configuration Window (Sample, NV5128)
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If the control card is for an expanded (or expandable) router, the router frame can be con-
nected to an identical router frame to form an expanded switching matrix. The window for 
these routers displays an additional ‘Expansion Configuration’ region at the top right: 

Fig. 7-4: Configuration Window (Sample, NV8256)

3 Click Read All. UniConfig populates the window with the control card’s current partition 
configuration and Ethernet settings.

4 To make this a standalone router, choose the ‘Main - Standalone’ button in the expansion 
settings region.

5 To set up a partition, enter values in the fields of the row representing the partition. 

There are 4 rows. The first row initially contains default values for the router type. 

When you place a value in the ‘Level’ field of a row, the other fields in the row become 
enabled. 

For the NV5100MC and NV5128, there are up to 8 partitions. Only four display at any one 
time. Click Partition 1–4 or Partition 5–8 to view the corresponding levels.

For all other routers, there are up to 4 partitions. 

What you should configure in the partition table is subject to your router control system and 
your routing requirements and therefore beyond the scope of this document.

Choose the signal type according to the input signal format for the partition. The signal type, 
in conjunction with the switch point setup, determines the rules used by the router for 
switching the signals when operators execute a “take.” For information on setting the switch 
point, see Switch Point Settings on page 61. 

6 Click Write All to writes changes to the control card.

7 Repeat steps 1 through 6 for each control card being updated.
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Expanded Routers — Multiple Frames 
NV5256, NV7256-Plus, NV7512, NV8256-Plus, NV8288-Plus and NV8576-Plus router frames can 
be interconnected with like frames to form an expanded router with a larger switching matrix. 
For example, two NV8256 frames (nominally 256 × 256) can be connected to create a 512 × 512 
switching matrix.

When router frames are connected, one frame is designated the master frame. All configuration 
and crosspoint information is copied from the master frame to all connected slave frame. This 
ensures synchronization of all connected frames. After a frame is designated a slave frame in 
UniConfig, any change made to the master frame’s configuration is automatically copied to the 
slave frame’s control cards. Slave frame configurations cannot be updated. Their configurations 
display in the ‘Configuration’ window, but are inactive. All their partition data are greyed out. 

It is prudent, but not necessary, to configure the main frame before you configure the slave 
frames.

How to Set Up Partitions for a Main Router Frame 
1 Select the primary control card on the router acting as the master router. 

2 From ‘Window’ menu, select ‘Configuration’. The ‘Configuration’ window appears: 

Fig. 7-5: Configuration Window (Sample, NV8288-Plus, Master Frame)

If the window does not show an ‘Expansion Configuration’ section, the router frame cannot 
be part of an expanded router.

3 Click Read All. UniConfig populates the window with the control card’s current partition 
data and Ethernet settings. 

4 Choose the ‘Main - Expanded’ radio button in the ‘Expansion Configuration’ section. 

Doing so designates the control card as belonging to the master (or main) router frame. 
Because of the router’s frame interconnection, the master frame controls all the router’s 
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slave frames. (The master frame is also the frame that communicates with the router control 
system.)

When you click ‘Main - Expanded‘, additional fields appear in the ‘Expansion Configuration’ 
section: 

Fig. 7-6: Expansion Section (Sample, NV8288-Plus)

The expansion section identifies the range of physical inputs and outputs for the particular 
frame in the expanded router. The ‘Index’ value identifies the frame in the expanded router.

In the case of an NV7512-Plus audio router having 4 frames for a 2048 × 2048 (stereo) switch-
ing matrix,1 the ranges for the frames are

Frame Index Input Range Output Range 
Main 1 1–2048 1–512 
Slave 2 1–2048 513–1024 
Slave 3 1–2048 1025–1536 
Slave 4 1–2048 1537–2048

Other routers require different values in the ‘Expansion Configuration’ section. See Router 
Expansion on page 143.

5 Enter a number in the ‘Index’ field provided in the ‘Expansion’ section. The frames in the 
expanded router must have unique indexes. It is a good idea to specify 1 for the main frame.

6 Enter the range of inputs and outputs for the frame. 

7 Enter partition data. As mentioned, these data are dependent on your system requirements 
and cannot be addressed here. 

Reminder: the partition numbers must be unique.

Choose the signal type according to the input signal format for the partition. The signal type, 
in conjunction with the switch point setup, determines the rules used by the router for 
switching the signals when the operator executes a “take.”

For information on setting the switch point, see Switch Point Settings on page 61. 

8 Click Write All to write changes to the control card.

9 Repeat steps 1 through 8 for the secondary control card on the master router (if it exists). 

1. This is equivalent to a 4096 × 4096 mono matrix.
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How to Set Up Partitions for Slave Router Frames 
Partition data for slave frames cannot be configured independently. All slave frames derive their 
partition data from the master frame. 

If a slave Frame is to be changed, the changes must be made in the master frame. The changes 
are then propagated to the slave frames.

1 Select a control card on the slave frame. 

2 From the ‘Window’ menu, select ‘Configuration’. The ‘Configuration’ window appears: 

Fig. 7-7: Configuration Window (Sample, NV8288-Plus, Slave Frame)

If the window does not show an ‘Expansion Configuration’ section, the router frame cannot 
be part of an expanded router.

3 Click Read All. UniConfig populates the window with the control card’s current partition 
data and Ethernet settings. 

4 Choose the ‘Slave - Expanded’ radio button in the ‘Expansion Configuration’ section. 

Doing so designates the control card as belonging to the slave router frame. Because of the 
router’s frame interconnection, the master frame controls all the router’s slave frames. 

When you click ‘Slave - Expanded’, the partition fields of the window become disabled 
(greyed out).
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When you click ‘Slave - Expanded‘, additional fields appear in the ‘Expansion Configuration’ 
section: 

Fig. 7-8: Expansion Section (Sample, NV8288-Plus, Slave)

In the case of an NV8288-Plus having 2 frames for a 576 × 576 switching matrix, the ranges 
for the frames are

Frame Index Input Range Output Range 
Main 1 1–576 1–288 
Slave 2 1–576 289–576

Other routers require different values in the ‘Expansion Configuration’ section. See Router 
Expansion on page 143.

5 Enter a number in the ‘Index’ field provided in the ‘Expansion’ section. The frames in the 
expanded router must have unique indexes. It is a good idea to specify 1 for the main frame.

6 Enter the range of inputs and outputs for the frame. 

7 Click Write All to send changes to the control card.

The ‘Level’, ‘Physical Inputs’, ‘Controller Inputs’, ‘Physical Outputs’ and ‘Controller Output’ 
fields are greyed-out. All partition information is copied from the master router to the slave 
router. 

In addition, all crosspoint information is copied to each slave router to ensure synchroniza-
tion of all connected frames. 

You can access crosspoint information in the ‘Connections’ window. (See Connections Win-
dow on page 83.)

8 Repeat steps 1 through 7 for the other control card on the slave frame and for control cards 
on other slave frames if there are any.

Updating Partitions
You can update partition data at any time. 

If you are updating an expanded router, it is necessary to make changes only to the master 
frame. Those changes propagate to the slave frames automatically.

Important: If you make changes to the primary control card of a frame, copy the changes to the 
secondary control card (if there is one). See How to Apply a Configuration to Another Control 
Card on page 22. 
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Mono v. Stereo Audio
Most NVISION series routers that switch audio can switch the audio as stereo pairs or as indi-
vidual “mono” channels. NV8500 standard routers do not support mono audio. Nor do they 
support analog audio. 

Uniconfig can set up both stereo router partitions and mono partitions. NV9000 router control 
systems configurations support stereo switching and mono switching. Third-party control 
systems might or might not have support for stereo and mono.

Certain control system configuration problems arise when you want to route a signal as a stereo 
pair at one time and then switch the same signal as mono channels at a another time. 

How do you configure — in the control system — an input to be both stereo and mono? The 
problems related to this question lie in making the control system conform to the routing 
requirements of your facility and accommodating the expectations of control panel operators. 

The creation of audio partitions in UniConfig is involved in the configuration task.

We provide two methods for creating devices that can be used as either stereo or mono devices. 
To understand the methods better, please review the following definitions and concepts. 

Definitions and Concepts
Audio signals arrive at, and depart from, the audio router as stereo pairs, whether they are AES, 
MADI, or analog audio. 

In NVISION series routers, in UniConfig, and in this document, the term “stereo” means two 
audio signals combined into one. That is all it means. (The concept of left and right channels is 
supported but is by no means necessary.)

In NVISION series routers, in UniConfig, and in this document, “mono” means one or the other of 
the two parts of a “stereo” pair. That is all it means. We use the term “channel” for mono signals.

The NV9000 control system’s concept of breakaway is not possible for signals configured as 
stereo. Breakaway is possible, however, for the 2 (or more) mono signals that are defined in a 
level set. Third-party router control systems might differ. 

On router backplanes, AES connectors are BNCs, DIN (1.0/2.3), or Phoenix 3-pin (shielded 
twisted pair) quick-release connectors. 

On router backplanes, analog audio connectors are DB25s. (Each DB25 assigns 3 pins to a 
shielded twisted pair, and supports 8 channels or 4 “stereo” pairs.)

On router backplanes, MADI connectors can vary. (For the NV7512, the MADI input and output 
cards have two 75W BNCs for MADI (up to 64 channels). NV7512 configuration dictates how the 
ports are used.) 

Regardless of the external signal type, and regardless of the router, all audio signals are treated 
uniformly as AES internally and are converted to AES (if necessary) at input and converted from 
AES (if necessary) at output. 

When you create a “mono” partition in UniConfig, the number of ‘Controller’ ports is double the 
number of physical ports. That means the control system will recognize that there are two sepa-
rate channels on each connector and that the router will treat them separately.

The “mono” port numbers (L,R) for any stereo connector (S) are easy to calculate: 

R = S × 2 L = R – 1

For example, connector 47 provides mono channels 93 and 94.
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Method 1 (under NV9000)
Problem: how do you configure an input or output to be both stereo and mono?

Solution: 

In UniConfig, create 2 overlapping partitions: one for stereo and one for mono. (The stereo parti-
tion and the mono partition use the same physical ports.)

In the NV9000 configuration, create two sets of devices, one for use as stereo, and one or use as 
mono. Both sets of devices refer to the same ports, but in a different way. 

Here is a brief summary of the procedure. 

1 In UniConfig, create 2 overlapping partitions, one for stereo and one for mono. 

2 Switch to NV9000-SE Utilities.

3 Define the audio router and its two physical levels to match UniConfig. 

4 Create virtual levels if none available have suitable names. 

5 Create level sets: one for stereo and one for mono. 

6 Create devices for the stereo level set, input and output. 

7 Create 4 sets of mono devices: left input, left output, right input, right output. 

8 Examine NV9000-SE Utilities’ various tables to verify your work. 

(The device names for both level sets should be similar so that operators can choose the correct 
device without thinking.)

For more detail, see Method 1 Details on page 146.

Method 2 (under NV9000)
Problem: how do you configure an input or output to be both stereo and mono?

Solution: 

In UniConfig, create 1 mono partition. As mentioned, the number of mono (i.e., controller) ports 
is double the number of physical ports. 

In the NV9000 configuration, create a level set containing two mono levels and create devices 
that use that level set. Operators can switch the devices as stereo. Using breakaway, operators 
can switch the individual channels. 

Here is a brief summary of the procedure. 

1 In UniConfig, create 1 mono partition. 

2 Switch to NV9000-SE Utilities.

3 Define the audio router and its single physical level to match UniConfig. 

4 Create a virtual level if none available has a suitable name. 

5 Create a level set (for stereo). 

6 Create devices for the stereo level set, input and output. 

7 Examine NV9000-SE Utilities’ various tables to verify your work. 

(The device names for both level sets should be similar so that operators can choose the correct 
device without thinking.)

For more detail, see Method 2 Details on page 152.
55



Partitions and Signal Types
Defining a ‘Monitor’ Level
Defining a ‘Monitor’ Level
UniConfig supports output monitoring for the NV7256, NV7512, NV8256, and NV8288. 

Although output monitoring was planned for the NV7256 and NV7512, it was never 
implemented. 

The NV8256 and NV8288 each produce 2 monitor outputs. 

The NV8500 routers allow monitoring of output signals and input signals. The NV8144 produces 
one “input” monitor signals and one output monitor signal. The other routers in the NV8500 
family produce 2 “input” monitor signals and 2 “output” monitor signals. 

Other routers — the NV5128, NV5100MC, and NV5256 — do not support monitoring. 

In UniConfig, you can define a monitor level for the routers that support monitoring. You can 
also define monitor levels for the NV7256 and NV7512 even though they do not support 
monitoring. 

Monitor levels are not real partitions, but are artificial levels that use the partition table to 
define a router function.

To define a monitor level is relatively simple. 

NV8500 Standard Routers
Do not use UniConfig for NV8500 hybrid routers. Use MRC instead. 

Create a monitor level this way

The monitor port range is 1 to 4. Use other values, A–F, based on your system, where 

(A,B) define the max physical range of both your outputs and inputs. 

(C,D) form the controller range based on your inputs and outputs. 

(E, F) form the controller range based on the monitor port range. 

Except for the NV8144, monitor outputs 1 and 2 represent the “output” monitors. The monitor 
outputs 3 and 4 represent the “input” monitors. 

The NV8144 is the exception in the NV8500 family. It has only one “output” monitor and only 
one “input” monitor. Therefore, monitor ports 2 and 4 in your monitor level are null — they 
correspond to no output. Port 1 is for the single “output” monitor and port 3 is for the single 
“input” monitor. 

Level Phys Input Contr Input Phys Output Contr Output Signal Type

99 A B C D 1 4 E F Monitor
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NV7256, NV7512, NV8256, NV8288
Output monitoring was never implemented in the NV7256 and NV7512. 

Create a monitor level this way

The monitor port range is 1 to 2. Use other values, A–F, based on your system, where 

(A,B) define the max physical range of your outputs (only). 

(C,D) form the controller range based on your outputs. 

(E, F) form the controller range based on the monitor port range. 

Monitor outputs 1 and 2 represent “output” monitors. These routers do not have “input” 
monitors. 

In NV9000-SE Utilities
To switch a signal to a monitor, an NV9000 control panel operator must route a signal to a 
monitor output on a monitor level. (This operation cannot be performed in UniConfig.)

Therefore, you must also configure a monitor level in NV9000-SE Utilities. There is no “monitor” 
virtual level type. You will need to define a physical level of the same type as the outputs (or 
inputs) being monitored with the same level number you defined in UniConfig. (In the 
preceding examples, that is level 99.) Then define a virtual level that maps to this new physical 
level. 

Monitor signals can be switched on that virtual level. 

It is not possible to monitor two signals from the same input card or output card. 

Defining an ‘Output Follow’ Level
All routers but the NV5128, NV5100MC, and the NV5256 support “output follow.” 

“Output follow” is a concept that allows input I, routed to output J, to be routed to output K also. 
In such a case, we say that output K “follows” output J. 

Such outputs can be cascaded: if M follows L, L follows K, and K follows J, then input I will be 
routed to outputs, J, K, L, and M. 

A defined “output follow” level is not a partition of the crosspoint matrix. It is an artifice that 
uses the partition table to define the range of outputs that can follow or be followed. 

The mechanism by which “output follow” operates is part of the control card’s configuration. 
Control panel operators start and stop “output follow” by performing takes, on an “output 
follow” level, in a particular order.

Note: 

Outputs that follow can be dedicated to following (as when they are connected to monitoring 
equipment) or they can be interspersed in the set of normal outputs. 

Creating an Output Follow Level
Creating an output follow level is very much like creating a normal level, with one exception. 

Level Phys Input Contr Input Phys Output Contr Output Signal Type

99 A B C D 1 2 E F Monitor
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Defining an ‘Output Follow’ Level
You place a range of outputs that can be followed in the input columns. You place a range of 
outputs that do the following in the outputs column. Thus, the outputs that are followed are like 
inputs to the outputs that do the following. 

Example 1
Here is an example where the follower outputs are separate from the normal outputs, i.e., they 
function as dedicated monitoring ports: 

The operator creates an “output follow” by taking, on level 77 in this example, an output in the 
range 1–240 to an output in the range 241-256. Let’s say the operator takes 1 to 241. Now 
output 241 follows output 1. 

Then at some point, the operator takes input 3 to output 1, normally, on level 1. Input 3 will 
appear simultaneously on outputs 1 and 241. 

At a later point, the operator takes input 7 to output 1, normally, on level 1. Input 7 then appears 
simultaneously on outputs 1 and 241. 

In this scenario, outputs 241–256 are always reserved for monitoring.

In NV9000-SE Utilities, there is no “output follow” virtual level type. You’ll need to define a phys-
ical level of the same type as the outputs being followed with the same level number you 
defined in UniConfig. In this example, that is level 77. Then define a virtual level that maps to 
this new physical level. 

Example 2
Here is an example where the follower outputs are mingled with the normal outputs, i.e., they 
are not dedicated monitoring ports: 

As in example 1, the operator creates an “output follow” by taking, on level 77 in this example, 
an output in the range 1–256 to another output in the range 1–256. 

Consider this sequence: 

The operator takes 3 to 1 (normally, on level 1). 

The operator takes 7 to 105 (normally, on level 1). 

The operator takes 1 to 105 on level 77. Now output 105 follows output 1. Input 3 appears simul-
taneously on both outputs 1 and 105. 

At a later point, the operator takes input 7 to output 1, normally, on level 1. Now input 7 then 
appears simultaneously on outputs 1 and 105. 

Still later, the operator takes input 12 to output 105 on level 1. Now output 105 no longer 
follows output 1 and input 12 appears normally on output 105. 

In this scenario, you can clear an output follow situation by routing a source to the output on 
the normal level (not the output follow level).

Level Phys Input Contr Input Phys Output Contr Output Signal Type

1 1 256 1 256 1 240 1 240 Digital Video

77 1 240 1 240 241 256 241 256 Output Follow

Level Phys Input Contr Input Phys Output Contr Output Signal Type

1 1 256 1 256 1 256 1 256 Digital Video

77 1 256 1 256 1 256 1 256 Output Follow
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In NV9000-SE Utilities, there is not “output follow” virtual level type. You’ll need to define a phys-
ical level of the same type as the outputs being followed with the same level number you 
defined in UniConfig. In this example, that is level 77. Then define a virtual level that maps to 
this new physical level. 

Cascading Outputs
In the scenario of example 2, suppose the operator takes 30 to 31 on the output follow level and 
then takes output 1 to output 30 on the output follow level. 

Then the operator takes input 20 to output 1. Input 20 appears simultaneously on outputs 1, 30, 
and 31. 

The operator can create multiple “cascading” output follow states by issuing the appropriate 
takes on the output follow level. 

The operator can clear the output follow states by routing to those outputs on a normal level. 
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Switch Point Settings
Chapter 8 discusses UniConfig’s ‘Switch Point Setup’ Window. 

Topics
Background  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  61
The Switch Point Setup Window  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  62
About Video Signal Fields and Frames . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  63
Setting Switching Parameters . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  63

Background
A “switch point” is a point in time at which an output is switched from its current source to a new 
source. Different video and audio formats require different switch points. UniConfig’s ‘Switch 
Point Setup’ window lets you set switch point parameters for individual outputs. 

All the NVISION series routers have video and audio reference signals connections. 

For video reference signals, there are two connectors labeled ‘VIDEO REF’. The video reference 
connectors can use the same signal or different signals. 

For audio reference signals, there are two connections labeled ‘AES REF’. One or both connec-
tions are connected to a stable AES source at 48 kHz. If both AES reference are connected, one 
acts as a backup should the other AES reference source fail.

This section discusses how to make switch point settings for routers. For information on setting 
up EC9535 GSC Node Bus Converter switch points, see Setting Up EC9535 Switch Points on 
page 111.

Redundant v. Dual Video Reference
Each router has two video reference connectors. You can apply the same reference signal at 
both connectors or use a different reference at each connector. When you apply the same 
signal, the router has a “redundant” reference. If one reference fails, the control card automati-
cally switches to the other reference. 

If you use different references, the router has a “dual” reference. Router outputs can be config-
ured to occur using one or the other reference. For example, you might connect an NTSC 
reference at ‘Ref1’ and a PAL reference at ‘Ref2’. 

Note
In UniConfig, all routers have a ‘Switch Point Setup’ window except the NV5256. The 
NV5256 routes machine control signals, which do not require a switch point.

The ‘Switch Point Setup’ page does not control the actual point in time at which an 
output switches. For that you need special equipment. 
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The Switch Point Setup Window
This is the ‘Switch Point Setup’ window, showing dual reference: 

Specify an output range at the bottom of the page and click Read Outputs to display the 
router’s outputs in the output list at the right side of the window.

At the left side of the page are two radio button where you can choose whether the router uses 
a dual reference or a redundant reference. (If you have a single reference connection, use either 
setting.)

If you have selected dual reference, you can specify which reference to use for selected outputs. 
Use click, shift-click, and control-click techniques to select any set of outputs. Then choose the 
the reference connector in the section at the left and click the ‘Apply Changes to Selected 
Outputs’ button. The changed outputs redisplay in the output list.

You can also change the switching mode of selected outputs. The choices are to switch on frame 
boundaries or field boundaries. Select one or more outputs. Then choose the switching mode in 
the section at the left and click the Apply Changes to Selected Outputs button. The changed 
outputs redisplay in the output list.

To save your changes, click Write Changes at the bottom of the screen. If you close UniConfig or 
switch to a different window, your changes will be lost without warning.

Other fields, not shown here, can appear in the window, depending on the router type. See Setting 
Switching Parameters on page 63 for details of individual routers.

Output listSwitching 
parameters

Reference 
Type

Output 
Range
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About Video Signal Fields and Frames
An interlaced video frame is composed of two fields, field 1 and field 2. For NTSC, each frame is 
divided into 525 scan lines. Because a field is half a frame, each field is composed of 262.5 scan 
lines. 

For NTSC interlaced video, for example, there are 29.97 frames per second or 59.94 fields per 
second. For NTSC progressive video, there are only frames, or put another way, frames and fields 
are equivalent, so there are 59.94 frames per second. Some other video frame rates differ.

Depending on the router type, UniConfig lets you specify the following:

• The outputs for which the router will switch video on a frame or a field basis 

• Whether the router has dual reference or redundant reference and if dual, which outputs use 
reference 1 and which use reference 2. 

• Which outputs switch according to SD format and which outputs switch according to HD. 

• Which outputs use reclockers. 

• Which outputs allow cross-fade (NV7512 only).

Setting Switching Parameters
You can set switching parameters for video or audio routers. Depending on the router being 
configured, different fields display. Differences for specific routers are noted in the following 
procedures. Be sure to follow the instructions for your specific router.

Most routers require a video reference connection for proper switching. 

The EC9535 is a “GSC node bus” converter and is not configured in the same way as other 
routers. For details on setting up switching parameters for an EC9535 see Setting Up EC9535 
Switch Points on page 111.

Following are setup methods for these router types: 

NV5100MC or NV5128 Multi-Format Router

NV7256 and NV7256-Plus Routers

NV7512 and NV7512-Plus Routers

NV8256-Plus Routers

NV8288 and NV8288-Plus Routers

NV8500 Family Standard Routers

Note that the NV5256 machine control router does not use switch points. Therefore, there is no 
‘Switch Point Page’ for NV5256 routers.

Note
Each control card in a router frame must be configured separately and identically.
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NV5100MC or NV5128 Multi-Format Router 
1 Select a control card (for an NV5100MC or NV5128). 

2 From the ‘Window’ menu, select ‘Switch Point Setup’. The ‘Switch Point Setup’ window 
appears. Specify an output range at the bottom of the page and click Read Outputs: 

Fig. 8-1: Switch Point Setup Window (NV5128)

This table describes each column in the output list:

Column Description

Output The number assigned to the signal for routing purposes. The number usually 
refers to the physical port through which the signal is distributed.

Reclock/bypass Indicates whether the output bypasses re-clocking. 

HD/SD Indicates whether the output is a standard definition (SD) or high definition (HD) 
video signal. 

Ref1/Ref2 Indicates whether the output uses video reference 1 or reference 2 (in dual refer-
ence mode only).
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3 In the ‘Dual Video Reference Option’ section, choose ‘Redundant’ or ‘Dual’.

‘Redundant’ — You declare that the router will use redundant references. Both ‘VIDEO REF 1’ 
and ‘VIDEO REF 2’ are the same. If one fails, the other will be used as a fail-over. 

‘Dual’ — You declare that dual video references are in use. In this case, you can specify in step 
6 which reference selected outputs are to use. 

See Redundant v. Dual Video Reference on page 61.

4 In the ‘NTSC/PAL Reference Options’ section, you declare the type of reference signal for the 
reference connectors. 

Select the radio button corresponding to the signal type being used as a video reference: 
‘1080i’, ‘720p’ or ‘1080p’. 

These options appear only if the control card supports NTSC or PAL. (Both the NV5100MC 
and the NV5128 support NTSC and PAL.)

5 If you want to change any of the fields in the output list, select the outputs you want to 
change. Use standard Windows click, shift-click, and control-click techniques, 

Or. to select all outputs, choose ‘Select All’ from the ‘Edit’ menu.

Or, to clear all outputs from the list, choose ‘Remove All Outputs’ from the ‘Edit’ menu. 

6 In the switch settings section, check the check boxes that apply to reclocking, switching line 
(SD or HD), and video reference.

The following lists each check box and its function:

7 Click Apply Changes to Selected Outputs, or from the ‘Edit’ menu, choose ‘Apply Changes’. 

This does not write your changes to the control card, but causes the output list to redisplay. 

8 Finally, when you are satisfied that all your changes are correct, click Write Changes, or from 
the ‘Edit’ menu, choose ‘Write Changes’. UniConfig writes your changes to the control card.

Check Box(es) Description

Use Reclocker,  
Bypass Reclocker

Either use the output reclocker or bypass the output reclocker.

Switch on SD Line, 
Switch on HD Line

Choose ‘Switch on SD Line’ if the selected signals are SD (or analog video). 
Choose ‘Switch on HD Line’ if the selected signals are HD. 

Use video reference 1, 
Use video reference 2

Choose whichever reference you want to apply to the selected outputs (in 
dual reference mode). 
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NV7256 and NV7256-Plus Routers 
1 Select a control card (for an NV7256 frame). 

2 From the ‘Window’ menu, select ‘Switch Point Setup’. The ‘Switch Point Setup’ window 
appears. Specify an output range at the bottom of the page and click Read Outputs: 

Fig. 8-2: Switch Point Setup Window (NV7256, NV7256-Plus

This table describes each column in the output list:

3 In the ‘Dual Video Reference Option’ section, choose ‘Redundant’ or ‘Dual’.

‘Redundant’ — You declare that the router will use redundant references. Both ‘VIDEO REF 1’ 
and ‘VIDEO REF 2’ are the same. If one fails, the other will be used as a fail-over. 

Column Description

Output The number assigned to the signal for routing purposes. The number usually 
refers to the physical port through which the signal is distributed.

Field/frame Indicates whether the output switches at every (video) field or at every (video) 
frame. 

Ref1/Ref2 Indicates whether the output uses video reference 1 or reference 2 (in dual refer-
ence mode only).
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‘Dual’ — You declare that dual video references are in use. In this case, you can specify in step 
5 which reference selected outputs are to use. 

See Redundant v. Dual Video Reference on page 61.

4 If you want to change any of the fields in the output list, select the outputs you want to 
change. Use standard Windows click, shift-click, and control-click techniques, 

Or. to select all outputs, choose ‘Select All’ from the ‘Edit’ menu.

Or, to clear all outputs from the list, choose ‘Remove All Outputs’ from the ‘Edit’ menu. 

5 In the switch settings section, check the check boxes that apply to reclocking, switching line 
(SD or HD), and video reference.

The following lists each check box and its function:

6 Click Apply Changes to Selected Outputs, or from the ‘Edit’ menu, choose ‘Apply Changes’. 

This does not write your changes to the control card, but causes the output list to redisplay. 

7 Finally, when you are satisfied that all your changes are correct, click Write Changes, or from 
the ‘Edit’ menu, choose ‘Write Changes’. UniConfig writes your changes to the control card.

Check Box(es) Description

Use video reference 1,  
Use video reference 2

Choose whichever reference you want to apply to the selected out-
puts (in dual reference mode only). 

Switch on Field Boundary, 
Switch on Frame Boundary

Choose whether the selected output(s) switch on field boundaries or 
frame boundaries.
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NV7512 and NV7512-Plus Routers 
1 Select a control card (for an NV7512 frame). 

2 From the ‘Window’ menu, select ‘Switch Point Setup’. The ‘Switch Point Setup’ window 
appears. Specify an output range at the bottom of the page and click Read Outputs: 

Fig. 8-3: Switch Point Setup Window (NV7512, NV7512-Plus

This table describes each column in the output list:

3 In the ‘Dual Video Reference Option’ section, choose ‘Redundant’ or ‘Dual’.

‘Redundant’ — You declare that the router will use redundant references. Both ‘VIDEO REF 1’ 
and ‘VIDEO REF 2’ are the same. If one fails, the other will be used as a fail-over. 

‘Dual’ — You declare that dual video references are in use. In this case, you can specify in step 
5 which reference selected outputs are to use. 

See Redundant v. Dual Video Reference on page 61.

Column Description

Output The number assigned to the signal for routing purposes. The number usually 
refers to the physical port through which the signal is distributed.

Crossfade Indicates whether crossfades (for outputs switched) are enabled or disabled. 

Ref1/Ref2 Indicates whether the output uses video reference 1 or reference 2 (in dual refer-
ence mode only).
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4 If you want to change any of the fields in the output list, select the outputs you want to 
change. Use standard Windows click, shift-click, and control-click techniques, 

Or. to select all outputs, choose ‘Select All’ from the ‘Edit’ menu.

Or, to clear all outputs from the list, choose ‘Remove All Outputs’ from the ‘Edit’ menu. 

5 In the switch settings section, check the check boxes that apply to reclocking, switching line 
(SD or HD), and video reference.

The following lists each check box and its function:

6 Click Apply Changes to Selected Outputs, or from the ‘Edit’ menu, choose ‘Apply Changes’. 

This does not write your changes to the control card, but causes the output list to redisplay. 

7 Finally, when you are satisfied that all your changes are correct, click Write Changes, or from 
the ‘Edit’ menu, choose ‘Write Changes’. UniConfig writes your changes to the control card.

Check Box(es) Description

Use video reference 1,  
Use video reference 2

Choose whichever reference you want to apply to the selected out-
puts (in dual reference mode only). 

Switch on Field Boundary, 
Switch on Frame Boundary

Choose whether the selected output(s) switch on field boundaries or 
frame boundaries.

Switch on Field Boundary, 
Switch on Frame Boundary

Choose whether the selected output(s) switch on field boundaries or 
frame boundaries.
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NV8256-Plus Routers 
1 Select a control card (for an NV8256-Plus frame). 

2 From the ‘Window’ menu, select ‘Switch Point Setup’. The ‘Switch Point Setup’ window 
appears. Specify an output range at the bottom of the page and click Read Outputs: 

Fig. 8-4: Switch Point Setup Window (NV8256-Plus

This table describes each column in the output list:

3 The ‘Dual Video Reference Option’ is disabled (greyed out). The NV8256-Plus does not sup-
port dual reference. 

Column Description

Output The number assigned to the signal for routing purposes. The number usually 
refers to the physical port through which the signal is distributed.

Reclock/bypass Indicates whether the output bypasses re-clocking. 

Field/frame Indicates whether the output switches at every (video) field or at every (video) 
frame. 

HD/SD Indicates whether the output is a standard definition (SD) or high definition (HD) 
video signal. 
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4 In the ‘NTSC/PAL Reference Options’ section, you declare the type of reference signal for the 
reference connectors. 

Select the radio button corresponding to the signal type being used as a video reference: 
‘1080i’, ‘720p’, or ‘1080p’. 

These options appear only if the control card supports NTSC or PAL. (The NV8256-Plus 
supports NTSC and PAL.) 

5 If you want to change any of the fields in the output list, select the outputs you want to 
change. Use standard Windows click, shift-click, and control-click techniques, 

Or. to select all outputs, choose ‘Select All’ from the ‘Edit’ menu.

Or, to clear all outputs from the list, choose ‘Remove All Outputs’ from the ‘Edit’ menu. 

6 In the switch settings section, check the check boxes that apply to reclocking, switching line 
(SD or HD), and video reference.

The following lists each check box and its function:

7 Click Apply Changes to Selected Outputs, or from the ‘Edit’ menu, choose ‘Apply Changes’. 

This does not write your changes to the control card, but causes the output list to redisplay. 

8 Finally, when you are satisfied that all your changes are correct, click Write Changes, or from 
the ‘Edit’ menu, choose ‘Write Changes’. UniConfig writes your changes to the control card.

Note
If the ‘NTSC/PAL Reference Options’ section does not appear, you have an older control 
card. Contact Miranda Technical Support for assistance. 

Check Box(es) Description

Use Reclocker,  
Bypass Reclocker

Either use the output reclocker or bypass the output reclocker.

Switch on Field Boundary, 
Switch on Frame Boundary

Choose whether the selected output(s) switch on field boundaries or 
frame boundaries.

Switch on SD Line, Switch on 
HD Line

Choose ‘Switch on SD Line’ if the selected signals are SD (or analog 
video). 
Choose ‘Switch on HD Line’ if the selected signals are HD. 
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NV8288 and NV8288-Plus Routers 
1 Select a control card (for an NV8288 or NV8288-Plus frame). 

2 From the ‘Window’ menu, select ‘Switch Point Setup’. The ‘Switch Point Setup’ window 
appears. Specify an output range at the bottom of the page and click Read Outputs: 

Fig. 8-5: Switch Point Setup Window (NV8288)

This table describes each column in the output list:

Column Description

Output The number assigned to the signal for routing purposes. The number usually 
refers to the physical port through which the signal is distributed.

Reclock/bypass Indicates whether the output bypasses re-clocking. 

HD/SD Indicates whether the output is a standard definition (SD) or high definition (HD) 
video signal. 

Ref1/Ref2 Indicates whether the output uses video reference 1 or reference 2 (in dual refer-
ence mode only).
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3 In the ‘Dual Video Reference Option’ section, choose ‘Redundant’ or ‘Dual’.

‘Redundant’ — You declare that the router will use redundant references. Both ‘VIDEO REF 1’ 
and ‘VIDEO REF 2’ are the same. If one fails, the other will be used as a fail-over. 

‘Dual’ — You declare that dual video references are in use. In this case, you can specify in step 
6 which reference selected outputs are to use. 

See Redundant v. Dual Video Reference on page 61.

4 In the ‘NTSC/PAL Reference Options’ section, you declare the type of reference signal for the 
reference connectors. 

Select the radio button corresponding to the signal type being used as a video reference: 
‘1080i’, ‘720p’, or ‘1080p’. 

These options appear only if the control card supports NTSC or PAL. 

5 If you want to change any of the fields in the output list, select the outputs you want to 
change. Use standard Windows click, shift-click, and control-click techniques, 

Or. to select all outputs, choose ‘Select All’ from the ‘Edit’ menu.

Or, to clear all outputs from the list, choose ‘Remove All Outputs’ from the ‘Edit’ menu. 

6 In the switch settings section, check the check boxes that apply to reclocking, switching line 
(SD or HD), and video reference.

The following lists each check box and its function:

7 Click Apply Changes to Selected Outputs, or from the ‘Edit’ menu, choose ‘Apply Changes’. 

This does not write your changes to the control card, but causes the output list to redisplay. 

8 Finally, when you are satisfied that all your changes are correct, click Write Changes, or from 
the ‘Edit’ menu, choose ‘Write Changes’. UniConfig writes your changes to the control card.

Check Box(es) Description

Use video reference 1, 
Use video reference 2

Choose whichever reference you want to apply to the selected outputs (in 
dual reference mode). 

Use Reclocker,  
Bypass Reclocker

Either use the output reclocker or bypass the output reclocker.

Switch on SD Line, 
Switch on HD Line

Choose ‘Switch on SD Line’ if the selected signals are SD (or analog video). 
Choose ‘Switch on HD Line’ if the selected signals are HD. 
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NV8500 Family Standard Routers 
Use MRC, not UniConfig, to configure NV8500 hybrid routers — those having EM0833 
control cards. You must use UniConfig to configure NV8500 routers that have EM0666 
control cards. 

1 Select a control card (for an NV8144, NV8140, NV8280, NV8576, or NV8576-Plus frame). 

2 From the ‘Window’ menu, select ‘Switch Point Setup’. The ‘Switch Point Setup’ window 
appears. Specify an output range at the bottom of the page and click Read Outputs: 

Fig. 8-6: Switch Point Setup Window (NV8280)

This table describes each column in the output list:

Column Description

Output The number assigned to the signal for routing purposes. The number usually 
refers to the physical port through which the signal is distributed.

Reclock/bypass Indicates whether the output bypasses re-clocking. 

HD/SD Indicates whether the output is a standard definition (SD) or high definition (HD) 
video signal. 

Ref1/Ref2 Indicates whether the output uses video reference 1 or reference 2 (in dual refer-
ence mode only).
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3 In the ‘Dual Video Reference Option’ section, choose ‘Redundant’ or ‘Dual’.

‘Redundant’ — You declare that the router will use redundant references. Both ‘VIDEO REF 1’ 
and ‘VIDEO REF 2’ are the same. If one fails, the other will be used as a fail-over. 

‘Dual’ — You declare that dual video references are in use. In this case, you can specify in step 
6 which reference selected outputs are to use. 

See Redundant v. Dual Video Reference on page 61.

4 If you want to change any of the fields in the output list, select the outputs you want to 
change. Use standard Windows click, shift-click, and control-click techniques, 

Or. to select all outputs, choose ‘Select All’ from the ‘Edit’ menu.

Or, to clear all outputs from the list, choose ‘Remove All Outputs’ from the ‘Edit’ menu. 

5 In the switch settings section, check the check boxes that apply to reclocking, switching line 
(SD or HD), and video reference.

The following lists each check box and its function:

6 Click Apply Changes to Selected Outputs, or from the ‘Edit’ menu, choose ‘Apply Changes’. 

This does not write your changes to the control card, but causes the output list to redisplay. 

7 Finally, when you are satisfied that all your changes are correct, click Write Changes, or from 
the ‘Edit’ menu, choose ‘Write Changes’. UniConfig writes your changes to the control card.

Check Box(es) Description

Use video reference 1, 
Use video reference 2

Choose whichever reference you want to apply to the selected outputs (in 
dual reference mode). 

Use Reclocker,  
Bypass Reclocker

Either use the output reclocker or bypass the output reclocker.

Switch on SD Line, 
Switch on HD Line

Choose ‘Switch on SD Line’ if the selected signals are SD (or analog video). 
Choose ‘Switch on HD Line’ if the selected signals are HD. 
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Machine Control
Chapter 9 discusses machine control routing, machine control port types, and using the 
‘Connections’ window for machine control routers. 

Topics
Background Information  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  77
The Port Configuration Window  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  80
Setting Up Machine Control Ports . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  81

Background Information
Machine control routers switch signals between recording and playback equipment such as 
VTRs. These “machines” have control signals such as play, stop, and rewind, and can perform 
functions such as pre-roll and cueing. 

Machine control ports are bi-directional and machine control routes are point-to-point. This 
means that (1) an input can be connected to at most one output and (2) signals flow both ways, 
from the input to the output and from the output to the input. 

Because machine control routes are point-to-point, 2 ports are consumed for each route. Thus, a 
256-port machine control router allows up to 128 routes.

The NV5256 is a 256-port machine control router. The NV5128 Multi-Format Router can include 
include a small set of machine control ports, up to 64 ports. 

Using the ‘Connections’ window (Chapter 10), you can view and test machine control ports. 

Using the ‘Partitions’ window (Chapter 7), you can define machine control partitions. 

Using the ‘Machine Control Port Setup’ window (described in this chapter), you can configure 
machine control ports. 

Machine Control Ports
When two devices communicate, through a router, one is considered the controlling device and 
the other is considered the controlled device. One sends control signals to the other and receives 
status signals from the other. 

Router ports can be configured to match the devices to which they connect — controlling or 
controlled — and they can be configured as flexible, either controlling or controlled as required 
at any given time. 
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Background Information
Machine control ports can be configured with the following port types. All of these are variants 
on controlling and controlled: 

• Controlling

Declares that the port connects to a device that normally functions as a controlling device 
(but may also serve as a controlled device).

• Controlled

Declares that the port connects to a device that normally functions as a controlled device 
(but may also serve as a controlling device).

• Dynamic

Declares that the port type can change to match the requirements of the current operation. 
The changes take place under the direction of the router control system. 

Note: This is both the default and the recommended setting for most applications.

• DTE

Declares that the port connects to a controlling device. This port type is used only in RS-232 
applications. 

• DCE

Declares that the port connects to a controlled device. This port type is used only in RS-232 
applications. 

• Master

Declares that the port connects to a primary (or master) device. A dynamic port that is 
routed to or from a master port becomes a slave port. 

• Slave

Declares that the port connects to a secondary (or slave) device. A dynamic port that is 
routed to or from a slave port becomes a master port. 

By default, all machine control ports are set to ‘Dynamic’. 

Machine Control Partitions
The routers that support machine control (the NV5128 and the NV5256) have 4 machine control 
partition types: 

Reverse Forward Broadcast Data X/Y

Reverse is the default because it is the most commonly applicable. 

It is in the ‘Partitions’ window that you can configure a machine control partition as one of the 
following types:

• Forward

Signals flow from the controlling device to the controlled device. 

• Reverse

Signals flow from the controlled device to the controlling device. 

• Broadcast

Allows the router to send signals from the controlling device to multiple controlled devices. 
For more information, see Broadcasting Machine Control Signals on page 79.
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• Data X/Y

The partition acts as if the machine control ports are standard I/O ports and not bidirectional 
and point-to-point. Signal flow is unidirectional and an input can be routed to any or all out-
puts. 

Broadcasting Machine Control Signals
In a broadcast partition, the router can send signals from one device to one or more connected 
devices. The first receiving device returns status to the sending device. The other receiving 
devices do not return status: 

Operators using an NV9000 control panel to perform broadcast takes use the methods appro-
priate for their panels. In non-specific terms, they perform these 2 steps to set up a broadcast 
scenario: 

1 Set up normal communication between a controlling device (A) and one of the controlled 
devices (B). This is bidirectional communication, control in one direction and status in the 
other. 

2 Set up unidirectional communication between the controlling device and all remaining con-
trolled devices (C and D). These devices receive the control signals but do not return status. 
All status reporting is through the first controlled device. 

Diagnostic Takes
In UniConfig, you can perform diagnostic machine control takes — under reverse, forward, 
broadcast, or data X/Y modes — in the ‘Connections’ window. See Connections Window on 
page 83 for details. 

In each of the mode, the characteristics of a take are different.

The diagnostic crosspoint list of the ‘Connections’ window is not intended for general use by 
customers. It is not an effective way to perform takes in day-to-day operations.
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The Port Configuration Window
This is the ‘Machine Control Port Setup’ window: 

Click Read to read the port configuration from the router. The port data appear in the port list. 

Click Write to save any changes to the port configuration that you have made. 

Machine Control Port Commands
When you have the machine control port window open, the ‘Edit’ menu provides commands 
that are appropriate to the machine control port window: 

If you right-click anywhere in the machine control port window, a context menu appears that 
has the same commands as the ‘Edit’ menu. 

You can use these commands to change the port types of the router. 

See Machine Control Ports on page 77. 

Port List

Edit Menu Context Menu
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Setting Up Machine Control Ports
As described earlier, machine control ports can be configured with the following types: 

Dynamic Master DTE 
Controlling Slave DCE 
Controlled

By default, all machine control ports are set to ‘Dynamic’. A dynamic port changes its configura-
tion to match the current operation requirements as directed by the router control system. 

For the ‘Connections’ window to function properly for machine control routers, all the 
machine control port types must be set to “dynamic” in the ‘Machine Control Port Setup’ 
window. 

This requirement is in conflict with the necessity of defining different port types for the 
machine control partition(s) you create (unless all your port types are in fact “dynamic”). The 
‘Connections’ window is a diagnostic window. For machine control routers, it is effective 
only before you have configure machine control ports or when you have a serious problem 
to solve. 

How to Configure Machine Control Ports
1 Select a control card (of an NV5128 or NV5256 router). 

2 From ‘Window’ menu, select ‘Machine Control Port Setup’. The ‘Machine Control Port Setup’ 
window appears: 

Fig. 9-1: Machine Control Port Setup Window

3 Click Read, or from the ‘Edit’ menu, choose ‘Read All’. The current configurations of the 
router’s ports appear in the port list.

4 Enter a value in the ‘Take Delay’ field. The “take delay” is the number of video frames 
between the time a port is disconnected from one device and connected to another. The 
delay is typically 20 to 30 frames. Be sure to verify that the delay is appropriate for your 
router. 
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5 In the port list, use standard Windows click, shift-click, and control-click techniques to select 
the ports you want to change to a particular type. 

6 Choose a port type command from the ‘Edit’ menu or the context menu. That will apply the 
chosen port type to all the ports you had selected. 

7 Repeat steps 5 and 6 for other ports of other types. 

8 Click Write or, from the ‘Edit’ menu, choose ‘Write Ports’ to send the port settings to the con-
trol card of the router.

9 Repeat steps 1–8 for other control cards you are updating. (Both control cards in a router 
frame must be configured identically.)
82



Connections Window
Chapter 10 discusses UniConfig’s ‘Connections’ window. 
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Introduction
The ‘Connections’ window displays a diagnostic crosspoint matrix of the router you have 
selected and allows you to perform takes for testing or for other purposes. 

Although you can use the ‘Connections’ window to perform takes, it is not intended for general 
use by customers, or as a control panel, but for diagnostics performed by Miranda service 
personnel. 

We say it is a diagnostic crosspoint matrix because (1) it spans the entire space of the router’s 
crosspoint matrix without regard to any of the partitions you have defined and (2) you can 
perform takes from almost any input to any output without regard to partition boundaries. 

In the case of an NV5128 Multi-Format Router, where there are mixed signal types, it is possible 
to take a video input to a machine control output in the ‘Connections’ window. For routers that 
have an output-follow partition, the ‘Connection’ window can perform output-follow takes 
outside the output-follow partition. 

(Such takes are not possible when the router is operating normally in a router control system.)

Depending on the router you have selected and the partitions you have defined for the router, 
the ‘Connections’ window has distinct modes and submodes and the window appears differ-
ently in the different modes: 

• XY/standard

This mode applies to routers that have video partitions or stereo audio partitions. The term 
“XY” denotes that the matrix is a standard X/Y crosspoint matrix.

• XY/mono

This mode applies to routers that have mono audio partitions and has additional controls 
with which to specify mono channels. The term “XY” denotes that the matrix is a standard 
two-dimensional crosspoint matrix.
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• Machine control

This mode applies to routers that have machine control partitions. When the ‘Connections’ 
window shows a machine control crosspoint list, there are 4 sub-modes available:

Reverse, Forward, Broadcast, Data X/Y

The ‘Connections’ behaves differently in the 4 submodes. Note that the 4 submodes corre-
spond to the 4 machine control partition types, but the submodes do not affect the parti-
tions, but only the behavior of the ‘Connections’ window.

Important: for the ‘Connections’ window to execute machine control takes properly, you 
must have set the type of all machine control ports to “dynamic.” 

Machine control matrices are not X/Y matrices. Machine control connections are bidirec-
tional and point-to-point. Each connection consumes 2 ports. That is, in a 256-port 
machine control router, you can make up to 128 connections.

• Output-follow

This mode must be enabled and is available only when the router you have selected has an 
output follow partition. 

When this mode is enabled, the ‘Connection’ window performs output-follow take func-
tions. When this mode is disabled, the ‘Connections’ window performs normal take func-
tions. 

Writing Connections Reports
When you have the ‘Connections’ window open, the ‘File’ menu provides commands related to 
salvos and a ‘Write Connections Report (.TXT file) . . .’ command: 

Click the command to write the report. A dialog appears in which you can browse your PC’s file 
system to find a folder in which to save the report, create a name for the report file, and save the 
report. 

The report is a text image of the output list of the ‘Connections’ window. The report has tab-
separated fields in 4 columns: input, output, ‘LPR’, and status. 
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The Connections Window
This is a sample of the ‘Connections’ window for an NV8256: 

The NV8256 is a video router. For this router, the ‘Connections’ window shows one crosspoint list 
in XY/standard mode. 

Standard 
Diagnostic 
Crosspoint 
List

Single 
Takes

Output 
Range
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The Connections Window
The window’s fields might differ slightly for other routers. For example, the audio routers 
(NV7256 and NV7512) have an additional tab for an XY/mono view of the crosspoint list: 

Routers that support machine control have a machine control tab: 

The controls for machine control views are the same as for XY/standard views.

Mono 
Output 
Range

Mono 
Take

Mono  
Diagnostic 
Crosspoint 
List

Machine 
Control 
Diagnostic 
Crosspoint 
List
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If output follow takes have been enabled, the window enters “output follow” mode: 

This example shows an NV5128 router. All three tabs remain in view when the window is in 
“output follow mode.”

Window Features
Every ‘Connections’ window has one or more diagnostic crosspoint lists, depending on the 
router. 

Every ‘Connections’ window has a section in which you can specify and execute a single take. 

Every ‘Connections’ window has a section in which you can specify a range of outputs, and read 
those outputs from the router. 

The audio routers have additional sections in which you can issue a mono take and specify a 
mono output range. 

A context menu applies to the ‘Connections’ window. See Setting Connection Window Options 
on page 90.

Views

XY/Standard View
In the “XY/standard” view of the diagnostic crosspoint matrix, there are 4 columns:

• Input — the input that is routed to the output in the same row

• Output — the list is ordered by output port

• LPR — the “lock, protect, release” status of the output. An L in the field indicates that the out-
put in that row is locked. A P indicates that the output is protected. A blank field means that 
there is no lock or protect on that output. 

• Status — additional status or error states. 

Output  
Follow 
Diagnostic 
Crosspoint 
List

Single 
“Follow” 

Take
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XY/Mono View
In the “X-Y/mono” view of the diagnostic crosspoint matrix, there are 8 columns:

• Mono (input) — the mono input port of the signal routed to the output in the same row.

• Phys (input) — the physical connector number of the signal routed to the output in the same 
row

• Channel (input) — The values can be either 1 or 2. 

• Mono (output) — the mono output port.

• Phys (output) — the physical connector number of the output.

• Channel (output) — The values can be either 1 or 2. 

• LPR — the “lock, protect, release” status of the output. An L in the field indicates that the out-
put in that row is locked. A P indicates that the output is protected. A blank field means that 
there is no lock or protect on that output. 

• Status — additional status or error states. 

Machine Control View
Machine control crosspoints are different from video and audio crosspoints. Machine control 
routers are bi-directional and point-to-point. For every machine control take, there is an 
matching take in the opposite direction. 

Further, machine control ports on the diagonal are tristated (i.e., turned off ). This is a sample of 
the ‘Connections’ window for the NV5256: 

In the machine control view, there are 4 columns:

• Input — the input that is routed to the output in the same row

• Output — the list is ordered by output port
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• LPR — the “lock, protect, release” status of the output. An L in the field indicates that the out-
put in that row is locked. A P indicates that the output is protected. A blank field means that 
there is no lock or protect on that output. 

• Status — indicates whether a port is tristated (i.e., disconnected) or, if the port is in use, 
whether it is “controlled” or “controlling.”

Saving and Loading Crosspoint States 
You can create a “snapshot” of the current crosspoint matrix state that can be saved for loading 
at a future point. This snapshot is called a “salvo.” (These salvos are not the same as NV9000 
system salvos.) For more information, see Salvos on page 121.

If you enable salvos, a salvo pane appears in the ‘Connections’ window, at the right of the cross-
points list: 

The salvo pane has an ‘Execute’ button. If the salvo is not empty, pressing the ‘Execute’ button 
causes the crosspoint connections defined in the salvo to be moved to the crosspoint matrix of 
the router. The crosspoint list of the window is updated accordingly. 

You can modify the entries in the salvo pane in several ways. See Salvos on page 121. 

Added 
Salvo  
Pane
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Setting Connection Window Options
When you have the ‘Connections’ window open, the ‘Actions’ menu and the ‘Options’ command 
of the ‘Tools’ menu have specific commands that can be used with the ‘Connections’ window. A 
context menu is available if you right-click anywhere in the ‘Connections’ window: 

For more detail, see Special Takes on page 101

When you click the ‘Options’ command, the ‘Connection Options’ dialog appears: 

This dialog has several commands in these 3 tabs. 

• Preferences

• Machine Control

• Salvo. (See chapter 14, Salvos on page 121.)

• Other

Connection Preferences Tab

Automatic Refresh After Take 
When you check the ‘Auto refresh connections after take’ check box, UniConfig refreshes the 
crosspoint list each time you perform a take. 

If you leave this check box unchecked, you must click ‘Read Outputs’ in the ‘Connections’ 
window to refresh the crosspoint list. 

Tools Menu

Actions Menu

Context Menu
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Automatic Increment and Decrement after Takes
These 4 options apply to the input and the output fields in the ‘Single Take’ section. 

When you check the ‘Auto increment after Take’ check box, the input (or output) field incre-
ments every time you click the ‘Execute’ button in the ‘Single Take’ section of the ‘Connections’ 
window. 

When you check the ‘Auto decrement after Take’ check box, the input (or output) field decre-
ments every time you click the ‘Execute’ button in the ‘Single Take’ section of the ‘Connections’ 
window. 

When you have one or two of these options checked, clicking ‘Execute’ repeatedly creates a take 
sequence that might be useful. 

For example, if you check ‘Auto increment after Take’ for outputs but not for inputs, you can 
perform a small sequential range take. 

For another example, if you check ‘Auto increment after Take’ for inputs but not for outputs, you 
can repeatedly take inputs, one after another, to the same output. 

Machine Control Tab
If the router you are configuring is an NV5256, or an NV5128 that supports machine control, the 
‘Connection Options’ dialog has a machine control tab: 

Here there are 4 radio buttons that reflect the machine control partition types: 

Forward Reverse Broadcast Data X/Y

Here, these radio buttons govern how the diagnostic crosspoint matrix in the ‘Connections’ 
window behaves. These options do not affect the partitions you have defined, but only how the 
‘Connections’ window behaves. 

For the ‘Connections’ window to work correctly for machine control, the type of all the 
router’s machine control ports must be defined as “dynamic.” 

For example, if you take port 7 to 12 in reverse mode, port 7 is “controlled” and port 12 is 
“controlling”. if you take port 7 to 12 in forward mode, however, port 7 would be “controlling” 
and port 12 would be “controlled” — the reverse. 

If you instead took port 12 to 7 in reverse mode, port 12 is “controlled” and port 7 is “controlling”. 

If you choose “data X/Y mode”, you could take any input to multiple outputs. 
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Broadcast mode allows you to perform broadcast takes in the ‘Configuration’ window. See 
Broadcasting Machine Control Signals on page 79

‘Other’ Tab
There are two check box options in this tab: 

Show Take Buttons on Connection Dialog
When you check this check box, a ‘Diagonal Take’ button and a ‘Range Take’ button appear in 
the ‘Connections’ window. 

When you leave the check box unchecked, you must use the ‘Actions’ menu — or a context 
menu — to perform a diagonal take or a range take. 

Enable Output-Follow Takes
If you have defined an output follow partition for the selected control card and you check this 
box, the ‘Connections’ window treats the crosspoint list as an “output follow” crosspoint matrix. 
Fields in the window change and the status fields indicate where a “follow” occurs. 

If your control card has no output follow partition, this option is not present in the dialog.

See Output-Follow Takes on page 103.
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Salvo Tab
There are two check box options in this tab:  

The two salvo options also appear in the context menu, providing a shortcut 

There is one salvo at any time. The salvo can be large — it is often a copy of the diagnostic cross-
point matrix. It can be as small as a single take. You can control the content of the salvo. 

A single take copies all displayed outputs to the salvo. Adding a take (from the ‘Actions’ menu) 
to an empty salvo creates a salvo of one take. Adding a take to any salvo increases the size of the 
salvo by one take.

Show Salvo Window
When you check this check box, UniConfig shows a salvo pane in the ‘Connections’ window — to 
the right of the diagnostic crosspoint list. 

The salvo pane shows a sequence of takes. The takes in the salvo pane are not necessarily in any 
particular order. But if you add takes to the salvo, they are placed at the bottom of the salvo. 

The salvo window has an ‘Execute’ button. When you press that button, UniConfig executes the 
takes in the salvo, in this case in order from top to bottom. The takes occur in the router’s cross-
point and are reflected in the diagnostic crosspoint list. 

You can clear the salvo pane with the ‘Clear Salvo’ command of the ‘Actions’ menu.

Send All Reads to Salvo Window
When you check this check box, UniConfig sends all crosspoint “reads” to the salvo pane. 
Whether you execute a single take or press Read Outputs, all displayed outputs are “read” and 
all are copied to the salvo pane. 

Check this and the salvo window becomes checked automatically. 

See chapter 14, Salvos on page 121.

Context Menu
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Viewing Diagnostic Crosspoint Data
The ‘Connections’ window displays either XY/standard (video or audio), XY/mono, or machine 
control crosspoint lists. The lists are often displayed in tabbed viewing panes or “tabs.” 

The following is a list of what tabs are viewable for each router:

• NV5100MC — standard and mono tabs. 

• NV5128 — standard, mono, and machine control tabs.

• NV5256 — machine control tab.

• NV7256 and NV7256-Plus — standard and mono tabs.

• NV7512 — standard and mono tabs.

• NV8256-Plus — standard tab only.

• NV8288 and NV8288-Plus — standard tab only.

• NV8500 Family — standard tab only.

Output follow crosspoints must be explicitly enabled. An output follow crosspoint list is a re-
interpretations of the XY/standard, XY/mono, or machine control list you are viewing. The inter-
pretation allows you to specify output follow connections rather than perform takes. 

How to View Crosspoints
1 Select a control card. 

2 From the ‘Window’ menu, choose ‘Connections’. The ‘Connections’ window appears. The 
crosspoint list is empty. 

3 If you are viewing the crosspoints of an NV5100MC, NV7256 or NV7512, click the ‘X-Y/Stan-
dard’ tab or the ‘X-Y/Mono’ tab to bring it to the front. If the mono tab is in front, the window 
will show controls appropriate for mono signals. 
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If you are viewing the crosspoints of a video router (or the NV8500), only the ‘X-Y/Standard’ 
tab appears. If you are viewing the “crosspoints” of a machine control router, only the 
‘Machine Control’ tab appears. If you are viewing the crosspoints of an NV5128 multi-format 
router, all three tabs appear. Choose the one you want to use. 

4 To view crosspoints, enter a ‘Start’ and ‘End’ number in the fields of the ‘Physical Output 
Range’ section (or the ‘Mono Output Range’ section) and click Read Outputs. UniConfig dis-
plays the corresponding crosspoints in the tab.

The crosspoint list shows the input that has been routed to each output, its “LPR” state, and 
additional status. (If any output follow states exist, information about those states appears in 
the status fields.

The column names for mono crosspoints are different from those of standard crosspoints. 
The ‘Status’ fields for machine control crosspoints show how the machine control ports are 
connected (or not connected). 

Performing Takes 
The purpose of the ‘Connections’ window is for you to perform ‘takes’. Doing so, you can test 
standard, mono, and machine control switching. You can perform takes for any reason.

You can perform simple takes, diagonal takes, and range takes. 

For information on machine control takes (for the NV5128 and the NV5256), see Machine 
Control on page 77.

It is possible, in a multi-format router such as the NV5128, to perform takes from an input 
that do not match the output. You could, for example, route a video input to an audio 
output. Exercise care if you need to avoid making such routes. 

XY/Standard Signals
The ‘XY/Standard’ tab appears for all routers except the NV5256. (Standard audio takes are 
stereo.)

How to Perform Standard Takes
1 Select a control card. 

2 From the ‘Window’ menu, choose ‘Connections’. The ‘Connections’ window appears with 
blank fields. 

3 Select the ‘XY/Standard’ tab if it is not in front.

4 Select a range of outputs. In the ‘Physical Output Range’ section, enter a ‘Start’ and ‘End’ 
number and click Read Outputs. UniConfig displays the selected crosspoints in the diagnos-
tic crosspoint list.

5 To take a single input to a single output, enter an input and an output number in the ‘Single 
Take’ section and click Execute. 

(To be viewable, the output must in the diagnostic crosspoint list.)
95



Connections Window
Performing Takes
6 To perform multiple takes, either choose a command from the ‘Action’ menu or right-click 
anywhere in the crosspoint list to open a context menu and select an option. If an option is 
not applicable, the option is greyed out (disabled).

These are the command options: ‘Diagonal take’, ‘Range Take’, ‘Reverse Diagonal Take’, and 
‘Chop Take’. See Special Takes on page 101 for details. 

Mono Signals
The ‘XY/Mono’ tab appears only for the NV5100, NV5128, NV7256, NV7256-Plus, and NV7512 
routers. If you have created no mono partitions, this tab is inactive. 

(See Partitions and Signal Types on page 41.)

How to Perform Mono Takes
1 Select a control card (for a router that can switch mono channels). 

2 From the ‘Window’ menu, choose ‘Connections’. The ‘Connections’ window appears.

3 Select the ‘X-Y/Mono’ tab if it is not in front.

4 Select a range of outputs. In the ‘Mono Output Range’ section, enter a ‘Start’ and ‘End’ num-
ber and click Read Outputs. UniConfig displays the selected outputs in the diagnostic cross-
point list. Note that there are ‘Mono’, ‘Phys’, and ‘Chnl’ columns for both inputs and outputs.

5 To take a single mono input to a single mono output, enter a mono input and a mono out-
put number in the ‘Single Take’ section and click Execute Mono. 

Or, enter a physical input and a physical output number in the ‘Physical Mono Take’ section 
and select either channel 1 or channel 2, from the drop-down lists, for both the input and 
the output. Then click Execute (in the ‘Physical Mono Take’ section).

(To be viewable, the output must in the diagnostic crosspoint list.)

6 To perform multiple takes, either choose a command from the ‘Action’ menu or right-click 
anywhere in the crosspoint list to open a context menu and select an option. If an option is 
not applicable, the option is greyed out.

These are the command options: ‘Diagonal take’, ‘Range Take’, ‘Reverse Diagonal Take’, and 
‘Chop Take’. See Special Takes, following, for details. 

Machine Control Signals
The ‘Machine Control’ tab appears only for the NV5128 and NV5256 routers. (The NV5128 allows 
a 64-port machine control crosspoint matrix. UniConfig does not allow you to read or write 
beyond that range.)

See Partitions and Signal Types on page 41.

See Chapter 9, Machine Control on page 77, for details of machine control switching. 

To use the ‘Connections’ window for machine control takes, you must select a machine control 
submode using the ‘Options’ command of the ‘Tools’ menu. There are 4 machine control 
submodes: 

Reverse, Forward, Broadcast, Data X/Y

as described in Machine Control Tab on page 91.
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How to Perform Machine Control Takes
(The takes described here are performed in the ‘Connections’ window, not at an NV9000 control 
panel. Keep in mind that such takes are diagnostic takes and are made without regard to the 
existence of partitions and their boundaries.)

Forward Takes
To perform a single take:

1 Go to the ‘Connections’ window. Use the ‘Options’ command of the ‘Tools’ menu to place 
the ‘Connections’ window in forward mode.

2 Enter an input number and an output number in the ‘Single Take’ section and click ‘Execute’.

3 The diagnostic crosspoints list shows the take results. You might have to scroll the list and 
you might have to click ‘Read Outputs’ to see the change. 

This is an example: 

Here, 2 entries in the list change. Because this is a forward take, port 7 is “controlling” and port 12 
is “controlled.” The term “P2P” is just a reminder that the take is point-to-point. 

You can also perform diagonal takes and range takes. See Special Takes on page 101.

Reverse Takes
To perform a single take:

1 Go to the ‘Connections’ window. Use the ‘Options’ command of the ‘Tools’ menu to place 
the ‘Connections’ window in reverse mode.

2 Enter an input number and an output number in the ‘Single Take’ section and click ‘Execute’.

3 The diagnostic crosspoints list shows the take results. You might have to scroll the list and 
you might have to click ‘Read Outputs’ to see the change. 
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This is an example: 

Here, 2 entries in the list change. Because this is a reverse take, port 7 is “controlled” and port 12 
is “controlling.” The term “P2P” is just a reminder that the take is point-to-point. 

This is the opposite of a forward take. 

You can also perform diagonal takes and range takes. See Special Takes on page 101.

Broadcast Takes
Broadcast takes involve multiple outputs. For information, see Broadcasting Machine Control 
Signals on page 79.

The example shown here takes input 7 to outputs 12, 13, 14, and 15. Port 12 returns status to 
port 7. Ports 13, 14, and 15 are passive and do not return status. 

To perform a broadcast take:

1 Go to the ‘Connections’ window. Use the ‘Options’ command of the ‘Tools’ menu to place 
the ‘Connections’ window in broadcast mode.

2 In the ‘Single Take’ section, enter an input number and the output number of the first out-
put. Click ‘Execute’. In our example, these ports are 7 and 12 respectively. 

The diagnostic crosspoints list shows the take results. Thus far, the result is the same as a sin-
gle forward take: 
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3 In the ‘Single Take’ section, enter an input number and the output number of the next out-
put. Click ‘Execute’. In our example, the input remains 7 and the second output would be 13. 

The diagnostic crosspoints list shows the take results. Now port 7 changes from ‘P2P Con-
trolling’ to ‘Bcast Controlling’ and the additional output, port 13, becomes ‘RecvOnly Con-
trolled’: 

4 Repeat step 3 for any additional outputs. 

In our example, broadcasting port 7 to ports 12–15, these are the results: 

You can also perform a broadcast take as a range take if the receivers have contiguous port 
numbers. See Special Takes on page 101.

Data X/Y Takes
Takes in data XY mode are like normal takes for non-machine-control routers. They are not 
point-to-point or bidirectional.

To perform a single take:

1 Go to the ‘Connections’ window. Use the ‘Options’ command of the ‘Tools’ menu to place 
the ‘Connections’ window in ‘Data XY’ mode.

2 Enter an input number and an output number in the ‘Single Take’ section and click ‘Execute’.

3 The diagnostic crosspoints list shows the take results. You might have to scroll the list and 
you might have to click ‘Read Outputs’ to see the change. 
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This is an example: 

Here, 2 entries in the list change. Because this is a data XY take, the route to output 7 is not 
changed. Input 7 reports as “Bcast Controlling” and port 12 reports as “RecvOnly Controlled.” 

If you route the same input to another output, the results are similar: 

You can also perform diagonal takes and range takes. See Special Takes, following.
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Special Takes
Use the ‘Actions’ menu or the context menu to have access to additional commands: 

In all case, the takes affect the crosspoint matrix in the router and the crosspoint states are 
reflected in the ‘Connection’ window’s crosspoint list, either automatically or when you click 
Read Outputs.

Diagonal Takes
When you choose the ‘Diagonal Take’ command, a dialog appears: 

Specify the range of outputs that will be affected. Specify in the input field the starting point for 
the take. The inputs for the take increment from the starting point. The result for the take illus-
trated here is that input 1 switches to output 1, input 2 switches to output 2, and so on, for 
inputs 1–256 and outputs 1–256.

Notes
1 Diagonal takes need not start at input 1 or output 1. 

2 Machine control ports “connected” on the diagonal (1 to 1, 2 to 2, and so on) are really 
tristated (disconnected) unless the partition in the router (or the diagnostic crosspoint list in 
UniConfig) is in data X/Y mode. In data X/Y mode, status fields in the crosspoint list read 
“Bcast controlled.”

Actions Menu

Context Menu
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Range Takes
When you choose the ‘Range Take’ command, a dialog appears: 

Specify the range of outputs that will be affected. Specify in the input field the (single) input for 
the take. The result for the take illustrated here is that input 12 switches to all outputs in the 
range 100–116.

Notes
Range takes are not enabled for machine control partition types forward and reverse and are 
not enabled for these diagnostic crosspoint modes. 

Range takes are enabled for broadcast and data X/Y partitions and for these diagnostic cross-
point modes as well. 

Reverse Diagonal Takes
When you choose the ‘Reverse Diagonal Take’ command, a dialog appears: 

Specify the range of outputs that will be affected. Specify in the input field the starting point for 
the take. The inputs for the take decrement from the starting point. The result for the take illus-
trated here is that input 20 switches to output 110, input 19 switches to output 111, input 18 
switches to output 112, and so on, for inputs 20–10 and outputs 110–120.

Notes
Machine control ports “connected” on the diagonal (1 to 1, 2 to 2, and so on) are really tristated 
(disconnected) unless the partition in the router (or the diagnostic crosspoint list in UniConfig) is 
in data X/Y mode. In data X/Y mode, status fields in the crosspoint list read “Bcast controlled.”
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Chop Takes
When you choose the ‘Chop Take’ command, a dialog appears: 

A “chop” switches one input to another input, and back again, to the specified output at a rate 
indicated by the value you place in the interval field. 

The result for the chop take illustrated here is that output 7 switches from input 5 to input 6 after 
6 frames, then switches back to input 5 after another 6 frames, and continues to switch at that 
interval indefinitely. 

To terminate the chop, perform a single take to the affected output. 

Chop takes are available only for certain routers. 

Output-Follow Takes 
The “output-follow takes” feature is disabled unless the control card you are editing has an 
output follow partition. 

If your control card has an output follow partition, you can enable the feature in the ‘Connection 
Options’ dialog that appears when you select the ‘Options’ command from the ‘Tools’ menu 
(when the ‘Connections’ window is open). You can also enable the feature in the context menu 
of the ‘Connections’ window. 

How to Perform a Single Output-Follow Take
Follow these steps: 

1 Go to the ‘Connections’ window. Choose the XY/standard, XY/mono, or machine control tab 
(if you have the choice) as required by your objective. 

2 Right-click anywhere in the ‘Connections’ window to access the window’s context menu. 
Check ‘Enable Output-Follow Take Mode’ to enable output-follow takes. 

The ‘Connections’ window alters its appearance to support output-follow takes. For 
instance, the ‘Input’ field in the ‘Single Take’ section becomes the ‘Follows’ field. 
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3 Enter a “follows” number and an output number in the ‘Single Take’ section and click ‘Exe-
cute’: 

Here, output 4 follows output 13. In the diagnostic crosspoint list, you can see that input 127 
has been routed to output 13. Because output 4 follows output 13, input 127 appears at out-
put 4 as well. 

4 The diagnostic crosspoints list shows the take results. You might have to scroll the list and 
you might have to click ‘Read Outputs’ to see the change. 

You can disable output-follow takes at any time if you wish to perform normal takes. 

How to Perform an Output-Follow Diagonal Take
A diagonal take in output-follow mode creates a cascade of output-follow pairs. The result is 
multiple outputs emitting the same input signal.

Follow these steps: 

1 Go to the ‘Connections’ window. Choose the XY/standard, XY/mono, or machine control tab 
(if you have the choice) as required by your objective. 

2 Right-click anywhere in the ‘Connections’ window to access the window’s context menu. 
Check ‘Enable Output-Follow Take Mode’ to enable output-follow takes. 

The ‘Connections’ window alters its appearance to support output-follow takes. For 
instance, the ‘Input’ field in the ‘Single Take’ section becomes the ‘Follows’ field. 
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3 Choose the ‘Diagonal Take . . .’ command from the ‘Actions’ menu or choose ‘Execute Diago-
nal Take’ from the context menu: 

Enter an initial “follows” number and a range of outputs and click ‘Execute’. This is the result 
for the range specified above: 

You can see that output N follows output N–1 where N ranges from 2 to 9. Because one fol-
lows the other in sequence, all of them follow output 1, which is the “follows” number you 
entered in the diagonal take dialog. Input 33 feeds output 1. Therefore input 33 feeds out-
puts 2–9 also. 
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Chapter 11 discusses the EC9535 GSC Node Bus Converter. 

Topics
Setting Up EC9535 Communication . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  108
Setting Up EC9535 Partitions  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  109
Setting Up EC9535 Switch Points . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  111

The EC9535 GSC Node Bus Converter is a communications protocol converter designed to allow 
Miranda’s NV8288, NV8288-Plus or NV8500 family routers (NV8144, NV8140, NV8280, NV8576, or 
NV8576-Plus) to communicate with an SMS7000 router control system. 

To be used with an SMS7000 directly, a router must have (1) a GSC Node Bus connector and (2) a 
control card that follows the SMS7000 protocol. The NV8288, NV8288-Plus and the NV8500 
family routers do not have these items. 

The EC9535 provides the GSC Node Bus connector and the control cards that follow the 
SMS7000 protocol. The SMS7000 connects to the EC9535, which in turn, connects to the router: 

The EC9535 interprets commands from the SM7000, sending equivalent commands to the 
router. It also interprets status messages from the router, returning their equivalent to the 
SMS7000.

Using UniConfig, you can configure the EC9535 so that the SMS7000, the EC9535, and the router 
can communicate. 

Follow these broad steps to configure an EC9535. Details follow.

1 Set up communication between UniConfig and EC9535. See Setting Up EC9535 Communi-
cation on page 108.

2 If you intend to use an Ethernet connection to UniConfig, set up initial parameters so that 
UniConfig and EC9535 can communicate over Ethernet. 

3 Set up the EC9535 partition. See Setting Up EC9535 Partitions on page 109.

4 Configure EC9535 switch points. See Setting Up EC9535 Switch Points on page 111.

For more information, especially regarding hardware connections, please refer to the EC9535 
GSC Node Bus Converter User’s Guide.

SMS7000 EC9535 Router

command

status

command

status
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Setting Up EC9535 Communication
The control cards of the EC9535 can communicate with UniConfig either through diagnostic 
serial ports or over Ethernet. 

Each control card has 2 diagnostic connectors, both DE9. One is at the front of the control card 
and the other is located at the rear of the EC9535, labeled ‘DIAG’. You can use either one.

Each control card also has an Ethernet port. 

For the control card and UniConfig to communicate, the Ethernet or serial port must be initial-
ized in UniConfig. The EC9535’s IP address must be configured, initially, using a serial connection 
between UniConfig and the EC9535. 

Connections
This diagram shows the physical connections required the EC9535: 

After you have made the physical connections between the EC9535 and the SMS7000 and 
between the EC9535 and the router, you can make a connection between UniConfig and the 
EC9535. This connection can either be serial or Ethernet. 

The initial connection must be made to the diagnostic connector at the front of one of the 
EC9535’s control cards. Using this connection, you can set up the control card’s IP address and 
the Baud rate for its DIAG connector. If the EC9535 has a secondary control card, do the same for 
the secondary control card. 

For details regard the initialization of the EC9535, see Communicating with the Router for the 
First Time on page 31. 

EC9535 and Router Baud Rates 
The Baud rates of the EC9535 and the router must match.

The EC9535’s ‘CTRL 1’ serial port must be set to the same Baud rate as the router’s ‘CTRL 1’ serial 
port rate. By default, the NV8288, NV8288-Plus and NV8500 family routers have the ‘CTRL 1’ 
ports set to 38,400 Baud. However, the number of destinations that can be switched per frame 
under SMS7000 is determined by the EC9535 and the router’s Baud rates. You might want to set 
the serial ports at the highest available rate (115,200 Baud) unless doing so results in communi-
cation errors. 

Note
Each control card in the EC9535 must be configured separately and identically. 
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Follow these steps:

1 From the ‘Window’ menu, choose ‘Router Serial Configuration’. The ‘Router Serial Configura-
tion’ window appears: 

Fig. 11-1: Router Serial Configuration Window

2 Click Read to obtain the control card’s current settings. 

3 In the ‘Control 1 and 2 Baud Rate Setting’ section, select 115200 from the ‘Baud Rate’ drop-
down list. 

4 In the ‘Control 1 Settings’ section, choose ‘enabled’ in the ‘Control 1 (Main) field and ‘active 
only’ in the ‘Reply When’ field. 

5 Ignore the ‘Control 2’ settings and the diagnostic settings. 

6 Click Write to write changes to the control card, overwriting any previous settings. 

Setting Up EC9535 Partitions
The EC9535 is allowed one partition. The partition data must support operation under the 
SMS7000 control system. (See About Partitions on page 41.)
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How to Set Up Partitions for an EC9535
1 Select a control card. 

2 From the ‘Window’ menu, choose ‘Configuration’. The ‘Configuration’ window appears: 

3 Click Read All. The ‘Configuration’ window populates with the current configuration and 
Ethernet settings. If no prior configuration is stored, many of the fields are blank.

4 Create a level. 

To do so, enter ‘Level’, ‘Physical Inputs’, ‘Controller Inputs’, ‘Physical Outputs’ and ‘Controller 
Output’ information in the grid at the top of the window. Each row represents a level. 

The EC9535 has only one partition. The level number must be 0 to be compatible with the 
requirements of the SMS7000. 

The following is a list of the fields and the values you should enter (for an EC9535):

These values are appropriate for the SMS7000 control system. 

5 Click Write All to writes changes to the control card.

6 Repeat steps 1–5 for the other EC9535 control card.

UniConfig Field Description Values

Level Numeric value identifying the partition. 0

Physical Inputs Starting and ending physical input connector numbers. 1–1024

Controller Input Starting logical input connector number. The ending num-
ber is derived.

1

Physical Outputs Starting and ending physical output connector numbers. 1–1024

Controller Output Starting logical output connector number. The ending 
number is derived.

0

Signal Type Acceptable signal types for the partition ‘Video, Async, 
AES, Timecode’
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Setting Up EC9535 Switch Points
A “switch point” is a point in time in which an output is switched from the current source to a 
new source. Different video formats require different switch points. UniConfig lets you set 
switch point parameters for individual outputs. 

Important: in general, the video reference and AES reference on the EC9535 are not used. The 
reference signals that are applicable are those of the router that is connected to the EC9535. If 
you plan to connect reference signals to the EC9535, please contact Miranda Technical Support 
before proceeding. 

Router outputs are managed through the ‘Switch Point Setup’ window. 

For video reference signals, there are two connections labeled ‘VIDEO REF’. The two video refer-
ence connections can use the same signal or different signals. For audio reference, there are two 
connections labeled ‘AES REF’. One or both of these are connected to a stable 48 kHz AES source. 
If both AES references are connected, one is active and the other is a backup.

How to Make Switch Point Settings for the EC9535
1 Select a control card. 

2 From the ‘Window’ menu, choose ‘Switch Point Setup’. The ‘Switch Point Setup’ window 
appears displaying current output settings for the EC9535: 
111



EC9535
Setting Up EC9535 Switch Points
3 In the ‘Output Range’ section, enter a ‘Start’ number of ‘1’ and an ‘End’ number of ‘1024’ and 
click Read Outputs. Outputs corresponding to the range entered display in the ‘Select Out-
puts to edit’ pane with default settings.

The following lists each column and the information it presents:

4 In the ‘Select Outputs to edit’ list, select any outputs being updated 

To select specific outputs, use standard click, shift-click and control-click methods. Selected 
outputs are highlighted. 

Or, to select all outputs, click ‘Select All’ in the ‘Edit’ menu. 

Or, to clear all outputs currently displayed, click ‘Remove All Outputs’ in the ‘Edit’ menu.

5 In the ‘Set selection(s) to’ section, check the appropriate check boxes to apply switching 
parameters (video reference, bypass, and video format) for the outputs you have selected. 

The following lists each check box and its function:

6 In the ‘Dual Video Reference Option’ section, choose ‘Redundant’ or ‘Dual’. 

‘Redundant’ — Both ‘VIDEO REF 1’ and ‘VIDEO REF 2’ are used. If one fails, the other can be 
used as a fail-over. Both video reference signals should be identical in rate and format.

‘Dual’ — Choose which video reference signal to use, ‘VIDEO REF1’ or ‘VIDEO REF 2’. In this 
instance, the reference signals can be different. 

For information on dual or redundant references, see Redundant v. Dual Video Reference on 
page 61.

Column Description

Output The number of the output port.

Reclock/bypass Specifies whether the router output bypasses re-clocking. See step 5.

HD/SD Specifies whether the router output is SD or HD. See step 5.

Ref1/Ref2 Specifies whether the output uses ‘VIDEO REF1’ or ‘VIDEO REF2’ connection on 
the router. See step 5.

Note
Contact Miranda Technical Support before using an EC9535 video reference. 

Check Box(es) Description

Use Video Reference 1 
Use Video Reference 2

Choose whether to use the ‘VIDEO REF 1’ or ‘VIDEO REF 2’ connection on the 
router as the reference.
Either ‘Ref1’ or ‘Ref2’ appears in the ‘Ref1/Ref2’ column.

Use Reclocker 
Bypass Reclocker

Choose whether the router output should re-clock its signal or bypass the 
re-clocker, retaining the signal’s current rate.
Either ‘Reclock’ or ‘Bypass’ appears in the ‘Reclock/Bypass’ column.

Switch on SD Line 
Switch on HD Line

Choose ‘Switch on SD Line’ if the selected output is either SD or analog 
video. Choose ‘Switch on HD Line’ if the selected output is HD.
Either ‘SD’ or ‘HD’ appears in the ‘SD/HD’ column. 

Note
Contact Miranda Technical Support before using an EC9535 video reference. 
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7 Click Apply Changes to Selected Outputs, or, in the ‘Edit’ menu, click ‘Apply Changes’ to 
apply your changes to the selected outputs. This does not write your changes to the control 
cards. The changes appear in the list of outputs.

8 Optionally, repeat steps 5–7 for other outputs that have different switching parameters. 

9 Click Write All, or in the ‘Edit’ menu, click ‘Write Changes’ to write changes to the control 
card.

10 Repeat steps 1–9 for each control card being updated.
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NV8500 Monitors
Chapter 12 Discusses input and output monitors for the NV8500 family routers and how 
UniConfig can be used to configure them. 

Topics
Monitor Overview  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  115
UniConfig Settings  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  116
Using the Monitor Level . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  117

The NV8500 family of routers supports the monitoring of output and input signals. (Older 
routers support only output monitors.)

Your system will use third-party monitoring equipment to receive monitor signals from the 
router. 

UniConfig is used to create a monitor level. Operators can then perform takes of either router 
inputs or router outputs to outputs on the monitor level. 

NV8500 control cards running application versions 13.0.3.xx and older support output monitors 
only. NV8500 control cards running application versions 14.0.0.xx and newer support both input 
and output monitors.

To access and control monitor cards and monitor signals properly, a monitor level must be 
configured using either UniConfig v8.9.0.42, or later, or MRC. 

Monitor Overview
The NV8500 family comprises the following routers:  

The NV8140 does not support monitoring. 

For instructions on making connections to the monitor backplanes, please refer to the NVV8500 
Family Routers User’s Guide.

Router Switching Matrix I/O Cards Monitor Cards

NV8144 144 × 144 9 inputs, 18 outputs 1 (input and output)

NV8140 144 × 288 18 inputs, 18 outputs none

NV8280 288 × 576 9 inputs, 18 outputs 2 (1 input, 1 output)

NV8576 576 × 1152 9 inputs, 18 outputs 4 (2 input, 2 output)

NV8576-Plus 576 × 576 9 inputs, 9 outputs 4 (2 input, 2 output)

Expanded NV8576-Plus 1152 × 11521

1. Two interconnected router frames

9 inputs, 9 outputs 8 (4 input, 4 output)
 115



NV8500 Monitors
UniConfig Settings
UniConfig Settings
So that control panel operators and UniConfig users can access and control monitor signals, you 
must create a monitor level in UniConfig. 

For the NV8280, NV8576, and NV8576-Plus, each output monitor backplane has two outputs. 
The outputs must come from different output cards. 

For the NV8280, NV8576, and NV8576-Plus, each input monitor backplane also has two outputs. 
The outputs must come from different input cards. 

The NV8144 has outputs for one output monitor and one input monitor. Therefore, the issue of 
multiple cards is not present.

Mapping to the Monitor Level
A monitor level, in UniConfig, is a partition having a maximum of 4 outputs: 

Port Description NV8144 Other NV8500 routers

1 Output monitor 1 Used Used

2 Output monitor 2 Not used Used

3 Input monitor 1 Used Used

4 Input monitor 2 Not used Used

The NV8144 uses only the first and third ports of the partition. 

The following shows how, for each router, the associated monitor backplane connectors, map to 
UniConfig Monitors on the Monitor Page, and to the ports on monitor Level:

How to Set Up a Monitor Level
1 Select a control card.

2 From the ‘Window’ menu, click ‘Configuration’. The ‘Configuration’ window appears. 

3 Click Read All. The ‘Configuration’ window populates with the control card’s current configu-
ration data. If no prior configuration is stored, many of the fields are blank.

4 On a blank row, in the ‘Level’ column, enter a unique number between 1 and 240. (You will 
also use this level number in the configuration of your router control system.)

Router On Monitor Card Partition Ports

NV8144 Output Monitor Monitor 1

NV8144 Input Monitor Monitor 3

NV8280, NV8576, 
NV8576-Plus 

Output Monitor 1 Monitor 1

Output Monitor 2 Monitor 2

NV8280, NV8576, 
NV8576-Plus 

Input Monitor 1 Monitor 3

Input Monitor 2 Monitor 4
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5 Enter values for inputs and outputs for the level in the following fields. 

For control cards having application version 13.0.3.xx and earlier, enter values selected from 
this table: 

For control cards having application version 14.0.0.xx and later, enter values selected from 
this table

Note that controller ‘End’ values for input and output are derived. You cannot enter 
values in these fields (which are grayed out). 

6 From the ‘Signal Type’ drop-down list, select the signal type ‘Monitor’. 

7 Click Write All to writes changes to the control card.

8 Repeat steps 1–7 for each control card in the router.

Using the Monitor Level
The control panel operator can switch signals to monitoring equipment if the router control 
system defines a monitor level that corresponds to the monitor level, in the router, that was 
defined in UniConfig.

Third-party control systems or software drivers can be used to control the monitoring of router 
inputs and outputs. 

The ability to monitor NV8500 router inputs assumes that the control card in the router is 
running application version 14.0.0.xx and later (matching FPGA versions: CPLD, SV0900-07, 
SV0901-06 and newer).

Router

Physical Input Controller Input Physical Output Controller Output

Start End Start End Start End Start End

NV8144 1 144 1 144 1 2 1 2

NV8280 1 576 1 576 1 2 1 2

NV8576, 
NV8576-Plus

1 1152 1 1152 1 2 1 2

Router

Physical Input Controller Input Physical Output Controller Output

Start End Start End Start End Start End

NV8144 1 144 1 144 1 4 1 4

NV8280/
NV8280-Plus

1 576 1 576 1 4 1 4

NV8576/
NV8576-Plus

1 1152 1 1152 1 4 1 4
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Locks
Chapter 13 provides information about locks. 

Under NV9000 family router control systems, router sources and destinations can be locked or 
protected. Operators at different control panels can set or clear those locks and “protects.”

Both inputs and outputs can be locked or protected “in the system controller.” Outputs, but not 
inputs, can also be locked or protected “in the router.” Refer to the NV9000-SE Utilities User’s 
Guide for details.

UniConfig can release locks and protects that are set “in the router” but it cannot detect (or 
release) locks and protects that are set “in the system controller.”

Third-party router control systems might also provide a locking capability.

How to Remove Locks
1 Go to the ‘Connections’ window in UniConfig. 

Having the ‘Connections’ window open enables certain commands in the ‘Actions’ menu. 

2 Click ‘System > Clear > All Locks and Protects’ in the ‘Actions’ menu to release all locks.
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Chapter 14 discusses salvos. 
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Introduction
UniConfig’s ‘Configuration’ window allows you to create, manipulate, and execute salvos. In 
UniConfig, a salvo is either (1) a “snapshot” of the currently displayed diagnostic crosspoint 
matrix or (2) a sequence of takes that you can define independently of the router’s crosspoint 
matrix. 

You can execute a salvo if it is displayed in the ‘Connections’ window. When you execute a salvo, 
UniConfig performs the takes that compose the salvo, in sequence. The takes occur in the 
crosspoint matrix of the router immediately. 

You can also save salvos in your computer’s file system and load them from your file system. 

A salvo can be used to reset a crosspoint to a known state after a system failure. 

The use of salvos is an option of the ‘Connections’ window that you can enable or disable. To 
enable salvos, click ‘Show Salvo Window’ in the context menu of the ‘Connections’ window: 

The command is also available in the dialog that appears when you choose the ‘Options’ 
command from the ‘Tools’ menu.
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When salvos are enabled, the ‘Connections’ window has an additional salvo pane: 

If you check the ‘Send All Reads to the Salvo Window’ option in the context menu, UniConfig 
will transfer the contents of the diagnostics crosspoint list to the salvo window every time you 
click the ‘Read Outputs’ button. 

If you have checked ‘Auto Refresh After Take’ in the ‘Connection Options’ dialog, the window 
automatically reads the output range specified and refreshes the display. Thus, the effects of 
single takes, range takes, and diagonal takes you have performed appear in the salvo 
automatically. 

Using the ‘Actions’ menu, you can issue commands to edit the salvo in the salvo pane directly. 

When you have the ‘Connections’ window open, with salvos enabled, the ‘File’ menu provides 
commands related to salvos: 

(Salvo files and connection reports are all text files that can be opened in NotePad, WordPad, 
and other PC applications. The default file extension for salvos is .svo. The default file extension 
for report files is .txt.)
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These are the commands: 

• Open existing salvo . . . 

This command produces a dialog in which you can browse your PC’s file system to locate 
and open a salvo file. The salvo in the file is copied to the salvo pane of the ‘Connections’ 
window. 

If the salvo pane is not displayed, it becomes displayed when you open the salvo file.

• Save opened salvo . . .

If you have not opened a salvo file, this command will show an error message: 

The command saves the salvo, in its current state, to the file that you had opened. 

• Save salvo as . . . 

Use this command to save the current salvo if you have not opened a salvo file.

This command produces a dialog in which you can browse your PC’s file system to find a 
folder in which to save a salvo, create a name for the salvo file, and save the salvo. The salvo 
that is saved is the one in the salvo pane of the ‘Connections’ window. 

See Writing Connections Reports on page 84for information about the ‘Write connection report 
(.txt file) . . .’ command.
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Creating a Salvo
You can create a salvo by opening a salvo pane in the ‘Connections’ window. 

Follow these steps: 

How to Create a Salvo
1 From the ‘Window’ menu, choose ‘Connections’. The ‘Connections’ window appears: 

Note that the ‘Connections’ window must be active of you are to use salvo commands.

2 From the ‘Tools’ menu, choose ‘Options’. The ‘Connection Options’ dialog appears: 

Select the ‘Salvo’ tab.

Check ‘Show Salvo Window’ to cause the ‘Connections’ window to display its salvo pane. 
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Check ‘Send all reads to Salvo Window’ to have cause the ‘Connections’ window to display 
data that are the result of a read or a take in the salvo pane. 

Click ‘OK’ to dismiss the dialog and retain its settings. 

When you have opted to “show salvo window,” the salvo pane appears in the ‘Connections’ 
window: 

The salvo pane, freshly created, is empty. 

Building a Salvo
There are 3 ways to build a salvo:

• Read outputs from the router (if you have enabled ‘Send reads to the Salvo Window’).

• Add takes to the salvo.

• Edit individual takes in the salvo. 

Reading Outputs from the Router
1 Go to the ‘Connections’ window and turn on the salvo pane if you have not done so.

2 Also enable ‘Send reads to the Salvo Window’ if you have not done so. 

You can use the ‘Connection Options’ dialog to do this or you can check the ‘Send reads to 
the Salvo Window’ option of the ‘Connections’ window’s context menu. 

3 In the ‘Connections’ window, specify a range of outputs and click Read Outputs. 

The outputs, with the inputs currently routed to them, are transferred to the salvo pane.
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Adding Individual Takes
You can append individual takes to the salvo using the ‘Add Single Take’ command of the 
‘Actions’ menu.

How to Add Individual Takes
1 Go to the ‘Connections’ window and turn on the salvo pane if you have not done so.

2 From the ‘Actions’ menu, choose ‘Edit/Change Salvo > Add Single Take’. A dialog appears: 

3 Enter an ‘Input’ number and an ‘Output’ number in the fields provided. 

4 Click Add. The take you specified is appended to the salvo. (It appears at the end of the list of 
takes in the salvo, increasing the number of takes in the salvo by one.) 

5 Repeat steps 3 and 4 until you have added the individual takes you wanted. 

6 The dialog does not automatically close when you add a take. When you have finished, click 
Close to dismiss the dialog.

Modifying Individual Takes Within a Salvo
You can modify any take in a salvo.

How to Modify Individual Takes
1 Go to the ‘Connections’ window and turn on the salvo pane if you have not done so.

2 Select a take in the salvo. (You can select only one.)

3 From the ‘Actions’ menu, choose ‘Edit/Change Salvo > Modify Single Take’. A dialog appears: 

4 Enter an ‘Input’ number and an ‘Output’ number in the fields provided. 

‘Add’ Button

‘Modify’ Button
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5 Click Modify. The take you selected is modified accordingly, in its place in the salvo. 

Both the input and the output of the take can be changed. You can leave either one as it was. 

After you click Modify, the dialog closes.

6 Repeat steps 2–5 until you have modified the individual takes you wanted to modify. 

Salvo Management

Saving a New Salvo
1 Ensure that the ‘Connections’ window is active.

2 From the ‘File’ menu, choose ‘Save Salvo As . . .’ A dialog appears.

3 Click Browse in the dialog, then specify a folder and file name for the salvo.

4 Click Save.

Saving an Existing Salvo
If you have opened a salvo (that exists in your PC’s file system), you can re-save the (possibly 
modified) salvo. 

1 Ensure that the ‘Connections’ window is active.

2 From the ‘File’ menu, choose ‘Save Opened Salvo’. 

3 No further action is necessary.

Opening a Salvo
You can open salvo files at any time. When you open the file, the file’s contents appears in the 
salvo window. 

If the file you open is not a salvo or the contents of the salvo file have been modified improp-
erly, UniConfig will that the file is invalid. 

Be sure that the salvo you are opening contains the set of takes you want. 

How to Open and Upload a Salvo
1 Go to the ‘Connections’ window. 

2 From the ‘File’ menu, choose ‘Open Existing Salvo’. A dialog appears.

3 Click Browse and navigate to the folder that contains the file.

4 Select the file and click Open. 

The takes in the file appear in the salvo pane. 

5 Optionally, click Execute in the salvo pane to execute the salvo (i.e., perform the takes in the 
salvo). The takes affect the router’s crosspoint directly.
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Clearing a Salvo
You can clear the current salvo. Clearing means removing all the takes from the salvo. 

How to Clear a Salvo
The ‘Connections’ window must be active and a salvo must be displayed. 

From ‘Actions’ menu, choose ‘Edit/Change Salvo > Clear Salvo’. All takes are removed from the 
current salvo. 
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Chapter 15 discusses control card firmware. 
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Using UniConfig, you can identify and update the firmware used by a router’s control card. Firm-
ware is stored in flash memory on the control card. 

In contrast, configuration data are stored in EEPROM associated with the control card. 

For information on compatible control card firmware, contact Miranda Technical Support. 

Firmware files are listed either as an ‘APP’ or a ‘PLD’ in the ‘Configuration’ window. 

Viewing Control Card Firmware
The firmware files currently loaded on a control card are listed in the ‘Configuration’ window. 
There are two settings for viewing: basic or expanded. The difference is that the software 
description fields are blank in the basic view and contain information in the expanded view.
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How to View the Software List Using the ‘Basic’ Setting
1 Select a control card. 

2 From the ‘Window’ menu, choose ‘Configuration’. The ‘Configuration’ window appears: 

3 Click Read All. Identifiers for currently loaded software appear in the ‘Software Versions’ sec-
tion. 

How to View the Software List Using the ‘Expanded’ Setting
1 Go to the ‘Configuration’ window.

2 From the ‘Tools’ menu, choose ‘Options’. The ‘Configuration Options’ dialog appears: 

3 Check the ‘View expanded software descriptions’ check box. By default, this box is not 
checked. 

4 Click OK to save changes and close the dialog box.

Or, click Cancel to close the dialog box without saving changes.

1 Select a control card. 

2 Click Read All. Current configuration settings for the selected control card populate the 
‘Configuration’ window fields.

Asterisks 
indicate files 

currently 
in use
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The ‘Configuration’ window displays full descriptions in the ‘Description’ column in the ‘Soft-
ware Versions’ section: 

To view the full text of a description, move the scroll bar at the bottom of the ‘Software Ver-
sions’ section.
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Uploading a Firmware File
Firmware is saved in flash memory on the control card. 

How to Upload New Firmware
1 Select a control card. 

2 From the ‘Window’ menu, choose ‘Configuration’. The ‘Configuration’ window appears: 

3 Click Read All. The ‘Configuration’ window populates with current router information.

The ‘Software Versions’ section shows all firmware files currently being used by the control 
card. 

4 Make a note of the part number (SVxxxx-xx) of the file(s) you want to replace. 

If you do not have the firmware files, you might have to request the files, by part number, 
from Miranda. (Firmware files have the extension .mx.)
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5 From the ‘Window’ menu, choose ‘Flash Memory’. The ‘Flash Memory’ window appears: 

6 In the row corresponding to the firmware file you want to replace, (e.g., ‘APP0’), click Browse 
and navigate to the location in your PC’s file system of the new firmware file. Click Open. 

The pathname of the firmware file appears in the row of the ‘Flash Memory’ window. 

7 Repeat step 6 for additional firmware files that you want to update. 

8 Click Write Flash. The ‘Status’ bar at the bottom of the window indicates the progress of the 
upload. 

9 Again, from the ‘Window’ menu, choose ‘Configuration’. The ‘Software Versions’ section of 
the window lists the new firmware.

10 Repeat steps 1–9 for each control card being updated.

Using Flash Configuration Files 
The ‘Flash Window’ offers you a shortcut. You can save the names of the firmware files you use in 
a file. Then you can load the names back into the flash window rather than entering the file 
names by hand. This can save time if you have multiple control cards to configure. 

The file extension for the name list is .flashcfg and the files are called flash configuration files. 

To Save a Flash Configuration File
1 Populate the ‘Flash Memory’ window with the firmware files you want to use. 

2 From the ‘File’ menu, choose ‘Save As Flash Configuration File’ to save the firmware file 
name(s) locally on your PC. A dialog appears in which you can browse to locate and name 
the .flashcfg file. 

To Read a Flash Configuration File
From the ‘File’ menu, choose ‘Read From Flash Configuration File’ to read the firmware file 
name(s) from the file on your PC. A dialog appears in which you can browse to locate the 
.flashcfg file. 

Reading the file restores the saved pathnames to the ‘Flash Memory’ page.
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System Status
Chapter 16 discusses the ‘System Status’ window. 

Viewing System Status
UniConfig’s ‘System Status’ window displays the state of the router’s power supplies, video and 
audio references, fans, and other components. 

To view system status, you must have an Ethernet connection between the router’s control card 
and UniConfig.

When the ‘System Status’ window is displayed, you can perform certain functions, using the 
‘Actions’ menu, that affect the router. See Performing System Tasks on page 136.

How to View System Status
1 From the ‘Window’ menu, choose ‘System Status’. The ‘System Status’ window appears: 

This illustration is a sample for the NV5128. The details for other routers differ slightly. 

2 Click Read to view the router’s current status. The ‘This Control Card Status’ section displays 
the “health” of the reference connections and the control card to which UniConfig is con-
nectted. The ‘Other Card Status’ section displays the “health” of the other control card — if 
present — in the router frame.

3 Alarm, power supply, and fan status appear in the sections at the bottom of the window.

4 (Optionally) click Start Auto Read to have UniConfig automatically read and display system 
status every two seconds. 

If you click Start Auto Read, the button legend changes to Stop. Click the button again to 
stop the automatic reads. When you click the button the second time, the legend again 
changes — to Auto Upload. This has the same meaning as Start Auto Read. 
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Performing System Tasks
When the ‘System Status’ window is active, the ‘Actions’ menu provides several commands. 
From the ‘Actions’ menu, choose either ‘System’ or ‘Controller State’ and then follow the 
submenus to select an option. 

Following are the menu options.

System > Erase 

Do not perform this operation unless directed to do so by a Miranda support engineer.

There are 3 options and a few sub-options: 

• ‘All Flash’ — erases the entire flash memory, including all firmware.

• ‘All Battery-Backed RAM’— erases the contents of battery-backed RAM.

• ‘EEPROMS’ — select either ‘All’, ‘512 Byte’ or ‘2048 Byte’. This option erases the selected 
EEPROM(s).

System > Clear 

There are two options:

• ‘All Locks and Protects’ — releases all locks and protects that have been applied in the router 
control system. See Locks on page 119.

• ‘Logs’ — erases the log file.
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System > Recall Last Serial EE Write Status
This is a diagnostic command. Choose this command to display the ‘Serial EE Write Status’ 
window: 

The command takes no options. The display will be empty if you have not recently written to the 
control card’s EEPROM.

Controller State > Other Controller
The word “controller” in this command means control card. 

Note: If a secondary control card is not installed, the word ‘Offline’ appears.

There are two options:

• ‘Hold Offline’ — places, and retains, the secondary control card off-line.

• ‘Release Offline’ — places the secondary control card online.

Controller State > This Controller
The word “controller” in this command means control card. 

There are 3 options:

‘Offline’ — forces this control card (the one with which UniConfig is communicating) off-line. 
(The other control card, if present, becomes active.)

‘Standby’ — places this control card in standby mode. (The other control card, if present, 
becomes active.)

‘Reset’ — resets this control card.
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Chapter 17 discusses UniConfig’s ‘Logs’ window and its log files. 

Using the Logs Window
A ‘Logs’ window is present when UniConfig is communicating through an Ethernet connection. 

The ‘Logs’ window is a trouble-shooting tool to be used only as directed by an Miranda service 
engineer. 

A router creates a log file that resides in the RAM on the control card. The log file can be read, 
and saved on your PC, in UniConfig’s ‘Logs’ window. 

Should a problem arise with the router, a Miranda service engineer might request that you 
furnish the router’s log file.
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Logging Modes
You can set the logging levels for several components of the router. 

Click the ‘Set Log Modes’ button to set the logging level for system events, serial control events, 
and Ethernet control events. The ‘Set Log Modes’ dialog initially does not show the logging 
levels. Click the ‘Read All’ button to obtain the current logging levels in the current MCPM. The 
‘Set Log Modes’ dialog appears: 

The 5 router event categories are 

• System

• Serial Comm 1, 2, 3

• Ethernet 1

For each of these components, you can choose a logging level, which controls when events are 
logged and with what kind of detail. These are the 7 logging levels, in increasing levels of 
severity and detail: 

None Log no events.

Errors Log only errors.

Warnings Log warnings and errors.

System events Log warnings, errors, and system-level events.

Transactions Log warnings, errors, system events, and all messages between system 
components.

All events Log all events.

Debug Log all events and provide debugging information. 

All event categories are recorded in the same log, in order of occurrence.

If you change any of the logging levels, click ‘Write All’ to send the change to the control card. 
Click ‘Close’ to return to the ‘Logs’ page.
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Operations
When you open the ‘Logs’ window, it is initially empty. Click the ‘Read Logs’ button to cause 
UniConfig to display the logs. 

There are a few other buttons of interest: 

• Save Logs to File . . . 

Click this button to save the router’s log to a file in your PC’s file system. A dialog appears in 
which you can specify a location and a name for the file.

• Clear Log

Click this button to erase the log file in the router’s control card. (The ‘Logs’ window also 
becomes empty.)

• Clear Display

Click this button to clear the ‘Logs’ window. The operation does not affect the log files in the 
router’s control card.
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Chapter 18 provides supplementary, but important, information about NVISION series routers 
and router architecture. Also provided are tips and techniques for creating mono and stereo 
partitions in UniConfig and in NV9000-SE Utilities. 
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Router Expansion 
The following table lists the number of router frames and sizes for expanded routers: 

Other NVISION series routers are not expanded and do not support expansion.

Expansion Configuration Settings
Listed here are the maximum values you can use in the ‘Expansion Configuration’ section of the 
‘Configuration’ window.

The general idea for expansion settings is that each frame of an expanded router (1) receives 
inputs from all frames, i.e., receives all inputs and (2) produces its individual range of outputs. 

NV5256 (Expanded)
The expanded NV5256 has a 512 x 512 matrix, as if it were two 512×256 routers. The values for 
the ‘Expansion Configuration’ section that give maximal range are:

Main Slave 
Input Output Input Output 

Start 1 1 1 257 
End 512 256 512 512

Router Number of Frames That Can be Connected

NV5256-Plus 2 frames at 256 ports each, resulting in 512×512 router

NV7256-Plus 2, 3, or 4 frames, 256 × 256 each, resulting in a 512×512, 768×768, or 1024×1024 
router (1024×1024, 1536×1536, or 2048×2048 mono)

NV7512-Plus 2, 3, or 4 frames, 512 × 512 each, resulting in a 1024×1024, 1536×1536, or 2048×2048 
router (2048×2048, 3072×3072, or 4096×4096 mono)

NV8256-Plus 2, 3, or 4 frames, 256 × 256 each, resulting in a 512×512, 768×768, or 1024×1024 
router

NV8288-Plus 2 frames, 288×288 each, resulting in a 576×576 router

NV8576-Plus 2 frames, 576×576 each, resulting in an 1152×1152 router
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NV7256-Plus
The NV7256-Plus can be configured with 1, 2, 3, or 4 frames and its maximal matrix grows 
linearly with the number of frames: 256×256, 512×512, 768×768, or 1024×1024. Its architecture 
is the same as if it were 1, 2, 3, or 4 nnn×256 routers, where nnn is 256, 512, 768, or 1024. The 
values for the ‘Expansion Configuration’ section that give maximal range are:

Main Slave1 Slave2 Slave3 
Frames In Out In Out 
2 Start 1 1 1 257 

End 512 256 512 512

3 Start 1 1 1 257 1 513 
End 768 256 768 512 768 768

4 Start 1 1 1 257 1 513 1 769 
End 1024 256 1024 512 1024 768 1024 1024

The matrix sizes given represent stereo I/O. These can also be routed as up to 2048×2048 mono 
signals. 

NV7512-Plus
The NV7512-Plus can be configured with 1, 2, 3, or 4 frames and its maximal matrix grows 
linearly with the number of frames: 512×512, 1024×1024, 1536×1536, or 2048×2048. Its archi-
tecture is the same as if it were 1, 2, 3, or 4 nnn×512 routers, where nnn is 512, 1024, 1536, or 
2048. The values for the ‘Expansion Configuration’ section that give maximal range are:

Main Slave1 Slave2 Slave3 
Frames In Out In Out 
2 Start 1 1 1 513 

End 1024 512 1024 1024

3 Start 1 1 1 513 1 1025 
End 1536 512 1536 1024 1536 1536

4 Start 1 1 1 513 1 1025 1 1537 
End 2048 512 2048 1024 2048 1536 2048 2048

The matrix sizes given represent stereo I/O. These can also be routed as up to 4096×4096 mono 
signals. 
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NV8256-Plus
The NV8256-Plus can be configured with 1, 2, 3, or 4 frames and its maximal matrix grows 
linearly with the number of frames: 256×256, 512×512, 768×768, or 1024×1024. Its architecture 
is the same as if it were 1, 2, 3, or 4 nnn×256 routers, where nnn is 256, 512, 768, or 1024. The 
values for the ‘Expansion Configuration’ section that give maximal range are:

Main Slave1 Slave2 Slave3 
Frames In Out In Out 
2 Start 1 1 1 257 

End 512 256 512 512

3 Start 1 1 1 257 1 513 
End 768 256 768 512 768 768

4 Start 1 1 1 257 1 513 1 769 
End 1024 256 1024 512 1024 768 1024 1024

NV8288-Plus
The NV8288-Plus has a matrix up to 576 x 576. Its architecture is the same as if it were two 
576×288 routers. The values for the ‘Expansion Configuration’ section that give maximal range 
are:

Main Slave 
Input Output Input Output 

Start 1 1 1 289 
End 576 288 576 576

NV8576-Plus
The expanded NV8576-Plus has a matrix up to 1152 x 1152. Its architecture is the same as if it 
were two 1152×576 routers. The values for the ‘Expansion Configuration’ section that give 
maximal range are:

Main Slave 
Input Output Input Output 

Start 1 1 1 577 
End 1152 576 1152 1152
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Connectors
The following table shows the pinout for the DE9 connectors (RS-232) at the front of EM0374 
control cards:

The same pinout applies to the DE9 connectors (RS-232) at the rear of the NV8288 and NV8288-
Plus router (which use EM0529 control cards). 

Mono and Stereo Configuration Methods
These methods are for NV9000 systems. We cannot address third-party router control systems.

Method 1 
Problem: how do you configure an input or output to be both stereo and mono?

In UniConfig, create 2 overlapping partitions: one for stereo and one for mono. (The stereo parti-
tion and the mono partition use the same physical ports.)

In the NV9000 configuration, create two sets of devices, one for use as stereo, and one or use as 
mono. Both sets of devices refer to the same ports, but in a different way. 

Method 1 Details

In UniConfig
Create 2 overlapping partitions, one for stereo and one for mono. This is an example for the 
NV7512: 

Here we have 512 connectors supporting 512 stereo signals or 1024 mono channels. Here we 
chose levels 2 and 3 because, in the NV9000 system of this example, level 1 is for the HD router. 

PC End Pin Router End 

DCD 1 Ground

RXD 2 TXD

TXD 3 RXD

DTR 4 DSR

Signal Ground 5 Signal Ground

DSR 6 DTR

RTS 7 CTS

CTS 8 RTS

Ground 9 Ground
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In NV9000-SE Utilities
1 Define the audio router and its two physical levels so that they match UniConfig: 

(In this NV9000 configuration, an HD router was also defined, but it is not shown.)

2 Create virtual levels if none available have suitable names. In this configuration, we created 
two: “AES” for stereo and “MONO” for mono: 

It is a 2-step process. First add the virtual levels to the virtual level table. Then, assign a signal 
type to the virtual level in the virtual level bindings table. The signal types are ‘AES/EBU’ (ste-
reo) and ‘AES mono’.

Virtual Level Table

Virtual Level Bindings Table

1

2
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3 Create level sets: one for stereo and one for mono: 

The level sets includes the video level. The virtual levels map to the physical levels you 
defined for the router(s). The physical levels match what you defined in UniConfig.

4 Create devices for the stereo level set, input and output. Here we show the steps to create 
the stereo input devices. Creating output devices follows the same pattern. 

In the tasks pane, click ‘Add Multiple Devices’. The first of 3 windows appears: 

This window defines the names of the devices and more importantly the level set to which 
the devices belong (stereo).

Fill in the appropriate values and click ‘Next’. The second window appears: 

Stereo Mono
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Because we are defining input devices, we must uncheck both output check boxes and 
ignore the other columns labeled ‘Output’. (If the devices we are creating were bidirectional, 
we would not ignore the outputs.)

For stereo, the inputs will start at 1 and increment by 1 (because there is one connector for 
each stereo input). 

Complete the settings in this page and click ‘Next’ at the bottom of the window. The third 
and final window appears, in which is displayed a table of the devices that will be created: 

The table shows the ports for each of the virtual levels for each device. Note that the AES 
level (stereo) increments by 1. 

If the proposed result appearing in this window is correct, click ‘Finish’. Otherwise, amend or 
cancel your entries. 

Perform the same 3-step process for stereo outputs. When you process the second step, 
ignore the input columns and assign starting and increment values for the outputs. 
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5 Create devices for the mono level set. 

Here we create 4 sets of mono devices: left input, left output, right input, right output. The 
process for each these 4 sets are similar but differ in crucial small details. Here we show the 
steps to create the “mono left” input devices. 

In the tasks pane, click ‘Add Multiple Devices’. The first of 3 windows appears: 

Here, the level set to which the devices belong is ‘MONO’.

Fill in the appropriate values and click ‘Next’. The second window appears: 

Because we are defining input devices, we must uncheck both output check boxes and 
ignore the other columns labeled ‘Output’. 

For “mono left” devices, the inputs will start at 1. Here, we increment by 2 (because each 
connector provides 2 mono inputs). 

“Mono left” outputs will also start at 1 and increment by 2. 

“Mono right” inputs will start at 2 and increment by 2. 

“Mono right” outputs will start at 2 and increment by 2. 

Notice that when you specify 2 as the increment for inputs, the max input value drops to 
half. Where it was 1024, it is now 512. The same will hold true for outputs.
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Complete the settings in this page and click ‘Next’ at the bottom of the window. The third 
and final window appears, in which is displayed a table of the devices that will be created: 

The table shows the ports for each of the virtual levels for each device. Note that the MONO 
left inputs start at 1 and increment by 2. 

If the proposed result appearing in this window is correct, click ‘Finish’. Otherwise, amend or 
cancel your entries. 

Later, when you complete the mono right inputs, the MONO right inputs start at 2 and incre-
ment by 2. Thus, left/right pairs proceed (1,2), (3,4) (5,6) and so on.

Perform the same 3-step process for the remaining mono devices. When you process the 
second step, be aware of the starting port number for inputs or outputs. The increment for 
inputs and outputs is 2 for all mono device sets.

6 When you complete all 6 device sets, you can examine NV9000-SE Utilities’ various tables to 
verify your work. This is an excerpt from the ‘PhysConns’ table showing input 55: 

A few seconds of scrutiny shows that the stereo input (INS 55) is 55 as expected. The mono 
inputs (INL 55, INR 55) are 109 and 110, also as expected and fit the formulas given earlier: 

R = S × 2 L = R – 1

“Mono left” Inputs “Mono right” Inputs
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(The device names for both level sets should be similar so that operators can choose the right 
device without thinking.)

The NV9000 configuration used in this example is somewhat contrived and simplistic, but it 
illustrates the method. It is easy to create variations of the method. 

Method 2 
Problem: how do you configure an input or output to be both stereo and mono?

In UniConfig, create 1 mono partition. As mentioned, the number of mono (i.e., controller) ports 
is double the number of physical ports. 

In the NV9000 configuration, create a level set containing two mono levels (call them L and R if 
you like) and create audio devices that use that level set. You can switch the devices as stereo. 
Using breakaway, you can switch the individual channels. 

Method 2 Details

In UniConfig
Create 1 mono partitions. This is an example for the NV7512: 

Here we have 512 connectors supporting 1024 mono channels. We chose level 2 because, in the 
NV9000 system of this example, level 1 is for the HD router. 
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In NV9000-SE Utilities
1 Define the audio router and its physical level so that it matches UniConfig: 

(In this NV9000 configuration, an HD router was also defined, but it is not shown.)

2 Create virtual levels if none available have a suitable name. In this configuration, we created 
two mono levels, “LEFT” and “RIGHT”: 

It is a 2-step process. First add the virtual levels to the virtual level table. Then, assign a signal 
type to the virtual level in the virtual level bindings table. The signal type is ‘AES Mono’. 

Virtual Level Table
Virtual Level Bindings Table1

2
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3 Create a level set for stereo: 

The level set includes the video level. The “stereo level set includes two mono virtual levels. 
The two virtual levels map into the single mono physical level you defined for the router. The 
physical level match what you defined in UniConfig.

4 Create devices for the stereo level set, input and output. Here we show the steps to create 
the stereo input devices. Creating output devices follows the same pattern. 

In the tasks pane, click ‘Add Multiple Devices’. The first of 3 windows appears: 

This window defines the names of the devices and more importantly the level set to which 
the devices belong (stereo).

Fill in the appropriate values and click ‘Next’. The second window appears: 

Because we are defining input devices, we must uncheck both output check boxes and 
ignore the other columns labeled ‘Output’. (If the devices we are creating were bidirectional, 
we would not ignore the outputs.)
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For stereo, the “left” inputs will start at 1 and the “right” inputs will start at 2. Both levels 
increment by 2 (because each connector provides 2 mono inputs).

Complete the settings in this page and click ‘Next’ at the bottom of the window. The third 
and final window appears, in which is displayed a table of the devices that will be created: 

The table shows the ports for each of the virtual levels for each device. Note that each of the 
mono levels increments by 2 and that the mono levels are paired for each device (1,2), (3,4), 
(5,6) and so on. 

If the proposed result appearing in this window is correct, click ‘Finish’. Otherwise, amend or 
cancel your entries. 

Perform the same 3-step process for stereo outputs. When you process the second step, 
ignore the input columns and assign starting and increment values for the outputs. 

5 When you complete both input and output device sets, you can examine NV9000-SE Utili-
ties’ various tables to verify your work. This is an excerpt from the ‘PhysConns’ table showing 
input 55: 

This table fragment shows that the stereo input (IN 47) has two mono levels that come from 
ports 93 and 94 as expected and fit the formulas given earlier: 

R = S × 2 L = R – 1

(The device names for both level sets should be similar so that operators can choose the right 
device without thinking.)

The NV9000 configuration used in this example is somewhat contrived and simplistic, but it 
illustrates the method. It is easy to create variations of the method. 
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3Gig Video at 2.97 or 2.967 Gbps. In Miranda routers, 3Gig cards support HD and SD signals 
as well. Video at 3Gig conforms to SMPTE standard 424M.

Active control 
card

A router may have both a primary and a secondary control for redundancy. One of the 
two control cards is the active card and the other is the inactive or stand-by card.

AES A term used, at Miranda GVD, to represent the digital audio format (AES3id) generally 
supported at Miranda and switched by NVISION series routers. AES is an abbreviation 
of the Audio Engineering Society, Inc., New York (www.aes.org). 

AES/EBU (Audio Engineering Society/European Broadcasting Union) a professional serial inter-
face for transferring digital audio from CD and DVD players to amplifiers and TVs. AES/
EBU is typically used to transmit PCM and Dolby Digital 5.1, but is not tied to any 
sampling rate or audio standard.

AES3, AES3id The AES routers support AES3id and provide 75W BNC connectors. AES3id is specified 
for 75W coaxial cable up to 1000 meters. (AES3 uses 110W shielded twisted pair (STP) 
cable with XLR connectors up to a distance of 100 meters.) 

AES3, AES3id NVISION series routers that switch audio generally support AES3id and provide 75W 
BNC connectors. AES3id is specified for 75W coaxial cable up to 1000 meters. (AES3 
uses 110 W shielded twisted pair (STP) cable, with XLR connectors, up to a distance of 
100 meters.) 

Analog Audio A signal whose varying voltage represents the waveform of the audio.

Async AES,  
Sync AES

The term “Async AES” refers to an asynchronous (free-running) AES-compliant audio 
signal, whereas “Sync AES” refers to a synchronous (clocked) AES signal with a data 
rate of 48,000 samples per second. 

AVC Analog Video Conversion. A simple conversion from composite analog video input to 
digital output or vice versa. 

Baud rate The transmission rate of a serial communication link. Usually means bits per second.

D/A Digital to analog

DB25 A DB25 connector is the common 25-pin D-type connector. 

dBu Unit of audio level where 0dBu is 0.775 VRMS.

DC Direct current

DCE Data Communication Equipment (an RS-232 term).

DE9 Sometimes called a DB9 connector, a DE9 connector is the common 9-pin D-type 
connector. 

Device As the term is used in an NV9000 router control system, a device is a grouping of input 
and output ports, possibly spanning multiple routers of different types. These inputs 
and outputs typically connect to a single physical device such as a VTR. 
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DSP Digital signal processing. 

A DSP sub-module that can be installed on the NV7512 router crosspoint card. The 
DSP sub-module enables gain adjustment, phase inversion, crossfade, and channel 
summing functionality for audio stereo signals. The DSP module is no longer available.

DTE Data Terminal Equipment (an RS-232 term).

EEPROM (EE or “serial EE” for short). Electrically erasable programmable read-only memory. In 
the context of UniConfig, this is non-volatile memory associated with a router control 
card. EE retains its data indefinitely in the field (unless it is reprogrammed).

EIA Electronic Industries Alliance. The EIA (until 1997 Electronic Industries Association) is a 
trade organization for electronics manufacturers in the United States. EIA is accredited 
by the American National Standards Institute (ANSI) to help develop standards on 
electronic components, consumer electronics, electronic information, telecommunica-
tions, and Internet security. 

ESD Electrostatic discharge

HD High-definition (video). An HD signal is a serial digital video format that conforms to 
the SMPTE 292M standard.

Hot- 
Swappable

A module that is “hot-swappable” can be safely removed and/or installed while power 
is applied to the system.

I/O Inputs and outputs. 

The term “input port” is used interchangeably with “input” and the term “output port” 
is used interchangeably with “output.”

Jumpers Jumpers are usually small conductors, in plastic sleeves, that fit over a set of pins on a 
circuit board. The placement of jumpers can enable or disable a board function, or 
configure a board function.

LED Light Emitting Diode

Matrix In general, a 2-dimensional array. 

In NVISION series routers, the switching mechanism is called a crosspoint matrix, that is, 
a 2-dimensional array of crosspoints. A crosspoint is a theoretical point where an input 
is connected to an output. 

Module Any removable subassembly may be called a module. 

UniConfig uses the term module to refer to I/O cards, backplane modules, monitor 
cards, control cards, etc. 

MRC A software application that configures and manages NV8500 hybrid routers primarily 
and that can perform some management tasks for other NVISION series routers. 

Operator The term operator usually refers to a control panel operator — a user that is not a 
system administrator. An operator is the person responsible for making routes. 

P2P An abbreviation for “point to point.”
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Physical Level A physical level is a partition (i.e., a region) of a router’s switching matrix (or crosspoint 
matrix). Often the router has a single partition and that partition is the entire matrix. 

The idea is that multiple routers provide different “levels” on which to switch the 
signals of devices in the router control system. 

Some routers switch signals of a single type; other routers can switch signals of 
multiple types (HD, SD, AES, etc.). 

In the NV9000 router control system, a route, or “take,” can occur on multiple physical 
levels — whether in multiple routers or a single router — simultaneously. 

Port A port is a connection on a router. There are input ports, output ports, and control 
ports. 

Input ports and output ports are numbered in sequence, and each one usually corre-
sponds to a physical connector, but in the case of MADI, up to 64 ports are time-
multiplexed on a single connector. 

RAM Random Access Memory. (Contrasted with archaic sequential access memory.)

Reference  
Signal

A video reference is a timing signal used to synchronize the switching of video signals 
during a specific portion of the vertical retrace interval. An AES reference signal 
synchronizes the switching of AES signals.

RJ45, RJ-45 Registered Jack, type 45, as defined in the United States Code of Federal Regulations. A 
common 8-pin modular plug and/or jack used in the telecommunications and broad-
cast industry to transport Ethernet or machine control signals.

RS-422 A bidirectional serial communication standard. NVISION series routers usually have a 
DE-9 connector for RS-422 communication.

RU Rack Units. A standard measure or size for frames (1.75 inches).

SD Standard Definition. An SD signal is a serial digital video format that conforms to the 
SMPTE 259M standard.

SMPTE Society of Motion Picture and Television Engineers. An international professional asso-
ciation, based in the United States. 

Source/ 
Destination

The term “source device” is used interchangeably with “source” and the term “destina-
tion device” is used interchangeably with “destination.” A source is a device, such as a 
camera, that is connected to one or more input ports. A destination is a device that is 
connected to one or more output ports. An example of such a device would be a 
monitor. A device can be both a source and destination. An example of such a device is 
a VTR.

SWB (Super Wide Band). A term originating at Miranda GVD that refers to the ability of a 
router to pass a wide range of digital video formats. Miranda’s SWB supports data rates 
from about 15 Mb/s to 1.5 GB/s. (This term does not include 3Gig signals.)

Sync AES, Async 
AES

The term ‘Async AES” refers to an asynchronous (free-running) AES-compliant audio 
signal, whereas ‘Sync AES” refers to a synchronous (clocked) AES signal with a data rate 
of 48,000 samples per second. 

System admin-
istrator

In this document, a system administrator is a person responsible for installing, config-
uring, or maintaining a router control system, including configuration workstations, 
routers, and control panels.
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System  
Controller

The name given to an NV9000, an NV915, or NV920. An NV9000 router control system 
includes one or more system controllers. 

Time Code A linear time code signal complying with SMPTE 12M or the corresponding EBU 
standard.

UniConfig A Windows-based application used to configure NVISION series routers (other than 
NV8500 hybrid routers) and some other products. UniConfig has an easy-to-learn 
graphical user interface (GUI).
160



Index
0–9
3Gig

defined . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 157

A
Acrobat usage

bookmarks  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2
hyperlinks . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2
navigating and searching  . . . . . . . . . . . . . . . . . . . . . . . . . 2

Active control card
defined . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 157

Adding takes (to a salvo) . . . . . . . . . . . . . . . . . . . . . . . . . . . . 126
AES reference

defined . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 159
AES, defined . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 157
AES/EBU, defined . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 157
AES3  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 157
AES3, defined  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 157
AES3id  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 157
Africa, contact . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 167
Agreement, license  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . iii
All events (logging level) . . . . . . . . . . . . . . . . . . . . . . . . . . . . 140
Americas, contact . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 167
Analog audio, defined  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 157
Appearance, UniConfig  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 6
Application, launching . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 20
Applications, managing . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 129
Applying all settings . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 17
Applying current changes  . . . . . . . . . . . . . . . . . . . . . . . . . . . 17
Asia, contact . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 167
Async AES, defined  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 157
Audio Engineering Society . . . . . . . . . . . . . . . . . . . . . . . . . . 157
Auto-increment after Takes  . . . . . . . . . . . . . . . . . . . . . . . . . . 91
Auto-refresh after takes . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 90
AVC, defined  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 157

B
Baud rate, defined . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 157
Before starting configuration . . . . . . . . . . . . . . . . . . . . . . . . . 19
BNC connectors  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 157
Bold-face or capital letters  . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2
Bookmarks, Acrobat  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2

Broadcast (mode)  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .46
Broadcasting machine control signals . . . . . . . . . . . . . . . . .79
Building a salvo  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 126
Buttons

read all  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 140
set log modes . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 140
write all . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 140

C
Cable

Ethernet  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .27
RS-232 . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .27

Capital or bold-face letters  . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2
CE  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . iii
Change history . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . ii
Changes, applying current  . . . . . . . . . . . . . . . . . . . . . . . . . . .17
Changes, saving . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .22
Chapter structure  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1
Chapters

1, Preface  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1
2, Introduction . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3
3, UniConfig Basics . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5
4, Configuration Basics  . . . . . . . . . . . . . . . . . . . . . . . . . . .19
5, Installation  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .27
6, Communication  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .31
8, Partitions and Signal Types . . . . . . . . . . . . . . . . . . . . .41
9, Switch Point Settings  . . . . . . . . . . . . . . . . . . . . . . . . . .61
10, Inputs and Outputs . . . . . . . . . . . . . . . . . . . . . . . . . . .83
11. Machine Control Ports  . . . . . . . . . . . . . . . . . . . . . . . .77
12, EC9535 . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 107
13, NV8500 Monitors . . . . . . . . . . . . . . . . . . . . . . . . . . . 115
16, Locks . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 119
17, Salvos . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 121
18, Protocols . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 129
19, System Status  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 135
20, Reports and Logs  . . . . . . . . . . . . . . . . . . . . . . . . . . . 139
21, Technical Details  . . . . . . . . . . . . . . . . . . . . . . . . . . . 143

China, contact  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 167
Clearing a salvo  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 128
Communication

Initial  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .31
Permanent ports . . . . . . . . . . . . . . . . . . . . . . . . . . . . 32, 108
Removing parameters . . . . . . . . . . . . . . . . . . . . . . . . . . . .39
Router control system . . . . . . . . . . . . . . . . . . . . . . . . . . . .31
Temporary ports  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .32

Communication parameters . . . . . . . . . . . . . . . . . . . . . 31, 108
161



Index
Configuration
Copying . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 22
Starting  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 19
Viewing  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 21

Configuration settings, storing . . . . . . . . . . . . . . . . . . . . . . . . 3
Connecting to UniConfig  . . . . . . . . . . . . . . . . . . . . . . . . . . . . 20
Connection reports

Creating . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 146
Printing  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 146

Connection window preferences . . . . . . . . . . . . . . . . . . . . . 90
Connectors

BNC . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 157
DB25 . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 157
DE9  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 27, 157
RJ-45 . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 27
RJ45, RJ-45  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 159
XLR  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 157

Contact Miranda . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 167
Control card

Writing sequence . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 15
Control Cards Pane

About . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 12
Location . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5
Moving . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 14
Opening  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 12

Control cards, Save As  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 22
Copying configurations . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 22
Corporate office, contact . . . . . . . . . . . . . . . . . . . . . . . . . . . . 167
Creating a log  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 139
Customer support  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 167

D
D/A, defined . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 157
Data X/Y (mode) . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 46
dBu, defined . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 157
DC, defined . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 157–158
DCE  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .78, 81
DE9 connector . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 27
DE9 ports . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 32, 108
Debug (logging level) . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 140
Declaration of conformance  . . . . . . . . . . . . . . . . . . . . . . . . . . iii
Destination, defined . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 159
Device

defined . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 157
Device, defined . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 158
Diagnostic connections . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 33
Document

notice of use  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . ii
part number . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . ii
revision  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . ii

Dolby Digital 5.1 . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 157
DTE  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .78, 81
Dual references . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 61

E
EC9535  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 107

Partitions  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 109
Switch points  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 111

EEPROM  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3
defined  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 158

EIA, defined . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 158
E-mail address  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 167
Errors (logging level)  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 140
ESD, defined  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 158
Ethernet

expanded settings  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .38
switch  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .27

Europe, contact  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 167
European Broadcasting Union . . . . . . . . . . . . . . . . . . . . . . 157
Expanded Ethernet settings  . . . . . . . . . . . . . . . . . . . . . . . . . .38
Expanded routers  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 50, 52

F
FAX numbers  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 167
FCC statement  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . ii
Fields . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .63
Find, Acrobat  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2
First Page, Acrobat  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2
Flash memory . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 129
Flash, reading and saving . . . . . . . . . . . . . . . . . . . . . . . . . . . 133
Flash, uploading  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 132
Forward (mode) . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .46
Frame expansion . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .50
Frames  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .63
France, contact  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 167

G
Gateways . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .38
Go to Next View, Acrobat . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2
Go to Previous View, Acrobat . . . . . . . . . . . . . . . . . . . . . . . . . . 2

H
Hardware version  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . ii
HD, defined . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 158
Hot-Swappable, defined . . . . . . . . . . . . . . . . . . . . . . . . . . . . 158
Hours of operation . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 167
Hyperlinks, Acrobat  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2
162



UniConfig
User’s Guide
I
Initial setup . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 31
Inputs and outputs, viewing  . . . . . . . . . . . . . . . . . . . . . . . . . 94
Installation  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 27
Installing UniConfig . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 28
Interface, about  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5
Introduction . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3

L
Last Page, Acrobat . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2
Launching . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 20
Launching UniConfig  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 28
LED, defined . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 158
Level, physical, defined  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 159
Levels  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 41
License . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . iii
Location of, serial router connections  . . . . . . . . . . . . . . . . 33
Locks . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 119
Logs window . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 139

M
Machine control ports  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 77
Machine control signals

Setting up . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 81
Managing protocols  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 129
Master router frames  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 50
Matrix, defined  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 158
MCPM, RS-232 port  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 27
Memory, viewing sequence . . . . . . . . . . . . . . . . . . . . . . . . . . 15
Menu bar . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5–6
Middle East, contact  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 167
Miranda, contact  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 167
Modes

broadcast  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 46
data X/Y . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 46
forward  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 46
reverse . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 46

Module, defined . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 158
Mono I/O signals, testing . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 96
Mono signals

Viewing  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 94
Moving Control Cards Pane  . . . . . . . . . . . . . . . . . . . . . . . . . . 14
Multiple frames . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 50

N
Network basics  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 24
Networks . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 24
Next Page, Acrobat  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2

None (logging level)  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 140
Notice, use . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . ii
NV5100, switch point settings  . . . . . . . . . . . . . . . . . . . . . . . .64
NV5128, switch point settings  . . . . . . . . . . . . . . . . . . . . . . . .64
NV7256, switch point settings  . . . . . . . . . . . . . . . . . . . . . . . .66
NV7256-Plus, switch point settings  . . . . . . . . . . . . . . . . . . .66
NV7512, switch point settings  . . . . . . . . . . . . . . . . . . . . . . . .68
NV8256-Plus, switch point settings  . . . . . . . . . . . . . . . . . . .70
NV8288, switch point settings  . . . . . . . . . . . . . . . . . . . . . . . .72
NV8288-Plus, switch point settings  . . . . . . . . . . . . . . . . . . .72
NV8500 Family switch point settings . . . . . . . . . . . . . . . . . .74
NV9000

router control system  . . . . . . . . . . . . . . . . . . . . . .157, 160
system controller  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 160

O
Opening

Control Cards Pane . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .12
Windows  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .12

Opening a salvo . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 127
Operator, defined . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 158
Organizing the router  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .41
Overview

EC9535  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 107
EC9535 switch point settings  . . . . . . . . . . . . . . . . . . . 111
Partitions  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .41

Overview of UniConfig  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3

P
Part number, document . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . ii
Partitions  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .41

Setting up  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .47
Setting up EC9535  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 109
Updating  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .53

PC requirements  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .27
PCM  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 157
PDF documents . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2
PDF documents, navigating and searching . . . . . . . . . . . . . 2
Performing takes . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .95
Permanent serial ports  . . . . . . . . . . . . . . . . . . . . . . . . . . 32, 108
Physical levels

defined  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 159
Port

defined  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 159
Port, defined . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 158
Port, RS-232 MCPM . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .27
Preface  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1

terms, conventions and abbreviations  . . . . . . . . . . . . . 2
Preferences

Connection window . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .90
Previous Page, Acrobat . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2
Product summary . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3
163



Index
Products supported  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4
Protocols . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 129

Uploading . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 132
Viewing  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 129

Protocols, Saving  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 133

R
RAM, defined . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 159
Read all (button) . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 140
Reading and saving protocols . . . . . . . . . . . . . . . . . . . . . . . 133
Redundant references  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 61
Reference

Video, dual  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 61
Video, redundant . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 61

Removing a salvo . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 128
Removing communication . . . . . . . . . . . . . . . . . . . . . . . . . . . 39
Report, switching connections  . . . . . . . . . . . . . . . . . . . . . . 146
Requirements, PC . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 27
Retaining serial port settings . . . . . . . . . . . . . . . . . . . . . . . . . 37
Reverse (mode) . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 46
Revision, document . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . ii
RJ-45 connector  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 27
Router control system  . . . . . . . . . . . . . . . . . . . . . . . . . 157, 160
Router control system, communicating . . . . . . . . . . . . . . . 31
Router, serial ports . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 32, 108
Routers

master frames  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 50
Multiple connected . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 50
slave frames . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 52
Standalone . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 48
Supported products  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4

RS-232 port . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 27
RU, defined . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 159

S
Salvos . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 121

adding takes  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 126
Clearing . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 128
Opening  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 127
Removing  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 128
Updating . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 126
Uploading . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 127

Save As function . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 22
Saving changes . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 22
Saving serial port settings . . . . . . . . . . . . . . . . . . . . . . . . . . . . 37
Search, Acrobat . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2
Serial ports

Location on router . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 33
On control cards . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 32
Permanent on router  . . . . . . . . . . . . . . . . . . . . . . . 32, 108
Retaining settings  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 37
Temporary  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 32

Set log modes (button) . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 140
Setting

Communication parameters . . . . . . . . . . . . . . . . . 31, 108
EC9535 partitions  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 109
Machine control signals  . . . . . . . . . . . . . . . . . . . . . . . . . .81
Partitions  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .47
Switch points  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .63

Setting Up Communication  . . . . . . . . . . . . . . . . . . . . . 31, 108
Signal connections, viewing . . . . . . . . . . . . . . . . . . . . . . . . . .94
Signal types and partitions  . . . . . . . . . . . . . . . . . . . . . . . 41, 44
SIIG, Inc . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .23
Slave router frames  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .52
SMPTE

defined  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 159
Software license  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . iii
Software version  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .ii, 4
Source, defined  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 159
Standalone routers . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .48
Standard I/O signals, testing . . . . . . . . . . . . . . . . . . . . . . . . . .95
Standard signals, viewing  . . . . . . . . . . . . . . . . . . . . . . . . . . . .94
Start up . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .31
Starting UniConfig  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .20
Support, contact  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 167
Supported routers  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4
SWB, defined . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 159
Switch point settings . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .61

NV5100 . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .64
NV5128 . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .64
NV7256 . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .66
NV7256-Plus  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .66
NV7512 . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .68
NV8256-Plus  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .70
NV8288 . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .72
NV8288-Plus  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .72
NV8500 Family . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .74
Setting up  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .63

Switch, Ethernet  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .27
Switching configuration, connection report . . . . . . . . . 146
Switching configurations

Saving . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .89
Switchpoint settings  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .61
Switchpoints . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .61
Sync AES, defined . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 159
System administrator, defined . . . . . . . . . . . . . . . . . . . . . . 159
System controller, defined . . . . . . . . . . . . . . . . . . . . . . . . . . 160
System events (logging level) . . . . . . . . . . . . . . . . . . . . . . . 140
System status, viewing  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 135

T
Takes

Auto-decrement  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .91
Auto-refresh  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .90

Takes, Auto-increment  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .91
Takes, performing . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .95
164



UniConfig
User’s Guide
Technical support  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 167
Telephone numbers  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 167
Temporary serial ports

Control cards, serial ports  . . . . . . . . . . . . . . . . . . . . . . . . 32
Terms, conventions and abbreviations  . . . . . . . . . . . . . . . . 2
Testing

Mono switching  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 96
Standard switching . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 95

Time code, defined  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 160
Trademarks . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . iii
Transactions (logging level) . . . . . . . . . . . . . . . . . . . . . . . . . 140

U
UniConfig  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3

Connecting to . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 20
Installing  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 28
Launching . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .20, 28

UniConfig, appearance  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 6
UniConfig, defined  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 160
UniConfig, interface  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5
United Kingdom, contact  . . . . . . . . . . . . . . . . . . . . . . . . . . . 167
Updating

Partitions . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 53
Salvos . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 126

Uploading a salvo  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 127
Uploading Flash  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 132
Uploading protocols . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 132
User’s guide, chapter structure . . . . . . . . . . . . . . . . . . . . . . . . 1
Utilities, about . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4

V
Version

hardware  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . ii
software  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . ii

Version, software . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4
Video reference

defined  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 159
Viewing

Configuration . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .21
Control cards on network  . . . . . . . . . . . . . . . . . . . . . . . .12
Protocols  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 129
Signal I/O connections  . . . . . . . . . . . . . . . . . . . . . . . . . . .94
System status  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 135
Writing to control card  . . . . . . . . . . . . . . . . . . . . . . . . . . .15

Viewing inputs and outputs  . . . . . . . . . . . . . . . . . . . . . . . . . .94

W-X-Y-Z
Warnings (logging level)  . . . . . . . . . . . . . . . . . . . . . . . . . . . 140
Warranty . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . iii
Web site  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 167
Window, active  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5
Windows

About  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .12
Arrangement  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .12
Making active . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .12
Opening . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .12

Write all (button) . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 140
Writing sequence  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .15

XLR connectors  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 157
165



Index
166



Contact Us
Miranda Technical Support
For technical assistance, please contact the Miranda Technical Support center nearest you:

Corporate Head Office 
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3499 Douglas-B.-Floreani, St-Laurent, Quebec, Canada  H4S 2C6

Telephone: 514-333-1772

Fax: 514-333-9828

Web: www.miranda.com

Americas 
Office hours: 9:00 a.m. – 9:00 p.m. (EST)

Telephone: +1-800-224-7882

Fax: +1-514-335-1614

E-mail: techsupp@miranda.com

Europe, Middle East, Africa, UK
Office hours: 9:00 a.m. – 6:00 p.m. (GMT)

Telephone: +44 118 952 3444

Fax: +44 118 952 3401

E-mail: eurotech@miranda.com

France 
Office hours: 9:00 a.m. – 5:00 p.m. (GMT+1)

Telephone: +33 1 55 86 87 88

Fax: +33 1 55 86 00 29

E-mail: eurotech@miranda.com

Asia 
Office hours: 9:00 a.m. – 5:00 p.m. (GMT+8)

Telephone: +852-2539-6987

Fax: +852-2539-0804

E-mail: asiatech@miranda.com

China 
Telephone: +86-10-5873-1814

E-mail: asiatech@miranda.com
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